PDA

View Full Version : LEAP 15.4 opensuse 15.4 no reconoce video



vipamon
08-Jun-2022, 06:54
no me deja postear en el foro oficial, según e leído es por que no funciona.

Pues lo dicho, opensuse 15.4 no reconoce video, tengo barios reproductores y codecs instalados y ni a si funciona.


Pongo los s.o que e probado

No funcionan los videos
openSUSE Leap 15.4 RC
Fedora-Workstation-Live-x86_64-35-1.2
ubuntu-22.04-desktop-amd64

Si lee los videos
Windows
linuxmint-20.3-mate-64bit
slax-64bit-9.11.0

https://i.servimg.com/u/f57/16/80/16/45/opensu10.png

https://i.servimg.com/u/f57/16/80/16/45/linux_10.png

mikrios
08-Jun-2022, 11:36
Hola:


En vlc es importante instalar los codecs, si no no funciona : vlc-codecs-3.0.17.3-pm154.2.3.x86_64.rpm , ademas tiene que ser vlc de packman , ese repositorio tiene que tener la prioridad mas alta, y si se instala desde soft de yast2, en opciones tienes que tener marcado cambio de proveedor, entonces debe aparecer vlc de pacman marcado en azul, para que actualices o cambies a el .

si ejecutas zypper con opción -si marcara la fuente y si esta instalado (zypper se -si vlc* ) , ejemplo :



HP-OMEN:~ # zypper se -si vlc*
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
---+---------------------+---------+--------------------+--------+-------------------
i+ | vlc | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-codec-gstreamer | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-codecs | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-lang | package | 3.0.16-pm153.2.6.2 | noarch | Packman Repository
i+ | vlc-noX | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-qt | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-vdpau | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository



Si pones s solo salen todos :



HP-OMEN:~ # zypper se -s vlc*
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
---+-------------------------------+------------+--------------------------------+--------+---------------------
--------------------
i+ | vlc | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
v | vlc | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
v | vlc | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
v | vlc | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc | srcpackage | 3.0.16-pm153.2.6.2 | noarch | Packman Repository
| vlc | srcpackage | 3.0.16-pm153.2.6.1 | noarch | Packman Repository
| vlc | srcpackage | 3.0.17.3-lp153.2.3.1 | noarch | Repositorio principa
l de actualizaciones
| vlc | srcpackage | 3.0.16-bp153.2.3.1 | noarch | Update repository of
openSUSE Backports
| vlc-beta | package | 20220530.aecc375d02-pm153.10.1 | x86_64 | Packman Repository
| vlc-beta | srcpackage | 20220530.aecc375d02-pm153.10.1 | noarch | Packman Repository
| vlc-beta-debuginfo | package | 20220530.aecc375d02-pm153.10.1 | x86_64 | Packman Repository
| vlc-beta-debugsource | package | 20220530.aecc375d02-pm153.10.1 | x86_64 | Packman Repository
i+ | vlc-codec-gstreamer | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
v | vlc-codec-gstreamer | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
v | vlc-codec-gstreamer | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
v | vlc-codec-gstreamer | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-codec-gstreamer-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-codecs | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-codecs-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-debugsource | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-devel | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-devel | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
| vlc-devel | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
| vlc-devel | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-jack | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-jack | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
| vlc-jack | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
| vlc-jack | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-jack-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-lang | package | 3.0.16-pm153.2.6.2 | noarch | Packman Repository
v | vlc-lang | package | 3.0.16-pm153.2.6.1 | noarch | Packman Repository
v | vlc-lang | package | 3.0.17.3-lp153.2.3.1 | noarch | Repositorio principa
l de actualizaciones
v | vlc-lang | package | 3.0.16-bp153.2.3.1 | noarch | Update repository of
openSUSE Backports
v | vlc-lang | package | 3.0.16-bp153.2.3.1 | noarch | Repositorio principa
l
i+ | vlc-noX | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
v | vlc-noX | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
v | vlc-noX | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
v | vlc-noX | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-noX-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-opencv | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
| vlc-opencv | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
| vlc-opencv | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
| vlc-opencv | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-opencv-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-qt | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
v | vlc-qt | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
v | vlc-qt | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
v | vlc-qt | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-qt-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
i+ | vlc-vdpau | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository
v | vlc-vdpau | package | 3.0.17.3-lp153.2.3.1 | x86_64 | Repositorio principa
l de actualizaciones
v | vlc-vdpau | package | 3.0.16-bp153.2.3.1 | x86_64 | Update repository of
openSUSE Backports
v | vlc-vdpau | package | 3.0.16-bp153.2.3.1 | x86_64 | Repositorio principa
l
| vlc-vdpau-debuginfo | package | 3.0.16-pm153.2.6.2 | x86_64 | Packman Repository



Esto es un ejemplo, pero es para la 15.3 (aún no instale 15.4, a la espera de probar lo en un disco especial raid 0 nvme) .

El caso es que he mirado en packman y si está para la 15.4 , instala todo desde ese proveedor y veras que si funciona todo .

Saludos cordiales .

vipamon
08-Jun-2022, 12:26
me pasa lo mismo en opensuse 15.3.
ya instale los codecs de pacman, https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

mikrios
08-Jun-2022, 13:15
Hola:


Ejecuta en consola en modo super usuario este comando : zypper se -si vlc* ( si tienes la 15.3, tiene que coincidir con lo que puse arriba) , para la 15.4 cambia el nombre de los archivos, fijate en los codecs de vlc, pone pm154 si fuese en la 15.3 seria pm153 .

Recuerda que en la 15.4 tienes que tener a packman con prioridad alta , ejemplo un 70 va bien (numero bajo es prioridad alta) , para que descargue los codes y librerías funcionales .

El repo de packman consta de varios repositorios , lo ideal es poner el general , ya que hay archivos que están divididos entre ellos .

Este es uno de los generales : http://ftp.fau.de/packman/suse/openSUSE_Leap_15.4/ de ahí va a esenciales, extra, juegos, multimedia, etc... , si pones la 1ª dirección incluye a todos esos ( en esenciales están los codecs de vlc ) .

La paginas de packman son estas : http://packman.links2linux.org/mirrors , de ahí elige la mas rápida para tu zona,

También lee, las notas de la versión de la 15.4 por si hay cambios.

Y si te pasa lo mismo en 15.3 , tiene que haber algo que falta.

Hay algo que si se puede hacer, la 1ª vez en una instalación nueva, sin ser actualización y sin añadir repositorios, solo los que figuran en los comunitarios, y es cambio de prioridad a packman a 70 y desde consola zypper dup , de que añadas algún repo, o las veces posteriores, ya no se debe usar dup, si no up , o sea zypper up (excepto TW, que lo que hace es cambiar de versión cada vez que actualice) .

Saludos cordiales .

DiabloRojo
09-Jun-2022, 01:41
Para que los codecs funcione en Leap 15.4 es necesario añadir los repos Packman y dvd, instalar los codecs desde ahi y cambiar los paquetes al proveedor Pacman.

Aquí te lo explica, te en cuenta una cosa, yo tienes 15.4 y se habla de 15.3, solo cambia la parte del repo de _15.3 a _15.4: https://victorhck.gitlab.io/guia_openSUSE/codecs.html

vipamon
09-Jun-2022, 06:31
vipamon@localhost:~> su
Contraseña:
localhost:/home/vipamon # zypper addrepo -f http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/ packman
Añadiendo el repositorio packman ......................................................................................................................................................................................................................................[error]
Ya existe un repositorio con el nombre 'packman'. Utilice otro alias.
localhost:/home/vipamon # zypper addrepo -f http://opensuse-guide.org/repo/openSUSE_Leap_15.4/ dvd
Añadiendo el repositorio dvd ......................................................................................................................................................................................................................................[terminado]
El repositorio 'dvd' se ha añadido correctamente

URI : http://opensuse-guide.org/repo/openSUSE_Leap_15.4/
Habilitado : Sí
Comprobación GPG : Sí
Actualización automática : Sí
Prioridad : 99 (prioridad por defecto)

Prioridades del repositorio en vigor: (Consulte 'zypper lr -P' para obtener más información)
90 (prioridad aumentada) : 1 repositorio
99 (prioridad por defecto) : 19 repositorios
localhost:/home/vipamon #




Los errores que me aparecen los subo a mediafire en texto, porque no deja postearlos.

https://www.mediafire.com/file/ivzw0cyflbyuly5/Instalaci%25C3%25B3n_mediante_la_l%25C3%25ADnea_de_comandos.txt/file

https://www.mediafire.com/file/da14dzab2nrwyic/Instalaci%25C3%25B3n_mediante_la_l%25C3%25ADnea_de_comandos_2.txt/file

DiabloRojo
09-Jun-2022, 06:51
Los errores que me aparecen los subo a mediafire en texto, porque no deja postearlos.

https://www.mediafire.com/file/ivzw0cyflbyuly5/Instalaci%25C3%25B3n_mediante_la_l%25C3%25ADnea_de_comandos.txt/file

https://www.mediafire.com/file/da14dzab2nrwyic/Instalaci%25C3%25B3n_mediante_la_l%25C3%25ADnea_de_comandos_2.txt/fileTienes problemas con los repos por lo que veo, vete a este hilo y reporta tus repos, sigue las instrucciones
Comprobar idoneidad de los repositorios (https://forums.opensuse.org/showthread.php/567064-Comprobar-idoneidad-de-los-repositorios)

karlggest
09-Jun-2022, 06:59
Hola.

Tenemos un servicio para subir imágenes y ficheros de texto: https://paste.opensuse.org

Sobre el post, bien, los mensajes te dicen que estás intentendo añadir repositorios que ya se llaman así, y eso es porque ya los tienes por lo que sea.

En el artículo de victorhck tienes un botón rojo muy chulo que instalará los códecs, al menos los que no estén ya instalados. No te compliques. Por lo demás, deberías de borrar esos repositorios packman y dvd que tienes ahora (o opensuse-guide). Yo usaría YaST -> Repositorios de software y eleminaría ambos antes de hacer nada.

Otra forma de instalar los codecs es usando opi (en terminal): https://es.opensuse.org/Search_opi

Salud!!

vipamon
09-Jun-2022, 12:34
Solucionado.

Abrir discover




Desistalar GStreamer Multimedia Codecs y GStreamer Multimedia Codecs Extra


Abrir la consola y escrivir su, poner el password de administrador y ejecutar los siguientes codigos






zypper addrepo -f http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/ packman


zypper addrepo -f http://opensuse-guide.org/repo/openSUSE_Leap_15.4/ dvd


zypper dup --from http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/

DiabloRojo
10-Jun-2022, 01:11
Me alegro de que lo hayas solucionado. :good:

vipamon
10-Jun-2022, 05:52
Abrir discover


https://i.servimg.com/u/f57/16/80/16/45/01_abr10.png






Buscar codecs


https://i.servimg.com/u/f57/16/80/16/45/02_bus10.png






Desistalar GStreamer Multimedia Codecs y GStreamer Multimedia Codecs Extra


https://i.servimg.com/u/f57/16/80/16/45/03_des10.png






Abrir la consola y escribir su, poner el password de administrador y ejecutar los siguientes codigos


zypper addrepo -f http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/ packman

zypper addrepo -f http://opensuse-guide.org/repo/openSUSE_Leap_15.4/ dvd

zypper dup --from http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/

vipamon
11-Jun-2022, 07:06
No se si soi masoca o que, e instalado otra vez el opensuse y e seguido los mismos pasos y a ora no me los lee en la nueva instalación.


e escrito zypper repos y me aparece lo siguiente.


localhost:/home/vipamon # zypper repos
Prioridades del repositorio en vigor: (Consulte 'zypper lr -P' para obtener más información)
90 (prioridad aumentada) : 1 repositorio
99 (prioridad por defecto) : 3 repositorios

# | Alias | Name | Enabled | GPG Check | Refresh
---+-----------------------------+---------------------------------------------------------------------------------------------+------------+------------------+-----------
1 | dvd | dvd | Sí | ( p) Sí | Sí
2 | packman | Packman | Sí | ( p) Sí | Sí
3 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No | ---- | ----
4 | repo-debug | Debug Repository | No | ---- | ----
5 | repo-debug-non-oss | Debug Repository (Non-OSS) | No | ---- | ----
6 | repo-debug-update | Update Repository (Debug) | No | ---- | ----
7 | repo-non-oss | Repositorio Non-OSS | Sí | (r ) Sí | Sí
8 | repo-sle-debug-update | Update repository with debuginfo for updates from SUSE Linux Enterprise 15 | No | ---- | ----
9 | repo-source | Source Repository | No | ---- | ----
10 | repo-update-non-oss | Repositorio de actualizaciones (No OpenSource) | Sí | (r ) Sí | Sí




Cuando escribo

zypper dup --from http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/


Me aparece lo siguiente


localhost:/home/vipamon # zypper dup --from http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/

Se ha recibido una nueva clave de firma para el repositorio o paquete:

Repositorio: dvd
Huella digital de la clave: BB43 B333 6DDF 49C5 C5A6 3613 B2F7 96E7 6867 F5BE
Nombre de la clave: Martin Schlander (cb400f) <martin.schlander@gmail.com>
Algoritmo de cifrado: DSA 1024
Clave creada: mié 09 mar 2011 20:02:37
La clave caduca: (no caduca)
Subclave: D1327E059D80BB97 2008-10-18 [caducado: 2010-10-18]
Nombre de rpm: gpg-pubkey-6867f5be-4d77cecd



Nota: Firmar los datos permite al destinatario verificar que no se han producido modificaciones
después de la firma. Aceptar datos sin sumas de verificación o con sumas incorrectas o
desconocidas puede provocar daños en el sistema y, en casos extremos, incluso que el sistema se
vea comprometido.

Nota: Una clave GPG se identifica claramente por su huella. No confíe en los nombres de las
claves. Si no está seguro si la clave presentada es auténtica, consulte al proveedor del
repositorio o verifique su sitio web. Muchos proveedores mantienen una página web que muestra
las huellas de las claves GPG que están utilizando.

¿Desea rechazar la clave, confiar en ella temporalmente o confiar en ella siempre? [r/t/a/?] (r): r
Recuperando los metadatos del repositorio 'dvd' ...........................................................................................................................[error]
El repositorio 'dvd' no es válido.
[dvd|http://opensuse-guide.org/repo/openSUSE_Leap_15.4/] No se han encontrado metadatos válidos en la URL especificada
Historial:
- Signature verification failed for repomd.xml
- Can't provide /repodata/repomd.xml

Compruebe si los URI definidos para este repositorio apuntan a un repositorio válido.
Advertencia: Se va a omitir el repositorio 'dvd' debido al error anterior.

Se ha recibido una nueva clave de firma para el repositorio o paquete:

Repositorio: Packman
Huella digital de la clave: F887 5B88 0D51 8B6B 8C53 0D13 45A1 D067 1ABD 1AFB
Nombre de la clave: PackMan Project (signing key) <packman@links2linux.de>
Algoritmo de cifrado: RSA 4096
Clave creada: mar 16 sep 2014 00:18:00
La clave caduca: vie 13 sep 2024 00:17:21
Nombre de rpm: gpg-pubkey-1abd1afb-54176598



Nota: Firmar los datos permite al destinatario verificar que no se han producido modificaciones
después de la firma. Aceptar datos sin sumas de verificación o con sumas incorrectas o
desconocidas puede provocar daños en el sistema y, en casos extremos, incluso que el sistema se
vea comprometido.

Nota: Una clave GPG se identifica claramente por su huella. No confíe en los nombres de las
claves. Si no está seguro si la clave presentada es auténtica, consulte al proveedor del
repositorio o verifique su sitio web. Muchos proveedores mantienen una página web que muestra
las huellas de las claves GPG que están utilizando.

¿Desea rechazar la clave, confiar en ella temporalmente o confiar en ella siempre? [r/t/a/?] (r): r
Recuperando los metadatos del repositorio 'Packman' .......................................................................................................................[error]
El repositorio 'Packman' no es válido.
[packman|https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/] No se han encontrado metadatos válidos en la URL especificada
Historial:
- Signature verification failed for repomd.xml
- Can't provide /repodata/repomd.xml

Compruebe si los URI definidos para este repositorio apuntan a un repositorio válido.
Advertencia: Se va a omitir el repositorio 'Packman' debido al error anterior.
Algunos de los repositorios no se han actualizado debido a un error.
Cargando datos del repositorio...
Leyendo los paquetes instalados...
Calculando actualización de distribución...
No se ha encontrado el repositorio 'http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/' por su alias, número o URI.
Utilice 'zypper repos' para obtener la lista de los repositorios definidos.

krovikan
11-Jun-2022, 09:02
A veces pasa. Entra en Yast, refresca todos los repos y acepta todo lo que te pida confiar.

Y en serio, olvida ese programa por ahora.

Primero es arreglar tus repos en el otro hilo. Aparca este hilo por ahora.


Saludos

vipamon
12-Jun-2022, 04:43
Solucion para Opensuse:


Abrir discover


https://i.servimg.com/u/f57/16/80/16/45/01_abr10.png






Buscar codecs


https://i.servimg.com/u/f57/16/80/16/45/02_bus10.png






Desistalar GStreamer Multimedia Codecs y GStreamer Multimedia Codecs Extra


https://i.servimg.com/u/f57/16/80/16/45/03_des10.png






Abrir la consola y escribir su, poner el password de administrador y ejecutar el siguiente comando


egrep '^(VERSION|NAME)=' /etc/os-release && zypper lr -Epu


Veras los repositorios.


Contraseña:
localhost:/home/vipamon # egrep '^(VERSION|NAME)=' /etc/os-release && zypper lr -Epu

NAME="openSUSE Leap"

VERSION="15.4"

# | Alias | Name | Enabled | GPG Check | Refresh | Priority | URI

---+-----------------------+--------------------------------------------------------------+------------+------------------+------------+-----------+------------------------------
------------------------------------

3 | repo-backports-update | Update repository of openSUSE Backports | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
update/leap/15.4/backports/

8 | repo-non-oss | Repositorio Non-OSS | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
distribution/leap/15.4/repo/non-oss/

9 | repo-oss | Repositorio principal | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
distribution/leap/15.4/repo/oss/

11 | repo-sle-update | Update repository with updates from SUSE Linux Enterprise 15 | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
update/leap/15.4/sle/

13 | repo-update | Repositorio principal de actualizaciones | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
update/leap/15.4/oss

14 | repo-update-non-oss | Repositorio de actualizaciones (No OpenSource) | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/
update/leap/15.4/non-oss/






Borrar los repositorios, ejemplo.


zypper rr 2



Descargar los repositorios:


https://www.mediafire.com/file/khxptt9lu264xfy/Lista.repo/file








Ahora has de importar los repos del fichero. Para ello teclea:




sudo zypper ar /home/donde_hayas_descargado_el_fichero/Lista.repo


Ejemplo:
sudo zypper ar /home/vipamon/Descargas/Lista.repo












Instalar los codecs:


https://opensuse-community.org/



Ahora funciona pero quiero saber como instalar los codecs con comandos.
esta vez lo e probado en 3 opensuse.

karlggest
12-Jun-2022, 08:42
Hola.

El único asunto es saber si tienes o no los repos adecuados. Si no los tienes, los añades. Luego instalas los códecs.

En sección "usando terminal" tienes los comandos tanto para añadir los repositorios packman y libdvdcss si no los tienes aún como la forma de:

Instalar los códecs y software necesarios que no vienen con la distribución.
Actualizar los paquetes multimedia instalados que pueden estar capados en la versión oficial por temas de licencia a las versiones sin capar disponibles en packman.


Lo más mejor de openSUSE es que cuantas más formas de hacer las cosas de forma simple se añaden, más se persiste en las viejas. La forma de instalar códecs (y otro software comunitario) desde el terminal se describe aquí: https://es.opensuse.org/Search_opi#Instalación

Salud!!

vipamon
12-Jun-2022, 08:55
El problema no era los repositorios si no los codecs, en otra PC e instalado los codecs de https://opensuse-community.org/ sin tocar los repositorios y lee los videos.
lo que no se el comando para instalar los codecs de esta pagina.

karlggest
12-Jun-2022, 10:48
Hola.

Aunque dicen que "no hay como preguntar si quieres que te respondan algo", lo cierto es que "no hay como leer/escuchar para tener una respuesta". En la misma página que enlazas de openSUSE-guide tiene una sección para la instalación desde el terminal.

La otra opción es con opi, ya ves tú:

sudo opi codecs

Por su parte, openSUSE Leap sí instala códecs: no instala todos los códecs. Y algunos programas de los que vienen con la distribución puede que no puedan usar esos códecs que no instala el proceso de instalación ni aun cuando los instales posteriormente a menos que instales una versión de la aplicación que sí pueda hacerlo.

Y aquí acaba todo lo necesario respecto a los códecs, no hay mucho más. La mayoría de usuarios añadimos el repositorio packman y cambiamos las versiones oficiales de muchos de los programas y librerías, incluidos códecs, que instala la distribución por los contenidos en dicho repositorio. Es posible que a día de hoy muchos ni haga falta, pero primero por costumbre y luego por no tener que verificar si un paquete determinado es suficiente o no: si está en packman, lo cambiamos a dicha versión.

Salud!!

vipamon
13-Jun-2022, 03:59
Hola.

Aunque dicen que "no hay como preguntar si quieres que te respondan algo", lo cierto es que "no hay como leer/escuchar para tener una respuesta". En la misma página que enlazas de openSUSE-guide tiene una sección para la instalación desde el terminal.

La otra opción es con opi, ya ves tú:

sudo opi codecs

Por su parte, openSUSE Leap sí instala códecs: no instala todos los códecs. Y algunos programas de los que vienen con la distribución puede que no puedan usar esos códecs que no instala el proceso de instalación ni aun cuando los instales posteriormente a menos que instales una versión de la aplicación que sí pueda hacerlo.

Y aquí acaba todo lo necesario respecto a los códecs, no hay mucho más. La mayoría de usuarios añadimos el repositorio packman y cambiamos las versiones oficiales de muchos de los programas y librerías, incluidos códecs, que instala la distribución por los contenidos en dicho repositorio. Es posible que a día de hoy muchos ni haga falta, pero primero por costumbre y luego por no tener que verificar si un paquete determinado es suficiente o no: si está en packman, lo cambiamos a dicha versión.

Salud!!

Pues no veo por ningun lado el comando en la paguina, y el comando sudo opi codecs no instala los codecs necesarios.


sudo opi codecs