PDA

View Full Version : LEAP 15.3 Actualizar versión de GNOME Shell



asurraco
13-May-2022, 13:16
Buenas tardes, estoy teniendo un problema con la versión de GNOME Shell que tiene instalada mi versión de suse.

La versión que tiene instalada es la GNOME Shell 3.34.5, debido a un problema de compatibilidad con la extensión Hide Top Bar estoy necesitando actualizar la versión de GNOME Shell a una mas actual que soporte esta extensión.

El problema que ya he probado varias maneras, he instalado varias actualizaciones que tenía pendiente pero sigo sin poder actualizar la versión de GNOME Shell.

Ahora la duda es: Es posible actualizar la versión de GNOME Shell a una mas reciente o en suse LEAP 15.3 o no tengo posibilidad?

Alguien podría guiarme un poco en este tema?

Desde ya muchas gracias

Saludos

krovikan
13-May-2022, 13:46
Por lo que he podido ver en el centro de software de opensuse --> https://software.opensuse.org/package/gnome-shell

es imposible de resolver varias dependencias de las versiones 40.x y 41.x.

Puedes verlo en el enlace que te he puesto haciendo click en el botón Show de "Unsupported distributions" y bajar hasta llegar a la sección SUSE:SLE-15:GA.

De los varios enlaces que salen, haciendo click en el enlace de alguno de ellos, verás que todos los 40.x y 41.x que tengan en la columna "Build results" situada a la derecha la línea openSUSE_Leap_15.3 saldrá siempre Unresolvable en rojo.

Como muestra: https://build.opensuse.org/package/show/home%3Ayfjiang%3Abranches%3AGNOME%3ASTABLE%3A41/gnome-shell

En cambio SLE_15_SP4 sale como succeeded, que es una esperanza para que el Leap 15.4 que sale en menos de 1 mes lo traiga funcional.


Saludos

malcolmlewis
13-May-2022, 16:04
~/.local/share/gnome-shell/extensions/hidetopbar..../metadata.json

https://github.com/mlutfy/hidetopbar/blob/master/metadata.json





"shell-version": ["3.38","40","41","42"],


"shell-version": ["3.34","3.38","40","41","42"],



ALT+F2 r <enter>

DiabloRojo
14-May-2022, 04:11
Bienvenido al foro, asurraco :good: