PDA

View Full Version : Aktualizacja samby tumbleweed i problem z logowaniem - Security User



StargatePL
22-Apr-2022, 01:39
Problem z logowaniem i korzystaniem zdalnie z samby po aktualizacji systemu " zypper dup" - samba 4.16.0+git.227.931848a12ab-1.1 - do tej pory wszystko chodziło ok.
/etc/samba/smb.conf
[global]
workgroup = WORKGROUP
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
# usershare allow guests = Yes
usershare allow guests = No
security = user
template shell = /bin/bash
workgroup = home
netbios name = desk
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
user = piotr,@sambausers,@users
username = piotr,@sambausers,@users
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
----------------------------------------------
/var/log/samba/log.smbd

[2022/04/22 10:23:46.152409, 0] ../../lib/param/loadparm.c:1791(lpcfg_do_service_parameter)
Ignoring unknown parameter "user"
[2022/04/22 10:23:46.152456, 0] ../../lib/param/loadparm.c:747(lpcfg_map_parameter)
Unknown parameter encountered: "username"

W dolphin, przy próbie ustawieniu udostępniania katalogu pojawia się komunikat:
"Wystąpił błąd przy próbie udostępnienia katalogu. Udział nie został utworzony.
Samba wewnętrznie zgłasza:
net usershare add: cannot convert name "Everyone" to a SID. {Access Denied} A process has requested access to an object but has not been granted those access rights.."


Jak poprawnie skonfigurować sambę by z niej teraz korzystać?

/var/log/samba/log.nmbd



*****
[2022/04/22 10:52:02.599291, 0] ../../source3/nmbd/nmbd.c:59(terminate)
Got SIGTERM: going down...
[2022/04/22 10:52:02, 0] ../../lib/param/loadparm.c:1060(lp_set_enum_parm)
WARNING: Ignoring invalid value 'share' for parameter 'security'
Can't load /etc/samba/smb.conf - run testparm to debug it
nmbd - Failed to load config file!
[2022/04/22 10:54:14, 0] ../../lib/param/loadparm.c:1060(lp_set_enum_parm)
WARNING: Ignoring invalid value 'share level' for parameter 'security'
Can't load /etc/samba/smb.conf - run testparm to debug it
nmbd - Failed to load config file!
[2022/04/22 10:55:39.510857, 0] ../../source3/nmbd/nmbd.c:901(main)
nmbd version 4.16.0-git.227.931848a12abSUSE-oS15.9-x86_64 started.
Copyright Andrew Tridgell and the Samba Team 1992-2022
[2022/04/22 10:56:02.540010, 0] ../../source3/nmbd/nmbd_become_lmb.c:398(become_local_master_stage2)
*****


Samba name server DESK



Taki log był ustawieniem SECURITY LEVEL - Share
W przypadku SECURITY LEVEL - user
-> /var/log/messages
"
2022-04-22T11:43:46.151153+02:00 localhost smbd[8856]: Unknown parameter encountered: "user"
2022-04-22T11:43:46.151264+02:00 localhost smbd[8856]: [2022/04/22 11:43:46.150142, 0] ../../lib/param/loadparm.c:1791(lpcfg_do_service_parameter)
2022-04-22T11:43:46.151358+02:00 localhost smbd[8856]: Ignoring unknown parameter "user"
2022-04-22T11:43:46.151465+02:00 localhost smbd[8856]: [2022/04/22 11:43:46.150191, 0] ../../lib/param/loadparm.c:747(lpcfg_map_parameter)
2022-04-22T11:43:46.151584+02:00 localhost smbd[8856]: Unknown parameter encountered: "username"
"


Skompilowałem ze źródełek samba-4.16.0.tar.gz i wszystko chodzi :)

pbojczuk
23-Apr-2022, 14:58
Problem z logowaniem i korzystaniem zdalnie z samby po aktualizacji systemu " zypper dup" - samba 4.16.0+git.227.931848a12ab-1.1 - do tej pory wszystko chodziło ok.

Skoro przed aktualizacją wszystko działało, to dlaczego nie spróbowałes obniżyć jedynie wersji samby do poprzedniej, w/g Ciebie działającej wersji? W ten sposób byś wiedział, czy obwiniać paczkę, czy też konfigurację.

Oczywiście nikt nie broni Ci korzystać ze źrodeł i aktualizować samby co chwila kompilując ją samodzielnie do nowszj wersji.

No i na przyszość polecam korzystać z:
http://paste.opensuse.org/

Ułatwi to innym przeglądanie Twoich logów - zwłaszcza tych dłuższych.

StargatePL
24-Apr-2022, 09:17
Znalazłem w logach działająca ostatnio wersję samby przed aktualizacją -to |4.14.6+git.168.6a9fc8a1ddd-1.1|x86_64 na wersję 4.16.0+git.224.70319beb8f8-1.1|x86_64| - która miała problem z "security = user" i nie można było się zalogować do katalogów.