PDA

View Full Version : OTHER VERSION adaptador TP-link rtl8812au



ajunior1208
15-Mar-2022, 11:41
Buenas tardes a tod@s. Tengo instalado en mi PC Tumbleweed. Actualmente se encuentra con el kernel: 5.16.14-1-default. He comprado el adaptador usb rtl8812au y no hay forma de que pueda instalarlo. Tengo instalado dkms:2.6. Tengo habilitado el repositorio /Ximi1970:/Dkms:/staging/openSUSE_Tumbleweed/ que supuestamente no debería darme problemas en una actualización. Eso por que el adaptador funcionaga cuando yo tenia el kernel source-5.16.11-1.1.x86_64 y al ser actualizado ya no cubrio mas y no logro la compilacion anterior mismo eliminando todos lo que habia instalado antes. Encuentro muchas guías pero ninguan me ha funcionado. No sé si estoy brindando todas las informaciones necesarias. Cualquier duda estoy abierto a responderlas. Gracias.

nemonix
15-Mar-2022, 14:32
Hola, no dices que tienes instalado...
https://software.opensuse.org/package/rtl8812au

ajunior1208
15-Mar-2022, 15:26
Hola pingüino estudiante. Sí, ya lo tenía instalado. Me fui al link que me diste y lo instalé. Absolutamente nada. Te agradezco haberme respondido. Pero creo que dejaré de lado esa instalación. Hace más de un mes que vengo luchando para su instalación. Muchas gracias.

nemonix
15-Mar-2022, 16:27
Hola siempre viene bien pasar mas info si no te puedo ayudar, otros a lo mejor si pueden ayudarte.

sudo lsmod | grep 8812au

lsusb

sudo dkms status

saludos.

nemonix
15-Mar-2022, 16:36
sudo dkms autoinstall
Reconstruye todos los módulos para el kernel que se está ejecutando.

mikrios
15-Mar-2022, 17:06
Hola:

Haber si por despiste, tienes parado dkms (tiene que estar activo en el cambio del kernel) .

Yast----> gestión de servicios------> dkms -----> iniciar: durante el arranque ; estado : activo ( en ejecución) ya sea para drivers, virtualbox, etc...

Ademas debe haber un directorio en /etc/dkms/ .

Vuelve a intentar lo como te comentan haber si a la 2ª va la vencida .

Saludos cordiales .

nemonix
16-Mar-2022, 08:44
Hola, he descomprimido el rpm rtl8812au-kmp-default-5.9.3.2+git20210427.6ef5d8f_k5.16.14_1-3.15.x86_64 y por lo visto lo instala en /usr/lib/modules/5.16.14-1-default/updates/8812au.ko cuando debería ser en lib/modules/5.16.14-1-default/updates/8812au.ko.
en Leap 15.3 lo instala en lib/modules/5.3.18-57-default/updates/8812au.ko
saludos.

ajunior1208
23-Mar-2022, 09:28
Hola:

Haber si por despiste, tienes parado dkms (tiene que estar activo en el cambio del kernel) .

Yast----> gestión de servicios------> dkms -----> iniciar: durante el arranque ; estado : activo ( en ejecución) ya sea para drivers, virtualbox, etc...

Ademas debe haber un directorio en /etc/dkms/ .

Vuelve a intentar lo como te comentan haber si a la 2ª va la vencida .

Saludos cordiales .

Hola, mikrios. Mucho he intentado instalar tal dispositivo. En todas las opciones que me han presentado ninguna me había dicho o insinuado que yo debería iniciar y mantener el servicio dkms activo. Y después de muchos intentos resolví hacer una instalación limpia ya que la que usaba fue la primera ya que venía de Leap 15. Seguí tu orientación y de primero logré activar el dispositivo. Activé el dkms de forma que se inicie con el sistema. Es decir, a probar caramba. Pero estoy optimista que ahora sí va a funcionar. Gracias por tu TIP. Daré una feedback con la próxima actualización. Gracias amigo.