PDA

View Full Version : TUMBLEWEED Instalar RPM con YAST?



leo777
20-Nov-2021, 04:02
Buenos días y saludos a todos, acabo de logearme en el foro y aprovecho para desearos salud y bienestar a todos.

Soy usuario de Tumbleweed KDE y a la hora de instalar un paquete RPM externo, YAST me tira siempre el mismo error, que indico abajo; con discover, a veces instala y otras no, y casi siempre me tengo que ir a zypper para proceder. He reinstalado YAST pero la cosa sigue igual. Espero a ver si alguien me indica que pasa, gracias anticipadas.


Internal error. Please report a bug report with logs.

Run save_y2logs to get complete logs.




Caller: /usr/share/YaST2/lib/ui/ui_extension_checker.rb:93:in `exist?'




Details: no implicit conversion of nil into String

DiabloRojo
20-Nov-2021, 07:41
Prueba el comando rpm

sudo rpm -ivh nombre-completo-del-paquete.rpm

malcolmlewis
20-Nov-2021, 08:22
https://forums.opensuse.org/showthread.php/562574-Google-Earth-Not-Installing?highlight=ui_extension_checker.rb

leo777
20-Nov-2021, 08:25
Si que funciona, pero yo me refiero a dar clic derecho en el paquete y decirle que lo instale con YAST

malcolmlewis
20-Nov-2021, 08:28
Si que funciona, pero yo me refiero a dar clic derecho en el paquete y decirle que lo instale con YAST
Hi
Parece que está roto

openSUSE:Submitting bug reports - openSUSE (http://en.opensuse.org/openSUSE:Submitting_bug_reports)

mandrivaONE07
05-Apr-2022, 16:41
Hola, si hay algo bueno en openSUSE, es que los repositorios de software con packman (http://packman.links2linux.org/), tienen todos los paquetes que existen para Linux... no existe razón alguna para que intentes instalar "un paquete externo"; por lo demás, Yast como gestor de paquetes es horrendo, hay que ir uno a uno, no puedes seleccionar varios paquetes a la vez para instalar reinstalar!


Buenos días y saludos a todos, acabo de logearme en el foro y aprovecho para desearos salud y bienestar a todos.

Soy usuario de Tumbleweed KDE y a la hora de instalar un paquete RPM externo, YAST me tira siempre el mismo error, que indico abajo; con discover, a veces instala y otras no, y casi siempre me tengo que ir a zypper para proceder. He reinstalado YAST pero la cosa sigue igual. Espero a ver si alguien me indica que pasa, gracias anticipadas.


Internal error. Please report a bug report with logs.


Run save_y2logs to get complete logs.




Caller: /usr/share/YaST2/lib/ui/ui_extension_checker.rb:93:in `exist?'




Details: no implicit conversion of nil into String

victorhck
06-Apr-2022, 08:14
Hola mandrivaONE07.

Por favor no escribas con fuentes grandes tus mensajes. Gracias.

Cierto que Packman tiene un montón de software disponible, pero cada usuario tiene unas necesidades y cada cual sabe qué necesita y ahí está lo bueno, que tienes libertad para poder instalarte paquetes externos si lo deseas.

En YaST puedes buscar varios paquetes, marcarlos e instalar varios a la vez si lo deseas.

Saludos.