PDA

View Full Version : LEAP 15.3 Pulse Secure cliente



soyasi
29-Oct-2021, 14:10
Pulse Secure es una empresa absorvida por ivanti.

Hace poco, en el canal de Telegram "openSUSE español (https://t.me/openSUSE_ES)", el compañero @cascode09, preguntaba como instalar el cliente VPN de Pulse Secure, es un programa que nunca había usado, ya que es software privativo.
En los repositorios de openSUSE obviamente no hay ningún rpm, pero si encontramos en varias universidades, la redireccion al archivo rpm para Centos/RedHat:

Universidad de Amsterdan (https://student.uva.nl/en/content/az/uvavpn/download/download-uvavpn-software.html?cb) ------> https://surfdrive.surf.nl/files/index.php/s/TgLO0NfbOKS4vtB/download (ps-pulse-linux-9.1r11.0-b6725-64-bit-installer.rpm)

Instituto Tecnológico de Israel (https://cis.technion.ac.il/en/central-services/communication/off-campus-connection/ssl-vpn/install-pulse-client-linux/) --> http://webdev.web3.technion.ac.il/docs/cis/public/ssl-vpn/ps-pulse-centos-rhel.rpm (ps-pulse-centos-rhel.rpm)

Este paquete es funcional, pero hay que decirle cuando lo instalas que rompa la dependencia con libbsd, ya que el nombre en openSUSE es libbsd0.

https://i.ibb.co/cJwBFm9/photo-2021-10-11-15-12-08.jpg

Antes de instalar el paquete rpm de Pulse Secure, comprueba que tienes instaladas o instala las siguientes dependencias:


sudo zypper in libcairomm-1_0-1 libglibmm-2_4-1 libpangomm-1_4-1 libgiomm-2_4-1 libatkmm-1_6-1 libgtkmm-3_0-1 libbsd0 libbsd-devel

Instalada las dependencias y el paquete rpm de Pulse Secure, ya solo tienes que conectarte.


https://i.ibb.co/VCmMp4H/photo-2021-10-29-21-54-30.jpg (https://ibb.co/n1CQ8J3)


Nota: "Pulse Secure" es un cliente que se podría usarse con los paquetes openconnect de networkmanager, pero es la empresa la que debería de facilitar los parámetros de conexión o el archivo .conf