PDA

View Full Version : Zacinające się filmy



GarryMoveOut
03-Sep-2021, 00:08
Niedawno zainstalowałem OpenSuse Tumbleweed, zainstalowałem kodeki zgodnie z tym poradnikiem (https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories) ale filmy HD lub FHD się zacinają podczas odtwarzania. Próbowałem różne filmy (mp4, mkv) nawet te z którymi nigdy nie miałem problemów i zacinają się że nie da się ich oglądać. Wcześniej miałem Fedorę i tam nie było problemów. Nie wiem w czym problem, jak sobie z tym poradzić?

Laptop Asus K52JC

przem
03-Sep-2021, 16:08
W Leap 15.2 jaki miałem poprzednio zainstalowany, również występował problem z lekko zacinającymi się starymi AVI, odtwarzanymi lokalnie. jednak dało się ogladać. Obecnie użytkuję 15.3 i... nie mam pojęcia jak wyglada obecnie sytułacja z multimediami. Naprawdę rzadko oglądam filmy. Pewnie nie pomogłem.

ps. jednak teledyski na yt odtwarzane są bardzo dobrze, przynajmniej pod chrome.

Rozumiem że filmy są odtwarzane z dysku a nie z napędu optycznego - którego obsługa kuleje w Pingwine. Zapomniałem wspomnieć o tym wcześniej.

GarryMoveOut
04-Sep-2021, 11:23
Tak z dysku (SSD) są odtwarzane, z YT nie tną się.

szwagier
05-Sep-2021, 06:18
Przyczyn może być kilka. Słaba karta graficzna, zatkana pamięć, za mały swap.
System za często buforuje, stąd te przycięcia. Instalowanie Tumbleweed z KDE na laptopie to raczej kiepski pomysł.
Radził bym ci stabilny Leap 15.3 ale z pulpitem Xfce a nie KDE - Xfce nie zamula tak pamięci jak KDE.
Możesz też wypróbować MX Linux - to chyba najlepszy system na laptopy.
Pamiętaj że w Suse multimediami rządzi Packman. Częste aktualizacje systemu szczególnie w Tumbleweed mogą podmienić jego kodeki, dlatego co jakiś czas trzeba przełączać pakiety systemowe w repo Packmana.

przem
05-Sep-2021, 12:11
Jeśli masz zainstalowane Chrome ( nie Chromium) to spróbuj odtworzyć dowolną zacinającą mp4 w przeglądarce. Chrome ma własne kodeki, dostarczane w pakiecie. Możliwe że nie będzie dźwięku, ale to nie istotne, chodzi tylko o przetestowanie.
Powodzenia



Pamiętaj że w Suse multimediami rządzi Packman. Częste aktualizacje systemu szczególnie w Tumbleweed mogą podmienić jego kodeki, dlatego co jakiś czas trzeba przełączać pakiety systemowe w repo Packmana.

Gdyby aktualizacje faktycznie były by w stanie podmienić kodeki z Packmana na te domyślne, to nic by nie obejrzał !

BTW sprawdziłem film w rozdzielczości HD Ready i nic nie zacina. poprzednie problemy sprzed roku mogły wynikać z powolnego nośnika (pendrive).

GarryMoveOut
07-Sep-2021, 01:09
Na Fedorze z KDE nie miałem problemu na tym laptopie. A przesiadłem się tylko z powodu Wayland który nie był stabilny. Nie wiem może to problem sterowników. Wcześniej jak miałem openSuse zanim przesiadłem się na Fedorę też wszystko działało poprawnie. Mój laptop ma dwie kart jedną w procesorze i5 a druga to GeForce 310M. Ale obie powinny sobie z tym poradzić.

przem
08-Sep-2021, 10:31
Wspomniałeś że filmy na yt prawidłowo są odtwarzane, więc sterowniki kart graficznych działają prawidłowo, więc i kodeki również są ok. Obstawiał bym któryś z modułów jądra z dostępem do dysku, używasz może BTRFS ? Mi on sprawia "psikusy" w postaci śmieci w folderze domowym. Być może w świeższym wydaniu kernela ten moduł otrzymał jakieś łatki. Spróbuj (jak możesz) za bootować z poprzednią wersją kernela. Lub po prostu poczekaj na aktualizacje.