PDA

View Full Version : Kan geen verbinding met internet krijgen.



jkvl
02-Feb-2019, 05:18
Heb op een Lenovo type Yoga 530 Suse Leap 15 geïnstalleerd.


Werk er nu een paar maanden met volle tevredenheid met het systeem.
Echter vanochtend wil het systeem geen verbinding met het internet maken.
Als eerste heb ik het hele systeem gereset. Dus alles opnieuw opgestart.
Dus de infrastructuur staat er volgens mij prima bij.

Ik heb een dual systeem.
Dus de laptop op Microsoft opgestart. (auw)
De Microsoft Windows 10 draait wel prima en maakt gewoon verbinding met het internet.
Zowel bekabeld als met Wifi.

Mijn tablets (appel en android) draaien ook allemaal (Wifi verbindingen)

Laptop opnieuw opgestart op Suse Leap. Niets werkt! Zowel bekabeld als met Wifi



Nu heb ik van de week een aantal updates laten plaatsen is er iets bekend of daar wat mis mee is.

Heeft iemand een suggestie?

hcvv
02-Feb-2019, 06:03
Ten eerste willen we altijd graag weten waarom je denkt dat je geen verbinding hebt met het internet.

En verder vindt je hier een logisch stappenplan: https://forums.opensuse.org/showthread.php/503845-Korte-uitleg-Netwerk-problemen-eerste-analyse

jkvl
02-Feb-2019, 07:21
Henk bedankt voor je snelle reactie.

Verbinding
Mijn eerste indruk dat ik met Suse Leap 15 geen verbinding met het internet kon krijgen was dat mijn browser geen verbinding kon opbouwen. Daarna andere apparaatjes getest. Als controle MS Windows opgestart.
Alles liep “normaal”, daarom het vermoeden dat Suse leap 15 de verbinding niet goed opbouwt. Als redmiddel jullie hulp ingeroepen.


Het stappenplan
Hier de resultaten


linux-plcj:~ # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:60:6e:63:b1:7a brd ff:ff:ff:ff:ff:ff
inet 192.168.1.74/24 brd 192.168.1.255 scope global noprefixroute dynamic eth1
valid_lft 85701sec preferred_lft 85701sec
inet6 fe80::5f93:5da4:201f:f780/64 scope link noprefixroute
valid_lft forever preferred_lft forever




linux-plcj:~ # ping -cl 192.168.1.1
ping: bad number of packets to transmit.

Even –cl weggelaten (waar dient -cl voor)
linux-plcj:~ # ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.726 ms


Naar buiten?
linux-plcj:~ # ip route
default via 192.168.1.1 dev eth1 proto dhcp metric 20100
192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.74 metric 100


linux-plcj:~ # ping -cl 130.57.66.6
ping: bad number of packets to transmit.


Ook hier even -cl weggelaten
linux-plcj:~ # ping 130.57.66.6
PING 130.57.66.6 (130.57.66.6) 56(84) bytes of data.
64 bytes from 130.57.66.6: icmp_seq=1 ttl=46 time=161 ms
64 bytes from 130.57.66.6: icmp_seq=2 ttl=46 time=161 ms
64 bytes from 130.57.66.6: icmp_seq=3 ttl=46 time=160 ms
64 bytes from 130.57.66.6: icmp_seq=4 ttl=46 time=160 ms
^C
--- 130.57.66.6 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3006ms
rtt min/avg/max/mdev = 160.526/161.100/161.700/0.593 ms

linux-plcj:~ # ping -cl forms.opensuse.org
ping: bad number of packets to transmit.


Zonder -cl
linux-plcj:~ # ping forms.opensuse.org
ping: forms.opensuse.org: Name or service not known


Ik hoop dat het jou duidelijk is wat er niet helemaal goed gaat.

hcvv
02-Feb-2019, 07:47
Eerst een paar dingen om de communicatie hier te vergemakkelijken.

Als je computer code hier post, doe dat dan aub tussen CODE tags. Je krijgt die door bij het maken van de post bovenaan in de werkbalk op de knop met het # te klikken. En dan kopie/plak ertussen. Dat is is makkelijk om te weten zonder uitleg, dus schaam je niet als je dat niet wist.

De tekst die je laat zien is prima: de prompt, het commando, de uitvoer (en eventueel de volgende prompt, je laat dan duidelijk zien dat dit alles is).

Maar kopie/plak werkt natuurlijk twee kanten op. als ik dus vraag om

ping -c1 192.168.1.1
en je kopieëert/plakt dat krijg je vast niet

ping -cl 192.168.1.1
Ook is het altijd beter om eerst te kijken wat een kommando gaat doen. Je gelooft mij kennelijk op mijn eerlijke gezicht, maar wat als ik een gevaarlijk kommando geef (al dan niet per ongeluk)? In dit geval kijk je dus met

man ping
en dan zie je voor -c:

-c count
Stop after sending count ECHO_REQUEST packets. With deadline option, ping waits for count ECHO_REPLY packets, until the timeout expires.
Die 1 is dus een getal en niet een l.

Ok, genoeg achtergrond. Terug naar het probleem.

Je hebt een draaiende (UP) netwerk kaart eth1 (kabel).

Je kan contact maken met je router.

Je hebt een default (verstek) route door je router naar buiten.

Je kunt contact maken met 130.57.66.6 en dat is het adres van de openSUSE forums. Je hebt dus wel verbinding met het internet!

Je kunt de forums niet aanspreken met hun domeinnaam. Je hebt dus een probleem met het oplossen van domeinnamen (DNS).

Waarschijnlijk is het bestand /etc/resolv.conf niet goed.. Je kunt dat hier laten zien met

cat /etc/resolv.com
en dan kunnen we eraan gaan prutsen, maar het is waarschijnlijk het vlugst als je het als root) weggooit
rm /etc/resolv.conf en dan even opnieuw boot..

Als laatste, ik hoop dat je nu ziet dat je beter kunt vertellen wat je doet en wat er er gebeurt (Ik probeer met Firefox naar ... te gaan en ik krijg ....) dan om je conclusie (geen verbinding met internet) hier te posten.

jkvl
02-Feb-2019, 08:26
Henk


Hier heel blij vanaf mijn vertrouwde werkomgeving, dus hij doet het weer!


Bedankt voor de achtergrond info.

Het bestand etc/resolf.com bestaat niet.
Neem aan dat je bedoelt etc/resolf.conf



In de oude resolf.conf stonden de laatste twee regels niet in:

search lan

nameserver 192.168.1.1


Hij ziet er nu zo uit.

### /etc/resolv.conf file autogenerated by netconfig!

#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# NETCONFIG_DNS_STATIC_SEARCHLIST
# NETCONFIG_DNS_STATIC_SERVERS
# NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
# NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search lan
nameserver 192.168.1.1


Sorry voor mijn ongelukkige omschrijving.
MAAAAR
Ben weer heel gelukkig met jouw hulp en de oplossing.

Vriendelijke groet jkvl

hcvv
02-Feb-2019, 08:40
Sorry, ik heb inderdaad één maal resolv.com i.p.v. resolv.conf getikt, maar die resolf heb ik echt niet gedaan, die heb jij verzonnen.

En je huidige /etc/resolv.conf ziet er goed uit, maar waarom geen CODE tags gebruikt????

In ieder geval leuk dat het weer werkt.

Knurpht
03-Feb-2019, 14:31
Sorry, ik heb inderdaad één maal resolv.com i.p.v. resolv.conf getikt, maar die resolf heb ik echt niet gedaan, die heb jij verzonnen.

En je huidige /etc/resolv.conf ziet er goed uit, maar waarom geen CODE tags gebruikt????

In ieder geval leuk dat het weer werkt.

Is een bug in Leap 15.0, op sommige systemen, meestal laptops wordt de eerste keer geen correcte resolv.conf aangemaakt. Als je dan, als root


netconfig -f update
eenmalig doet, wordt een correcte aangemaakt, en komt acuut het netwerk tot leven.

jkvl
04-Feb-2019, 01:44
Is een bug in Leap 15.0, op sommige systemen.

Mooi dat het zo weer is opgelost, Ook bedankt Knurpht.