PDA

View Full Version : nach Update kein WLan mehr



pleniger
16-Jan-2019, 06:42
Hallo,

nachdem ich diverse Updates installiert (kein Kernel) und den Laptop neu gestartet habe, gibt es nur noch das Kabelgebundene Netzwerk.
Nach dem ich mir diverse Foren-Beiträge durchgelesen habe, traue ich mich zu sagen, dass die Hardware funktioniert.
Folgende Test habe ich gemacht:

localhost:~ # lspci -nnk | grep -iEA3 net
01:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 30)
Subsystem: Lenovo Device [17aa:4035]
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller [10ec:8136] (rev 07)
Subsystem: Lenovo Device [17aa:381e]
Kernel driver in use: r8169
Kernel modules: r8169
localhost:~ # modprobe -D ath10k_pci
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/net/rfkill/rfkill.ko
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/drivers/net/wireless/ath/ath.ko
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko
insmod /lib/modules/4.12.14-lp150.12.28-default/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
localhost:~ # rfkill list
0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
localhost:~ # journalctl -k | grep -Ei "iwlwifi|wlan"
Jän 16 13:11:17 localhost kernel: ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
Jän 16 13:49:02 localhost.localdomain kernel: ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
localhost:~ # ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether c8:5b:76:be:8f:dd brd ff:ff:ff:ff:ff:ff
inet 192.168.240.73/24 brd 192.168.240.255 scope global noprefixroute dynamic eth0
valid_lft 688501sec preferred_lft 688501sec
inet6 fe80::62ea:829e:5837:4bad/64 scope link noprefixroute
valid_lft forever preferred_lft forever

Jetzt stehe ich irgendwie an. Wie kann ich mich dem Problem nähern?
Danke im vorhinein.

Sauerland
16-Jan-2019, 09:56
Lese bis zum letzten Beitrag und installier dir die vorletzte Version von kernel-firmware und kernel-default:
https://forums.opensuse.org/showthread.php/534542-Kernel-firmware-update-20181026-lp150-2-6-1-locks-up-system

pleniger
16-Jan-2019, 10:29
Das war's, perfekt. Danke!

Muss ich den Thread jetzt irgendwie schließen?

Sauerland
16-Jan-2019, 10:58
Ne hier nicht.