PDA

View Full Version : K3b brandt geen DVD



Andreverkentsuse
04-Jul-2018, 13:15
Leap 15 KDE , pc : i3 4 GB ram . Als ik in K3b naar Instellingen , K3b instellen , Apparaten ga , zie ik in een oranje gekleurd veld de volgende foutmelding :

Om K3b volledig toegang te geven tot het schrijfapparaat dient deze toegevoegd te worden aan de groep cdrom.
Het hulpprogramma voor toestemming dat dit voor u zou kunnen doen was niet ingeschakeld tijdens het bouwen.
Bouw het pakket opnieuw met het hulpprogramma voor toestemming ingeschakeld of neem contact op met uw distributie.



Als ik in Yast naar
Gebruikers en groepenbeheer , zie ik bij Groepen staan : cdrom 491 . Als ik op Bewerken klik, zie ik bij Groepsleden nergens staan : K3b

Dus ik begrijp de foutmelding niet.
Wat moet ik doen , zodat K3b wel DVD's gaat branden ?

Knurpht
04-Jul-2018, 13:45
Leap 15 KDE , pc : i3 4 GB ram . Als ik in K3b naar Instellingen , K3b instellen , Apparaten ga , zie ik in een oranje gekleurd veld de volgende foutmelding :


Als ik in Yast naar
Gebruikers en groepenbeheer , zie ik bij Groepen staan : cdrom 491 . Als ik op Bewerken klik, zie ik bij Groepsleden nergens staan : K3b

Dus ik begrijp de foutmelding niet.
Wat moet ik doen , zodat K3b wel DVD's gaat branden ?

Er is geen user k3b, maar een user 'andre' oid. In YaST gebruikers en groepenbeheer, je eigen account bewerken, dan zie je rechts een lijst. Vink daar cdrom aan. Herstart je systeem en probeer 't opnieuw. Kan 't niet nadoen want ik heb een DVD-brander-loze laptop. Maar, in de Instellingen van k3b zie je ook 'Apparaten'. daar staan permissies bij, zowel huidige als voorgestelde. Daar zou je ook naar kunnen kijken. Je kunt schermafdrukken uploaden op paste.opensuse.org, rechts boven op Image klikken, en dan de link hier plaatsen.

Andreverkentsuse
05-Jul-2018, 09:45
Dank je , Knurpht. De foutmelding is verdwenen.
Echter, als ik nu op branden druk, krijg ik een andere foutmelding :

De grootte van het resulterende imagebestand kon niet worden vastgesteld.

Dit is de debug uitvoer :

Devices
-----------------------
ASUS SH-224DB 1.10 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R sequentieel, DVD-R Dual Layer sequentieel, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW met beperkte overschrijving, DVD-RW sequentieel, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Beperkte overschrijving, Layer Jump] [%7]

K3b::IsoImager
-----------------------
mkisofs print size result: 0 (0 bytes)

System
-----------------------
K3b Version: 17.12.3
KDE Version: 5.45.0
Qt Version: 5.9.4
Kernel: 4.12.14-lp150.12.4-default

Used versions
-----------------------
mkisofs: 3.2a09

mkisofs
-----------------------
mkisofs: Warning: Cannot add inode hints with -no-cache-inodes.
mkisofs: Bestand of map bestaat niet. Failed to open '/tmp/k3bVideoDvdWthg1S//VIDEO_TS/VIDEO_TS.IFO'.
mkisofs: Can't open VMG info for '/tmp/k3bVideoDvdWthg1S/'.
mkisofs: Unable to parse DVD-Video structures.
mkisofs: Could not find correct 'VIDEO_TS' directory.

mkisofs calculate size command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -print-size -quiet -volid K3b-gegevensproject -volset -appid K3B THE CD KREATOR (C) 1998-2017 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.wA4077 -no-cache-inodes -udf -iso-level 1 -path-list /tmp/k3b.Om4077 -dvd-video -f /tmp/k3bVideoDvdWthg1S

Andreverkentsuse
05-Jul-2018, 11:57
Als ik het programma DeVeDe gebruik om een DVD voor een DVD-speler te maken, kan K3b het wel branden.
K3b wordt automatisch opgestart, zodra DeVeDe klaar is met het maken van de iso.

Knurpht
05-Jul-2018, 12:52
Als ik het programma DeVeDe gebruik om een DVD voor een DVD-speler te maken, kan K3b het wel branden.
K3b wordt automatisch opgestart, zodra DeVeDe klaar is met het maken van de iso.

Het lijkt erop. Heb je ook gekeken naar k3b-Instellingen-Programma's-Toegangsrechten? Als je daar op Toepassen klikt worden de rechten goed gezet na invoeren van het root ww.

Het zou best kunnen zijn dat daarmee ook het eerdere probleem is opgelost

Andreverkentsuse
06-Jul-2018, 05:18
Als ik in K3b , Programma's , Toegangsrechten op Toepassen druk, gebeurt er niets. Er verschijnt geen vraag of ik m'n root wachtwoord wil invullen.
Er staat :
programma Toegangsrechten Nieuwe toegangsrechten
x /usr/bin/cdrdao 0755 root.root 4711 root.root
x /usr/bin/cdrecord 0755 root.root 4711 root.root
/usr/bin/growisofs 0755 root.root geen wijziging

Knurpht
06-Jul-2018, 05:26
Als ik in K3b , Programma's , Toegangsrechten op Toepassen druk, gebeurt er niets. Er verschijnt geen vraag of ik m'n root wachtwoord wil invullen.
Er staat :
programma Toegangsrechten Nieuwe toegangsrechten
x /usr/bin/cdrdao 0755 root.root 4711 root.root
x /usr/bin/cdrecord 0755 root.root 4711 root.root
/usr/bin/growisofs 0755 root.root geen wijziging

En kun je daar niks aanvinken, voordat je op toepassen klikt? Kan het niet nazien omdat ik geen brander heb, en dan is dat schermpje leeg.

Andreverkentsuse
06-Jul-2018, 06:21
De eerste twee regels zijn aangevinkt. De derde regel heeft geen hokje om te kunnen aanvinken.

Knurpht
06-Jul-2018, 06:55
De eerste twee regels zijn aangevinkt. De derde regel heeft geen hokje om te kunnen aanvinken.

En ook niet in de kolom met nieuwe settings voor de eerste twee? Ik vraag maar, hoor.

Knurpht
06-Jul-2018, 06:58
Je zou 't zelf goed kunnen zetten met


chmod 4711 /usr/bin/cdrdao
chmod 4711 /usr/bin/record

Dan rebooten en kijken of 't wel werkt.
Evt. ook eens kijken of je kunt vinden hoe DeVeDe k3b aanroept, omdat 't dan wel wil.

Andreverkentsuse
06-Jul-2018, 07:00
Alleen in de eerste van de drie kolommen "Programma" is er een mogelijkheid tot aan/uitvinken. Dus niet in de kolommen "Toegansrechten" of "Nieuwe toegangsrechten".

Andreverkentsuse
06-Jul-2018, 23:31
Sorry, ik zie deze reactie van jou nu pas.

andre@linux-cjvd:/> sudo chmod 4711 /usr/bin/cdrdao
andre@linux-cjvd:/> sudo chmod 4711 /usr/bin/cdrecord
andre@linux-cjvd:/> ls -al /usr/bin/cdrecord
-rws--x--x 1 root root 442160 13 mei 01:41 /usr/bin/cdrecord
andre@linux-cjvd:/> ls -al /usr/bin/cdrdao
-rws--x--x 1 root root 646984 20 feb 04:13 /usr/bin/cdrdao
andre@linux-cjvd:/>

Heb ik 't goed gedaan zo ?


Evt. ook eens kijken of je kunt vinden hoe DeVeDe k3b aanroept, omdat 't dan wel wil.
Ik kies in DeVeDe :

Video DVD - Creates a Video DVD suitable for all home players
vervolgens voeg ik video bestanden toe in de lijst, dan klik ik op de knop Volgende.
dan moet ik een map kiezen.
Ik kies dan mijn homedirectory (ik kan ook kiezen : Werkblad of Bestandssysteem)
Dan gaat DeVeDe een iso maken.
Als ie daarmee klaar is kan ik kiezen ok of Burn, ik kies Burn.
Dan wordt K3b opgestart en ik zie dan bovenaan staan :
/home/andre/None/movie/movie.iso

Andreverkentsuse
07-Jul-2018, 00:07
Na herstart pc staat in K3b bij Toegangsrechten bij de derde kolom bij alle drie regels : Nieuwe Toegangsrechten : "Geen wijziging".
K3b is dus blij met deze nieuwe instellingen.
Echter K3b wil nog steeds niet branden.
Als ik in K3b kies : Video DVD , maak ik eerst van .mov bestanden .vob bestanden.
Ik plaats die dan in K3b in de map Video_TS
Als ik op Branden druk, krijg ik 4 regels te zien :

mkisofs 3.2a09 wordt gebruikt - Copyright enz....
Het project bevat niet alle noodzakelijke Video DVD bestanden
De resulterende DVD is waarschijnlijk niet afspeelbaar op een HiFi DVD speler
De grootte van het resulterende image bestand kon niet worden vastgesteld.


heeft t soms hier mee te maken :

mkisofs: Bestand of map bestaat niet. Failed to open '/tmp/k3bVideoDvdWthg1S//VIDEO_TS/VIDEO_TS.IFO'.

Andreverkentsuse
07-Jul-2018, 01:10
Knurpht,
ik maak een denkfout :

First of all you will have to have your Video files ready. K3B does well with DVD projects that have been split into the AUDIO_TS and VIDEO_TS directories that programs like DeVeDe can create.
bron :
https://www.linux.com/news/burn-cds-dvds-and-isos-k3b

In ieder geval heb je me geholpen de fout op te lossen dat mijn username niet in de groep cdrom stond en
dat de rwx instellingen van de subdirectories nu goed staan.
Hartelijk dank.