PDA

View Full Version : Problem mit MP4 im HTML5 Media-Element in Firefox



User9595
12-Jul-2017, 11:10
Hallo,
auf dem PC kann ich MP4 Videos problemlos abspielen. Dazu habe ich den Fluendo Codec Pack gekauft und installiert. Leider kann ich aber keine MP4-Videos abspielen, die im HTML5 Media-Element eingebettet sind. Das kann ich wie folgt feststellen:

Auf die Testseite gehen: https://www.w3schools.com/html/tryit.asp?filename=tryhtml5_video
Das Video spielt problemlos.
Nun die Zeile <source src="mov_bbb.ogg" type="video/ogg"> entfernen, sodass nur noch MP4 eingebunden ist und den Code mit dem Run Button starten.
Ich bekomme folgenden Fehler angezeigt: Kein Video mit unterstütztem Format oder MIME-Typ gefunden

Ich habe bereits den Fluendo Support angeschrieben. Der hat mich darauf hingewiesen, dass gstreamer in Firefox nicht mehr unterstützt wird.

Hat jemand vielleicht Erfahrung damit? Ich kann es mir nicht ganz erklären warum das nicht funktioniert. Der MP4-Codec ist ja ordnungsgemäß installiert, da ich alle MP4-Dateien abspielen kann. Und wenn Firefox tatsächlich nicht mehr gstreamer unterstützt, wurde tatsächlich keine Alternative geschaffen?

User9595
17-Jul-2017, 07:34
Ich habe die Frage auch mal in das offizielle Firefox Forum eingestellt. Vielleicht gibt es dort Ideen.

https://www.camp-firefox.de/forum/viewtopic.php?f=1&t=121094

Sauerland
17-Jul-2017, 08:20
Hast du alle Codecs beschrieben wie in den ersten Beiträgen im englischsprachigen Forum ----Multimedia installiert?

Hier funktioniert das alles ohne gekaufte fluendo-Codecs....

zypper se -si fluendo
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name | Typ | Version | Arch | Repository
---+-----------------------+-------+---------+--------+----------------------------------
i+ | gstreamer-fluendo-mp3 | Paket | 21-2.1 | x86_64 | openSUSE-Leap-42.2-Update-Non-Oss

User9595
18-Jul-2017, 10:32
Hast du alle Codecs beschrieben wie in den ersten Beiträgen im englischsprachigen Forum ----Multimedia installiert?

Hier funktioniert das alles ohne gekaufte fluendo-Codecs....

Vielen Dank für den Hinweis! Vor etwa 2 Jahren habe etwas ähnliches versucht. Da hatte ich aber dann massiv Probleme mit jeglichen MP4 Dateien.
Gerade habe ich mal diese Anleitung (https://forums.opensuse.org/showthread.php/521016-Multimedia-Guide-for-openSUSE-Leap-42-2?p=2802678#post2802678) befolgt, und siehe da, es funktioniert! Ich habe zuvor die zugekauften Fluendo Codecs aber nicht entfernt, ich hoffe das macht keine Probleme.

Ich hätte noch 2 Fragen bezüglich der Anleitung:

Bei dem Installationsprozess wurde mir angezeigt, dass ein (Anzahl 1) Fehler aufgetreten ist. Leider fehlte die Angabe wo. Kann man das irgendwie herausfinden?
Den Schritt open Yast > Software Management and Apply the Package Switcher on Packman konnte ich nicht ganz nachvollziehen. Die Einstellung dazu habe ich nicht gefunden. Der dort angeführte Link für weitere Informationen ist leider abgelaufen. Wie ist das gemeint?

Sauerland
18-Jul-2017, 12:23
Den Schritt open Yast > Software Management and Apply the Package Switcher on Packman konnte ich nicht ganz nachvollziehen. Die Einstellung dazu habe ich nicht gefunden. Der dort angeführte Link für weitere Informationen ist leider abgelaufen. Wie ist das gemeint?
http://openmafia.org/~osf/Screenshots/YaST2_217.jpg

User9595
21-Jul-2017, 07:41
Vielen Dank!