PDA

View Full Version : TUMBLEWEED WMA auf Tumbleed



brandy
17-Jun-2017, 14:50
Hallo!

Ich bekomme es nicht WMA-Dateien auf meinem Open Suse abzuspielen - verwende dazu Audacious.

Ich habe schon einiges darüber gelesen. Unter anderem sollte man die Packman-Quellen hinzufügen - schon erledigt.
Ich hab auch alle Gstreamer-Plugins aktiviert.

Hier die Ausgabe von zypper lr:

# | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung
--+-----------------------------------+-----------------------------+-----------+-----------------+---------------
1 | http-ftp.uni-erlangen.de-b307ba0c | Packman Repository | Ja | (r ) Ja | Ja
2 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ----
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja
4 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja
5 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ----
6 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja


Was fehlt hier noch?
Weder Audacious, noch VLC, noch ein kurzfristig installierter MPlayer spielt mir kein WMA ab!

Vielen Dank!

Sauerland
17-Jun-2017, 23:45
https://forums.opensuse.org/entry.php/174-openSUSE-Leap-42-2-Multimedia-Guide

Siehe:
For KDE Use oder for Gnome Use

Sowie folgend das umstellen der Pakete auf das Packman Repo.

brandy
20-Jun-2017, 11:06
Gilt dieser Link auch für Tumbleweed?

zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_42.2/ packman

Sauerland
20-Jun-2017, 11:37
Nö, ist für Leap42.2.

Aber du kannst den Link ja mal im Browser öffnen und dann weiterschauen......

PS:
zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_42.2/ packman

Bedeutet:
zypper ar = zypper Add Repository, neues Repository (einfach ausgedrückt Installationsverzeichnis) hinzufügen. Muss auch nicht unbedingt irgendeine URL im Internet sein, du kannst z.B auch Repositories auf deinem Rechner einrichten.
-f = den automatische Refresh des Repos einschalten, wenn du mit Yast/zypper irgendetwas veranstaltest, wird zuerst einmal das Repository mit den bei dir gespeicherten Programmen des Repositories verglichen, ob neue Versionen usw vorliegen.
http://packman.inode.at/suse/openSUSE_Leap_42.2 = das ist die URL des Repositories, in diesem Fall für Leap42.2, kann aber auch ein Verzeichnis sein: dir:///home/xxxxxxx/Programme86x64/LibreOffice
packman = das ist der Name, den du diesem Repo gibst, wird in Yast oder z.B. bei zypper lr -d unter Name angezeigt.

brandy
21-Jun-2017, 02:27
Das ist mir klar.

Ich hab in Repositories folgende Packman-URL hinterlegt:
http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Tumbleweed

Sauerland
21-Jun-2017, 07:19
Passt.

Du hättest aber nur auf den von dir geposteten und abgeschnittenen Link klicken müssen:
http://packman.inode.at/suse/

Da hättest du als vorletztes Verzeichnis Tumbleweed und damit diese URL:
http://packman.inode.at/suse/openSUSE_Tumbleweed/

Aber letztendlich ist das egal, welche URL du benutzt.

Ich benutze z.B. diese:
http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_42.2/

brandy
21-Jun-2017, 13:17
Ja, cool - ich hab jetzt mal die Adresse geändert (obwohls egal ist, ich weiß) und dann hab ich dieses hier ins Terminal eingegeben:


zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux vlc-beta smplayer totem-browser-plugin h264enc x264 gstreamer-plugins-libav vlc-beta-codecs

und folgende Meldung bekommen:


Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paket 'gstreamer-plugins-bad-orig-addon' nicht gefunden.
Paket 'gstreamer-plugins-libav' nicht gefunden.
Paket 'gstreamer-plugins-ugly-orig-addon' nicht gefunden.
Paket 'libxine2-codecs' nicht gefunden.
Paket 'totem-browser-plugin' nicht gefunden.
Paket 'vlc-beta' nicht gefunden.
Paket 'vlc-beta-codecs' nicht gefunden.
'ffmpeg' ist bereits installiert.
Kein Aktualisierungskandidat für 'ffmpeg-3.3.2-1.1.x86_64'. Die neueste Version ist bereits installiert.
'gstreamer-plugins-base' ist bereits installiert.
Kein Aktualisierungskandidat für 'gstreamer-plugins-base-1.12.0-1.1.x86_64'. Die neueste Version ist bereits installiert.
'gstreamer-plugins-good' ist bereits installiert.
Kein Aktualisierungskandidat für 'gstreamer-plugins-good-1.12.0-1.1.x86_64'. Die neueste Version ist bereits installiert.
'gstreamer-plugins-ugly' ist bereits installiert.
Kein Aktualisierungskandidat für 'gstreamer-plugins-ugly-1.12.0-1.1.x86_64'. Die neueste Version ist bereits installiert.
'dvdauthor07' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
'dvdauthor', welches 'dvdauthor07' bietet, ist bereits installiert.
'lame' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'lame' gefunden.
'libdvdcss2' ist bereits installiert.
Paket 'libdvdcss2' ist in Ihren Repositorys nicht vorhanden. Erneute Installation, Upgrade oder Downgrade nicht möglich.
'gstreamer-0_10-plugins-bad' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-bad' gefunden.
'gstreamer-0_10-plugins-bad-orig-addon' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-bad-orig-addon' gefunden.
'gstreamer-0_10-plugins-ffmpeg' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-ffmpeg' gefunden.
'gstreamer-0_10-plugins-fluendo_mpegdemux' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-fluendo_mpegdemux' gefunden.
'gstreamer-0_10-plugins-fluendo_mpegmux' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-fluendo_mpegmux' gefunden.
'gstreamer-0_10-plugins-good' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-good' gefunden.
'gstreamer-0_10-plugins-good-extra' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-good-extra' gefunden.
'gstreamer-0_10-plugins-ugly' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-ugly' gefunden.
'gstreamer-0_10-plugins-ugly-orig-addon' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'gstreamer-0_10-plugins-ugly-orig-addon' gefunden.
'h264enc' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'h264enc' gefunden.
'x264' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'x264' gefunden.
Paketabhängigkeiten werden aufgelöst...

Problem: gstreamer-plugins-bad-1.12.0-1.1.x86_64 benötigt libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit), kann jedoch nicht zur Verfügung gestellt werden
Nicht installierbare Anbieter: libopenssl1_0_0-1.0.2k-2.2.x86_64[repo-oss]
Lösung 1: Folgende Aktionen werden ausgeführt:
gstreamer-plugins-bad-1.12.0-1.1.x86_64 nicht installieren
smplayer-17.6.0-1.1.x86_64 nicht installieren
Lösung 2: Downgrade von libopenssl1_0_0-1.0.2k-3.1.x86_64 zu libopenssl1_0_0-1.0.2k-2.2.x86_64
Lösung 3: gstreamer-plugins-bad-1.12.0-1.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/3/a] (a):



Was mache hier?

Sauerland
21-Jun-2017, 22:18
Was mache hier?

Keine Ahnung, beschäftige ich mich nicht mit, ich mach um Tumbleweed einen Bogen, installiere kein Rolling Release.

tomm_fa
22-Jun-2017, 10:50
Die 0.10er Versionen von Gstreamer gibt es für Tumbleweed nicht mehr, nur noch die 1.*er Versionen. Lame, h264enc usw. sollte aber verfügbar sein. Zeige hier doch mal die Ausgabe von

zypper lr -d

brandy
23-Jun-2017, 13:52
user@linux-cau3:~> zypper lr -d
Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

# | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
--+-----------------------------------+-----------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------+-------
1 | http-ftp.uni-erlangen.de-b307ba0c | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
2 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
4 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss/ |
5 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/tumbleweed/repo/oss/ |
6 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
davidb@linux-cau3:~>

brandy
25-Aug-2017, 08:44
Hallo!

Gibts dazu keine Lösung?
Ich hab jetzt nochmal alle audacious-Pakete entfernt und neu installiert!

zyyper lr -d gibt bei mir folgendes aus:



# | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
--+---------------------------+-----------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------------+-------
1 | http-ftp.gwdg.de-23030c20 | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/ |
2 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
4 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss/ |
5 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/tumbleweed/repo/oss/ |
6 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

Sauerland
25-Aug-2017, 10:54
Poste:

zypper se -si ffmpeg vlc gstreamer

brandy
28-Aug-2017, 05:35
S | Name | Typ | Version | Arch | Repository
---+-----------------------------------+-----------+-------------+--------+----------------------------
i+ | GStreamer Multimedia Codecs | Anwendung | | noarch | (Systempakete)
i+ | PackageKit-gstreamer-plugin | Paket | 1.1.6-2.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | VLC Media player | Anwendung | | noarch | openSUSE-Tumbleweed-Oss
i+ | ffmpeg | Paket | 3.3.3-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-fluendo-mp3 | Paket | 21-3.5 | x86_64 | openSUSE-Tumbleweed-Non-Oss
i+ | gstreamer-libnice | Paket | 0.1.14-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugin-gstclutter-3_0 | Paket | 3.0.24-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-bad | Paket | 1.12.2-5.14 | x86_64 | Packman Repository
i+ | gstreamer-plugins-bad-orig-addon | Paket | 1.12.2-5.14 | x86_64 | Packman Repository
i+ | gstreamer-plugins-base | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-cogl | Paket | 1.22.2-1.7 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-farstream | Paket | 0.2.8-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-good | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-good-extra | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | gstreamer-plugins-libav | Paket | 1.12.2-3.3 | x86_64 | Packman Repository
i+ | gstreamer-plugins-ugly | Paket | 1.12.2-4.3 | x86_64 | Packman Repository
i+ | gstreamer-plugins-ugly-orig-addon | Paket | 1.12.2-4.3 | x86_64 | Packman Repository
i+ | gstreamer-utils | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libgstreamer-1_0-0 | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libgstreamer-1_0-0-32bit | Paket | 1.12.2-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libgupnp-dlna-backend-gstreamer | Paket | 0.10.5-2.4 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libvlc5 | Paket | 2.2.4-239.2 | x86_64 | (Systempakete)
i+ | libvlccore8 | Paket | 2.2.4-239.2 | x86_64 | (Systempakete)
i+ | phonon-backend-gstreamer | Paket | 4.9.0-1.8 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | phonon4qt5-backend-gstreamer | Paket | 4.9.0-1.7 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | vlc | Paket | 2.2.4-239.2 | x86_64 | (Systempakete)
i+ | vlc-codec-gstreamer | Paket | 2.2.4-12.1 | x86_64 | (Systempakete)
i+ | vlc-lang | Paket | 2.2.4-12.1 | noarch | (Systempakete)
i+ | vlc-noX | Paket | 2.2.4-239.2 | x86_64 | (Systempakete)
i+ | vlc-qt | Paket | 2.2.4-239.2 | x86_64 | (Systempakete)

wolfi323
28-Aug-2017, 07:43
Ruf folgendes auf und es sollte eigentlich funktionieren...

sudo zypper dup --from 1

brandy
28-Aug-2017, 22:29
Wenn ich dass eingebe bekomme ich folgende Fehler:


Distributions-Aktualisierungen werden verarbeitet...
49 Probleme:
Problem: Problem mit installiertem Paket libvlc5-2.2.4-239.2.x86_64
Problem: Problem mit installiertem Paket libvlccore8-2.2.4-239.2.x86_64
Problem: Problem mit installiertem Paket vlc-2.2.4-239.2.x86_64
Problem: Problem mit installiertem Paket vlc-noX-2.2.4-239.2.x86_64
Problem: Problem mit installiertem Paket vlc-qt-2.2.4-239.2.x86_64
Problem: Problem mit installiertem Paket libavformat56-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libavfilter6-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libavdevice56-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libgstbadbase-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libgstcodecparsers-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libavcodec56-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libgstphotography-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libmlt++3-6.4.1-4.1.x86_64
Problem: Problem mit installiertem Paket libgstmpegts-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket melt6-6.4.1-4.1.x86_64
Problem: Problem mit installiertem Paket vlc-codec-gstreamer-2.2.4-12.1.x86_64
Problem: Problem mit installiertem Paket libgstbasecamerabinsrc-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libsox3-14.4.2-2.2.x86_64
Problem: Problem mit installiertem Paket libswscale3-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket ffmpeg-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libgsturidownloader-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libavfilter5-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libmlt6-modules-6.4.1-4.1.x86_64
Problem: Problem mit installiertem Paket libswscale4-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libpostproc53-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libmjpegutils-2_0-0-2.0.0-20.2.x86_64
Problem: Problem mit installiertem Paket libavutil55-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libpostproc54-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libgstwayland-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libavresample3-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libavcodec57-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket melt-6.4.1-4.1.x86_64
Problem: Problem mit installiertem Paket mjpegtools-2.0.0-20.2.x86_64
Problem: Problem mit installiertem Paket libgstbadaudio-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libgstbadvideo-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libgstadaptivedemux-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket libavutil54-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libquicktime0-1.2.4cvs20150223-9.1.x86_64
Problem: Problem mit installiertem Paket libswresample1-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libavdevice57-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libavresample2-2.8.12-2.1.x86_64
Problem: Problem mit installiertem Paket libswresample2-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libavformat57-3.3.3-1.1.x86_64
Problem: Problem mit installiertem Paket libmlt6-6.4.1-4.1.x86_64
Problem: Problem mit installiertem Paket libgstgl-1_0-0-1.12.2-2.2.x86_64
Problem: Problem mit installiertem Paket freshplayerplugin-0.3.7-1.1.x86_64
Problem: Problem mit installiertem Paket s2tc-1.0+git.20151227-2.1.x86_64
Problem: Problem mit installiertem Paket libmlt6-data-6.4.1-4.1.noarch
Problem: Problem mit installiertem Paket vlc-lang-2.2.4-12.1.noarch

Problem: Problem mit installiertem Paket libvlc5-2.2.4-239.2.x86_64
Lösung 1: libvlc5-2.2.6-7.2.x86_64 installieren (mit Anbieterwechsel)
VideoLAN Project (http://www.videolan.org) --> http://packman.links2linux.de

Wählen Sie die obige Lösung mittels '1' oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/u/w/a] (a):



Er fragt mich jedes Paket durch - soll ich alle auf packman setzen?

tomm_fa
30-Aug-2017, 10:07
Er fragt mich jedes Paket durch - soll ich alle auf packman setzen?
Ja. Wenn du damit fertig bist entsorgst du das Repo von VLC/Videolan, es reicht PackMan für die dort enthaltenen Pakete.

wolfi323
30-Aug-2017, 11:58
Ja. Wenn du damit fertig bist entsorgst du das Repo von VLC/Videolan, es reicht PackMan für die dort enthaltenen Pakete.

Hm, das VideoLAN Repo war ja gar nicht in der Liste... Die installierten Pakete kommen aber dennoch davon, und das ist wahrscheinlich der Grund für das Problem.

Dann würd ich das empfehlen:

sudo zypper dup --allow-vendor-change --from 1

Hintergrund: in Tumbleweed wird seit kurzem auch für "zypper dup" per default kein "Vendor Switch" gemacht um das Updaten zu "erleichtern". Das heißt, Pakete werden nicht (automatisch) von anderen Repos installiert als sie ursprünglich kommen.

brandy
31-Aug-2017, 13:26
Also hab ich jetzt verstanden - ist alles von Packman.

Aber wenn ich den Befehl eingebe - kommt diese Meldung:


Problem: vlc-noX-2.2.6-7.2.x86_64 benötigt liblua5.3.so.5()(64bit), kann jedoch nicht zur Verfügung gestellt werden
Nicht installierbare Anbieter: liblua5_3-5-5.3.4-1.1.x86_64[repo-oss]
Lösung 1: Folgende Aktionen werden ausgeführt:
vlc-noX-2.2.6-7.2.i586 trotz der nachrangigen Architektur installieren
libvlc5-2.2.6-7.2.i586 trotz der nachrangigen Architektur installieren
libvlccore8-2.2.6-7.2.i586 trotz der nachrangigen Architektur installieren
libmtp9-1.1.13-1.3.i586 trotz der nachrangigen Architektur installieren
libopencv3_2-3.2.0-3.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libmtp9-1.1.13-1.3.x86_64 zu libmtp9-1.1.13-1.3.i586
Architekturwechsel von libopencv3_2-3.2.0-3.1.x86_64 zu libopencv3_2-3.2.0-3.1.i586
libmtp-udev-1.1.13-1.3.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libmtp-udev-1.1.13-1.3.x86_64 zu libmtp-udev-1.1.13-1.3.i586
Architekturwechsel von kio-extras5-17.08.0-1.1.x86_64 zu kio-extras5-17.08.0-1.1.i586
kio-extras5-17.08.0-1.1.i586 trotz der nachrangigen Architektur installieren
libkioarchive5-17.08.0-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von gvfs-backends-1.32.1-1.3.x86_64 zu gvfs-backends-1.32.1-1.3.i586
gvfs-backends-1.32.1-1.3.i586 trotz der nachrangigen Architektur installieren
libnfs8-1.11.0-1.2.i586 trotz der nachrangigen Architektur installieren
libudisks2-0-2.1.8-1.3.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von frei0r-plugins-1.4-9.7.x86_64 zu frei0r-plugins-1.4-9.7.i586
frei0r-plugins-1.4-9.7.i586 trotz der nachrangigen Architektur installieren
libgavl1-1.4.0rsvn4256-2.9.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libopenblas_pthreads0-0.2.20-1.1.x86_64 zu libopenblas_pthreads0-0.2.20-1.1.i586
Downgrade von libtbb2-2017_20170412-2.2.x86_64 zu libtbb2-2017_20170412-2.1.i586
Architekturwechsel von libtbb2-2017_20170412-2.2.x86_64 zu libtbb2-2017_20170412-2.1.i586
Architekturwechsel von gegl-0_2-0.2.0-16.4.x86_64 zu gegl-0_2-0.2.0-16.5.i586
gegl-0_2-0.2.0-16.5.i586 trotz der nachrangigen Architektur installieren
liblensfun1-0.3.2-2.1.i586 trotz der nachrangigen Architektur installieren
libumfpack-5_7_6-5.7.6-26.1.i586 trotz der nachrangigen Architektur installieren
libamd-2_4_6-2.4.6-26.1.i586 trotz der nachrangigen Architektur installieren
libcholmod-3_0_11-3.0.11-26.1.i586 trotz der nachrangigen Architektur installieren
libsuitesparseconfig-4_5_5-4.5.5-26.1.i586 trotz der nachrangigen Architektur installieren
libcamd-2_4_6-2.4.6-26.1.i586 trotz der nachrangigen Architektur installieren
libccolamd-2_9_6-2.9.6-26.1.i586 trotz der nachrangigen Architektur installieren
libcolamd-2_9_6-2.9.6-26.1.i586 trotz der nachrangigen Architektur installieren
libmetis5-5.1.0-4.12.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libumfpack-5_7_6-5.7.6-26.1.x86_64 zu libumfpack-5_7_6-5.7.6-26.1.i586
Architekturwechsel von libcholmod-3_0_11-3.0.11-26.1.x86_64 zu libcholmod-3_0_11-3.0.11-26.1.i586
Architekturwechsel von gegl-0_3-0.3.14-2.4.x86_64 zu gegl-0_3-0.3.14-2.4.i586
gegl-0_3-0.3.14-2.4.i586 trotz der nachrangigen Architektur installieren
libbabl-0_1-0-0.1.28-1.1.i586 trotz der nachrangigen Architektur installieren
libgegl-0_3-0-0.3.14-2.4.i586 trotz der nachrangigen Architektur installieren
libraw16-0.18.2-1.2.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libkioarchive5-17.08.0-1.1.x86_64 zu libkioarchive5-17.08.0-1.1.i586
Architekturwechsel von libnfs8-1.11.0-1.2.x86_64 zu libnfs8-1.11.0-1.2.i586
Architekturwechsel von libudisks2-0-2.1.8-1.3.x86_64 zu libudisks2-0-2.1.8-1.3.i586
Architekturwechsel von libgavl1-1.4.0rsvn4256-2.9.x86_64 zu libgavl1-1.4.0rsvn4256-2.9.i586
Architekturwechsel von udisks2-2.1.8-1.3.x86_64 zu udisks2-2.1.8-1.3.i586
udisks2-2.1.8-1.3.i586 trotz der nachrangigen Architektur installieren
libatasmart4-0.19-8.5.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von gnome-multi-writer-3.24.0-1.3.x86_64 zu gnome-multi-writer-3.24.0-1.3.i586
gnome-multi-writer-3.24.0-1.3.i586 trotz der nachrangigen Architektur installieren
libgusb2-0.2.10-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von gnome-disk-utility-3.24.1-1.3.x86_64 zu gnome-disk-utility-3.24.1-1.3.i586
gnome-disk-utility-3.24.1-1.3.i586 trotz der nachrangigen Architektur installieren
libpwquality1-1.3.0-2.3.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libamd-2_4_6-2.4.6-26.1.x86_64 zu libamd-2_4_6-2.4.6-26.1.i586
Architekturwechsel von libsuitesparseconfig-4_5_5-4.5.5-26.1.x86_64 zu libsuitesparseconfig-4_5_5-4.5.5-26.1.i586
Architekturwechsel von libcamd-2_4_6-2.4.6-26.1.x86_64 zu libcamd-2_4_6-2.4.6-26.1.i586
Architekturwechsel von libccolamd-2_9_6-2.9.6-26.1.x86_64 zu libccolamd-2_9_6-2.9.6-26.1.i586
Architekturwechsel von libcolamd-2_9_6-2.9.6-26.1.x86_64 zu libcolamd-2_9_6-2.9.6-26.1.i586
Architekturwechsel von libmetis5-5.1.0-4.12.x86_64 zu libmetis5-5.1.0-4.12.i586
Architekturwechsel von libbabl-0_1-0-0.1.28-1.1.x86_64 zu libbabl-0_1-0-0.1.28-1.1.i586
Architekturwechsel von libgegl-0_3-0-0.3.14-2.4.x86_64 zu libgegl-0_3-0-0.3.14-2.4.i586
Architekturwechsel von libraw16-0.18.2-1.2.x86_64 zu libraw16-0.18.2-1.2.i586
Architekturwechsel von liblensfun1-0.3.2-2.1.x86_64 zu liblensfun1-0.3.2-2.1.i586
Architekturwechsel von libgegl-0_2-0-0.2.0-16.5.x86_64 zu libgegl-0_2-0-0.2.0-16.5.i586
libgegl-0_2-0-0.2.0-16.5.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von gimp-2.8.22-1.2.x86_64 zu gimp-2.8.22-1.2.i586
gimp-2.8.22-1.2.i586 trotz der nachrangigen Architektur installieren
ghostscript-9.21-2.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libKF5KDcraw5-17.08.0-1.1.x86_64 zu libKF5KDcraw5-17.08.0-1.1.i586
libKF5KDcraw5-17.08.0-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libatasmart4-0.19-8.5.x86_64 zu libatasmart4-0.19-8.5.i586
Architekturwechsel von libgusb2-0.2.10-1.1.x86_64 zu libgusb2-0.2.10-1.1.i586
Architekturwechsel von libpwquality1-1.3.0-2.3.x86_64 zu libpwquality1-1.3.0-2.3.i586
Architekturwechsel von kdegraphics-thumbnailers-17.04.3-1.2.x86_64 zu kdegraphics-thumbnailers-17.04.3-1.2.i586
kdegraphics-thumbnailers-17.04.3-1.2.i586 trotz der nachrangigen Architektur installieren
libKF5KExiv2-15_0_0-17.08.0-1.1.i586 trotz der nachrangigen Architektur installieren
....
Architekturwechsel von libosinfo-1_0-0-1.1.0-1.1.x86_64 zu libosinfo-1_0-0-1.1.0-1.1.i586
Architekturwechsel von libgspell-1-1-1.4.2-1.1.x86_64 zu libgspell-1-1-1.4.2-1.1.i586
Architekturwechsel von libgnome-autoar-0-0-0.2.2-1.2.x86_64 zu libgnome-autoar-0-0-0.2.2-1.2.i586
Architekturwechsel von libfolks25-0.11.4-1.2.x86_64 zu libfolks25-0.11.4-1.2.i586
typelib-1_0-GtkSource-3_0-3.24.3-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von typelib-1_0-GtkSource-3_0-3.24.3-1.1.x86_64 zu typelib-1_0-GtkSource-3_0-3.24.3-1.1.i586
Architekturwechsel von gnome-calculator-3.24.0-1.3.x86_64 zu gnome-calculator-3.24.0-1.3.i586
gnome-calculator-3.24.0-1.3.i586 trotz der nachrangigen Architektur installieren
libosinfo-1.1.0-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libosinfo-1.1.0-1.1.x86_64 zu libosinfo-1.1.0-1.1.i586
Architekturwechsel von typelib-1_0-Gspell-1_0-1.4.2-1.1.x86_64 zu typelib-1_0-Gspell-1_0-1.4.2-1.1.i586
typelib-1_0-Gspell-1_0-1.4.2-1.1.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libgnome-autoar-gtk-0-0-0.2.2-1.2.x86_64 zu libgnome-autoar-gtk-0-0-0.2.2-1.2.i586
libgnome-autoar-gtk-0-0-0.2.2-1.2.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libfolks-telepathy25-0.11.4-1.2.x86_64 zu libfolks-telepathy25-0.11.4-1.2.i586
libfolks-telepathy25-0.11.4-1.2.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libfolks-eds25-0.11.4-1.2.x86_64 zu libfolks-eds25-0.11.4-1.2.i586
libfolks-eds25-0.11.4-1.2.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von audacious-3.9-1.1.x86_64 zu audacious-3.9-1.1.i586
audacious-3.9-1.1.i586 trotz der nachrangigen Architektur installieren
libaudcore5-3.9-1.1.i586 trotz der nachrangigen Architektur installieren
libaudgui5-3.9-1.1.i586 trotz der nachrangigen Architektur installieren
libaudqt2-3.9-1.1.i586 trotz der nachrangigen Architektur installieren
libaudtag3-3.9-1.1.i586 trotz der nachrangigen Architektur installieren
libsidplayfp4-1.8.7-1.3.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libaudcore5-3.9-1.1.x86_64 zu libaudcore5-3.9-1.1.i586
Architekturwechsel von libaudgui5-3.9-1.1.x86_64 zu libaudgui5-3.9-1.1.i586
Architekturwechsel von libaudqt2-3.9-1.1.x86_64 zu libaudqt2-3.9-1.1.i586
Architekturwechsel von libaudtag3-3.9-1.1.x86_64 zu libaudtag3-3.9-1.1.i586
Architekturwechsel von libsidplayfp4-1.8.7-1.3.x86_64 zu libsidplayfp4-1.8.7-1.3.i586
Architekturwechsel von libevent-2_1-8-2.1.8-1.3.x86_64 zu libevent-2_1-8-2.1.8-1.3.i586
Architekturwechsel von libqt5-qtwebengine-5.9.1-2.3.x86_64 zu libqt5-qtwebengine-5.9.1-2.3.i586
Architekturwechsel von nfs-client-2.1.1-3.1.x86_64 zu nfs-client-2.1.1-3.1.i586
nfs-client-2.1.1-3.1.i586 trotz der nachrangigen Architektur installieren
nfsidmap-0.26-1.8.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von ntp-4.2.8p10-1.2.x86_64 zu ntp-4.2.8p10-1.2.i586
ntp-4.2.8p10-1.2.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von transmission-2.92-4.1.x86_64 zu transmission-2.92-4.1.i586
transmission-2.92-4.1.i586 trotz der nachrangigen Architektur installieren
libb64-0-1.2.1-2.7.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von bitcoin-qt5-0.14.2-1.3.x86_64 zu bitcoin-qt5-0.14.2-1.3.i586
bitcoin-qt5-0.14.2-1.3.i586 trotz der nachrangigen Architektur installieren
libboost_chrono1_64_0-1.64.0-2.5.i586 trotz der nachrangigen Architektur installieren
libzmq5-4.2.2-2.4.i586 trotz der nachrangigen Architektur installieren
libpgm-5_2-0-5.2.122-1.22.i586 trotz der nachrangigen Architektur installieren
libsodium18-1.0.12-1.6.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von nfsidmap-0.26-1.8.x86_64 zu nfsidmap-0.26-1.8.i586
Architekturwechsel von libb64-0-1.2.1-2.7.x86_64 zu libb64-0-1.2.1-2.7.i586
Architekturwechsel von libboost_chrono1_64_0-1.64.0-2.5.x86_64 zu libboost_chrono1_64_0-1.64.0-2.5.i586
Architekturwechsel von libzmq5-4.2.2-2.4.x86_64 zu libzmq5-4.2.2-2.4.i586
Architekturwechsel von zeromq-tools-4.2.2-2.4.x86_64 zu zeromq-tools-4.2.2-2.4.i586
zeromq-tools-4.2.2-2.4.i586 trotz der nachrangigen Architektur installieren
Architekturwechsel von libpgm-5_2-0-5.2.122-1.22.x86_64 zu libpgm-5_2-0-5.2.122-1.22.i586
Architekturwechsel von libsodium18-1.0.12-1.6.x86_64 zu libsodium18-1.0.12-1.6.i586
Lösung 2: Ersatz von liblua5_3-5.3.3-2.2.x86_64 durch liblua5_3-5-5.3.4-1.1.x86_64
Lösung 3: Deinstallation von vlc-noX-2.2.4-239.2.x86_64
Lösung 4: veraltetes vlc-noX-2.2.4-239.2.x86_64 beibehalten
Lösung 5: vlc-noX-2.2.6-7.2.x86_64 durch Ignorieren einiger Abhängigkeiten brechen

Nehme ich eine Lösung, fragt er mich ein anderes Paket und immer so weiter - was ist hier zu empfehlen? Jedes Paket durchzugehen und ersetzen, oder das veraltete behalten?[/CODE]

Sauerland
31-Aug-2017, 22:04
Bei dieser "Lösung" würden viele Pakete auf 32Bit umgestellt, was du bestimmt nicht haben möchtest.

Poste noch einmal:

zypper lr -d

brandy
31-Aug-2017, 23:56
# | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
--+---------------------------+-----------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------------+-------
1 | http-ftp.gwdg.de-23030c20 | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/ |
2 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
4 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss/ |
5 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/tumbleweed/repo/oss/ |
6 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

wolfi323
04-Sep-2017, 04:21
Also hab ich jetzt verstanden - ist alles von Packman.

Aber wenn ich den Befehl eingebe - kommt diese Meldung:


Problem: vlc-noX-2.2.6-7.2.x86_64 benötigt liblua5.3.so.5()(64bit), kann jedoch nicht zur Verfügung gestellt werden
Nicht installierbare Anbieter: liblua5_3-5-5.3.4-1.1.x86_64[repo-oss]...
Die "richtige" Lösung wäre vermutlich:


Lösung 2: Ersatz von liblua5_3-5.3.3-2.2.x86_64 durch liblua5_3-5-5.3.4-1.1.x86_64

brandy
04-Sep-2017, 13:29
Vielen vielen Dank!
Lösung zwei funktioniert - WMAs werden nun abgespielt!