PDA

View Full Version : MIXXX installeren



kagepc
11-Dec-2016, 10:59
Dag,

Sinds 42.2 is uitgekomen probeer mixxx te installeren. Omdat er een afhankelijkheid mist lukt het niet.

Mixxx staat gewoon in de packman repo want bij software installeren wordt versie 2.0 gewoon gevonden. Wanneer ik Mixxx aanklik om te installeren komt gelijk de opmerking dat libchromaprint.so0()(64bit) nodig is maar niet kan worden gevonden.
Hoopte dat het upstream zou worden gecorrigeerd maar na pakweg 4 weken lijkt het erop dat het niet zal gebeuren.

Weet iemand een oplossing?

grtz
kage

Benmh
11-Dec-2016, 11:45
Dag,

Sinds 42.2 is uitgekomen probeer mixxx te installeren. Omdat er een afhankelijkheid mist lukt het niet.

Mixxx staat gewoon in de packman repo want bij software installeren wordt versie 2.0 gewoon gevonden. Wanneer ik Mixxx aanklik om te installeren komt gelijk de opmerking dat libchromaprint.so0()(64bit) nodig is maar niet kan worden gevonden.
Hoopte dat het upstream zou worden gecorrigeerd maar na pakweg 4 weken lijkt het erop dat het niet zal gebeuren.

Weet iemand een oplossing?

grtz
kage

Heb je tijdens het installeren van 42.2, ook de repro erbij gezet in YaST libdvdcss http://opensuse-guide.org/repo/openSUSE_Leap_42.2/

kagepc
11-Dec-2016, 12:50
Heb je tijdens het installeren van 42.2, ook de repro erbij gezet in YaST libdvdcss http://opensuse-guide.org/repo/openSUSE_Leap_42.2/

Hoi Benmh

Dank voor je reactie.

Nee, wist ook niet dat MIXXX daar afhankelijk van was.
De link die je geeft llopt dood:
ForbiddenYou don't have permission to access /repo/openSUSE_Leap_42.2/ on this server.

Nu weet ik wel hoe de repo toe te voegen maar moet ik daarna nog systeempakketten omzetten?

Grtz
Kage

Knurpht
12-Dec-2016, 01:43
Hoopte dat het upstream zou worden gecorrigeerd maar na pakweg 4 weken lijkt het erop dat het niet zal gebeuren.

Weet iemand een oplossing?

grtz
kage

Geen directe oplossing, maar wel een advies: rapporteer een bug. Als de packagers niet weten dat mixxx een verkeerde afhankelijkheid heeft en het pakket wordt verder goed gebouwd, dan weten ze van niks. En dan kunnen wij hier wel allemaal kunstgrepen met elkaar bedenken, maar 't pakket blijft dan gewoon niet OK.

Knurpht
12-Dec-2016, 08:51
En nu ook een oplossing, al is 't in mijn ogen meer een workaround:

Kies bij de installatie om de afhankelijkheid voor libchromaprint.so.0 te negeren.
Open een terminal en doe


cd /usr/lib64
ln -s libchromaprint.so.1 libchromaprint.so.0


Hierna kun je Mixxx starten. Het heeft ermee te maken dat Mixxx nog gebouwd is tegen een oudere versie van libchromaprint dan die die voor Leap beschikbaar is. En da's niet OK, verdient een bugreport.
-

kagepc
13-Dec-2016, 06:50
Dankjewel Knurpht,

Bug report is aangemaakt

grtz
Kage