PDA

View Full Version : Qualcomm QCA6174 geht nicht



tho_ho
28-Feb-2016, 12:20
Hi,
ich habe einen neuen Acer Laptop mit dem o.g. Wlan Adapter.


sudo lspci

07:00.0 Network Controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

Bin dann zuerst nach dieser Anleitung verfahren:
https://bbs.archlinux.org/viewtopic.php?pid=1607047
Hat nicht funktioniert.
Danach hier:
https://wireless.wiki.kernel.org/en/users/drivers/ath10k/firmware
Funktioniert auch nicht.

Ich bekomme im Systemtray nichts vonwegen Wlan angezeit, auch unter Yast->Netzwerkeinstellungen taucht der Adapter nicht auf
Bin langsam echt am Ende, und brauche daher etwas Hilfe =)

Grüße

wolfi323
28-Feb-2016, 13:11
Ich bekomme im Systemtray nichts vonwegen Wlan angezeit, auch unter Yast->Netzwerkeinstellungen taucht der Adapter nicht auf

Damit im Systemtray was passiert musst du in YaST->System->Netzwerkeinstellungen von "Wicked Service" auf "NetworkManager" umstellen.

Wenn der Adapter aber auch in YaST nicht auftaucht, gibts ein Problem mit dem Treiber.

Kannst du bitte mal die Ausgabe von "lspci -nnk" posten? Würde die Hilfe vereinfachen.

Und schau in YaST ob das Paket "kernel-firmware" installiert ist, das sollte eigentlich die benötigte Firmware enthalten, denke ich.

tho_ho
28-Feb-2016, 13:38
Network Manager ist ausgewählt

lspci -nnk


07:00.0 Network Controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
Subsystem: Foxconn International, Inc. Device [105b:e09d]
Kernel driver in use: r8169
Kernel modules: r8169

kernel-firmware ist installiert.

Ich hab mal was anderes ausprobiert:

modinfo ath10k_pci

filename: /lib/modules/4.1.12-1-default/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware: ath10k/QCA988X/hw2.0/board.bin
firmware: ath10k/QCA988X/hw2.0/firmware-3.bin
firmware: ath10k/QCA988X/hw2.0/firmware-2.bin
firmware: ath10k/QCA988X/hw2.0/firmware.bin
...

Diese ganzen Dateien habe ich nicht. Liegt da des Pudels Kern?

wolfi323
29-Feb-2016, 10:40
Network Manager ist ausgewählt

lspci -nnk


07:00.0 Network Controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
Subsystem: Foxconn International, Inc. Device [105b:e09d]
Kernel driver in use: r8169
Kernel modules: r8169

Hm. Da wird der r8169 Treiber an Stelle von ath10k verwendet.


Ich hab mal was anderes ausprobiert:

modinfo ath10k_pci

filename: /lib/modules/4.1.12-1-default/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware: ath10k/QCA988X/hw2.0/board.bin
firmware: ath10k/QCA988X/hw2.0/firmware-3.bin
firmware: ath10k/QCA988X/hw2.0/firmware-2.bin
firmware: ath10k/QCA988X/hw2.0/firmware.bin
...

Diese ganzen Dateien habe ich nicht. Liegt da des Pudels Kern?
Möglich.
Kann sein dass der ath10k Treiber wegen der fehlenden Firmware nicht geladen werden kann, und dann r8169 als "Fallback" verwendet wird (obwohl der zumindest auf meinem 13.2 System gar nicht angibt das er dieses Gerät unterstützt...).

https://wireless.wiki.kernel.org/en/users/drivers/ath10k/firmware enthält einen Download-Link und sagt man soll die Dateien nach /lib/firmware/ath10k/QCA988X/hw2.0/ kopieren, ich sehe da aber nur eine firmware-4.bin und firmware-5.bin, und auch das kernel-firmware von Leap 42.1 enthält nur /lib/firmware/ath10k/QCA988X/hw2.0/firmware-4.bin...

Was sagt denn:

dmesg | grep ath10k
?

Ansonsten würde ich mal den neuesten Kernel (und kernel-firmware) von Kernel:stable probieren, bzw. eine Tumbleweed LiveCD.
Die kernel-firmware von Tumbleweed enthält jedenfalls mehr Dateien/Ordner in /lib/modules/firmware/ath10k/...

Und nur zur Sicherheit, um ein Problem mit plasma-nm5 auszuschließen: funktionierts mit dem Textmodus NetworkManager?

nmtui
(als Benutzer ausführen)

tho_ho
29-Feb-2016, 12:10
Hi,

nmtui
funktioniert.

dmesg | grep ath10k
[ 3.824609] ath10k_pci 0000:07:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 4.014628] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[ 4.014666] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-4.bin failed with error -2
[ 4.014668] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-4.bin': -2
[ 4.014701] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-3.bin failed with error -2
[ 4.014702] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-3.bin': -2
[ 4.014733] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-2.bin failed with error -2
[ 4.014734] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-2.bin': -2
[ 4.014941] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware.bin failed with error -2
[ 4.014943] ath10k_pci 0000:07:00.0: could not fetch firmware (-2)
[ 4.014963] ath10k_pci 0000:07:00.0: could not fetch firmware files (-2)
[ 4.014981] ath10k_pci 0000:07:00.0: could not probe fw (-2)




uname -r
4.1.12-1-default
Der aktuelle Kernel ist so weit ich sehe 4.4.3-1

Habe also aus Kernel:stable die Dateien
kernel-default-4.4.3-1.1.g171b8f1.x86_64.rpm
und
kernel-firmware-20160112git-35.1.src.rpm
runtergeladen, auf meinen USB Stick gepackt und dann auf dem Laptop per

rpm -ivh XXXXX.rpm
installiert.
Daraus resultierte

uname -r
4.4.3-1.g171b8f1-default
Dann:

g | grep ath10k
[ 64.915882] ath10k_pci 0000:07:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 65.157156] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[ 65.157173] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[ 65.157175] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[ 65.157356] ath10k_pci 0000:07:00.0: invalid firmware magic
[ 65.157365] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-3.bin failed with error -2
[ 65.157366] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-3.bin': -2
[ 65.157371] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-2.bin failed with error -2
[ 65.157372] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-2.bin': -2
[ 65.157377] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware.bin failed with error -2
[ 65.157378] ath10k_pci 0000:07:00.0: could not fetch firmware (-2)
[ 65.157379] ath10k_pci 0000:07:00.0: could not fetch firmware files (-2)
[ 65.157381] ath10k_pci 0000:07:00.0: could not probe fw (-2)



Hier hat sich jetzt was getan:

lspci -nnk
07:00.0 Network Controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
Subsystem: Foxconn International, Inc. Device [105b:e09d]
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

Geht aber leider immernoch nicht :(
Reboot hab ich gemacht.

Edit:
Netter Nebeneffekt: Mein Touchpad geht plötzlich:)

tho_ho
29-Feb-2016, 12:53
Gute Nachrichten, funktioniert. Ich habe einfach nochmal
https://bbs.archlinux.org/viewtopic.php?pid=1607047
Post #2 befolgt. Was mir von Anfang an gefehlt hat, war das Kernel Update. Ist aber auch was mit der neuen Hardware....
Danke fürs helfen Wolfi!

wolfi323
29-Feb-2016, 15:57
Hi,

nmtui
funktioniert.
Wirklich? Du kannst damit eine WLAN-Verbindung aufbauen?
Dann wäre der Rest ja nicht nötig gewesen... ;)


Gute Nachrichten, funktioniert. Ich habe einfach nochmal
https://bbs.archlinux.org/viewtopic.php?pid=1607047
Post #2 befolgt. Was mir von Anfang an gefehlt hat, war das Kernel Update. Ist aber auch was mit der neuen Hardware....
Danke fürs helfen Wolfi!
Freut mich dass es jetzt geht... :)

hw1380
18-Apr-2016, 02:19
Ich habe (leider) die gleiche WLAN-Karte und deshalb auch die gleichen Probleme gehabt.
Einen Kernel-Update wollte ich vermeiden und habe mir deshalb von kavaso die entsprechende Firmware auf githib runtergeladen und dann noch unter /etc/modprobe.d/ eine Option dazu gesetzt.
Das funktionierte bei mir zwar auch, aber leider nur im 2.4Ghz Band. APs im 5Ghz Band werden zwar erkannt - es ist bei mir aber leider nicht möglich eine Verbindung herzustellen.
Da ich bisher nur Ärger mit den WLAN-Karten von realtek/Qualcomm hatte, werde ich versuchen diese durch eine von Intel auszutauschen.
Jetzt hat man schon eine ac-Karte und muss sich trotzdem im dicht besiedelten 2.4Ghz Band rumdrücken.

Sauerland
18-Apr-2016, 05:11
Jetzt hat man schon eine ac-Karte und muss sich trotzdem im dicht besiedelten 2.4Ghz Band rumdrücken.
Das ist aber Deine Entscheidung, mit einem neueren Kernel würde es gegebenenfalls funktionieren.

hw1380
30-Apr-2016, 00:40
Das ist aber Deine Entscheidung, mit einem neueren Kernel würde es gegebenenfalls funktionieren.

Ich habe mittlerweile einen Kernel-Upgrade auf 4.5.2 durchgeführt - hauptsächlich wegen den i915-Freezes.
Diese sind zwar Vergangenheit, jedoch habe ich nach wie vor Probleme mit dem WLAN.
Ich habe schon verschiedene Firmwares durchprobiert. Ich kann zwar in beiden Bändern Verbindung aufbauen, jedoch ist die Übertragungsrate mit 1--2MB extrem niedrig.
Wenn niemand eine Lösung hat, werde ich sie gegen eine von Intel tauschen müssen.

Akoellh
30-Apr-2016, 02:45
Am Sat, 30 Apr 2016 07:46:01 GMT
schrieb hw1380

> Ich habe mittlerweile einen Kernel-Upgrade auf 4.5.2 durchgeführt -

> Ich habe schon verschiedene Firmwares durchprobiert. Ich kann zwar in
> beiden Bändern Verbindung aufbauen, jedoch ist die Übertragungsrate
> mit 1--2MB extrem niedrig.

Das klingt nach den üblichen "Kinderkrankheiten" bei relativ neuen Treibern, das ist (leider) keine Seltenheit.

> Wenn niemand eine Lösung hat, werde ich sie gegen eine von Intel
> tauschen müssen.


Wenn ich mir auf https://git.kernel.org ansehe, was sich bei dem Treiber seit 4.5 (= wird in 4.6 landen) getan hat, würde ich die Flinte noch nicht so schnell ins Korn werfen, zwischen 4.4 und 4.5 war jedenfalls weniger los.

Da Intel ein eigenes Team von Programmierern für Wireless unter Linux (und nicht nur dafür) hat, geht es dort meist recht schnell und mit relativ wenig "Kinderkrankheiten", wäre also sicherlich nicht die schlechteste Wahl (Ausnahmen bestätigen die Regel).

AK

P.S. Wer mal eine (Viertel)Stunde Zeit hat, kann sich diesen Vortrag von Felix Fietkau (openWRT-Entwickler) ansehen.

https://www.youtube.com/watch?v=niu14NoLeQc

Da kommen einige der Probleme zur Sprache, welche bei der Kommunikation "Hersteller <-> Entwickler freier Treiber" auftreten können, auch bezogenauf Qualcomm/Atheros und ath10k, wozu man sich auch nur die ersten 15-20 Minuten ansehen braucht.

--
Never attribute to malice that which can be adequately explained by stupidity. (R.J. Hanlon)