PDA

View Full Version : Update probleem?



Gps2010
24-Feb-2015, 07:10
Ik krijg nu al sinds een aantal dagen, constant te zien dat er dezelfde updates zijn, Ik ken de lijst niet uit mijn hoofd, maar drie dingen wel. Het zijn gstreamer updates, XMMS2 updates en een youtube download tool.

Waarom ik die laatste krijg is me niet helemaal duidelijk, maar goed.


Via het inlezen op dit forum:

uus@linux-ab3o:~> zypper ref && zypper up
Er zijn root-privileges vereist voor het vernieuwen van de systeeminstallatiebronnen.
guus@linux-ab3o:~> sudo zypper ref && zypper up
root's password:
Installatiebron 'nVidia Graphics Drivers' is actueel.
Installatiebron 'Installatiebron voor bijwerken (niet-Oss)' is actueel.
Installatiebron 'openSUSE BuildService - Mozilla' is actueel.
Installatiebron 'Hoofd-installatiebron (niet-opensource)' is actueel.
Installatiebron 'Hoofd-installatiebron (opensource)' is actueel.
Installatiebron 'Hoofd-installatiebron voor bijwerken' is actueel.
Installatiebron 'Packman Repository' is actueel.
Installatiebron 'games:tools' is actueel.
Installatiebron 'google-chrome' is actueel.
Installatiebron 'home:DarkPlayer:Pipelight' is actueel.
Installatiebron 'home:Nemton' is actueel.
Installatiebron 'home:wengo' is actueel.
Installatiebron 'openSUSE-13.1-1.10' is actueel.
Installatiebron 'windows:mingw:win32' is actueel.
Installatiebron 'windows:mingw:win64' is actueel.
Alle installatiebronnen zijn vernieuwd.
Er zijn root-privileges vereist voor het bijwerken van pakketten.



Als ik echter kijk in de lijst van apper? kde ? dan zie ik:

Het opwaarderen van de distributie is gereed.
Het installeren bijwerken is gereed.
Een transactie met succes afronden is mislukt
Opnieuw opstarten van het systeem is nodig
Bericht van de software beheerder
Opwaarderingen worden geinstalleerd
Elementen voor bijwerken worden gedownload
Nieuwe zaken voor bijwerken beschikbaar
Er deed zich een fout voor in een transactie
Het opwaarderen van de distributie is beëindigd met een fout.
Opwaarderingen van een distributie beschiikbaar.

Oa gisteren opnieuw opgestart, maar dat helpt dus blijkbaar niet ?

En net als de afgelopen dagen, zegt het apper? icoon ( kever ? ) dat mijn systeem bij de tijd is.

Toch lijkt het mij zeer onwaarschijnlijk dat er nu al 4 dagen op een rij, gestreamer en xmms2 updates zijn.

hcvv
24-Feb-2015, 07:21
Ik gebruik Apper niet (heb het zelfs niet geïnstalleerd), dus mijn advies is noet helemaal neutraal.

Is er een probleem als je YaST gebruikt (waarschijnlijk niet, net als met zypper)? Geen probleem? OK.

Knurpht
24-Feb-2015, 08:36
Sommige updates laat Apper wel zien, maar zijn niet voor jou, omdat je ergens een "Schakel systeempakketten ..." op een repo hebt losgelaten. Yast's softwarebeheer is daar wat ingelligenter in. Volg alsjeblieft geen adviezen op om de "vendor" controle uit te zetten. Voor je het weet heb je KDE pakketten uit 3 verschillende repos, met ongewenste resultaten.

Terzijde: ik zie dat je pipelight nog gebruikt. Dat is voor Netflix en Magister6 niet meer nodig.

Gps2010
24-Feb-2015, 09:22
Om achteraan te beginnen, ik heb pipelight geïnstalleerd, omdat er een site (rtl7 ? ) begon te zeuren dat ik geen silverlight heb.

Pipelight loste dit echter niet op, en ik kreeg ook niet wat ik eerder wel zag, de optie om pipelight toe te staan.

Maar nu terug naar apper. Dat kan ik dus uitzetten? Het is namelijk al langer een bron ven ergernis.

Als ik in yast bij gstreamer kijk, dan lijk ik de laatste versie te hebben.

Verder begint ook XMMS2 op me zenuwen te werken, omdat het crashed als je dubbele grote weergeven kiest.
Uit een korte zoektocht op internet blijkt dat ik niet de enige met dit probleem ben, en het heeft ook niet echt met openSUSE te maken.
QMMP werkt prima, en kan zelfs winamp skins laden. Ik gebruik nu op openSUSE een skin, die ik vroegah op windows gebruikte, maar die niet meer werkte met de laatste winamp op windows.
De oorspronkelijke reden waarom ik die spelers installeerde was mijn afkeer voor Amarok, en het probleem dat het veel van mijn "mp3" niet af wilde spelen.
Amarok speelt echter tegenwoordig wel alles af (verdor change packman) en qmmp is alles wat ik nodig heb,

Ik ga dus nu eerst XMMS2 verwijderen, maar het is mij niet duidelijk, hoe ik apper uitzet, en hoe ik dan me systeem update?
Hoe ik apper uitzet, ga ik vast wel vinden via google en of dit forum, maar hoe doe ik dan de updatess ?

hcvv
24-Feb-2015, 09:29
Apper echt goed uitzetten:
YaST > Software > Softwaremanagement. In het zoekveld apper intikken en Zoeken klikken.
Het vierkentje voor Apper in het rechter veld is zwart met een wit V-tje. Rechts-klik of dat vierkantje en kies de rode X. Dan rechts beneden klikken op Accepteren.

Ik dacht trouwens dat je wel wist hoe pakketten te (de)ïnstalleren.

Gps2010
24-Feb-2015, 09:35
Dat klopt, mijn denkfout was dat ik niet verwachtte dit gewoon via Yast te kunnen doen.

Ik mis Apper nu al niet meer. :)

Nu nog even opnieuw opstarten.

Knurpht
24-Feb-2015, 09:40
Maar, je hoeft apper helemaal niet uit te zetten. Gewoon niet gebruiken is prima. Tenzij je, net als meer openSUSE gebruikers, met je repos en prioriteit daarvan aan het stoeien bent geweest, of "Allow vendor change" aan hebt gezet in Yast.
Het wonderbaarlijke is ( misschien gewoon Tumbleweed ) dat ik Apper gewoon kan gebruiken, en het zich precies zo gedraagt als Yast's softwarebeheer. Zodanig goed dat ik de laatste tijd het voorstel van Firefox om met Apper te installeren gewoon opvolg.

Gps2010
24-Feb-2015, 09:53
Maar hoe doe ik dan de updates zonder apper ?

Wat ik net gedaan heb:


guus@linux-ab3o:~> sudo zypper update
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...

De volgende 36 pakketten zijn gesuggereerd, maar zullen niet worden geïnstalleerd:
gstreamer-0_10-plugin-gnomevfs libdvdnav4 libdvdread4 libfreebl3 libsoftokn3 libxcb1 libxcb1-32bit libxcb-composite0 libxcb-damage0 libxcb-devel libxcb-dpms0
libxcb-dri2-0 libxcb-glx0 libxcb-randr0 libxcb-record0 libxcb-render0 libxcb-res0 libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-xevie0 libxcb-xf86dri0
libxcb-xfixes0 libxcb-xinerama0 libxcb-xprint0 libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 MozillaFirefox MozillaFirefox-branding-openSUSE
MozillaFirefox-translations-common mozilla-kde4-integration mozilla-nss-certs perl-HTML-Tidy perl-Text-Wrapper perl-XML-Simple

Niets te doen.
guus@linux-ab3o:~>

Ik herken die updates, daar viel apper me dus de afgelopen dagen ook al mee lastig.

En via zypper is nu ook dat youtube geval ge-update. ( ik draaide zypper twee keer, de uitvoer is alleen van de laatste keer )
Maar de zin: zijn gesuggereerd, maar zullen niet worden geïnstalleerd, brengt mij ernstig in verwarring.

hcvv
24-Feb-2015, 10:00
Maar, je hoeft apper helemaal niet uit te zetten. .
Maar waarom zou ik iets uitzetten dat ik helemaal niet hoef te hebben?lol!

Ik installeer Apper en Packagekit helemaal nooit (staat bij mij in het rijtje van "niet installeren tijdens systeeminstallatie evenals Samba, Apparmor). Heb ik er nooit last van.

Gps2010
24-Feb-2015, 10:57
Ik realiseer mij net dat ik twee antwoorden door elkaar gebruik.
Daarom even een stap terug en opnieuw.

@hcvv, hoe update jij dan openSUSE? Via Yast, online opwaarderen ?

@ Knurpht, hoe kom ik dan van dat gezeur af, dat apper elke dag met de zelfde mededeling (updates) komt ?

hcvv
24-Feb-2015, 11:22
@hcvv, hoe update jij dan openSUSE? Via Yast, online opwaarderen ?

Meestal één maal per week doe ik YaST > Software > Online opwaarderen (equivalent aan zypper patch). Ik kijk dan alrijd even snel door de lijst zodat ik iets eventueel kan uitstellen.

Ook éénmaal per week doe ik YaST > Software > Softwarebeheer; dan van View: Bronnen; kies Packman; in de rechterlijst rechtsklik en kies Alles in deze lijst > Opwaarderen als een nieuwere versie beschikbaar is. Daar is vast ook een zypper commando voor (iets met zypper up -r Packman of zo) als je dat prefereert.

Ik heb nog een paar repos met één product (of zo). Die zijn bij mij Disabled. Eens per half jaar of zo Enable ik die om te kijken of daar iets nieuws is.

Overigens is mijn aversie tegen Apper ook omdat het gepresenteerd wordt op de desktop van iedere gebruiker die je aanmaakt. Dat moet je dan eerst weghalen. Tenslotte heeft de gewone gebruiker er niets mee te maken en hoort geen icoontjes te zien waar zij/hij niets mee kan. Het is dus niet een questie van "Dan gebruik je het toch niet" (welke "je"?). Dat was overigens ook het nadeel van de vroegere SuSE update applet.

Knurpht
25-Feb-2015, 03:36
Je vraagt 't mij niet, maar ik gebruik al zeker meer dan een jaar de updater plasmoid. Zonder problemen. En update eigenlijk elke keer dat 't ding me meldt dat er updates zijn.
Ten overvloede: de plasmoid heeft nog steeds last van de verhalen die er de ronde over doen. Er hoeft maar een vraag over te komen en conservatieve gebruikers komen weer met "not stable" etc. Dat geldt ook voor Apper. Mijn ervaring met beide is prima. Nee, je kunt met de plasmoid niet selectief updaten, 't is alleen controleren of er updates zijn, en zo ja, ze wel of niet installeren.

hcvv
25-Feb-2015, 04:19
Zoals gezegd, ik wil mijn gebruikers (inclusief mijzelf) er niet mee lastig vallen. Daar hebben ze een systeembeheerder voor ;).

Het zal best dat het werkt, maar er zijn toch nog steeds draden op deze forums, die opgelost worden zodra de OP gevolg geeft aan het verzoek om het eens met YaST/zypper te doen.

Ik zal best conservatief zijn. Als er trots een nieuw feature wordt aangekondigd in een nieuwe versie van iets (niet alleen in ICT, maar voor van alles), is meestal mijn eerste vraag: "
Hoe kan ik dat uitzetten?" Dit tot frustratie van de leverancier, die altijd denkt dat iedereen hijgend op dat feature zit te wachten (en dus zet hij dat bij verstek aan, i.p.v. het aan de jarenlange gebruiker over te laten om het eerst voorzichtig te testen en dan eventueel te gaan gebruiken). Nee, ik heb te veel kapot verbeterde versies van spullen gezien.

Gps2010
25-Feb-2015, 09:29
Je vraagt 't mij niet, maar ik gebruik al zeker meer dan een jaar de updater plasmoid. Zonder problemen. En update eigenlijk elke keer dat 't ding me meldt dat er updates zijn.
Ten overvloede: de plasmoid heeft nog steeds last van de verhalen die er de ronde over doen. Er hoeft maar een vraag over te komen en conservatieve gebruikers komen weer met "not stable" etc. Dat geldt ook voor Apper. Mijn ervaring met beide is prima. Nee, je kunt met de plasmoid niet selectief updaten, 't is alleen controleren of er updates zijn, en zo ja, ze wel of niet installeren.

Maar ik heb dus wel een probleem. En na minstens 4 dagen steeds de zelfde updates te zien, was ik het zat.
Geen duidelijke reden waarom het niet lukte, alleen maar vage opmerkingen.

En elke dag ook nog beweren dat het wel gelukt is, totdat ik me pc opnieuw opstarten, en het spelletje weer van voor af aan begon.

En ik ga wel even zoeken op het net, maar het is me nog steeds duidelijk waar het nou mis gaat(ging) met apper.
Dat vind ik dus het voordeel van de Yast manier, dan zie je meteen, waarom er iets eventueel niet wil.

Knurpht
27-Feb-2015, 04:48
Het lijkt er op dat er nog ergens rommel rondhangt.


zypper clean && zypper ref
rpm --rebuilddb


zijn een paar opties die je zou kunnen proberen. De eerste schoont de cache van zypper en ververst de inhoud van de repos, de tweede bouwt de rpm database opnieuw op.
Ik denk overigens dat Apper in jouw geval updates laat zien, waarvan jij over de pakketten hebt gezegd dat je die uit een andere repo wilt gebruiken.

Gps2010
27-Feb-2015, 06:25
Nu denk ik dat ik het begrijp. Ik weet dat ik een vendor change gedaan heb.

En voor het eerst op openSUSE voor mij speelt Amarok ook ape bestanden af, en nog wat meer afwijkend spul in mijn mp3 collecties.

Misschien installeer ik apper opnieuw, en kijk ik dan hoe ik het oplos.

Knurpht
27-Feb-2015, 08:28
Nu denk ik dat ik het begrijp. Ik weet dat ik een vendor change gedaan heb.

En voor het eerst op openSUSE voor mij speelt Amarok ook ape bestanden af, en nog wat meer afwijkend spul in mijn mp3 collecties.

Misschien installeer ik apper opnieuw, en kijk ik dan hoe ik het oplos.

Amarok van Packman kan een flink aantal dingen wel, die de standaard openSUSE versie niet kan. Ook daar is het juridisch niet anders, dan dat openSUSE "crippled" pakketten bouwt.

Gps2010
05-Mar-2015, 10:08
De steam sale is er weer, en dus heb ik maar weer eens een spelletje gekocht, was maar 12 gig en werkt niet, maar nu on topic.

Ik heb apper weer geïnstalleerd, en het is gelijk feest.


patch:openSUSE-2015-185-1.noarch conflicts with mozilla-nss-devel.x86_64 < 3.17.4-52.1 provided by mozilla-nss-devel-3.17.4-1.1.x86_64 >:(




Ik ga even kijken via Yast, of ik het daar op kan lossen, maar anders gaat apper er weer af. Ik zag ook weer de gstreamer updates langskomen.
Maar deze keer wil ik er iets meer moeite insteken.

Word vervolgt.

Gps2010
05-Mar-2015, 10:12
Via yast voor een andere leverancier gekozen, en dat loste het probleem op. rotfl!

( kijken voor hoelang :P )

Gps2010
05-Mar-2015, 12:02
Google is soms je vriend. :)

https://nl.opensuse.org/SDB:Bijwerken_met_wijziging_van_leverancier

Wat ik gekozen heb, is de vendor stickyness uit te zetten.


In /etc/zypp/zypp.conf set


solver.allowVendorChange = true

Voor andere, lees wel even de hele pagina, voor je iets veranderd, er zijn meer mogelijkheden, met hun eigen voor en nadelen.

En ik moet nog controleren, of ik nu in yast ook alle files, die met een blauwe kleur weergegeven worden, kwijt ben.
( de blauwe kleur dus, niet de bestanden)

hcvv
06-Mar-2015, 02:18
Wat ik gekozen heb, is de vendor stickyness uit te zetten.

Inderdaad, waarschuwing voor iedereen.:

Gps2010 heeft kennelijk een speciale reden om dit te doen.
Dat doet verder (bijna) niemand. Als je dit ook gaat doen, denk daar dan dus eerst heel goed over na. En als er dan poroblemen optreden kan waarschijnlijk alleen Gps2010 je verder helpen.

Knurpht
06-Mar-2015, 07:35
Inderdaad, waarschuwing voor iedereen.:

Gps2010 heeft kennelijk een speciale reden om dit te doen.
Dat doet verder (bijna) niemand. Als je dit ook gaat doen, denk daar dan dus eerst heel goed over na. En als er dan poroblemen optreden kan waarschijnlijk alleen Gps2010 je verder helpen.

NIET D​OEN DUS

Vragen om moeilijkheden. Wat er gebeurt is dat er pakketten uit verkeerde repos worden "geupdate", er wordt immers alleen nog maar naar versienummers gekeken, dus als pakkettenbouwer A's pakketten eerder klaar zijn dan die van B, zijn de pakketten van B de updates. Dat die uit een repo B komen die niet compatible is met de andere pakketten uit repo A gaat vaak nog goed ook. Maar ik draai linux omdat ik wil dat 't altijd goed gaat, of helemaal goed, en niet "vaak". Mijn experiment hiermee eindigde met niet meer in kunnen loggen op KDE en GNOME, omdat ik die twee uit andere repos draaide, en er voor de met de distro meegeleverde kdm een update kwam die een hoger versienummer had dan de goeie kdm.