PDA

View Full Version : Kein WLAN bei Netbook



JumpysVater
09-Apr-2014, 09:22
Hallo!

Ich habe auf ein Netbook, das nicht mir, sondern einem Familienmitglied gehört und das früher unter dem inzwischen obsoleten Windows XP lief, OpenSuse 13.1 installiert, das auch bestens funktioniert.

Allerdings geht hier das WLAN nicht. Die Sache ist diesbezüglich sowieso etwas kompliziert. Das Teil hat eine interne WLAN-Karte, die aber kaputt zu sein scheint, weil sie schon unter Windows nicht funktioniert hat. Deshalb wurde ein Usb-WLAN-Stick eingesetzt, der unter Windows seinen Dienst versehen hat. Unter Linux allerdings nicht.

Das WLAN ist weder unter Yast noch im Network Manager zu erkennen, das System kann also scheinbar mit dem Adapter nichts anfangen.

Ich habe lsusb verwendet, die Ausgabe scheint mir aber nicht sinnvoll zu sein, ich schicke sie euch trotzdem:



Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 005: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 005 Device 002: ID 04ca:0030 Lite-On Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Deshalb habe ich auch noch den Teil der Ausgabe von lspci mitgeschickt, der mir sinnvoll erscheint, ich kann bei Bedarf aber auch alles schicken:



02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller [10ec:8199] (rev 22)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller [10ec:8199]
Kernel driver in use: r8180
Kernel modules: r8187se


Ich hoffe, ihr könnt was damit anfangen. Vielen Dank im voraus.

LG Reinhold

wolfi323
09-Apr-2014, 09:50
Das WLAN ist weder unter Yast noch im Network Manager zu erkennen, das System kann also scheinbar mit dem Adapter nichts anfangen.

Ich habe lsusb verwendet, die Ausgabe scheint mir aber nicht sinnvoll zu sein, ich schicke sie euch trotzdem:



Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 005: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 005 Device 002: ID 04ca:0030 Lite-On Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Das wird wohl der USB WLAN-Adapter sein.
Scheinbar wird der leider noch nicht direkt unterstützt, es gibt aber einen sogenannten "staging" Treiber (d.h. er ist noch im Versuchsstadium), den du dir selber compilieren kannst.
Siehe dazu hier:
http://forum.ubuntuusers.de/topic/problem-mit-usb-adapter-tp-link-tl-wn725n-v2/#post-6315992

Du solltest vorher das Schema "Kernel-Entwicklung" in YaST installieren. ("Anzeigen"->"Schemata"), "git" musst du auch installieren, das ist aber eh in den Standard-Repos. (das "sudo apt-get install git" gilt natürlich nur für Ubuntu, das kannst du weglassen)

Wenn du irgendwo anstehst, oder noch was unklar ist, einfach fragen! ;)


Deshalb habe ich auch noch den Teil der Ausgabe von lspci mitgeschickt, der mir sinnvoll erscheint, ich kann bei Bedarf aber auch alles schicken:



02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller [10ec:8199] (rev 22)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller [10ec:8199]
Kernel driver in use: r8180
Kernel modules: r8187se


Das ist die interne Karte.
Wenn die aber sowieso kaputt ist, brauchen wir wohl nicht versuchen, die zum Laufen zu bekommen.
Allerdings, vielleicht ist sie ja nur ausgeschaltet oder so. Installier bitte mal das Paket "rfkill" und poste die Ausgabe von "rfkill".
Ein Treiber scheint ja vorhanden und geladen zu sein.

tomm_fa
09-Apr-2014, 11:46
uname -r
3.14.0-2.gfa168d7-desktop

modinfo r8188eufilename: /lib/modules/3.14.0-2.gfa168d7-desktop/kernel/drivers/staging/rtl8188eu/r8188eu.ko
version: v4.1.4_6773.20130222
author: Realtek Semiconductor Corp.
description: Realtek Wireless Lan Driver
license: GPL
srcversion: CE2FC54044414CB5AB11BBE
alias: usb:v2001p3310d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v2001p330Fd*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v07B8p8179d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0BDAp0179d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0BDAp8179d*dc*dsc*dp*ic*isc*ip*in*
depends:
staging: Y
intree: Y
vermagic: 3.14.0-2.gfa168d7-desktop SMP preempt mod_unload modversions
parm: rtw_ips_mode:The default IPS mode (int)
parm: ifname:The default name to allocate for first interface (charp)
parm: if2name:The default name to allocate for second interface (charp)
parm: rtw_initmac:charp[…]

Schaut doch mal bei euch.

wolfi323
09-Apr-2014, 12:02
Schaut doch mal bei euch.
Hab ich natürlich vorher gemacht. ;)
Der Kernel 3.11, der bei openSUSE 13.1 dabei ist, enthält den Treiber leider noch nicht:

# rpm -ql kernel-desktop|grep r8188
# modinfo r8188eu
ERROR: modinfo: could not find module r8188eu
#

Aber danke für den Hinweis!

@JumpysVater:
Du bräuchtest also nur den neuesten Kernel installieren.

Erhältlich hier:
http://software.opensuse.org/download.html?project=Kernel%3Astable&package=kernel-desktop

tomm_fa
09-Apr-2014, 12:21
@JumpysVater:
Du bräuchtest also nur den neuesten Kernel installieren.

Erhältlich hier:
http://software.opensuse.org/download.html?project=Kernel%3Astable&package=kernel-desktop
Jein, nur wenn bestimmte Sachen/Kernelmodule nicht zum derzeitig verwendeten Kernel aus einem Repo installiert sind (z.B. Nvidia für Grafikkarte usw., was sich sicherlich auch lösen lässt), aber ansonsten, wenn nichts dagegen spricht…
;)

JumpysVater
10-Apr-2014, 05:31
Bei einem Netbook wird man wohl schwerlich eine Nvidia-Graka finden. Aber danke. Eines nach dem anderen. Ich schau erstmal, ob ich nicht doch die interne Karte zum Laufen bringe. Ich rühre mich wieder.

LG Reinhold

JumpysVater
10-Apr-2014, 05:52
Das habe ich gerade getan, aber rfkill gibt überhaupt nichts aus, obwohl ich die manpage studiert habe. Bei "rfkill list" oder "rfkill list all" tut sich gar nix. Was mache ich falsch?

LG Reinhold

wolfi323
10-Apr-2014, 06:11
Das habe ich gerade getan, aber rfkill gibt überhaupt nichts aus, obwohl ich die manpage studiert habe. Bei "rfkill list" oder "rfkill list all" tut sich gar nix. Was mache ich falsch?

Entweder für die interne Karte ist der falsche Treiber geladen, oder die ist wirklich so kaputt, dass rfkill sie nicht erkennt.
Dass der USB-Adapter nicht angezeigt wird, liegt wahrscheinlich daran, dass der Treiber nicht vorhanden ist.

Tja, wie gesagt. An deiner Stelle würde ich mal den aktuellsten Kernel probieren (sh. voriger Post), dann sollte zumindest die USB-Karte funktionieren.

Du solltest aber darauf achten, dass kernel-firmware installiert ist. Das Kernel:stable repo enthält eine neuere Version, also solltest du das auch updaten, selbst wenn es schon installiert ist. (sh. "Versionen" Tab in YaST->Software installieren/entfernen)

JumpysVater
10-Apr-2014, 09:09
Tja, ich hab jetzt den Kernel 3.14 drauf (wenn ich richtig gesehen habe) und der Update von Kernel-Firmware ist auch erfolgt. Geändert scheint das Ganze noch nicht viel zu haben. Wie gehts jetzt weiter?

LG Reinhold

wolfi323
10-Apr-2014, 09:12
Tja, ich hab jetzt den Kernel 3.14 drauf (wenn ich richtig gesehen habe) und der Update von Kernel-Firmware ist auch erfolgt. Geändert scheint das Ganze noch nicht viel zu haben. Wie gehts jetzt weiter?

Einen Neustart in den neuen Kernel hast du hoffentlich gemacht?
Dann sollte eigentlich automatisch der passende Treiber geladen werden.

Probier mal den Stick aus und anzustecken, und dann die Ausgabe von "dmesg|tail" posten.
Wird er in YaST->Netwerkgeräte->Netzwerkeinstellungen angezeigt?

JumpysVater
10-Apr-2014, 10:50
Ähemm.. zunächst einmal hab ich bemerkt, dass ich mich beim Kernel-Firmware-Update verfranzt habe. Ich habe das - diesmal richtig - wiederholt. Nach einem erneuten Restart konnte ich feststellen, dass an dem WLAN-Stick ein blaues Licht blinkt. Ich sehe das mal positiv. Wie gesagt, der Rechner gehört nicht mir, und auch den Stick habe ich nicht gekauft.

WLAN-Verbindung habe ich allerdings noch keine. Auch in Yast kann das Netz nicht erkannt werden. Ich habe noch etwas feststellen müssen: Wenn ich versuche, die Verbindungen über den Netzwerk-Manager zu konfigurieren, bricht die gesamte Netzwerkverbindung zusammen, auch die kabelgebundene. Nur durch einen Rückstieg auf Yast kann ich letztere wieder herstellen.

Hier der Vollständigkeit halber noch die Ausgabe von dmesg:



[ 1426.428196] usb 1-5: new high-speed USB device number 5 using ehci-pci
[ 1426.543313] usb 1-5: New USB device found, idVendor=0bda, idProduct=8179
[ 1426.543332] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1426.543345] usb 1-5: Product: 802.11n NIC
[ 1426.543356] usb 1-5: Manufacturer: Realtek
[ 1426.543367] usb 1-5: SerialNumber: 00E04C0001
[ 1426.546338] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
[ 1426.679780] systemd-udevd[11368]: renamed network interface wlan0 to wlp0s29f7u5
[ 1428.271679] MAC Address = f8:1a:67:19:fc:71
[ 1428.277165] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u5: link is not ready


LG Reinhold

wolfi323
11-Apr-2014, 03:42
Nach einem erneuten Restart konnte ich feststellen, dass an dem WLAN-Stick ein blaues Licht blinkt. Ich sehe das mal positiv.
Ja, würde ich auch so sehen.



WLAN-Verbindung habe ich allerdings noch keine. Auch in Yast kann das Netz nicht erkannt werden. Ich habe noch etwas feststellen müssen: Wenn ich versuche, die Verbindungen über den Netzwerk-Manager zu konfigurieren, bricht die gesamte Netzwerkverbindung zusammen, auch die kabelgebundene. Nur durch einen Rückstieg auf Yast kann ich letztere wieder herstellen.
Hm, dann stürzt scheinbar der NetworkManager ab.

Gehts vielleicht, wenn du ihn neustartest?

sudo systemctl restart NetworkManager.service

Gibts irgendwelche hilfreichen Meldungen in /var/log/NetworkManager?

Du kannst den NetworkManager manuell in einem Terminalfenster starten, dann gibts evtl. noch ausführlichere Meldungen:

sudo systemctl stop NetworkManager.service
sudo NetworkManager --no-daemon

Ansonsten weiß ich leider auch nicht weiter.
Wenn dein Englisch gut genug ist, könntest du mal im englischen Forum (unter "Wireless") nachfragen:
http://forums.opensuse.org/forumdisplay.php/676-Wireless

lwfinger hängt dort rum, das ist ein Kernel-Entwickler und der Author des r8188eu Treibers (unter anderem).
Wenn der dir nicht helfen kann, dann wohl niemand... ;)

JumpysVater
11-Apr-2014, 09:31
Bevor ich lwfinger kontaktiere, möchte ich dich noch mal fragen, ob du mit diesem Inhalt von /var/log/NetworkManager was anfangen kannst:



2014-04-11T18:19:21.394155+02:00 linux-1oi7 NetworkManager[9904]: <info> NetworkManager (version 0.9.8.8) is starting...
2014-04-11T18:19:21.396721+02:00 linux-1oi7 NetworkManager[9904]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
2014-04-11T18:19:21.403424+02:00 linux-1oi7 NetworkManager[9904]: <info> WEXT support is enabled
2014-04-11T18:19:21.414987+02:00 linux-1oi7 NetworkManager[9904]: <info> VPN: loaded org.freedesktop.NetworkManager.vpnc
2014-04-11T18:19:21.419193+02:00 linux-1oi7 NetworkManager[9904]: <info> VPN: loaded org.freedesktop.NetworkManager.pptp
2014-04-11T18:19:21.421333+02:00 linux-1oi7 NetworkManager[9904]: <info> VPN: loaded org.freedesktop.NetworkManager.openvpn
2014-04-11T18:19:21.446113+02:00 linux-1oi7 NetworkManager[9904]: <info> Loaded plugin ifcfg-suse: (C) 2008 Novell, Inc. To report bugs please use the NetworkManager mailing list.
2014-04-11T18:19:21.449158+02:00 linux-1oi7 NetworkManager[9904]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
2014-04-11T18:19:21.453440+02:00 linux-1oi7 NetworkManager[9904]: keyfile: parsing Neue drahtlose Verbindung ...
2014-04-11T18:19:21.521428+02:00 linux-1oi7 NetworkManager[9904]: keyfile: read connection 'Neue drahtlose Verbindung'
2014-04-11T18:19:21.523424+02:00 linux-1oi7 NetworkManager[9904]: keyfile: parsing Neue kabelgebundene Verbindung ...
2014-04-11T18:19:21.585775+02:00 linux-1oi7 NetworkManager[9904]: keyfile: read connection 'Neue kabelgebundene Verbindung'
2014-04-11T18:19:21.603351+02:00 linux-1oi7 NetworkManager[9904]: <info> monitoring kernel firmware directory '/lib/firmware'.
2014-04-11T18:19:21.616775+02:00 linux-1oi7 NetworkManager[9904]: <info> WiFi hardware radio set enabled
2014-04-11T18:19:21.625748+02:00 linux-1oi7 NetworkManager[9904]: <info> WiFi enabled by radio killswitch; enabled by state file
2014-04-11T18:19:21.628136+02:00 linux-1oi7 NetworkManager[9904]: <info> WWAN enabled by radio killswitch; enabled by state file
2014-04-11T18:19:21.630968+02:00 linux-1oi7 NetworkManager[9904]: <info> WiMAX enabled by radio killswitch; enabled by state file
2014-04-11T18:19:21.633033+02:00 linux-1oi7 NetworkManager[9904]: <info> Networking is disabled by state file
2014-04-11T18:19:21.636264+02:00 linux-1oi7 NetworkManager[9904]: <warn> failed to allocate link cache: (-12) Object not found
2014-04-11T18:19:21.638406+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp1s0): carrier is OFF
2014-04-11T18:19:21.641065+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp1s0): new Ethernet device (driver: 'r8169' ifindex: 2)
2014-04-11T18:19:21.650525+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp1s0): exported as /org/freedesktop/NetworkManager/Devices/0
2014-04-11T18:19:21.652987+02:00 linux-1oi7 NetworkManager[9904]: <warn> failed to allocate link cache: (-12) Object not found
2014-04-11T18:19:21.655276+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp2s0): driver does not support SSID scans (scan_capa 0x00).
2014-04-11T18:19:21.657699+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp2s0): using WEXT for WiFi device control
2014-04-11T18:19:21.660048+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp2s0): new 802.11 WiFi device (driver: 'r8180' ifindex: 3)
2014-04-11T18:19:21.662157+02:00 linux-1oi7 NetworkManager[9904]: <info> (enp2s0): exported as /org/freedesktop/NetworkManager/Devices/1
2014-04-11T18:19:21.666149+02:00 linux-1oi7 NetworkManager[9904]: <info> (wlp0s29f7u5): driver supports SSID scans (scan_capa 0x3F).
2014-04-11T18:19:21.668428+02:00 linux-1oi7 NetworkManager[9904]: <info> (wlp0s29f7u5): using WEXT for WiFi device control
2014-04-11T18:19:21.670544+02:00 linux-1oi7 NetworkManager[9904]: <info> (wlp0s29f7u5): new 802.11 WiFi device (driver: 'r8188eu' ifindex: 4)
2014-04-11T18:19:21.672667+02:00 linux-1oi7 NetworkManager[9904]: <info> (wlp0s29f7u5): exported as /org/freedesktop/NetworkManager/Devices/2
2014-04-11T18:19:21.674702+02:00 linux-1oi7 NetworkManager[9904]: <warn> /sys/devices/virtual/net/lo: couldn't determine device driver; ignoring...
2014-04-11T18:19:21.682731+02:00 linux-1oi7 NetworkManager[9904]: <warn> /sys/devices/virtual/net/lo: couldn't determine device driver; ignoring...
2014-04-11T18:19:21.694268+02:00 linux-1oi7 NetworkManager[9904]: <info> NetworkManager state is now ASLEEP
2014-04-11T18:19:21.718652+02:00 linux-1oi7 NetworkManager[9904]: <info> ModemManager available in the bus


LG Reinhold

wolfi323
13-Apr-2014, 12:13
Bevor ich lwfinger kontaktiere, möchte ich dich noch mal fragen, ob du mit diesem Inhalt von /var/log/NetworkManager was anfangen kannst:

Hm, ich sehe da jetzt eigentlich nichts das auf ein Problem hindeuten würde.
Die Karte wird erkannt, der "r8188eu" wird benutzt.

Von einem Absturz ist da nichts zu sehen.

Bekommst du danach einen Shell-Prompt? Oder läuft der NetworkManager weiter?
Was passiert, wenn du dann auf das Netzwerk-Symbol in der Kontrollleiste klickst?

JumpysVater
14-Apr-2014, 09:11
Shellprompt kriege ich keinen, wenn ich den NetworkManager im Terminal starte, also läuft er wohl weiter. Wenn ich auf das Symbol klicke, passiert nichts anderes als sonst. In der Logdatei erscheint dann nur folgendes:



NetworkManager[1649]: <warn> /sys/devices/virtual/net/lo: couldn't determine device driver; ignoring...


Ich habe jetzt alle Daten zusammen, die lwfinger braucht. Ich werd mir mal anschauen, was er dazu sagt.

LG Reinhold

JumpysVater
19-Apr-2014, 11:13
@wolfi323:

Hast du meinen Dialog mit lwfinger im englischen Forum verfolgt?
Ich hatte (und habe noch, macht aber nix mehr) das Problem, dass im NetworkManager die Checkbox, die das Netzwerk aktivieren soll, scheinbar keine Funktion hat. Ein Klick da drauf schlug sich nicht im zuständigen State-File nieder.
Ich konnte dieses File letztendlich finden, es heißt (incl.Pfad) '/var/lib/NetworkManager/NetworkManager.state'.
Dort ein 'false' durch 'true' ersetzen, und die Sache läuft.

Ich weiß nicht, ob so ein Problem auch bei anderen Usern vorkommt, aber vielleicht könnte man diesen Lösungsweg im Hinterkopf behalten.

LG Reinhold

wolfi323
19-Apr-2014, 11:20
@wolfi323:

Hast du meinen Dialog mit lwfinger im englischen Forum verfolgt?
Ja.


Ich weiß nicht, ob so ein Problem auch bei anderen Usern vorkommt, aber vielleicht könnte man diesen Lösungsweg im Hinterkopf behalten.

Tja, mir ist das noch nicht untergekommen. Und ich hab diese Meldung in deinem NetworkManager.log auch komplett übersehen.
Aber ich werde versuchen mir das zu merken, vielleicht hilfts ja mal... ;)