PDA

View Full Version : Bij KDE 4.10.3 version update zitten digikam en kipi-plugins dwars



GeckoSuse
14-Jun-2013, 13:25
Al 10 jaar geen enkel probleem met Yast. Echter; bij zowel update poging via Yast2 en via konsole (zypper) lukt het mij niet de aangegeven update van KDE 4.10.3 door te voeren bij mijn Suse 12.3.
Voordat ie zo'n 27 KDE pakketten wil installeren moet eerst digikam, kipi-plugins verwijderd worden. Digikam is wel geïnstalleerd maar deze kan hij niet vinden. Versie 3.2.0 zit standaard erbij, maar hij wil 3.1.0. verwijderen.
Krijg dan de melding:

Subprocess failed. Error: RPM is mislukt: error: package digikam-3.1.0-1.7.1.i586 is not installed

Negeren heeft geen zin, schijnbaar moet het eerst weg voordat ie verder wil opwaarderen. Ook via software verwijderen lukt het me niet. Hij ziet wel de 3.2.0 versie maar geeft de zelfde error code aan.
Ik kom er niet meer uit!

Knurpht
14-Jun-2013, 14:40
Al 10 jaar geen enkel probleem met Yast. Echter; bij zowel update poging via Yast2 en via konsole (zypper) lukt het mij niet de aangegeven update van KDE 4.10.3 door te voeren bij mijn Suse 12.3.
Voordat ie zo'n 27 KDE pakketten wil installeren moet eerst digikam, kipi-plugins verwijderd worden. Digikam is wel geïnstalleerd maar deze kan hij niet vinden. Versie 3.2.0 zit standaard erbij, maar hij wil 3.1.0. verwijderen.
Krijg dan de melding:

Subprocess failed. Error: RPM is mislukt: error: package digikam-3.1.0-1.7.1.i586 is not installed

Negeren heeft geen zin, schijnbaar moet het eerst weg voordat ie verder wil opwaarderen. Ook via software verwijderen lukt het me niet. Hij ziet wel de 3.2.0 versie maar geeft de zelfde error code aan.
Ik kom er niet meer uit!

Denkelijk komt je KDE uit de Update repo, da's nieuw. Eerder kreeg je KDE updates alleen via de KDE:Release repo, sinds 12.3 dus ook via de Update repo. Het kan zijn, dat nog niet alle benodigde pakketten daarin beschikbaar zijn.
Kun je eens output posten van


zypper lr -d
en de output hier posten, tussen CODE tags, de # in de editor. Dat maakt e.e.a. een stuk leesbaarder, en al helemaal leesbaarder dan cursieve output.

Als je dit vlot gefixt wilt hebben, zou ik de KDE:Release repo toevoegen en je KDE pakketten omschakelen om die repo. Als je daar meer over wilt weten, laat maar horen.

GeckoSuse
15-Jun-2013, 01:33
Dank voor de snelle reactie.
Als respons krijg ik


# | Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service
---+---------------------------+------------------------------------+--------------+------------+------------+--------+----------------------------------------------------------------------------------+--------
1 | LibreOffice:Stable | LibreOffice:Stable | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.3/ |
2 | Packman Repository | Packman Repository | Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_12.3/ |
3 | google-chrome | google-chrome | Ja | Ja | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386 |
4 | libdvdcss repository | libdvdcss repository | Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/12.3/ |
5 | openSUSE-12.3-1.7 | openSUSE-12.3-1.7 | Ja | Nee | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GSA-H62N_K6977522212,/dev/sr0 |
6 | repo-debug | openSUSE-12.3-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/distribution/12.3/repo/oss/ |
7 | repo-debug-update | openSUSE-12.3-Update-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/update/12.3/ |
8 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/update/12.3-non-oss/ |
9 | repo-non-oss | openSUSE-12.3-Non-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.3/repo/non-oss/ |
10 | repo-oss | openSUSE-12.3-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.3/repo/oss/ |
11 | repo-source | openSUSE-12.3-Source | Nee | Ja | 99 | NONE | http://download.opensuse.org/source/distribution/12.3/repo/oss/ |
12 | repo-update | openSUSE-12.3-Update | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/12.3/ |
13 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/12.3-non-oss/ |

Ook gaf ie bij een poging te updaten aan dat een beveilgd pakket niet verwijderd mocht worden. Dat zou dan over digikam of die plugins gaan, maar ik snap niet dat die beveilgd zouden zijn. Ik ga die release repo nog toevoegen en laat nog weten of het werkt!

GeckoSuse
15-Jun-2013, 01:44
Als je dit vlot gefixt wilt hebben, zou ik de KDE:Release repo toevoegen en je KDE pakketten omschakelen om die repo. Als je daar meer over wilt weten, laat maar horen.

Ik denk wel dat ik hierbij je hulp kan gebruiken. Kan de release versie niet zo gauw vinden!

Knurpht
15-Jun-2013, 05:04
Als je dit vlot gefixt wilt hebben, zou ik de KDE:Release repo toevoegen en je KDE pakketten omschakelen om die repo. Als je daar meer over wilt weten, laat maar horen.

Ik denk wel dat ik hierbij je hulp kan gebruiken. Kan de release versie niet zo gauw vinden!

Uit je eerdere post haal ik, dat er wel eens een "slot" op bepaalde pakketten zou kunnen zitten. Kun je dat checken, kan in Yast.

De repos zijn via webadressen gewoon te vinden: Index of /repositories (http://download.opensuse.org/repositories/) Ik zal er, gezien jouw geschiedenis met openSUSE, niet al teveel woorden aan vuil maken, klik er maar eens wat rond.
Één van de ingangen op de pagina noem ik wel even: home:/ . Daarin staan alle projecten in de buildservice van ontwikkelaars / packagers. Het gebruik van pakketten uit die repos is "op eigen risico".

Op de pagina zie je o.a. KDE:/ staan. Zo kun je 't adres van de Release repo vinden en deze met zypper toevoegen


zypper ar Index of /repositories/KDE:/Release:/410/openSUSE_12.3 (http://download.opensuse.org/repositories/KDE:/Release:/410/openSUSE_12.3/) KDE410
en die van de bijbehorenden KDE:/Extra: repo

zypper ar Index of /repositories/KDE:/Extra/KDE_Release_410_openSUSE_12.3 (http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_410_openSUSE_12.3/) KDE410extra

Je kunt uiteraard ook de links toevoegen via Yast.

Nu kun je via Softwarebeheer het volgende doen:
- Kies Beeld - Bronnen
- Klik de KDE410 bron aan, en klik op "Schakel systeempakketten ...."
- Doe hetzelfde voor de KDE410extra bron
- Doe daarna nog eens hetzelfde voor Packman, om je multimedia OK te houden.

In een enkel geval is uitloggen en weer inloggen niet genoeg, heb nu 2 keer meegemaakt, dat een herstart van het hele systeem nodig was. Reden onbekend.

GeckoSuse
18-Jun-2013, 12:04
Gedaan wat je suggereerde en er is veel ge-update (>200 pakketten), maar kreeg toen deze nieuwe foutmelding;


Een pakket dat benodigd is om de taak te voltooien is niet gevonden.
Meer informatie is beschikbaar in het gedetailleerde rapport.



patch:openSUSE-2013-467-1.noarch conflicts with yast2-qt-branding-openSUSE.noarch < 12.3-6.24.14 provided by yast2-qt-branding-openSUSE-12.3-2.3.noarch


Er zitten nu zo'n 58 updates te wachten, maar die krijg ik niet geinstalleert voordat ik iets doe met deze foutmelding.

Knurpht
18-Jun-2013, 12:09
Gedaan wat je suggereerde en er is veel ge-update (>200 pakketten), maar kreeg toen deze nieuwe foutmelding;


Een pakket dat benodigd is om de taak te voltooien is niet gevonden.
Meer informatie is beschikbaar in het gedetailleerde rapport.



patch:openSUSE-2013-467-1.noarch conflicts with yast2-qt-branding-openSUSE.noarch < 12.3-6.24.14 provided by yast2-qt-branding-openSUSE-12.3-2.3.noarch


Er zitten nu zo'n 58 updates te wachten, maar die krijg ik niet geinstalleert voordat ik iets doe met deze foutmelding.

Hoe update jij? Zo precies mogelijk graag. Heb nl. net vandaag een installatie gedaan, meteen door naar de KDE:Release repo

Knurpht
18-Jun-2013, 12:12
En wat ik me ook afvraag:
Is dit systeem geupgrade van 12.2 naar 12.3? Als ik nl. naar de foutmelding kijk lijkt 't alsof er een 12.2 pakket in het geding is .

GeckoSuse
18-Jun-2013, 12:52
Hoi,
inderdaad had ik een 12.2 versie hiervoor, maar heb ik wel een nieuwe installatie gedaan (met behoud van /home) en geen update. De eerste keer dat ik de update deed was gewoon via de update melding onder een reviewvenster. Dat is Apper volgens mij. Dat lukte niet dus heb ik vervolgens Yast2 (online opwaarderen) en vervolgens de konsole gebruikt.
Bij
zypper update leek ie net weer wel wat te doen, maar liep ie weer vast op de digikam en de eerder genoemde plugins.
Ik hoop dat dit specifiek genoeg is ander lever ik nog wel wat aan.

Knurpht
19-Jun-2013, 00:25
Apper gaat met sprongen vooruit, maar blijkbaar zit jij nog met een versie die niet goed met de patches (uit de Update repo) en de afhankelijkheden daarvan uit de voeten kan.

Wat er moet gebeuren, is een "vendor-switch" naar de KDE:Release repos. Om de klap het kortst te maken, is het het makkelijkst als je via Yast - Software - Softwarebronnen de naam die de beide repos op jouw systeem hebben verandert naar "KDE410" en "KDE410Extra", in de commando's hieronder ga ik ervan uit dat de Packman repo "Packman" heet.
Vervolgens open je een terminalvenster en doe je dit:


su -c 'zypper ref'
su -c 'zypper dup --from KDE410'
su -c 'zypper dup --from KDE410Extra'
su -c 'zypper dup --from Packman'

Dit bewerkstelligt, dat te allen tijde voor KDE pakketten eerst gekeken wordt in de KDE410* repos, tenzij pakketten bestaan in de Packman repo.

Knurpht
19-Jun-2013, 01:43
Nog even wat anders: Als je de commando's hierboven uitvoert, en er is toch een conflict, kun je dan de letterlijke output posten? Incl. de aangedragen oplossingen?

GeckoSuse
20-Jun-2013, 02:27
Klopt, ik krijg weer dezelfde foutmeldingen. Als ik de hele tekst wil posten is dat schijnbaar wat te lang (teveel tekens) en moet dat in 4 of 5 aparte berichten. Zal ik dat doen? Dan heb je wel het complete plaatje!

GeckoSuse
20-Jun-2013, 06:01
Heb zoveel mogelijk de overbodige info eruit gehaald, hoop dat dit duidelijkheid geeft!?


[
r@linux-6wff:~> su
Wachtwoord:
linux-6wff:/home/r # su -c 'zypper ref'
Installatiebron 'KDE410Extra' is actueel.
Installatiebron 'LibreOffice:Stable' is actueel.
Installatiebron 'Packman' is actueel.
Installatiebron 'openSUSE BuildService - KDE:UpdatedApps' is actueel.
Installatiebron 'google-chrome' is actueel.
Installatiebron 'libdvdcss repository' is actueel.
Installatiebron 'KDE410' is actueel.
Installatiebron 'openSUSE-12.3-Non-Oss' is actueel.
Installatiebron 'openSUSE-12.3-Oss' is actueel.
Installatiebron 'openSUSE-12.3-Update' is actueel.
Installatiebron 'openSUSE-12.3-Update-Non-Oss' is actueel.
Alle installatiebronnen zijn vernieuwd.
linux-6wff:/home/r # su -c 'zypper dup --from KDE410'
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...
Berekenen van distributie opwaardering...
2 problemen:
Probleem: k3b-codecs-2.0.2-15.52.i586 vereist k3b = 2.0.2-15.52, Maar aan deze eis kan niet voldaan worden
Probleem: openshot-1.4.2-3.22.noarch vereist mlt(5)(avformat), Maar aan deze eis kan niet voldaan worden

Probleem: k3b-codecs-2.0.2-15.52.i586 vereist k3b = 2.0.2-15.52, Maar aan deze eis kan niet voldaan worden
verwijderde leveranciers: k3b-2.0.2-15.52.i586
Oplossing 1: deïnstallatie van k3b-codecs-2.0.2-15.52.i586
Oplossing 2: k3b-2.0.2-15.54.i586 installeren uit een uitgesloten installatiebron
Oplossing 3: breek k3b-codecs-2.0.2-15.52.i586 door enige van zijn afhankelijkheden te negeren

Kies uit de bovenstaande oplossingen door een nummer of overslaan, op(n)ieuw of annuleren [1/2/3/o/n/a] (a): 2

Probleem: openshot-1.4.2-3.22.noarch vereist mlt(5)(avformat), Maar aan deze eis kan niet voldaan worden
Oplossing 1: deïnstallatie van openshot-1.4.2-3.22.noarch
Oplossing 2: verouderde libmlt5-modules-0.8.8-8.1.i586 handhaven
Oplossing 3: breek openshot-1.4.2-3.22.noarch door enige van zijn afhankelijkheden te negeren

Kies uit de bovenstaande oplossingen door een nummer of overslaan, op(n)ieuw of annuleren [1/2/3/o/n/a] (a): 1
Afhankelijkheden oplossen...
Berekenen van distributie opwaardering...

De volgende pakketten zullen worden VERWIJDERD:
digikam digikam kipi-plugins kipi-plugins kipi-plugins-acquireimage kipi-plugins-acquireimage kipi-plugins-geolocation kipi-plugins-geolocation openshot

De volgende pakketten zullen worden opgewaardeerd:
digikam gtk2-engine-oxygen gtk2-theme-oxygen k3b k3b-codecs kdenlive kipi-plugins kipi-plugins-acquireimage kipi-plugins-geolocation libmlt++3 libmlt5 libmlt5-data
libmlt5-modules libstrigi0 melt melt5 python-mlt strigi

De volgende pakketten zullen neerwaarts worden opgewaardeerd:
amarok amarok-lang bluedevil bluedevil-lang choqok kwebkitpart libbluedevil1

De volgende pakketten zullen worden geherinstalleerd:
kde-gtk-config kde-gtk-config-lang

De volgende pakketten zullen de leverancier wijzigen:
digikam openSUSE -> obs://build.opensuse.org/KDE
kipi-plugins openSUSE -> obs://build.opensuse.org/KDE
kipi-plugins-acquireimage openSUSE -> obs://build.opensuse.org/KDE
kipi-plugins-geolocation openSUSE -> obs://build.opensuse.org/KDE
libmlt++3 PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
libmlt5 PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
libmlt5-data PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
libmlt5-modules PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
libstrigi0 PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
melt PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
melt5 PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
python-mlt PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE
strigi PackMan :: Startseite (http://packman.links2linux.de) -> obs://build.opensuse.org/KDE


18 op te waarderen pakketten, 7 af te waarderen, 2 opnieuw te installeren, 9 te verwijderen, 13 te wijzigen van leverancier.
Totale downloadgrootte: 67,5 MiB Na de operatie zal 142,5 MiB worden vrijgemaakt.
Doorgaan? [j/n/?] (j): j
pakket k3b-2.0.2-15.54.i586 wordt opgehaald (1/27), 6,1 MiB ( 13,9 MiB uitgepakt) etc
.......[klaar]
(28/28) Installeert: kdenlive-0.9.6-36.1 ....[klaar]
Aanvullende rpm-uitvoer:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'


Er is een fout opgetreden tijdens of na de installatie of verwijdering van pakketten:
Failed to cache rpm database (1).
Zie bovenstaande foutmelding voor een hint.
Er zijn actieve programma's die bestanden gebruiken die recent zijn opgewaardeerd. U zou enige van deze mogelijk willen herstarten. Draai 'zypper ps' om een lijst te verkrijgen van deze programma's.
linux-6wff:/home/rob # su -c 'zypper dup --from KDE410Extra'
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...
Berekenen van distributie opwaardering...

Niets te doen.
linux-6wff:/home/r # su -c 'zypper dup --from Packman'
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...
Berekenen van distributie opwaardering...

De volgende pakketten zullen worden opgewaardeerd:
audacity gmplayer gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-lang gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good
gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-plugins-base libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstbasecamerabinsrc-0_10-23
libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 libgstphotography-0_10-23 libgstriff-1_0-0 libgstsignalprocessor-0_10-23
libgsttag-1_0-0 libgstvdp-0_10-23 libgstvideo-1_0-0 libvlc5 libvlccore5 lmms MPlayer realcrypt vlc vlc-codecs vlc-noX vlc-qt wine-mp3

De volgende pakketten zullen neerwaarts worden opgewaardeerd:
amarok amarok-lang kdenlive libmlt++3 libmlt5 libmlt5-data libmlt5-modules libstrigi0 melt melt5 python-mlt strigi

De volgende pakketten zullen de leverancier wijzigen:
amarok obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
amarok-lang obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
kdenlive obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
libmlt++3 obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
libmlt5 obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
libmlt5-data obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
libmlt5-modules obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
libstrigi0 obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
melt obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
melt5 obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
python-mlt obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)
strigi obs://build.opensuse.org/KDE -> PackMan :: Startseite (http://packman.links2linux.de)


34 op te waarderen pakketten, 12 af te waarderen, 12 te wijzigen van leverancier.
Totale downloadgrootte: 90,9 MiB Na de operatie zal aanvullend 201,0 KiB worden gebruikt.
Doorgaan? [j/n/?] (j): j
pakket audacity-2.0.3-80.17.i586 wordt opgehaald (1/46), 3,3 MiB ( 14,0 MiB uitgepakt)
Ophalen: audacity-2.0.3-80.17.i586.rpm ............etcetc opgehaald (46/46), 62,1 KiB ( 53,6 KiB uitgepakt)
Ophalen: libgstriff-1_0-0-1.0.7-2.12.i586.rpm .....[klaar]
( 1/46) Installeert: audacity-2.0.3-80.17 .......[klaar]
Aanvullende rpm-uitvoer:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'


( 2/46) Installeert: lmms-0.4.15-34.2 .................[klaar]
Aanvullende rpm-uitvoer:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'


( 3/46) Installeert: libgstphotography-0_10-23-0.10.23-19.37 ..........[klaar]
( 4/46) Installeert: libstrigi0-0.7.8-4.1 ...............[klaar]
( 5/46) Installeert: libgsttag-1_0-0-1.0.7-2.12 ............[klaar]
( 6/46) Installeert: libgstsignalprocessor-0_10-23-0.10.23-19.37....[klaar]
( 7/46) Installeert: MPlayer-1.1+35127-2.37 ............[klaar]
( 8/46) Installeert: libgstcodecparsers-0_10-23-0.10.23-19.37 .........[klaar]
( 9/46) Installeert: amarok-2.7.1-13.10 ................[klaar]
(10/46) Installeert: realcrypt-7.0a-3.37 ........................[klaar]
Aanvullende rpm-uitvoer:
/etc/group already contains an entry for realcrypt
leaving /etc/group untouched
Checking /etc/sudoers for realcrypt
/etc/sudoers already contains a directive for realcrypt
leaving /etc/sudoers untouched
If you want to use realcrypt without having to enter the root password
when mounting/umounting a device, add the respective user(s) to the group "realcrypt" .....


(11/46) Installeert: libgstinterfaces-0_10-0-0.10.36-9.35 ..........[klaar]
(12/46) Installeert: libmlt5-0.8.8-8.1 .............[klaar]
(13/46) Installeert: wine-mp3-1.1.39-12.34 ............[klaar]
(14/46) Installeert: libvlccore5-2.0.6-128.1 ........................[klaar]
(15/46) Installeert: strigi-0.7.8-4.1 ............................................[klaar]
(16/46) Installeert: libgstaudio-1_0-0-1.0.7-2.12 ...............................[klaar]
(17/46) Installeert: gmplayer-1.1+35127-2.37 ..........................[klaar]
(18/46) Installeert: amarok-lang-2.7.1-13.10 .............[klaar]
(19/46) Installeert: gstreamer-0_10-plugins-base-0.10.36-9.35 .........[klaar]
(20/46) Installeert: libmlt5-data-0.8.8-8.1 ..........[klaar]
(21/46) Installeert: libmlt++3-0.8.8-8.1 ...........[klaar]
(22/46) Installeert: melt5-0.8.8-8.1 .......[klaar]
(23/46) Installeert: libvlc5-2.0.6-128.1 ....[klaar]
(24/46) Installeert: libgstpbutils-1_0-0-1.0.7-2.1.....[klaar
(25/46) Installeert: libgstapp-0_10-0-0.10.36-9.35 .....[klaar]
(26/46) Installeert: python-mlt-0.8.8-8....[klaar]
(27/46) Installeert: melt-0.8.8-8.1 .....[klaar]
(28/46) Installeert: vlc-noX-2.0.6-128.1 ........[klaar]
(29/46) Installeert: libgstvideo-1_0-0-1.0.7-2.1...[klaar]
(30/46) Installeert: libgstvdp-0_10-23-0.10.23-19.37 ................[klaar]
(31/46) Installeert: gstreamer-0_10-plugins-good-0.10.31-12.6 .........[klaar]
(32/46) Installeert: libgstbasecamerabinsrc-0_10-23-0.10.23-19.37 .......[klaar]
(33/46) Installeert: gstreamer-0_10-plugins-ugly-0.10.19-10.32 .......[klaar]
(34/46) Installeert: gstreamer-0_10-plugin-gnomevfs-0.10.36-9.35 ....[klaar]
(35/46) Installeert: libgstbasevideo-0_10-23-0.10.23-19.37.............[klaar]
(36/46) Installeert: libmlt5-modules-0.8.8-8.1 .........[klaar]
(37/46) Installeert: vlc-codecs-2.0.6-128.1 .....[klaar]
(38/46) Installeert: vlc-qt-2.0.6-128.1 .......[klaar]
(39/46) Installeert: gstreamer-plugins-base-1.0.7-2.12 ..........[klaar]
(40/46) Installeert: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.32 .........[klaar]
(41/46) Installeert: gstreamer-0_10-plugins-bad-0.10.23-19.37 .......[klaar
(42/46) Installeert: kdenlive-0.9.6-2.17 .........[klaar]
Aanvullende rpm-uitvoer:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'


(43/46) Installeert: vlc-2.0.6-128.1 .............[klaar]
(44/46) Installeert: libgstapp-1_0-0-1.0.7-2.12 ....................................................[klaar]
(45/46) Installeert: gstreamer-0_10-plugins-bad-lang-0.10.23-19.37 .............[klaar]
(46/46) Installeert: libgstriff-1_0-0-1.0.7-2.12 ..................[klaar]
Er is een fout opgetreden tijdens of na de installatie of verwijdering van pakketten:
Failed to cache rpm database (1).
Zie bovenstaande foutmelding voor een hint.
Er zijn actieve programma's die bestanden gebruiken die recent zijn opgewaardeerd. U zou enige van deze mogelijk willen herstarten. Draai 'zypper ps' om een lijst te verkrijgen van deze programma's.
linux-6wff:/home/r

Knurpht
20-Jun-2013, 12:16
En kijk wat ik zie als ik
zypper dup --from Packman doe:


Oplossing 2: verouderde libnice10-0.1.3-2.1.1.x86_64 handhaven
Oplossing 3: breek libnice10-0.1.0-2.9.i586 door enige van zijn afhankelijkheden te negeren


Kies uit de bovenstaande oplossingen door een nummer of overslaan, op(n)ieuw of annuleren [1/2/3/o/n/a] (a): 2


Probleem: niets levert libgupnp-igd-1.0.so.3()(64bit) nodig voor libnice10-0.1.0-2.9.x86_64
Oplossing 1: deïnstallatie van gstreamer-0_10-libnice-0.1.3-2.1.1.x86_64
Oplossing 2: verouderde gstreamer-0_10-libnice-0.1.3-2.1.1.x86_64 handhaven
Oplossing 3: verouderde gstreamer-0_10-libnice-0.1.3-2.1.1.x86_64 handhaven
Oplossing 4: breek libnice10-0.1.0-2.9.x86_64 door enige van zijn afhankelijkheden te negeren


Kies uit de bovenstaande oplossingen door een nummer of overslaan, op(n)ieuw of annuleren [1/2/3/4/o/n/a] (a): 2
Afhankelijkheden oplossen...
Berekenen van distributie opwaardering...


De volgende pakketten zullen neerwaarts worden opgewaardeerd:
amarok amarok-lang kdenlive libmediastreamer1 libmlt++3 libmlt5 libmlt5-data libmlt5-modules libopencv2_4 libstrigi0 libstrigi0-32bit mediastreamer2 melt
melt5 strigi strigi-devel


De volgende pakketten zullen de leverancier wijzigen:
amarok obs://build.opensuse.org/KDE -> http://packman.links2linux.de
amarok-lang obs://build.opensuse.org/KDE -> http://packman.links2linux.de
kdenlive obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libmediastreamer1 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libmlt++3 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libmlt5 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libmlt5-data obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libmlt5-modules obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libopencv2_4 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libstrigi0 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
libstrigi0-32bit obs://build.opensuse.org/KDE -> http://packman.links2linux.de
mediastreamer2 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
melt obs://build.opensuse.org/KDE -> http://packman.links2linux.de
melt5 obs://build.opensuse.org/KDE -> http://packman.links2linux.de
strigi obs://build.opensuse.org/KDE -> http://packman.links2linux.de
strigi-devel obs://build.opensuse.org/KDE -> http://packman.links2linux.de




16 af te waarderen pakketten, 16 te wijzigen van leverancier.
Totale downloadgrootte: 48,8 MiB Na de operatie zal aanvullend 337,5 KiB worden gebruikt.
Doorgaan? [j/n/?] (j): j



Die libnice is niet interessant voor je, komt omdat ik ook GNOME, XFCE heb geïnstalleerd. Dat "afwaarderen" is maar betrekkelijk, versienummers zeggen niet alles meer, een seconde later aan het bouwen zetten is genoeg.

Je zult door jou beslissingen een aantal programma's opnieuw moeten installeren als je ze wilt gebruiken, o.a. digikam.

Wat zeker niet te verwaarlozen is, is dit


Er is een fout opgetreden tijdens of na de installatie of verwijdering van pakketten:
Failed to cache rpm database (1).
Zie bovenstaande foutmelding voor een hint.

Dit kan een aantal oorzaken hebben:
- Root partitie vol, te controleren met
df -h
- RPM databse kapot. Dit kan tot heel rare resultaten leiden, bijv. dat zypper versie 2 van iets installeert, en als je vervolgens informatie over het pakket opvraagt meldt dat zelfde zypper dat je versie 1 hebt. Met

rpm --rebuilddb
wordt de database opnieuw opgebouwd. Als database errors de oorzaak waren moet de melding daarna achterwege blijven.

Knurpht
20-Jun-2013, 12:27
Omdat je een aantal opties niet ziet, bijv. over het behouden van de Packman versie van k3b en mlt, vraag ik me af of je überhaupt ooit de vendor-switch naar Packman gemaakt hebt. Dat doe je door de

zypper dup --from Packman of door in Softwarebeheer Beeld - Bronnen te kiezen, de Packman repo aan te klikken en dan te klikken op "Schakel systeempakketten .." . Je geeft daarmee aan, dat je voor pakketten die in meerdere repos voorkomen (de KDE apps, sommige GNOME), uit de Packman repo gehaald moeten worden. De meldingen over "uitgesloten repo" wijzen daar op. Als de vendor switch wel heeft plaatsgevonden, wordt je voorgesteld om bijv. de huidige k3b versie te behouden.
Overigens is k3b niet, zoals veel mensen denken, een 100% KDE applicatie, maar een apart project, met sterke banden met het KDE project. Op K3b - The CD Kreator (http://k3b.org) staat ook


K3b - The CD/DVD Kreator for Linux - optimized for KDE - licensed under the GPL



Maar, zoals gezegd, eerst het probleem rpm database oplossen.

GeckoSuse
21-Jun-2013, 11:01
Bij

zypper dup --from Packman
zie ik weer:

Er is een fout opgetreden tijdens of na de installatie of verwijdering van pakketten:
Failed to cache rpm database (1).
Zie bovenstaande foutmelding voor een hint.
Er zijn actieve programma's die bestanden gebruiken die recent zijn opgewaardeerd. U zou enige van deze mogelijk willen herstarten. Draai 'zypper ps' om een lijst te verkrijgen van deze programma's.



en bij:

df -h


Krijg ik;
Bestandssysteem Grootte Gebruikt Besch Geb% Aangekoppeld op
devtmpfs 4,0G 36K 4,0G 1% /dev
tmpfs 4,0G 676K 4,0G 1% /dev/shm
tmpfs 4,0G 4,7M 4,0G 1% /run
/dev/sdb2 20G 7,3G 12G 39% /
tmpfs 4,0G 0 4,0G 0% /sys/fs/cgroup
tmpfs 4,0G 4,7M 4,0G 1% /var/lock
tmpfs 4,0G 4,7M 4,0G 1% /var/run
/dev/sdb3 437G 204G 233G 47% /home


Dat lijkt me geen probleem!

GeckoSuse
21-Jun-2013, 11:05
- RPM databse kapot. Dit kan tot heel rare resultaten leiden, bijv. dat zypper versie 2 van iets installeert, en als je vervolgens informatie over het pakket opvraagt meldt dat zelfde zypper dat je versie 1 hebt. Met

rpm --rebuilddb
wordt de database opnieuw opgebouwd. Als database errors de oorzaak waren moet de melding daarna achterwege blijven.

Dan krijg ik geen tekst alsof er niets is gebeurt;
linux-6wff:/home/r # rpm --rebuilddb
linux-6wff:/home/r #


Even nog een check; bij de Packman-URL in softwarebronnen staat bij mij; http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_12.3/
Is dat wel goed??

GeckoSuse
21-Jun-2013, 13:35
Bij online opwaarderen krijg ik nu overigens deze foutmelding, zonder een optie om een alternatief te kunnen kiezen;

#### YaST2 conflicts list - generated 2013-06-21 22:29:28 ####

patch:openSUSE-2013-467-1.noarch is in conflict met plymouth-branding-openSUSE.noarch < 12.3-6.24.14 die geleverd is door plymouth-branding-openSUSE-12.3-2.3.noarch

[x] patch:openSUSE-2013-467-1.noarch niet installeren

[ ] De volgende acties zullen uitgevoerd worden:
installeer plymouth-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer kdm-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer yast2-qt-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer wallpaper-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer kdelibs4-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer ksplash-qml-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer susegreeter-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer ksplashx-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer grub2-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer gimp-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer gfxboot-branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer branding-openSUSE-12.3-6.24.14.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer kdebase4-workspace-branding-openSUSE-12.3-10.41.9.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer kdebase4-runtime-branding-openSUSE-12.3-10.41.9.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
installeer kdebase4-openSUSE-12.3-10.41.9.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdm-4.10.4-12.1.i586 af tot kdm-4.10.3-1.37.7.i586
installeer kdm-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdebase4-workspace-4.10.4-12.1.i586 af tot kdebase4-workspace-4.10.3-1.37.7.i586
installeer kdebase4-workspace-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kwin-4.10.4-12.1.i586 af tot kwin-4.10.3-1.37.7.i586
installeer kwin-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdebase4-session-4.10.4-60.1.noarch af tot kdebase4-session-4.10.3-1.30.1.noarch
installeer kdebase4-session-4.10.3-1.30.1.noarch (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdebase4-workspace-plasma-calendar-4.10.4-12.1.i586 af tot kdebase4-workspace-plasma-calendar-4.10.3-1.37.7.i586
installeer kdebase4-workspace-plasma-calendar-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdebase4-workspace-liboxygenstyle-4.10.4-12.1.i586 af tot kdebase4-workspace-liboxygenstyle-4.10.3-1.37.7.i586
installeer kdebase4-workspace-liboxygenstyle-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kde4-kgreeter-plugins-4.10.4-12.1.i586 af tot kde4-kgreeter-plugins-4.10.3-1.37.7.i586
installeer kde4-kgreeter-plugins-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE
waardeer kdebase4-workspace-ksysguardd-4.10.4-12.1.i586 af tot kdebase4-workspace-ksysguardd-4.10.3-1.37.7.i586
installeer kdebase4-workspace-ksysguardd-4.10.3-1.37.7.i586 (met wijziging van leverancier)
obs://build.opensuse.org/KDE --> openSUSE



#### YaST2 conflicts list END ###

GeckoSuse
21-Jun-2013, 14:08
Zag bij de softwarebronnen dat openSUSE-12.3-Source niet ingeschakeld stond. Toch maar eens geprobeerd en na installatie van enkele pakketten en een herstart lijk ik al wat meer te kunnen maar nog niet alles;

linux-6wff:/home/r # zypper update
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...

De volgende pakketten zijn gesuggereerd, maar zullen niet worden geïnstalleerd:
amarok amarok-lang k3b kde4-kgreeter-plugins kdebase4-session kdebase4-workspace kdebase4-workspace-ksysguardd kdebase4-workspace-liboxygenstyle
kdebase4-workspace-plasma-calendar kdenlive kdm kwin libmediastreamer1 libmlt++3 libmlt5 libmlt5-data libmlt5-modules libmysqlcppconn6 libreoffice libreoffice-base
libreoffice-base-drivers-mysql libreoffice-base-extensions libreoffice-calc libreoffice-calc-extensions libreoffice-draw libreoffice-draw-extensions
libreoffice-filters-optional libreoffice-help-en-GB libreoffice-help-nl libreoffice-icon-theme-crystal libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast
libreoffice-icon-theme-oxygen libreoffice-icon-theme-tango libreoffice-impress libreoffice-impress-extensions libreoffice-kde4 libreoffice-l10n-en-GB libreoffice-l10n-nl
libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-templates-presentation-layouts libreoffice-writer libreoffice-writer-extensions libstrigi0 melt melt5
python-mlt strigi

De volgende pakketten zullen worden opgewaardeerd:
bluedevil bluedevil-lang google-chrome-stable kwebkitpart libbluedevil1

5 op te waarderen pakketten.
Totale downloadgrootte: 49,2 MiB Na de operatie zal aanvullend 5,6 KiB worden gebruikt.
Doorgaan? [j/n/?] (j): j
pakket kwebkitpart-1.3.2-48.1.i586 wordt opgehaald (1/5), 176,6 KiB (454,8 KiB uitgepakt)
Ophalen: kwebkitpart-1.3.2-48.1.i586.rpm .........................................................................................................................[klaar (413 B/s)]
pakket libbluedevil1-1.9.3-29.1.i586 wordt opgehaald (2/5), 76,0 KiB (234,0 KiB uitgepakt)
Ophalen: libbluedevil1-1.9.3-29.1.i586.rpm ...................................................................................................................[klaar (175,3 KiB/s)]
pakket bluedevil-1.3.1-70.1.i586 wordt opgehaald (3/5), 289,9 KiB ( 1,3 MiB uitgepakt)
Ophalen: bluedevil-1.3.1-70.1.i586.rpm .....................................................................................................................................[klaar]
pakket bluedevil-lang-1.3.1-70.1.noarch wordt opgehaald (4/5), 96,5 KiB (655,5 KiB uitgepakt)
Ophalen: bluedevil-lang-1.3.1-70.1.noarch.rpm ..............................................................................................................................[klaar]
pakket google-chrome-stable-28.0.1500.52-207119.i386 wordt opgehaald (5/5), 48,5 MiB (137,6 MiB uitgepakt)
Ophalen: google-chrome-stable-28.0.1500.52-207119.i386.rpm ...................................................................................................[klaar (542,7 KiB/s)]
(1/5) Installeert: kwebkitpart-1.3.2-48.1 ..................................................................................................................................[klaar]
(2/5) Installeert: libbluedevil1-1.9.3-29.1 ................................................................................................................................[klaar]
(3/5) Installeert: bluedevil-1.3.1-70.1 ....................................................................................................................................[klaar]
(4/5) Installeert: bluedevil-lang-1.3.1-70.1 ...............................................................................................................................[klaar]
(5/5) Installeert: google-chrome-stable-28.0.1500.52-207119 ................................................................................................................[klaar]
Er zijn actieve programma's die bestanden gebruiken die recent zijn opgewaardeerd. U zou enige van deze mogelijk willen herstarten. Draai 'zypper ps' om een lijst te verkrijgen van deze programma's.
linux-6wff:/home/r #

Knurpht
22-Jun-2013, 02:12
Aah, ik zie 'm. Je gebruikt YOU, Yast Online Update. Die kijkt alleen naar de standaard repos. Zodra je iets anders toevoegt, qua repos, kun je beter updaten via Softwarebeheer - Pakketten - Alle pakketten - Opwaarderen als er een nieuwe versie is. Dat respecteert de toegevoegde repos en de gemaakte vendor switches.

GeckoSuse
22-Jun-2013, 03:30
Aah, ik zie 'm. Je gebruikt YOU, Yast Online Update. Die kijkt alleen naar de standaard repos. Zodra je iets anders toevoegt, qua repos, kun je beter updaten via Softwarebeheer - Pakketten - Alle pakketten - Opwaarderen als er een nieuwe versie is. Dat respecteert de toegevoegde repos en de gemaakte vendor switches.

Inderdaad, nu gaat ie wel weer verder. Echter bedoel je dat ik voortaan altijd via jou beschreven methode moet updaten? Moet ik dan de review melding van Yast (een pop-up screen) negeren?
Als ik namelijk nu nog
zypper update doe dan krijg ik;


linux-6wff:/home/r # zypper update
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...

De volgende pakketten zijn gesuggereerd, maar zullen niet worden geïnstalleerd:
amarok amarok-lang k3b kde4-kgreeter-plugins kdebase4-session kdebase4-workspace kdebase4-workspace-ksysguardd kdebase4-workspace-liboxygenstyle
kdebase4-workspace-plasma-calendar kdenlive kdm kwin libmediastreamer1 libmlt++3 libmlt5 libmlt5-data libmlt5-modules libmysqlcppconn6
libreoffice-templates-presentation-layouts libstrigi0 melt melt5 python-mlt strigi

Niets te doen.


Moet ik die laatst genoemde pakketten dan maar laten voor wat ze zijn?

GeckoSuse
23-Jun-2013, 02:32
Opgelost bij deze!
Nu na herstart gaf het systeem via een review-(pop-up)melding dat er weer nieuwe (andere) updates waren. Toch geprobeerd en voor de eerste maal sinds het probleem kreeg ik de melding dat het systeem weer up to date is!


Oorspronkelijk geplaatst door Knurpht https://forums.opensuse.org/images/buttons/viewpost-right.png (https://forums.opensuse.org/nederlands-dutch/helpen-en-hulp/desktop/kde/487866-bij-kde-4-10-3-version-update-zitten-digikam-en-kipi-plugins-dwars-post2566493.html#post2566493) Aah, ik zie 'm. Je gebruikt YOU, Yast Online Update. Die kijkt alleen naar de standaard repos. Zodra je iets anders toevoegt, qua repos, kun je beter updaten via Softwarebeheer - Pakketten - Alle pakketten - Opwaarderen als er een nieuwe versie is. Dat respecteert de toegevoegde repos en de gemaakte vendor switches.


Zou dit dan de oplossing uiteindelijk zijn geweest? In ieder geval dank voor je hulp!

Knurpht
23-Jun-2013, 04:25
Opgelost bij deze!
Nu na herstart gaf het systeem via een review-(pop-up)melding dat er weer nieuwe (andere) updates waren. Toch geprobeerd en voor de eerste maal sinds het probleem kreeg ik de melding dat het systeem weer up to date is!



Zou dit dan de oplossing uiteindelijk zijn geweest? In ieder geval dank voor je hulp!

Ik denk, na het hele verhaal nog eens te hebben doorgelezen, dat je als eerste de vendor switch op de Packman repo niet hebt uitgevoerd. Daardoor denkt YOU dat die repo niet als alternatieve bron voor pakketten gebruikt mag worden. Vervolgens "ziet" YOU dat je wel een repo hebt waarin evt. die pakketten te vinden zijn, maar komt er dan achter dat dat niet precies de juiste versies zijn, de solver/oplosser komt er dan niet meer uit en gaat je de voorstellen doen zoals je die gezien hebt. Als je 't niet snapt, verwijt jezelf niets, heb 't me ook 's een keer goed moeten laten uitleggen door één van de devs.
Over het blokje pakketten dat je nu nog ziet, dat niet wordt opgewaardeerd, is correct. Dat zijn nl. de pakketten waarvoor de Update repo wel een update heeft (bijv. die van de distro zelf), maar waarvan jij zypper verteld hebt dat je die pakketten uit een andere repo (bijv. Packman) wilt hebben (de vendor switch).
Voorbeeld: er is o.a. een amarok update. Die is voor de amarok versie, zoals die bij installatie is meegekomen, of voor de KDE updates die via de Update repo verschenen zijn. Maar jij hebt inmiddels zypper verteld, dat amarok altijd uit de Packman repo moet komen (en dat moet ook, omdat je anders niet alle audio formaten kunt afspelen).

Samenvattend: de crux was het niet uitgevoerd hebben van de vendor switch naar Packman. Normaal gesproken moet de toevoeging van de Packman repo op zich dat al regelen, maar ik weet dat bepaalde keuzes die switch ongedaan kunnen maken. Da's achteraf bijna niet meer na te gaan.
Een bevestiging dat 't allemaal OK is nu, zou je kunnen vinden door digikam en de kipiplugins weer te installeren. Die zouden nu zonder gemekker en uit de juiste repo geïnstalleerd moeten worden.

Knurpht
23-Jun-2013, 04:31
Overigens, onderstaande omzeilt dit te allen tijde:
- Yast - Software - Softwarebeheer - Pakket - Alle pakketten - Opwaarderen als er een nieuwere versie is
-

zypper ref && zypper update


Ik gebruik zelf YOU nooit, maar doe 't al jaren zoals hierboven. Beide opties "doen" hetzelfde. Yast ververst de bronnen bij het opstarten van Softwarebeheer ( de zypper refresh ), de eerse optie selecteert alles wat echt geupdate kan worden (de zypper update)

GeckoSuse
27-Jun-2013, 00:34
Over het blokje pakketten dat je nu nog ziet, dat niet wordt opgewaardeerd, is correct. Dat zijn nl. de pakketten waarvoor de Update repo wel een update heeft (bijv. die van de distro zelf), maar waarvan jij zypper verteld hebt dat je die pakketten uit een andere repo (bijv. Packman) wilt hebben (de vendor switch).

Na al je prima adviezen is ook dat nu geregeld. Over de Vendor switch denk ik dat je gelijk hebt, die van Packman is mogelijk niet meteen uitgevoerd. Ook ga ik voortaan je tip gebruiken voor ;

zypper ref && zypper update

Nogmaals dank voor deze leerzame oefening in geduld!