PDA

View Full Version : Computer afsluiten



martinus2
29-May-2013, 06:28
Beste Forummers,

Weet niet of dit de goede plek is om de vraag te stellen.



Met opensuse 12.3 + kde4.

Het afsluiten werkt niet volgens het boekje.
Het afsluitprocedure-schermpje komt boven en daarin aangegeven een restart werkt prima;
echter aangeven shutdown blijft hangen.
Kan alleen uitgezet worden door de stroom uit te zetten,die knop moet lang vastgehouden worden,want de eerste reactie is,dat de computer wilt herstarten,
Op de engelstalige deel van dit forum gezocht en de daar aangevoerde oplossingen geprobeerd.
Werkten echter niet.
Ook via googelen aangevoerde oplossingen waren geen succes.

Heeft iemand een suggestie?

Alvast bedankt.

Martin.

Knurpht
29-May-2013, 06:39
Waar ik benieuwd naar ben, is of het probleem ook bestaat voor een nieuwe gebruiker.

En, hoe lang heb je gewacht ? Niet dat anderhalve minuut normaal zou zijn, maar zie je bijv. nog harde schijf activiteit, kun je er met ssh nog op inloggen.?

martinus2
30-May-2013, 05:25
Waar ik benieuwd naar ben, is of het probleem ook bestaat voor een nieuwe gebruiker.

En, hoe lang heb je gewacht ? Niet dat anderhalve minuut normaal zou zijn, maar zie je bijv. nog harde schijf activiteit, kun je er met ssh nog op inloggen.?

Beste Knurpht,

Als we gewoon uitloggen en dan escape indrukken dan krijgen we het tekstscherm met de volgende gegevens:


All filestems umnounted
Deactivating swap
All swaps deactivate
Detaching looping devices
All looping devices detached
Detaching dm devices
all dm devices detached
[2007,923932] system halted


Dat 2007,923932 verandert elke keer.
De computer staat dan helemaal vast,zelfs de cursor wil niet meer bewegen.
De harde schijf doet ook niets meer.

Geeft dit wat houvast?

Misschien iets met de hardware?

Groet,

Martin

Knurpht
30-May-2013, 06:05
Ha Martin,

Zeker maakt dat het duidelijker. Het systeem houdt er helemaal mee op, behalve dat de stroom er ook daadwerkelijk afgaat. Dat niets het dan meer doet is niet meer dan logisch.
Wat kun je er aan doen? In Yast - Systeem - Sysconfigeditor zoeken op "halt", er volgt een venster met zoekresultaten, daarvan klik je "HALT" aan, klikt "Ga naar" en verandert de waarde van "auto" is "poweroff".

martinus2
30-May-2013, 06:50
Beste Knurpht,

dank voor de snelle, duidelijke reactie.
Helaas kom ik er vandaag niet mer aan toe.

Morgen kom ik erop terug,

groet

martin

martinus2
01-Jun-2013, 03:59
Beste Knurpht,


In Yast - Systeem - Sysconfigeditor zoeken op "halt", er volgt een venster met zoekresultaten, daarvan klik je "HALT" aan, klikt "Ga naar" en verandert de waarde van "auto" is "poweroff".

Het wil niet lukken en de reden -denk ik- is dat er in de


/sbin/SuSEconfig

Dat is niet aanwezig. Uitkomst van locate:


ali@linux-vn4l:~> locate SuSEconfig
/etc/X11/xdm/SuSEconfig.xdm
/usr/share/doc/packages/susehelp/examples/SuSEconfig.susehelp
/usr/share/zsh/functions/Completion/openSUSE/_SuSEconfig
/var/adm/SuSEconfig
/var/adm/SuSEconfig/md5
/var/adm/SuSEconfig/md5/etc
/var/adm/SuSEconfig/md5/etc/X11
/var/adm/SuSEconfig/md5/etc/X11/xdm
/var/adm/SuSEconfig/md5/etc/X11/xdm/xdm-config
/var/adm/SuSEconfig/md5/etc/X11/xdm/Xservers
/var/adm/SuSEconfig/run-texhash
ali@linux-vn4l:~>















In het Yast software en in software opensuse gezocht niets gevonden.

Hoe nu verder?

Met vriendelijke groet,

Martin

Knurpht
01-Jun-2013, 05:07
Kijk, daar herkennen we de ervaren gebruiker: SuSEconfig .....
Maar, SuSEconfig is "deprecated", d.w.z. wordt niet meer gebruikt.

Ik verwijs ook niet naar de software installer, maar naar de sysconfig editor. Ik kan niet opmaken uit je post of je de waarde van "HALT" nou hebt veranderd van "auto" naar "poweroff". Denkelijk is het ook nog nodig dat je eerst herstart, dit zijn toch wel low-level settings, en die werken meestal pas als de kernel opnieuw geladen wordt. De simpelste manier om dat te bewerkstelligen is opniew opstarten.

Als je toch al bent ingelogd, kun je deze optie ook op een andere manier veranderen:


kdesu kwrite /etc/sysconfig/shutdown

Verander de regel


HALT="auto"

in


HALT="poweroff"

sla het bestand op, herstart het systeem en kijk wat er gebeurt als je 't uit probeert te zetten.

martinus2
03-Jun-2013, 05:59
Beste Knurpht,

Opensuse 12.3 64 bit + kde.


Als we met

sysconfig van auto naar poweroff gaan

en aangeven save


dan komt er een requestvenster van YaST2
configuration script failed.


Het van auto naar poweroff gaan wordt niet gesaved en handmatig werkt het ook niet.

Met vriendelijke groet,

Martin

Knurpht
03-Jun-2013, 14:34
Ha Martin,

Zie je post nu net, maar moet nu zelf eerst in de slaapstand. Het zou kunnen zijn dat 't een acpi probleem is, in de engelstalige forums heb ik dit ook al eens gezien. Morgen een vreselijk drukke dag ivm werken, maar tussendoor zal ik nog 's kijken of ik iets kan vinden.
De foutmelding van Yast heb ik ook 's gezien, je kunt checken of de waarde wel weggeschreven is door te kijken in /etc/sysconfig/shutdown. Dit is het deel waar het om draait:


## Type: list(poweroff,halt,auto)## Default: auto
#
# What should the system do on halt? With poweroff the
# system not only halt the OS but also switch the power
# down. On ix86 or x86_64 this depends on the APM and/or
# ACPI capabilities of the hardware, therefore "auto" will
# cause the system to check about.
#
HALT="auto"

Knurpht
04-Jun-2013, 04:44
Martin, dit vond ik nog:

In /usr/share/kde4/config/kdmrc staat dit


[Shutdown]
BootManager=None
HaltCmd=/sbin/shutdown -h -P now
RebootCmd=/sbin/shutdown -r now

Staat dat er bij jou net zo?

martinus2
06-Jun-2013, 04:23
Beste Knurpht,

De waardes worden wel goed weggeschreven met


/etc/sysconfig/shutdown

Het file is aanwezig met dezelfde waarde van wat je aangaf, er is alleen een klein verschil waar het staat.
Bij ons staat het in


/usr/share/kde4/config/kdm/kdmrc


Groet,

Martin.

Knurpht
06-Jun-2013, 06:14
Beste Knurpht,

De waardes worden wel goed weggeschreven met


/etc/sysconfig/shutdown

Het file is aanwezig met dezelfde waarde van wat je aangaf, er is alleen een klein verschil waar het staat.
Bij ons staat het in


/usr/share/kde4/config/kdm/kdmrc


Groet,

Martin.

Mijn fout. Als de waarden goed staan, is er in de configuratie niets waarvan ik weet dat 't zou kunnen helpen. Je zou kunnen proberen of 't met een nieuwere kernel blijft bestaan, maar ik kan me voorstellen dat je dat een stap te ver gaat. Ook kun je nog eens de BIOS instellingen wijzigen op het gebied van Energiebeheer / Slaapstand / Power etc.

martinus2
08-Jun-2013, 06:28
Beste Knurpht,

Dat gaat me inderdaad wat te ver.

Voor nu geef ik het op.

Hartelijk dank voor je reacties en geduld.

Met vriendelijke groet,

Martin

joostvanrooij
01-Feb-2014, 02:54
Wat is de output als je in een console het volgende commando ingeeft: zypper search acpi

Voor zowel acpi, acpica en acpid zou een "i" moeten staan wat aangeeft dat dit geinstalleerd is.

martinus2
07-Feb-2014, 08:11
Iemand op dit forum had hetzelfde probleem en zijn oplossing was om in
Yast >> boot loader >> advanced

Om daar de optie weg te halen van
acpi

uit- en inloggen en de computer sluit correct af.

Onderstaand het resultaat van je vraag.


ali@linux-vn4l:~> zypper search acpi
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+--------+-------------------------------------------------------------------+--------
| acpi | Command-line ACPI client | package
i | acpica | This is a set of tools to display and debug your BIOS ACPI tables | package
| acpid | Executes Actions at ACPI Events | package
ali@linux-vn4l:~>



Bedankt en succes.
Martin