PDA

View Full Version : Kdenlive 0.9.2 crasht



wfranssen
26-Jun-2012, 10:09
Kdenlive 0.9.2-1.1 (van Packman) crasht na voltooien configuratie wizard. Versie 0.8.2 werkte probleemloos.

kdenlive(2818)/kdeui (kdelibs): Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/root/.kde4/socket-linux-5al1/kdeinit4__0
Warning: connect() failed: : Verbinding is geweigerd
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
drkonqi(2819)/kdeui (kdelibs): Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)

Systeem: OpenSUSE 12.1 + KDE 4.7.2

Heeft iemand een idee?

vrgr, Willem Franssen

Knurpht
26-Jun-2012, 12:07
Ha Willem,

Kun je output alsjeblieft tussen CODE tags plaatsen? 't Is gewoon niet te doen om een hele avond output te lezen in proportionele fonts.

Over kdenlive: Het wordt al aangegeven, het zou heel goed kunnen dat 't met een keer in- en uitloggen ook gefixt is: Er kan door kdenlive niet gepraat worden met de sessie-bus (dwz met de dbus daemon). Kortom, kdenlive weet niet bij wie-ie hoort. Probeer het volgende eens vanuit een terminal :


export $(dbus-launch) && kdenlive


Ik gebruik op dit moment kdenlive niet veel, maar 't start bij mij goed op, crash niet. Het kan zelfs zijn, dat je moet rebooten, om te zorgen dat kdenlive wel met de dbus daemon kan praten.

Overigens ben ik zeer voor het upgraden naar KDE 4.8. Zo stabiel als ik weet niet wat, werkelijk niets gaat bij mij ondersteboven.

wfranssen
26-Jun-2012, 15:44
Dank voor je antwoord.
Heb je code uitgevoerd. Probleem blijft.
Als ik daarnaast die opdracht uitvoer als root krijg ik nog de volgende critical errors:


(gst-plugin-scanner:2893): GLib-GObject-CRITICAL **: g_param_spec_double: assertion `default_value >= minimum && default_value <= maximum' failed

(gst-plugin-scanner:2893): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

(gst-plugin-scanner:2894): GLib-GObject-CRITICAL **: g_param_spec_double: assertion `default_value >= minimum && default_value <= maximum' failed

(gst-plugin-scanner:2894): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

(gst-plugin-scanner:2895): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdc1394.so': /usr/lib/gstreamer-0.10/libgstdc1394.so: undefined symbol: dc1394_iso_release_all


Hoe upgrade ik KDE 4.7.2 trouwens naar KDE 4.8x?
vrgr, Willem Franssen

wfranssen
26-Jun-2012, 17:47
Ik laat trouwens upgrade naar KDE 4.8x maar zitten. Heb gelezen hoe het moet. Maar heb ook gelezen over nieuwe bugs.
Daar komt bij: ik gebruik bij voorkeur de multimedia-packages van Packman. En Packman bouwt alleen tegen de officiƫle distro-KDE release.

Verder overweeg ik na ruim 5 jaar OpenSUSE over te stappen naar een andere distro. Het laatste jaar zit er veel fout in de software updates en het package-onderhoud. Daar is ook alles over te lezen in Planet OpenSuse. Zelf heb ik in versie 12.1 niet anders dan veel gelazer met multimedia-software gehad, alsmede met de Flashplayer-updates. In oudere versies nooit ergens last mee gehad. Gelet op de voortdurende vertragingen vrees ik, dat ook OpenSUSE 12.2 een slechte release wordt. Teveel werkt gewoon niet zonder in grote ergernis iets aan de praat proberen te krijgen en dan nog meestal vergeefs. Met goed fatsoen valt OpenSUSE (en diverse andere Linux-distro's) niet meer te promoten bij de gemiddelde computeraar. Bij elke nieuwe versie (kernel, kde, applicaties) zijn er altijd weer veel nieuwe bugs en regressies. Los van mijn respect en waardering voor ontwikkelaars, maintainers, packagers en forum-helpers zou ik zeggen: de Linux-community's moeten na 20 jaar eindelijk eens begrijpen dat dit zo niet langer kan. Het disto-concept is naar mijn mening volledig achterhaald, voor iedereen onwerkbaar en voor "Joe User" nagenoeg onbruikbaar.
vrgr, Willem Franssen