PDA

View Full Version : 12.1: WLAN-Routerbau mit Komplikationen (kein Master-Modus) - NACH VERSCHIEBUNG



Robidu
19-Apr-2012, 03:32
Hallo!

Ich versuche derzeit unter 12.1 einen WLAN-Router aufzubauen (das soll nicht bloß ein einfacher Router sein - da täten es auch die Fertiglösungen - sondern der soll noch ein paar Dinge mehr bieten), nur jetzt weigert sich die WLAN-Karte (eine D-Link DWL G520), in den Mastermodus umzuschalten.
Ich möchte aus Sicherheitsgründen nicht das unsichere WEP haben, sondern WPA2, nur gibt es da anscheinend eine Kollision.

Gibt es irgendeinen Trick, wie ich der Karte dennoch den Master-Modus zusammen mit WPA beibiegen kann, oder gibt es da irgendeine Umgehungsstraße? Ich habe da zwar schon Verschiedenes ausprobiert, nur klappen wollte das nicht. :(

pistazienfresser
01-May-2012, 03:28
Insbesondere da es bislang keine Antworten in diesem Forum „Netzwerk“ gab, werde ich den Thread in das passende Unterforum „Wireless“ verschieben. Benutzer von NNTP werden gebeten, mit einer Antwort bis zum Ende der Verschiebung zu warten. Auf der NNTP-Seite dürfte dann eine Freigabenachricht aus dem 'Nichts' in der einschlägigen Newsgroup „Wireless“ auftauchen.
Bis dann
Martin

pistazienfresser
01-May-2012, 03:55
Hallo!

Ich versuche derzeit unter 12.1 einen WLAN-Router aufzubauen (das soll nicht bloß ein einfacher Router sein - da täten es auch die Fertiglösungen - sondern der soll noch ein paar Dinge mehr bieten), nur jetzt weigert sich die WLAN-Karte (eine D-Link DWL G520), in den Mastermodus umzuschalten.
Ich möchte aus Sicherheitsgründen nicht das unsichere WEP haben, sondern WPA2, nur gibt es da anscheinend eine Kollision.

Gibt es irgendeinen Trick, wie ich der Karte dennoch den Master-Modus zusammen mit WPA beibiegen kann, oder gibt es da irgendeine Umgehungsstraße? Ich habe da zwar schon Verschiedenes ausprobiert, nur klappen wollte das nicht. :(

Hallo Robidu,

habe Deinen Thread in das Unterforum/die Newsgroup „Wireless“ verschoben.
Leider habe ich selbst noch nicht versucht, mir einen WLAN-Router selbst zu bauen, daher kann ich höchstens begrenzt weiterhelfen.

Sollte das Problem (auch) durch die Wireless-LAN-Karte bedingt sein, so wäre es sinnvoll, mehr über diese Karte und den verwendeten Treiber (Kernel-Modul) zu erfahren. Das dürfte zwei Dinge wahrscheinlicher machen: Dass jemand mit dieser Karte Deine Frage findet und dass jemand anders Dir helfen kann, entsprechende Antworten im Netz zu finden.

Poste bitte mal die entsprechenden Absätze (möglichst auch in CODE-Tags) der Ausgaben:

für eine PCI-WLAN-Karte von

/sbin/lspci -nnk
oder
für ein USB-WLAN-Gerät von

lsusb.

Bis bald
Martin