PDA

View Full Version : Wordt de OBS van OpenSUSE een zooitje?



wfranssen
21-Feb-2012, 20:17
De OpenSUSE Community heeft vorig jaar de OBS geïntroduceerd. En tegelijkertijd zijn veel Packman packages daar naar toe gemigreerd. Packman zelf lijkt redelijk stil gevallen door wat het team zelf heeft genoemd een tekort aan packagers. De idee achter OBS leek mij handig, maar als simpel eindgebruiker heb ik er steeds meer slechte ervaringen mee.

In de goede tijden waren alle Packman pakketten perfect en voorzien van alle benodigde additionele pakketten. Je hoefde maar te installeren en het werkte. En als er al iets fout was, dan mailde je even een debuginfo en je werd geholpen, of pakketten werden ge-updated. In OBS is van dit alles geen sprake meer. Allerlei ontwikkelaars sleutelen aan dezelfde pakketten, zodat er verschillende versies ontstaan waarop een applicatie niet meer eenduidig is te compileren. Bij ffmpeg is dat bijvoorbeeld het geval. De nog overgebleven Packman-mensen zijn hierdoor in diverse gevallen merkbaar de draad kwijt geraakt.

In OBS zijn van eenzelfde applicatie voor dezelfde SUSE-versie vaak meerdere verschillende versies verkrijgbaar. Welke je moet hebben, dat zoekt de eindgebruiker zelf maar uit. En als er fouten in zitten, dan weet je als eindgebruiker niet tot wie of wat je je moet wenden. Om voor elke simpele applicatie een bugmelding te moeten doen naar god mag weten wie, dat heeft niets meer van doen met gebruikersvriendelijkheid.

Enkele voorbeelden onder OpenSUSE 12.1:
1. TuxGuitar start niet op. Kan de SWT library niet laden. Heeft iets te maken met Java. Vroeger werkten de Packman-pakketten van TuxGuitar feilloos.
2. KMid (al jarenlang bekend om het feit dat het niet werkt) start niet op. Maar nu krijg ik een fout die ik nog nooiit eerder heb gehad: Fatale fout ALSA-sequencer backend. Hetzelfde geldt voor KMidimon.
3. WinFF start wel op, maar kan FFplay niet vinden. Foutmelding: Access Violation. In vroegere jaren ook wel eens zo'n melding gehad. Dan veranderde ik iets in de KDE-stijlen en het was verholpen. Maar nu werkt het niet. Ook de voorinstellingen voor de uitvoer (converteren) kunnen niet worden gebruikt.
4. Kdenlive kan FFmpeg&play niet vinden. Dus kan er niet worden gespeeld met de webcam. Alle ffmpeg pakketten zijn geïnstalleerd, dus zeg het maar.
5. Firefox 10.0.1 was geïnstalleerd via de normale Mozilla-repository. Maar de update naar 10.0.2 moest ineens gebeuren via OBS/Mozilla. Waarom, dat is mij een raadsel.
6. BleachBit. Sinds jaar en dag is daarvan versie 0.9.1 beschikbaar. Maar de standaard repository komt niet verder dan 0.9.0. Versie 0.9.1 is wel in de OBS te vinden, maar is niet gecompileerd voor Suse 11.4 en 12.1.
7. (gtk)RecordMyDesktop is een ramp. Al jarenlang. Niet alleen onder OpenSUSE, maar ook onder andere distro's. Waarom? Het slaat frames over en de beelden bevriezen. Lees er de forums maar op na: het programma is al jarenlang bogus. En kennelijk heeft geen enkele Linux-community ooit gehoord van Krut. Geen enkele RecordMyDesktop versie uit de OBS werkt naar behoren.
8. Mono. Deze M$ Silverlight kloon is al jarenlang een giller van Novell. De huidige Mono-versie loopt jaren achter bij de huidige Silverlight-versies en is dus niet compatible. Probeer maar eens wat te bekijken op de baggersites van RTL bijvoorbeeld. Lukt niet. Mijn advies: laten "ze" stoppen met Mono. Zonde van tijd en moeite. Gewoon wachten op de invoering van html5.

Ik kan de lijst nog veel langer maken, maar ik houd het hierbij. Het gaat mij er meer om na te gaan hoe de gebruikerservaringen met OBS zijn. Mijn indruk is steeds meer, dat OBS een mooie hobbyplek is geworden voor ontwikkelaars en packagers, maar dat de eindgebruiker uit het zicht is verloren.

Laten we elkaar als Linux- en OpenSUSE-liefhebbers niet wijs blijven maken dat alles lekker out of the box werkt. Dat is niet het geval. Ik ben vrijwilliger voor Buurtlinux.nl, maar ik moet er niet aan denken, dat een nieuwe OpernSUSE-gebruiker mij vraagt alle multimedia op zijn computer vlekkeloos te laten draaien. Dat gaat mij een maand kosten. Mede dankzij de nog veel te grote geek-mentaliteit in de community.

Kijk, ik ben altijd dankbaar als iemand mij op een forum kan helpen. Maar er is de laatste tijd veel teveel mis met OpenSUSE-pakketten. Om elke dag op een forum te moeten zitten, omdat iets niet werkt, dat is niet normaal. Gewone gebruikersapplicaties horen gewoon out of the box te werken. Of niet soms?

Willem Franssen

Knurpht
23-Feb-2012, 03:28
Ik ben het op een aantal punten met je eens, toch wat aantekeningen:

1 - Tuxguitar heeft voor zover ik weet de sun-java versie nodig, en die kan niet zomaar meer verspreid worden dankzij Oracle
2 - Niet mee bekend
3 - Zelfde verhaal denkelijk als kdenlive, kun je eens output posten van


zypper lr -d

4 - Probleem bestaat bij mij niet. Ook nog even alles "schoongemaakt" zodat de config wizard opstartte, alles werd gevonden. Werking kdenlive ook OK.
5 - In de mailinglijsten, en voor zover ik 't me goed herinner ook hier in de announcements, is bekend gemaakt dat FF via de Update repo bijgewerkt wordt.
6.- software.opensuse.org: Zoekresultaten (http://software.opensuse.org/search?q=bleachbit&baseproject=openSUSE%3A12.1&lang=nl&exclude_debug=true) heeft ook de hogere versie voor 12.1 en Tumbleweed wel.
7 - Er zijn nog wel meer alternatieven, heb geen recente ervaring met recordmydesktop, vooral niet omdat GNOME3 een ingebouwde recorder heeft, die prima werkt (Ctrl-Shift-Alt-R).
8 - Breek me de gleuf in 't hoofd niet open. Toch ook hier een aantekening. M$ zou, volgens afspraken, code en kennis delen, de praktijk is dat de dingen die gedeeld worden pas komen op het moment dat M$ een volgende versie vrijgeeft, en er zo niet veel andere opties zijn, dan continue een versie achter lopen. Ik denk dat ook veel ontwikkelaars het nut niet zien, omdat html5 er (veel harder dan gedacht) aankomt.

OBS is nooit bedoeld voor eindgebruikers. Daarbij is het niet een project dat al jaren loopt; ik vind dan ook niet dat je dat in je oordeel mee moet nemen. Mijn eigen ervaringen ermee zijn niet dezelfde als de jouwe, ik zou dan ook graag eens lezen hoe jij er gebruik van maakt.

Het verhaal over multimedia deel ik ook niet. De one-click codec installers werken goed, in de forums komen multimedia problemen met 12.1 er in 99% van de gevallen op neer, dat mensen niet gezocht hebben, niet weten wat ze moeten doen. Toch zijn in de wiki, de SDB en de forums instructies hiervoor te vinden. Er wordt ook nog steeds gewerkt aan oplossingen die 't meer in de distro brengen, zonder dat er juridische dreigingen ontstaan. Is overigens een stuk waarvan ik vind dat 't al jaren behoorlijk goed geregeld en gedocumenteerd is. Als je pakketten vindt die niet goed werken, de ontwikkelaars luisteren echt wel, maar niet naar mededelingen hier, ze luisteren naar bug reports. Fouten die door niemand gemeld worden, worden in de regel ook niet opgelost.

In de laatste opmerking kan ik ook niet meegaan. Heb 12.1 nu op meer dan 50 verschillende machines geïnstalleerd, door de bank genomen zonder problemen. Maar misschien ligt dat ook wel aan mijn eigen protocollen (installeren, updaten, extra repos toevoegen etc. doe ik allemaal in een apart account, pas als alles er weer opstaat zoals ik 't wil hebben, log ik in op mijn normale account).

Knurpht
23-Feb-2012, 05:48
Ad 1. Heb "eclipse-swt" geïnstalleerd. Vervolgens /usr/lib(64)/eclipse/libswt* gekopiëerd naar ~/.swt//lib/linux/amd64 en jawel, tuxguitar opent, en mekkert nergens over (behalve over het niet bestaan van /dev/sequencer)......:D

wfranssen
23-Feb-2012, 20:16
Ik blijf erbij, dat de OBS niet deugt.
TuxGuitar: naast Java-openjdk heb ik destijds ook direct Java-sun en Java-sun-alsa geïnstalleerd. Ook eclipse-swt is geïnstalleerd. TuxGuitar versie 1.2-4.1.2 is geïninstalleerd, leverancier opensuse (Packman is geen leverancier).Fout:
Exception in thread "main" java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-gtk-3730 in java.library.path
no swt-gtk in java.library.path
Can't load library: /home/Wimmie/.swt/lib/linux/x86/libswt-gtk-3730.so
Can't load library: /home/Wimmie/.swt/lib/linux/x86/libswt-gtk.so

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:284)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:193)
at org.eclipse.swt.internal.C.<clinit>(C.java:21)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Los daarvan: stel nu, dat ik /usr/lib/eclipse/libswt nog zou moeten kopiëren, noem je dat dan gebruikersvriendelijk en out of the box? Nee natuurlijk. Verschil: TuxGuitar zat vroeger bij Packman. Die leverde een kant en klaar te installeren pakket, inclusief soundbank en het zaakje werkte.
WinFF: wordt al zo'n anderhalf jaar niet meer onderhouden door Packman. Onder Suse 11.4 haalde ik het daarom van de repository van Enzokiel. Onder Suse 12.1 WinFF 1.4.1-8.2 geïnstalleerd. De standaardversie. Eveneens van repositories/home:/enzokiel/opensuse/ enz. In Yast heet de leverancier: obs:/build/opensuse.
Een ander voorbeeld: Timidity. daar zijn in de OBS "tig" versies van. Gekozen voor de standaardversie 2.13-266.1.2, leverancier: opensuse. Bij deze versie zit geen debug info pakket. Dat zit wél in de obs/build.opensuse.org/games, maar dat is versie 2.13.2-550. In elk geval: Timidity start niet eens op. Timidity werd vroeger onderhouden door Packman. Werkte altijd.

Hoe gebruik ik OBS? Nou bijvoorbeeld een repository als "repositories/home:/enzokiel/opensuse/ enz. enz. importeren in Yast (voor WinFF). In de OBS is WinFF ook van die leverancier. Bij one click installs dezelfde problemen als hierboven genoemd. Deze methode gebruik ik liever niet, want anders kom ik met een waslijst aan verweesde geïnstalleerde pakketten te zitten. Lastig met updaten. Dus ik importeer bij voorkeur de betreffende repositories.
Firefox: geïnstalleerd versie 10.0.2-4.2 van obs:/build.opensuse.org/mozilla. Dat kwam zo: versie 10.0.1 was geïnstalleerd van mozilla/opensuse, maar al sinds lichtjaren was er een veiligheidsupdate naar 10.0.2. Was niet beschikbaar. Toen maar in de OBS gekeken. Daar was ie wel en toen maar de bijbehorende repository geïmporteerd. Sinds gisteren is Firefox 10.0.2-2.21 op de normale mozilla/opensuse repository beschikbaar. Kan die natuurlijk ook installeren.
Voor goed begrip: ik heb natuurlijk ook de Packman repository packman.inode.at/suse/opensuse/12.1 geïmporteerd.
Dus zo ongeveer ga ik met OBS om. Neemt niet weg, dat teveel niet werkt. Had ik absoluut bij Packman geen last van.

wfranssen
23-Feb-2012, 21:47
Nog even dit: multimedia en codecs daar gaat het helemaal niet om. Ik weet ook wel dat er restricted formats zijn en waar ik alle codecs vandaan moet halen. Dat is altijd een van de eerste dingen die ik doe. Het gaat erom, dat de laatste tijd teveel niet out of the box werkt. Als de community Oracle niet ziet zitten, ok. Maar als Tux Guitar Java van Sun nodig heeft, hoe moet een gemiddelde gebruiker dat weten? Een one click install van TuxGuitar hoort in te houden dat alle benodigde additionele pakketten mee worden geïnstalleerd en dat het direct werkt. En als er bezwaar is tegen Sun Java, dan dient TuxGuitar te worden gecompileerd op of met Java-openjdk. WinFF hoort gewoon te werken, evenals Timidity, KMid, gtkRecordMyDesktop en noem maar op. Bijkomend probleem met OBS is: tot wie moet ik mij nu wenden? Hebben diverse ontwikkelaars/packagers er nog behoefte aan om een gebruiker te antwoorden of moet die maar upstream een bug melden. Aan wie? Aan de ontwikkelaar van de applicatie, aan de ontwikkelaar van een additioneel pakket? En wordt daar nog wat mee gedaan?

Is het normaal dat veel doorsnee gebruikersapplicaties niet out of the box werken? Moet een gewone gebruiker duizend forums langs om iets op te lossen? Of kan een gewone gebruiker direct met zijn gewenste toepassing aan de slag? Bij Packman was dat het geval, bij OBS niet. Is het normaal dat (iets anders) pulse audio en KMix al jarenlang met elkaar conflicteren. maar beide wel standaard worden geïnstalleerd, waarna je één van beide applicaties moet deïnstalleren? Ik beschouw mijzelf iets meer dan een gemiddelde gebruiker. Maar vanuit de gewone consument ken ik het antwoord: nee, dat is niet normaal. Net zoals er dedain is ontstaan tegenover Ubuntu, omdat het teveel mainstream is geworden, bespeur ik aan de ontwikkelkant teveel dedain tegenover gewone computeraars die wellicht best aan Linux willen. Maar, kort door de bocht, zolang we het nog leuk vinden met ellenlange commandoregels oplossingen voor te schotelen aan "newbies" (zie de diverse forums) zal de gewone computeraar zich niet kunnen identificeren met Linux. En ik maar blijven volhouden dat Linux-distro's mooi zijn en gemakkelijk. Als het eenmaal werkt ja, dan is het prachtig.

Meneer Shuttleworth van Cannonical heeft het begrepen en trekt zich van alle protesten niets aan. Ook de jongens en meisjes van LibreOffice hebben het begrepen. Die gaan als een trein en hebben een grote commerciële vendor IBM binnengehaald. En ze werken als gekken aan een smartphone-versie. Android dan, dat is toch Linux? Welnee, Android is Google en die heeft niet voor niets de merknaam Linux laten vallen. Linux heeft, ook na 20 jaar, geen goed imago. Zoiets noemen we verstandige branding en marketing. Is OpenSUSE een merk? Niet in de consumentenwereld. Het belachelijke aan het hele Linux-concept vind ik de enorme versnippering van distributies. Is dat keuzevrijheid? Nee! The more choice, the more confusion. Het druist tegen alle marketingprincipes in. Het is verspilling van menskracht, moeite en geld. En je kunt er geen eenduidig groot merk mee vestigen waarmee gebruikers zich op grote schaal kunnen identificeren. Ben ik een voorstander van Linux? Ja. Niet omdat het gratis is, maar omdat ik het grote nut inzie van open standaarden en open formaten. Is dat een goed "verkoop"argument naar consumenten? Nee, die moet je daar niet mee lastig vallen. Die willen "something new and something shiny". Aan de meritocracy-prietpraat in de diverse Linux-communities hebben ze geen boodschap, ze weten niet eens wat het is. Als ze maar direct met hun pc kunnen werken.

De nieuwe OpenSUSE strategienota van vorig jaar is in dit licht bezien ook niet iets om vrolijk van te worden. OpenSUSE is gericht op gebruikers "die iets willen leren". Volkomen fout en elitair. Gebruikers willen niks leren. Een pc, laptop, netbook, tablet, of smartphone is om te gebruiken, niet om het besturingssysteem te doorgronden. Ik onderhoud Windows-pc's voor een tiental "klanten". Mensen met veel hersens en goede banen. Snappen ze iets van Windows? Nee natuurlijk. Als iets vastloopt, of als alles zwart wordt dan kom ik langs. Het enige wat een gebruiker wil leren is het gebruik van de applicaties waarmee hij wil, of moet werken. Jos Poortvliet heeft dus een verkeerde discussie geëntameerd.

Wat heeft dit alles te maken met OBS? Veel. Ook gebruikers moeten - al dan niet noodgedwongen - gebruik maken van OBS. Maar - in vergelijking tot vroeger - werken teveel pakketten niet en staat OBS mijlenver van de gebruiker af. Dat is, na 20 jaar Linux, nog steeds symptomatisch voor wat ik hierboven heb beschreven. Als "de consument" Linux niet wil, dan ligt het aan de communities, want de klant is altijd koning. En de consument is verzot op Android omdat het geen Linux heet. Zo simpel is het. Daar hebben we geen strategiediscussie voor nodig.

Niettemin blijf ik een tevreden OpenSUSE-gebruiker en promotor.

wfranssen
23-Feb-2012, 22:09
Nog even dit: multimedia en codecs daar gaat het helemaal niet om. Ik weet ook wel dat er restricted formats zijn en waar ik alle codecs vandaan moet halen. Dat is altijd een van de eerste dingen die ik doe. Het gaat erom, dat de laatste tijd teveel niet out of the box werkt. Als de community Oracle niet ziet zitten, ok. Maar als Tux Guitar Java van Sun nodig heeft, hoe moet een gemiddelde gebruiker dat weten? Een one click install van TuxGuitar hoort in te houden dat alle benodigde additionele pakketten mee worden geïnstalleerd en dat het direct werkt. En als er bezwaar is tegen Sun Java, dan dient TuxGuitar te worden gecompileerd op of met Java-openjdk. WinFF hoort gewoon te werken, evenals Timidity, KMid, gtkRecordMyDesktop en noem maar op. Bijkomend probleem met OBS is: tot wie moet ik mij nu wenden? Hebben diverse ontwikkelaars/packagers er nog behoefte aan om een gebruiker te antwoorden of moet die maar upstream een bug melden. Aan wie? Aan de ontwikkelaar van de applicatie, aan de ontwikkelaar van een additioneel pakket? En wordt daar nog wat mee gedaan?

Is het normaal dat veel doorsnee gebruikersapplicaties niet out of the box werken? Moet een gewone gebruiker duizend forums langs om iets op te lossen? Of kan een gewone gebruiker direct met zijn gewenste toepassing aan de slag? Bij Packman was dat het geval, bij OBS niet. Is het normaal dat (iets anders) pulse audio en KMix al jarenlang met elkaar conflicteren. maar beide wel standaard worden geïnstalleerd, waarna je één van beide applicaties moet deïnstalleren? Ik beschouw mijzelf iets meer dan een gemiddelde gebruiker. Maar vanuit de gewone consument ken ik het antwoord: nee, dat is niet normaal. Net zoals er dedain is ontstaan tegenover Ubuntu, omdat het teveel mainstream is geworden, bespeur ik aan de ontwikkelkant teveel dedain tegenover gewone computeraars die wellicht best aan Linux willen. Maar, kort door de bocht, zolang we het nog leuk vinden met ellenlange commandoregels oplossingen voor te schotelen aan "newbies" (zie de diverse forums) zal de gewone computeraar zich niet kunnen identificeren met Linux. En ik maar blijven volhouden dat Linux-distro's mooi zijn en gemakkelijk. Als het eenmaal werkt ja, dan is het prachtig.

Meneer Shuttleworth van Cannonical heeft het begrepen en trekt zich van alle protesten niets aan. Ook de jongens en meisjes van LibreOffice hebben het begrepen. Die gaan als een trein en hebben een grote commerciële vendor Intel binnengehaald. En ze werken als gekken aan een smartphone-versie. Android dan, dat is toch Linux? Welnee, Android is Google en die heeft niet voor niets de merknaam Linux laten vallen. Linux heeft, ook na 20 jaar, geen goed imago. Zoiets noemen we verstandige branding en marketing. Is OpenSUSE een merk? Niet in de consumentenwereld. Het belachelijke aan het hele Linux-concept vind ik de enorme versnippering van distributies. Is dat keuzevrijheid? Nee! The more choice, the more confusion. Het druist tegen alle marketingprincipes in. Het is verspilling van menskracht, moeite en geld. En je kunt er geen eenduidig groot merk mee vestigen waarmee gebruikers zich op grote schaal kunnen identificeren. Ben ik een voorstander van Linux? Ja. Niet omdat het gratis is, maar omdat ik het grote nut inzie van open standaarden en open formaten. Is dat een goed "verkoop"argument naar consumenten? Nee, die moet je daar niet mee lastig vallen. Die willen "something new and something shiny". Aan de meritocracy-prietpraat in de diverse Linux-communities hebben ze geen boodschap, ze weten niet eens wat het is. Als ze maar direct met hun pc kunnen werken.

De nieuwe OpenSUSE strategienota van vorig jaar is in dit licht bezien ook niet iets om vrolijk van te worden. OpenSUSE is gericht op gebruikers "die iets willen leren". Volkomen fout en elitair. Gebruikers willen niks leren. Een pc, laptop, netbook, tablet, of smartphone is om te gebruiken, niet om het besturingssysteem te doorgronden. Ik onderhoud Windows-pc's voor een tiental "klanten". Mensen met veel hersens en goede banen. Snappen ze iets van Windows? Nee natuurlijk. Als iets vastloopt, of als alles zwart wordt dan kom ik langs. Het enige wat een gebruiker wil leren is het gebruik van de applicaties waarmee hij wil, of moet werken. Jos Poortvliet heeft dus een verkeerde discussie geëntameerd.

Wat heeft dit alles te maken met OBS? Veel. Ook gebruikers moeten - al dan niet noodgedwongen - gebruik maken van OBS. Maar - in vergelijking tot vroeger - werken teveel pakketten niet en staat OBS mijlenver van de gebruiker af. Dat is, na 20 jaar Linux, nog steeds symptomatisch voor wat ik hierboven heb beschreven. Als "de consument" Linux niet wil, dan ligt het aan de communities, want de klant is altijd koning. En de consument is verzot op Android omdat het geen Linux heet. Zo simpel is het. Daar hebben we geen strategiediscussie voor nodig.

Niettemin blijf ik een tevreden OpenSUSE-gebruiker en promotor.

Correctie: Intel ipv IBM

wfranssen
24-Feb-2012, 09:44
Kijk, dit bedoel ik nou. De OpenSUSE community wijst mij erop, dat TuxGuitar niet in de Packman repo zit, maar in de main Suse repo. Ja, dat weet ik ook wel. Dat is nou juist het probleem. Sinds de meeste Packman pakketten zijn gemigreerd houden andere maintainers er zich mee bezig. Het werkt niet en je stuurt maar een bugmelding. Dan heb ik nog heel wat te doen als ik zo mijn lijstje naloop. Niet de beste manier om de populariteit van OpenSUSE te vergroten.

Dnia piątek, 24 lutego 2012 01:28:24 Willem Franssen pisze:
> Since the OBS-rubbish I'm not sure anymore this error message should
> be addressed to the good old Packman-team.
> Nevertheless, TuxGuitar can't startup in OpenSUSE 12.1+KDE 4.7.2. Error:
>
> Exception in thread "main" java.lang.UnsatisfiedLinkError: Could not
> load SWT library. Reasons:
> no swt-gtk-3730 in java.library.path
> no swt-gtk in java.library.path
> Can't load library:
> /home/Wimmie/.swt/lib/linux/x86/libswt-gtk-3730.so
> Can't load library:
> /home/Wimmie/.swt/lib/linux/x86/libswt-gtk.so
>
> at
> org.eclipse.swt.internal.Library.loadLibrary(Library.java:284)
> at
> org.eclipse.swt.internal.Library.loadLibrary(Library.java:193)
> at org.eclipse.swt.internal.C.<clinit>(C.java:21)
> at
> org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
> at
> org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
> at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
> at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
> at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

TuxGuitar for openSUSE 12.1 is in main OSS repository - not in Packman. Please
use https://bugzilla.novell.com/ to report this issue.
-- Pozdrawiam / Best regards, Mariusz Fik openSUSE Community Member GPG: 5FCE 7241 B3B9 32FD 455B C30E 42D6 6C88 9E83 7C3D

Knurpht
25-Feb-2012, 07:46
Voor wat betreft Tuxguitar: dit wordt inderdaad geleverd via de officiele repos, en had m.i. getest moeten worden. Maar ....... er is hier https://bugzilla.novell.com/show_bug.cgi?id=732684#c0 melding gemaakt van een bugreport, en van de oplossing, deze is gepubliceerd in de Education repo. Had, gezien het feit dat Tuxguitar in de standaard repo staat, vrijgegeven moeten worden in Update. Maar niet in de distribution repo, die dient dat te hebben wat ook op de DVD/CD's staat en wordt (al even) voor bevroren.
Voor wat betreft OBS: het wordt, op allerlei plaatsen, afgeraden om uit allerhande repos te installeren, m.n. de /home: repos zijn "Enter at own risk".

Voor het overige: ik vind de discussie over de hele materie interessant, maar vind dit (helpen en hulp-desktop-kde) niet echt de beste plek ervoor. Draadje openen in Community - Suggesties en Commentaar? of Praathoek? Jos 's opporren of-ie zijn licht hierop ook eens wil laten schijnen? Kan zo, al weet ik niet hoe Jos in z'n tijd zit.

Wat ik nog wel kwijt wil, me er bewust van dat er een behoorlijke persoonlijke factor is (je gebruikt waarschijnlijk een heel andere software-set dan ik), is dat mijn ervaringen met 12.1 juist erg it-just-works-and-out-of-the-box zijn.