PDA

View Full Version : KDE 4.8



satshow
27-Jan-2012, 04:39
Ik zie zojuist dat KDE 4.8 is verschenen. Komt hier vanzelf een melding voor binnen om deze te updaten?
Of gaat dat op een andere manier?

Is het verstandig om die te updaten trouwens?
Zit nu op KDE 4.7.2 release 5

Knurpht
27-Jan-2012, 04:57
Ik heb 'm draaien, ben zeer onder de indruk, maar afhankelijk van wat je allemaal geïnstalleerd hebt, zou je op dependency errors kunnen stuiten. De repo ervoor is deze: Index of /repositories/KDE:/Release:/48/openSUSE_12.1 (http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/)
Als je 11.4 draait moet je de 12.1 uit de link vervangen door 11.4.

Je voegt de repo toe middels Yast - Softwarebronnen en noemt 'm KDE48. Daarna start je Yast - Softwarebeheer op, selecteert i.p.v. Zoeken Installatiebronnen, klikt daar de KDE48 repo aan. Vervolgens klik je rechts bovenin het scherm op "Schakel systeem pakketten ...." en accepteert dat. Ongeveer 1GB later log je uit, weer in en je zit in KDE 4.8

mbenjamins
28-Jan-2012, 04:32
Ik krijg de volgende melding als ik openSUSE 12.1 naar KDE 4.8 wil updaten.
http://www.allesoverlinux.nl/screenshot/KDE4.jpg
Hieronder de output van zypper lr -d


# | Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service
--+--------------------------------------+--------------------------------------+--------------+------------+------------+--------+------------------------------------------------------------------------------------+--------
1 | Bijwerken-van-openSUSE-12.1-12.1-1.4 | Bijwerken van openSUSE 12.1 12.1-1.4 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/12.1/ |
2 | KDE4-Release | KDE4-Release | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/ |
3 | KDE_Extra | KDE Extra | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/ |
4 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/non-oss/ |
5 | repo-oss | openSUSE-12.1-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/oss/ |

Knurpht
28-Jan-2012, 04:53
Mmmmm, er mist nog wat blijkbaar voor de 32bits versie. Ik zou in dit geval ervoor kiezen om qt4-qtscript te deïnstalleren, en (omdat het alleen gaat om "branding" die niet verschilt van de oude versie) bij de tweede kiezen voor de laatste optie, negeren. Dat heb ik tijdens de beta fase gedaan (ik heb meerdere desktopomgevingen geïnstalleerd, en kan dus altijd wel werken) zonder dat dat tot problemen leidde.

satshow
28-Jan-2012, 11:23
Ik heb zojuist de upgrade uitgevoerd. Volgens mij is er ergens wat mis gegaan.
Tijdens het opstarten van mijn pc moet ik mijn inlog en paswoord ingeven, wat voorheen niet het geval is met daaronder een aantal foutmeldingen.
Verder zie ik na het opstarten een file met xconsole met daarin vanalles en nog wat.

Knurpht
28-Jan-2012, 16:15
Dan is er inderdaad iets misgegaan. In ieder geval is de autologin niet meer actief. Daar is wel te fixen, maar ik heb eerst een paar vragen:
- Kreeg je tijdens de update ook foutmeldingen? Over "afhankelijkheden"? Zo ja, wat heb je daarmee gedaan?
- Zie je wel het KDE login scherm? Dwz. een groen, grafisch scherm?
- "Een aantal foutmeldingen" zegt ons helemaal niet, we willen die foutmeldingen ook graag hier zien, omdat we dan kunnen bepalen wat er mis is gegaan.
- Wat bedoel je met "een file met xconsole", maak er desnoods een foto van en post een link ernaar hier, dan zien we tenminste wat je bedoelt.
- Graag de output van "zypper lr -d" hier posten.

satshow
29-Jan-2012, 05:58
Wat betreft de foutmeldingen dat waren de 2 die ik hierboven ook heb gezien. Ik heb het advies daarvan opgevolgd, alhoewel ik twijfel of ik bij kdm de juiste optie heb gekozen .
Tijdens het inloggen zie ik de grub en daarna zie ik de groene schil. Voor het opstarten met die vakjes zie ik het volgende scherm

http://www.imgdumper.nl/uploads5/4f253ea86c953/4f253ea8031cb-inlog.jpg

Op dezelfde pagina staat onderaan de volgende foutmelding

http://www.imgdumper.nl/uploads5/4f253ecc2329a/4f253ecbaecef-foutmeldinginlog.jpg

Ik kan gewoon mijn naam en paswoord invullen en daarna start deze door.

Nadat ik opgestart ben zie ik op het bureaublad de volgende file staan
http://www.imgdumper.nl/uploads5/4f253ed73fd4e/4f253ed6c4282-xcontrolescherm.jpg

Hieronder het resultaat van de output die je gevraagd hebt


fred@linux-lw2i:~> zypper lr -d
# | Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service
---+------------------------------------+------------------------------------+--------------+------------+------------+----------+-------------------------------------------------------------------------------------+--------
1 | KDE48 | KDE48 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/ |
2 | Opera | Opera | Ja | Ja | 99 | plaindir | dir:///home/fred/Prive/Opera |
3 | Packman Repository | Packman Repository | Ja | Ja | 99 | rpm-md | http://packman.inode.at/suse/12.1/ |
4 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/12.1/ |
5 | download.nvidia.com-opensuse | nVidia Graphics Drivers | Ja | Ja | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.1/ |
6 | libdvdcss repository | libdvdcss repository | Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/12.1/ |
7 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Ja | Nee | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorpCD_DVDW_SH-S182D,/dev/sr0,/dev/sr1 |
8 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1/ |
9 | repo-debug | openSUSE-12.1-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/distribution/12.1/repo/oss/ |
10 | repo-debug-update | openSUSE-12.1-Update-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/update/12.1/ |
11 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/non-oss/ |
12 | repo-oss | openSUSE-12.1-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/oss/ |
13 | repo-source | openSUSE-12.1-Source | Nee | Ja | 99 | NONE | http://download.opensuse.org/source/distribution/12.1/repo/oss/ |
fred@linux-lw2i:~>



Ik had in eerste instantie de afbeelding direct gelinkt maar dan was het scherm helemaal gevuld met de afbeelding. Ik heb besloten om de link te plaatsen naar de plaats waar de afbeeldingen staan.

Knurpht
29-Jan-2012, 08:01
Kijk, plaatjes, daar kunnen we wat mee

Wat je ziet is wat we vroeger, voordat KDE en GNOME er waren te zien kregen, nl. het X login scherm (ik wordt er gewoon helemaal nostalgisch van:D ). Wat je zou moeten zien is het, grafisch veel mooiere, KDM login scherm. Foutmeldingen zijn het niet, wat je ziet is een melding van de firewall (je ziet 't IP adres staan en dat je bedraad verbinding maakt (eth0). Nu is het dus zaak om uit te zoeken wat er mis is. We gaan eerst kijken of KDM überhaupt wil starten, dit is nodig om KDE op te starten. Je logt in op het grijze schermpje en krijgt dan de xconsole. Doe daar eens


su -c 'rckdm restart'


Laat maar weten of je daarmee het KDM/KDE login scherm krijgt dat je gewend was.

satshow
29-Jan-2012, 09:02
Als ik opstart en daarna onder in mijn bureaublad de xconsole aanklik kan ik daar niks in typen. Hij piept alleen maar als ik in dat venster wil typen waar die foutmeldingen staan.
Of zit ik ergens helemaal verkeerd te kijken?

Overigens als ik mijn naam en paswoord invul dan loopt alles door zoals het eerder was. Het enigste wat er bij is gekomen is dat scherm met die foutmelding en de plaats waar ik moet inloggen.

Knurpht
29-Jan-2012, 09:11
Wil dat zeggen, dat je dan "gewoon" in KDE komt ?

Wat er gebeurt, in de hoop dat je 't snapt: Eerst start linux op, d.w.z. het systeem. Als dat klaar is, start X op, de displayserver die het mogelijk maakt om een grafische desktop te startenm bijv. KDE. Nou hoort er bij KDE een eigen loginscherm (KDM) i.p.v. het lullige grijze schermpje van de X-server zelf (XDM). Als dat het enige is wat er mist, kan 't maar aan 2 dingen liggen: óf KDM is niet (goed) geïnstalleerd/geupdate, óf op één of andere manier is XDM de standaard geworden. Maar daarvoor moeten we wel weten of je inderdaad in KDE komt als je inlogt.

Knurpht
29-Jan-2012, 09:15
Toevoeging: post maar de output van


grep DISPLAYMANAGER /etc/sysconfig/displaymanager

satshow
29-Jan-2012, 09:26
Ja als ik mijn naam en paswoord invul log ik gewoon in op KDE in opensuse. Die melding van die xconcole is na dat ik in KDE ingelogd ben.
Ik kan ook gewoon alles doen voor de rest.

Knurpht
29-Jan-2012, 11:56
Het commando uit mijn vorige post moet als resultaat geven:


DISPLAYMANAGER_KDM_LOCALARGS=""
DISPLAYMANAGER_KDM_THEME="SUSE"
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
DISPLAYMANAGER_ROOT_LOGIN_LOCAL="yes"
DISPLAYMANAGER="kdm"
DISPLAYMANAGER_REMOTE_ACCESS="no"
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"
DISPLAYMANAGER_STARTS_XSERVER="yes"
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"
DISPLAYMANAGER_AUTOLOGIN=""
# DISPLAYMANAGER_AUTOLOGIN is empty.
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
DISPLAYMANAGER_AD_INTEGRATION="no"
DISPLAYMANAGER_SHUTDOWN="auto"
DISPLAYMANAGER_XSERVER=Xorg

check the (hier) vetgemaakte regel. Daar moet kdm staan.

Als dat niet het geval is, dan moet je dat veranderen. Dat doe je door


kdesu krwite /etc/sysconfig/displaymanager

Je zoekt dan de regel op die hier boven vetgemaakt is, verandert die zodanig dat 't er staat zoals hierboven, herstart de computer en dan moet je je vertrouwde loginscherm zien.
Om weer automatisch in te loggen, zet je in de roodgemaakte regel tussen de aanhalingstekens jouw gebruikersnaam. Je kunt dat gelijk met het eerste stuk doen.

Mocht e.e.a. er al goed uitzien, dan bljft er maar één mogelijkheid over: er is iets niet goed gegaan met de update naar KDE 4.8, ik vermoed dat je bij de oplossingen gekozen hebt om kdm te verwijderen :D. Doe dan het volgende:


su -c 'zypper ref'
su -c 'zypper up'
su -c 'zypper in kdm'

daarna zou e.e.a. weer als vanouds (maar dan met de nieuwste versies) moeten werken.

satshow
29-Jan-2012, 12:24
Oeps ik had je reactie niet gezien van die output. Hieronder de output daarvan


fred@linux-lw2i:~> grep DISPLAYMANAGER /etc/sysconfig/displaymanager
DISPLAYMANAGER="kdm"
DISPLAYMANAGER_REMOTE_ACCESS="no"
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"
DISPLAYMANAGER_STARTS_XSERVER="yes"
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"
DISPLAYMANAGER_AUTOLOGIN="fred"
# DISPLAYMANAGER_AUTOLOGIN is empty.
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
DISPLAYMANAGER_AD_INTEGRATION="no"
DISPLAYMANAGER_SHUTDOWN="auto"
DISPLAYMANAGER_XSERVER=Xorg
DISPLAYMANAGER_KDM_LOCALARGS=""
DISPLAYMANAGER_KDM_THEME="SUSE"
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
DISPLAYMANAGER_ROOT_LOGIN_LOCAL="yes"

Alles stond goed dus zal blijkbaar kdm gewist hebben.
Krijg bij laatste commando een foutmelding in de terminal


fred@linux-lw2i:~> su -c 'zypper in kdm'
Wachtwoord:
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...
Afhankelijkheden tussen pakketten oplossen...

Het volgende NIEUWE pakket zal worden geïnstalleerd:
kdm

1 nieuw te installeren pakket.
Totale downloadgrootte: 1,2 MiB Na de operatie zal aanvullend 2,5 MiB worden gebruikt.
Doorgaan? [j/n/?] (j): j
pakket kdm-4.8.0-2.1.i586 wordt opgehaald (1/1), 1,2 MiB (2,5 MiB uitgepakt)
Ophalen: kdm-4.8.0-2.1.i586.rpm [klaar]
Installeert kdm-4.8.0-2.1 [klaar]
Aanvullende rpm-uitvoer:
Warning: Do not know how to create missing GreeterUID user kdm
Information: reading pre-existing kdmrc /usr/share/kde4/config/kdm/kdmrc (config version 2.4)

Knurpht
29-Jan-2012, 12:44
Even voor de goede orde: een "Warning" is geen foutmelding. Een foutmelding moet minimaal het woord "Error" bevatten. Er wordt alleen gewaarschuwd dat het installatiescript (zit in het pakket) iets niet kan aanmaken. En dat klopt ook wel, omdat wat-ie wil aanmaken al bestaat. Een herstart van de computer zou je mijns inziens nu de "normale" situatie moeten geven. Je had inderdaad een verkeerde keuze gemaakt en zodoende kdm gedeïnstalleerd :D. Het mooie van linux is, dat er voor de echte systeemdingen vaak een soort "terugvaloplossing" is, in dit geval xdm.

satshow
29-Jan-2012, 12:53
Ik had inderdaad de verkeerde keuze gemaakt. Heb zojuist opnieuw opgestart en alles ging zoals het hoorde.
Bedankt voor je hulp om de zaak weer in orde te krijgen.

Gebruik ondertussen opensuse alweer een aantal maanden en ben er nog steeds tevreden over, nog steeds de beste die ik ooit gebruikt heb.

Knurpht
29-Jan-2012, 16:03
Ik had inderdaad de verkeerde keuze gemaakt. Heb zojuist opnieuw opgestart en alles ging zoals het hoorde.
Bedankt voor je hulp om de zaak weer in orde te krijgen.

Gebruik ondertussen opensuse alweer een aantal maanden en ben er nog steeds tevreden over, nog steeds de beste die ik ooit gebruikt heb.

Ikzelf vanaf de vorige eeuw :D. Allerlei distro's ernaast geprobeerd, maar openSUSE/SuSE is altijd gebleven.

akaper
16-Feb-2012, 13:05
Zonder de bovengenoemde problemen of meldingen 4.8 geinstalleerd. Had wel een ander probleempje: de venstertitel en -pictogrammen waren te groot en pastten niet in de titelbalk. Dat zag eruit alsof de titelbalk niet meer op mijn scherm pastte en rechts van het scherm verdween.
Oplossing: open de systeeminstellingen - Desktopeffecten - tabblad geavanceerd - " Type compositing" . Kies hier xrender ipv opengl.
Heb nu helaas geen kubus meer, maar wel weer het expo-effect (die het niet deed onder 4.7). Ach ja, lekker belangrijk: wat mij opvalt met mijn ouwe pc-bakkie, het draait allemaal sneller en vloeiender. Nu nog verdiepen in de nieuwe mogelijkheden.

Knurpht
16-Feb-2012, 13:26
Ha André/ Da's nie echt een oplossing, toch? Die zou volledige functionaliteit moeten waarborgen, xrender is een soort fall-back voor als openGL het niet doet.
Vraagje: gebruik je de default window decorations, of wat anders? En heb je ook gekeken bij "Fonts/Lettertypen"? En, en, en, bestaat het fenomeen ook voor een versch aangemaakte gebruiker? Als dat laatste niet zo is, zou ik eens beginnen met de plasma-files weg te zetten, ook zou ik eens switchen naar een andere window decoration en dan meteen weer terug. Check ook in Softwarebeheer of je ook "rode pakketten" ziet

akaper
17-Feb-2012, 13:37
Ha André/ Da's nie echt een oplossing, toch? Die zou volledige functionaliteit moeten waarborgen, xrender is een soort fall-back voor als openGL het niet doet.
Vraagje: gebruik je de default window decorations, of wat anders? En heb je ook gekeken bij "Fonts/Lettertypen"? En, en, en, bestaat het fenomeen ook voor een versch aangemaakte gebruiker? Als dat laatste niet zo is, zou ik eens beginnen met de plasma-files weg te zetten, ook zou ik eens switchen naar een andere window decoration en dan meteen weer terug. Check ook in Softwarebeheer of je ook "rode pakketten" ziet
Jeminee, dat zijn veel vragen;). Het meeste had ik al geprobeerd:
1 Ik gebruik inderdaad andere windo deco's dan default;
2 Zeker heb ik gekeken bij Fonts/Lettertypen. Ik heb een ander lettertype geprobeerd en ook andere groottes voor de titelbalk, maar dat hielp niet;
3 Het fenomeen bestaat voor de andere gebruikers ook, en zelfs voor een nieuwe gebruiker die ik speciaal voor dit geval heb aangemaakt;
4 De plasmafiles (kwinrc e.d.) heb ik weggezet (verplaatst), daarna afgemeld en weer aangemeld en dat hielp niet;
5 Het switchen van window deco's is een sport die ik vaak bedrijf, maar dat hielp niet;
6 Ik zie eigenlijk altijd rode paketten in softwarebeheer. Tot nu toe heb ik daar nooit veel van gemaakt.

Toen ik in softwarebeheer de systeempaketten weer wilde omschakelen naar die van packman, merkte ik dat er heel veel (maar niet alle) KDE 4.7 bestanden werden voorgesteld. Omdat ik mijn gebruikssysteem perse met systeempaketten van packman wil hebben draaien, heb ik daarom KDE 4.8 weer verwijderd.
Maar op mijn testsysteem staat nog wel KDE 4.8, ook met hetzelfde probleem. Dus als je een gouden idee hebt, houd ik me aanbevolen.

Knurpht
19-Feb-2012, 04:16
Als je plasmafiles verwijdert, moet je uitgelogd zijn :). Anders zet KDE bij het afsluiten ze keurig weer neer. Maar, gezien het feit dat 't voor een nieuwe gebruiker ook bestaat, hoeven we 't daarin niet te zoeken.
Videokaart + driver? Het lijkt er namelijk op dat openGL niet goed loopt, en da's vaak een driver kwestie.

Wat geeft


glxinfo | grep direct

akaper
19-Feb-2012, 08:18
Et voila:

tester@6d48226d:~> glxinfo | grep direct
direct rendering: Yes
Met nVidia Gforce FX 5200 en nvidia drivers. Het idiote is dat het probleem er niet meer is: titelbalken zijn nu ik het systeem met KDE 4.8 voor de derde keer opstart, weer gewoon. Terwijl ik de desktop effects weer laat renderen door opengl. Huh?? Nou ja, zolang het zo blijft, blijft het zo.

Knurpht
19-Feb-2012, 14:40
Et voila:
Met nVidia Gforce FX 5200 en nvidia drivers. Het idiote is dat het probleem er niet meer is: titelbalken zijn nu ik het systeem met KDE 4.8 voor de derde keer opstart, weer gewoon. Terwijl ik de desktop effects weer laat renderen door opengl. Huh?? Nou ja, zolang het zo blijft, blijft het zo.

How vivid is the letting go of knowledge..........:D:D

Ennuh, vraag niet hoe 't kan, geniet ervan.

satshow
07-Apr-2012, 01:06
Wordt KDE 4.8 vanzelf geupdate als je dit hebt toegevoegd wat in het begin van deze topic is uitgelegd?

Knurpht
07-Apr-2012, 03:25
Geen tijd om de hele thread te herlezen. Als je de KDE:Release48 repo hebt toegevoegd, en daar een "Switch system packages ...." op gedaan hebt, horen de updates vanzelf binnen te komen. Ik draai Tumbleweed, maar bij jou zouden 4.8.2 pakkketten moeten binnenkomen zodra ze in de repo staan.

satshow
07-Apr-2012, 04:26
Er komen regelmatig updates binnen. Zie alleen nog in dolphin als ik kijk bij KDE nog 4.8.0 staan release 462 vandaar mijn vraag hierover.
Volgens mij heb ik bovenstaande aangezet.

Knurpht
07-Apr-2012, 11:37
Wat je in ieder geval kunt doen, is in Softwarebeheer de repo selecteren, en dan nog een "Schakel systeempakketten ...." daarop loslaten, maar, post voor alle zekerheid eerst nog eens de output van


zypper lr -d

tussen CODE tags alsjeblieft.

satshow
07-Apr-2012, 13:43
Hierbij de gevraagde output


fred@linux-lw2i:~> zypper lr -d
# | Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service
---+------------------------------------+------------------------------------+--------------+------------+------------+----------+-------------------------------------------------------------------------------------+--------
1 | KDE48 | KDE48 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/ |
2 | KDE:Extra | KDE:Extra | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.1/ |
3 | Opera | Opera | Ja | Ja | 99 | plaindir | dir:///home/fred/Prive/Opera |
4 | Packman Repository | Packman Repository | Ja | Ja | 99 | rpm-md | http://packman.inode.at/suse/12.1/ |
5 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/12.1/ |
6 | download.nvidia.com-opensuse | nVidia Graphics Drivers | Ja | Ja | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.1/ |
7 | libdvdcss repository | libdvdcss repository | Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/12.1/ |
8 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Ja | Nee | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorpCD_DVDW_SH-S182D,/dev/sr0,/dev/sr1 |
9 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1/ |
10 | repo-debug | openSUSE-12.1-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/distribution/12.1/repo/oss/ |
11 | repo-debug-update | openSUSE-12.1-Update-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/update/12.1/ |
12 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/non-oss/ |
13 | repo-oss | openSUSE-12.1-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/oss/ |
14 | repo-source | openSUSE-12.1-Source | Nee | Ja | 99 | NONE | http://download.opensuse.org/source/distribution/12.1/repo/oss/ |
fred@linux-lw2i:~>

Knurpht
08-Apr-2012, 12:15
Ik zou de nrs 2, 7, 8, 10, 11, 14 verwijderen. En wel hierom:
2 - Is de "Extra" repo bij de KDE release die met 12.1 is meegekomen. Je zou de URL kunnen vervangen door Index of /repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1 (http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/)
7 - Niet nodig om te houden, als libdvdcss is geïnstalleerd
8 - Je hebt waarschijnlijk toch niet de hele tijd de DVD in het laatje liggen, en de pakketten zijn ook wel in de repos.
10, 11, 14 zjin alleen interessant als je ontwikkelaar bent.

Opera komt in principe ook wel via de repos (ik "volg" Opera al sinds 3.0, gebruik 't ook nog steeds heel veel, en installeer altijd de laatste stabiele versie van een gedownloade rpm, net als jij), maar soms duurt het even.

De repo nummer 2 zou in de weg kunnen zitten. Wat ik zou doen, is alle repos verversen


sudo zypper ref

vervolgens zorgen dat alle KDE pakketten uit de KDE48 repo komen:


zypper dup --from KDE48


Mocht je hierbij meldingen krijgen over afhankelijkheden die niet opgelost kunnen worden, post de meldingen dan hier.

satshow
09-Apr-2012, 04:45
Zo te zien is alles opgewaardeerd naar KDE 4.8.2
Heb ook alles verwijderd zoals je voorstelde.

Nu ik dit heb aangepast wordt KDE 4.8 nu weer vanzelf geupdate of moet ik je laatste code gebruiken?

Knurpht
09-Apr-2012, 05:51
Zolang we nog niet op KDE49 zitten, komen de updates in de KDE48 repo, en zou Yast - Software - Softwarebeheer - Pakket - Alle pakketten - opwaarderen als er een nieuwere versie is de updates moeten uitvoeren. Net als "zypper ref & zypper up". Het kan voorkomen, dat er pakketten worden toegevoegd aan een repo, die er eerst niet waren, als die pakketten bijv. door versienummeringfoutjes niet vanzelf "gepakt" worden, kun je de omschakeling nog 's doen.
Een ander iets: mocht je nu problemen krijgen met bepaalde mediaformaten in bijv. Amarok, voer dan de "omschakeling" nog eens uit op de Packman repo.

Jouw KDE-, kernel- en videodriver versie kun je in KDE heel makkelijk checken. Open Konqueror, en typ in de adresbalk "sysinfo:/".

satshow
10-Apr-2012, 10:18
Ik krijg zojuist een update melding via apper. Als ik wil updaten lukt dat niet en krijg ik bij details het volgende te zien:

openSUSE-release-12.1-1.4.i586 requires openSUSE-release = 12.1-1.4, but this requirement cannot be provided

Knurpht
10-Apr-2012, 14:17
Henk (hcvv) heeft er hier al eerder op gewezen: Apper is niet helemaal je van het. Bij mij kwamen steeds een stel patches naar voren, die conflicteerden. Mijn advies: deinstalleer Apper, en update je systeem via Yast's Softwarebeheer.

satshow
11-Apr-2012, 09:47
Ik heb Apper verwijderd. Hoe kan ik het beste de software updaten in softwarebeheer?
Moet ik bepaalde zaken aanvinken?

Knurpht
11-Apr-2012, 13:44
Ik heb Apper verwijderd. Hoe kan ik het beste de software updaten in softwarebeheer?
Moet ik bepaalde zaken aanvinken?

Nope. Als volgt:
- Yast - Software - Softwarebeheer
- Pakketten - Alle pakketten - opwaarderen als er een nieuwere versie is
Op een paar OK's en Accepterens na is dat 't. Of een terminal venster openen en dan


su -c 'zypper ref''
su -c 'zypper up'

waarbij het eerste commando de inhoud van de repos ververst (zie je ook als je softwarebeheer opstart) , en het tweede de actie uitvoert waarbij je alle pakketten opwaaardeert als er een nieuwere versie is.