PDA

View Full Version : WLAN lässt sich nicht verbinden



lutz09
30-Mar-2011, 00:39
Hallo allerseits,

ich habe Probleme eine WLAN-verbindung zwischen meinem Laptop (MSI EX720) und meinem WLAN zu erstellen.
Ich habe im NetworkManager-Applet SSID und BSSID sowie passwort und Verschlüsselungsart richtig eingetragen. Grundsätzlich wird mein WLAN auch angezeigt. Nur wenn ich dann tatsächlich die Verbindung herstellen will, öffnet sich ein Fenster in dem nochmals die Zugangsdaten abgefragt werden.
Trotz verschiedener Einstellungsänderungen (Offenes System statt Gemeinsamer Schlüssel) kam keine Verbindung zustande.

Hat jemand eine Idee, was ich falsch mache?:confused:
Danke für die Hilfe!

pistazienfresser
30-Mar-2011, 03:26
Hallo allerseits,

ich habe Probleme eine WLAN-verbindung zwischen meinem Laptop (MSI EX720) und meinem WLAN zu erstellen.
Ich habe im NetworkManager-Applet SSID und BSSID sowie passwort und Verschlüsselungsart richtig eingetragen. Grundsätzlich wird mein WLAN auch angezeigt. Nur wenn ich dann tatsächlich die Verbindung herstellen will, öffnet sich ein Fenster in dem nochmals die Zugangsdaten abgefragt werden.
Trotz verschiedener Einstellungsänderungen (Offenes System statt Gemeinsamer Schlüssel) kam keine Verbindung zustande.

Hat jemand eine Idee, was ich falsch mache?:confused:
Danke für die Hilfe!
Hallo lutz09,

aus der Bezeichnung "NetworkManager-Applet" würde ich schließen, dass Du GNOME benutzt. Welche Version von openSUSE (11.4, 11.3, ...)?

Folgende Möglichkeiten gehen mir so durch den Kopf:

1.
Probleme mit Abschreiben des Schlüssels?
-> Laptop per LAN Kabel an den Router anschließen, Router Einstellungen öffnen, Passwort sichtbar machen und mit Maus Kopieren (oder neues ausdenken, irgendwo temporär aufschreiben, kopieren, eintragen, vergeben, speichern), in nm-applet eintragen, WLAN verbinden?

2.
Wird als 'Verschlüsselung' WEP benutzt und irgendwie wird vielleicht die hexadezimale Schreibweise des Schlüssels gefordert?
-> WEP nicht benutzen, ist inzwischen wohl schon von Dummies wie mir mit der richtigen Software in 5 Minuten zu knacken (Anleitungen soll es schon auf YouTube geben...)
-> WPA2 mit AES benutzen, zumindest habe ich damit noch nicht von derartigen Problemen gelesen

3.
Wenn Du 'Kaputtkonfigurieren' einigermaßen ausschließen willst, magst Du es auch noch von einem Live System wie einer openSUSE 11.4 GNOME live CD aus versuchen.

4.
Probleme mit dem GNOME Passwortmanager/GNOME Keyring/Seahorse halte ich für nicht so wahrscheinlich, könnte sie aber auch nicht ausschließen.

Viel Erfolg und dann eine Menge Spaß
Martin
(pistazienfresser)

lutz09
30-Mar-2011, 03:44
Hallo pistazienfresser,

sorry, dass ich das nicht gleich mit angegeben habe. Ich nutze OpenSuse 11.4 (Kernel 2.6.37.1, 64bit) mit KDE 4.6.1
Das "Miniprogramm", das ich verwende liegt in der Kontrollleiste und heißt offiziell wohl "Netzwerkverwaltung".

Das Passwort ist korrekt eingegeben und es ist auch - soweit ich das beurteilen kann - kein technisches Problem. Die WLAN-Karte wird von Suse korrekt erkannt (Atheros AR928X).
Bisher (unter Sidux und PClinuxOS) war der WLAN-Betrieb ohne Probleme out-of-the-box möglich.

pistazienfresser
30-Mar-2011, 05:17
Hallo pistazienfresser,

sorry, dass ich das nicht gleich mit angegeben habe. Ich nutze OpenSuse 11.4 (Kernel 2.6.37.1, 64bit) mit KDE 4.6.1
Das "Miniprogramm", das ich verwende liegt in der Kontrollleiste und heißt offiziell wohl "Netzwerkverwaltung".

Das Passwort ist korrekt eingegeben und es ist auch - soweit ich das beurteilen kann - kein technisches Problem. Die WLAN-Karte wird von Suse korrekt erkannt (Atheros AR928X).
Bisher (unter Sidux und PClinuxOS) war der WLAN-Betrieb ohne Probleme out-of-the-box möglich.
Hallo Lutz09,
(übrigens mag es sinnvoll sein, als Fragender keinen extra anzusprechen - schließlich wirst Du wohl auch nicht böse sein, wenn Dir ein anderer in diesem Form helfen würde..),

Habe für Dich mal openSUSE 11.4 mit KDE (4.6.00 (4.6.0) "release 6") angeworfen.

1. und 2. kann ich nach Deinen bisherigen Ausführungen nicht ausschließen - insbesondere weil ich nicht weiß, ob und welche anderen Programme wann Probleme mit WEP oder/und mit der Schreibweise von Passwörtern/Passphrases in normalem Text oder in 16er-System-Zahlen haben.

4.2
Der entspechende Passwordmanager dürfte unter KDE etwas anders heißen, nämlich "kdewallet", als ich KDE mit meinen (vielleicht etwas paranoiden?) Sicherheitseinstellungen angeworfen habe kam:

Das Programm "KNetworkManager" hat die Öffnung der digitalen Brieftasche "kdewallet" angefordert. Bitte geben sie unten das Passwort dafür ein.

5.
Die Ursache mag in dem KDE-Miniprogramm/Frontent/Applet/Graphischeszwergenhilfsprogram/Leistenplasmoid/... liegen.

5.1
Das Ding heißt wohl KNetworkManager ist im Paket NetworkManager-kde4 enthalten:


zypper search -s -i -d knetworkmanager
[...]
S | Name | Type | Version | Arch | Repository
--+--------------------------------+---------+--------------------+--------+-------------------
i | NetworkManager-kde4 | package | 0.9.svn1192577-7.2 | i586 | openSUSE-11.4-Oss

5.2
Wenn du auf das Tag/Stichwort knetworkmanager (http://forums.opensuse.org/tags/knetworkmanager.html) klickst, wirst du sehen, das das arme kleine Programm derzeit für allerlei Probleme verantwortlich gemacht wird.
5.3
Zur Fehlereingrenzung würde ich wieder/noch immer das Gleiche wie unter 3. vorschlagen - mit einer GNOME live CD versuchen. Statt dessen könnte man wohl auch noch das Kommandozeilen-Frontend für das Programm networkmanager, den cnetworkmanager versuchen, aber ehrlich gesagt habe ich bislang für mich selbst keinen Grund gesehen, WLAN per Kommandozeile zu versuchen (vielleicht bin ich einfach etwas faul und Graphik-fixiert?;) ).

5.4
Sollte sich ein 'hinreichender Tatverdacht' in Bezug auf den KNetworkmanager ergeben, so kämen als Alternativen (insbesondere) in Frage:

- das andere KDE 4 miniprogramm (Paket: plasmoid-networkmanagement)
- das Networkmanager-Applet/nm-applet aus der GNOME Welt (Paket: NetworkManager-gnome)


6.
Möchtest Du noch die Hardware und die (nicht-)passenden Treiber als Verdächtige ausschließen?

Ich bin etwas skeptisch was die Benennung der Hersteller so angeht - die numeric ID (etwa in der Form wie 168c:002a)
wäre zuverlässiger.

Möchtest Du Rate-Hilfe (von mir oder klügeren Leuten) bekommen, so wäre es schön, wenn Du folgendes in Dein Programm konsole (oder den Terminal Emulator Deiner Wahl) geben würdest und dann das Ergebnis hier zwischen
und posten würdest:

6.1

/sbin/lspci -vnn
bzw. der Teil der Ausgabe, der sich auf Deine PCI/PCIe/...-WLAN Karte bezieht, klappen müsste auch:
/sbin/lspci -vnn | grep 168c

ODER ausführlicher:
6.2

/usr/sbin/hwinfo --wlan

Viel Erfolg noch
Martin
(pistazienfresser)

P.S.:

An alle:
Ich mag auch erst morgen hier wieder vorbeischauen - wer sonst weiterhelfen mag, mag das tun...

lutz09
30-Mar-2011, 07:25
Also mit dem Passwort bin ich mir sicher. da liegt der Fehler nicht. Ich habe die vorhandenen Möglichkeiten ausprobiert und bin nicht weitergekommen.



Möchtest Du Rate-Hilfe (von mir oder klügeren Leuten) bekommen, so wäre es schön, wenn Du folgendes in Dein Programm konsole (oder den Terminal Emulator Deiner Wahl) geben würdest und dann das Ergebnis hier zwischen
und posten würdest:

6.1

/sbin/lspci -vnn
bzw. der Teil der Ausgabe, der sich auf Deine PCI/PCIe/...-WLAN Karte bezieht, klappen müsste auch:
/sbin/lspci -vnn | grep 168c

ODER ausführlicher:
6.2

/usr/sbin/hwinfo --wlan


Also die Ausgabe von "/sbin/lspci -vnn" (zumindest der Teil, der sich auf ds WLAN bezieht):


05:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
Subsystem: AzureWave Device [1a3b:1067]
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at f9ff0000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k


Und hier noch "/usr/sbin/hwinfo --wlan":


22: PCI 500.0: 0282 WLAN controller
[Created at pci.318]
Unique ID: y9sn.XPdIv0PRSzE
Parent ID: hoOk.K7VPXKuR077
SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:05:00.0
SysFS BusID: 0000:05:00.0
Hardware Class: network
Model: "Atheros AR928X Wireless Network Adapter (PCI-Express)"
Vendor: pci 0x168c "Atheros Communications Inc."
Device: pci 0x002a "AR928X Wireless Network Adapter (PCI-Express)"
SubVendor: pci 0x1a3b
SubDevice: pci 0x1067
Revision: 0x01
Driver: "ath9k"
Driver Modules: "ath9k"
Device File: wlan0
Features: WLAN
Memory Range: 0xf9ff0000-0xf9ffffff (rw,non-prefetchable)
IRQ: 18 (no events)
HW Address: 00:24:23:01:88:cb
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v0000168Cd0000002Asv00001A3Bsd00001067bc02sc80i00"
Driver Info #0:
Driver Status: ath9k is active
Driver Activation Cmd: "modprobe ath9k"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

lutz09
30-Mar-2011, 09:01
Ich habe mal nachgeschaut, welche Meldungen mein Rechner während des Strats von sich gibt. Zum WLAN sagt er folgendes:



wlan0 starting wpa_supplicant
wlan0 starting DHCP4 clinet...
wlan0 IP address 192.168.2.26/24
wlan0 done
Setting up service (remotefs) network ......... done
30 MAR 17:49:18 sntp [3718]: started sntp


Verstehe ich das falsch oder hat er mir damit gesagt, dass er das WLAN eigentlich gestartet haben sollte? :confused:

pistazienfresser
30-Mar-2011, 09:50
Hallo lutz09,

0.
0.1
Networkmanager/Verwaltung im Benutzerraum aktiv?

Nur nochmal zur Klarstellung:

Kickoff Menue > Rechner > YaST/YaST Kontrollzentrum > Netzwerkgeräte > Netzwerkeinstellungen
steht auf

"Globale Optionen" > Methode für den Netzwerkaufbau:
[x] Benutzergesteuert mit Hilfe von Networkmanager

0.2
Jegliche Hardware- und Softwareschalter sind auch auf ein/nicht blockiert?

Was ergibt denn


/usr/sbin/rfkill list

Solltest Du das Komandozeilen Programm rfkill nicht installiert haben,
müsste das vorher installieren, zum Beispiel mit

sudo zypper install rfkill

zu 1./2./3.

Von einer openSUSE 11.4 GNOME Live CD (http://software.opensuse.org/114/de) aus funktioniert es auch nicht???
Dann bin ich jetzt ziemlich baf f:O - ich hätte doch sehr darauf getippt, das das Problem (wenn schon nicht bei der einer veralteteten Verschlüsselung oder bei dem Passwort - Asci oder hexadecimal) bei dem KDE Programm KNetworkmanager liegen würde.

Wie bereits beschrieben, würde ich mich an Deiner Stelle nicht aufs Tippen verlassen - von einer anderen lokalen/nationalen Tastatureinstellung, über immer wieder den selben Ablesefehler bis zum Aktivieren der Hochgestellt-, NUM- oder FN-Tasten kann da immer wieder der gleiche Fehler passieren.

Solltest Du - aus welchen Gründen auch immer - keine Zugriff auf den Router/Access Point/die Einstellungen haben, so kannst Du noch versuchen, auf Deinen anderen Linux basierten Systemen Dich mit dem WLAN zu verbinden und als Root/mit Root-Previlegien die Konfiguration inklusive dem hexadezimalen Schlüssel (sähe z. B. so aus: 821F-91AB-E264-9813-6788-7AA3-2E6A-93BF ) abzurufen und dann irgendwo zu speichern.


sudo /usr/sbin/iwconfig
ODER

su -
iwconfig

Achtung: Den Schlüssel nicht hier oder irgendwo öffentlich zugänglich machen/posten/veröffentlichen. - der Rest (insbesondere der Teil zur Art der Verschlüsselung wie "") könnte noch interessant sein.


Hast Du mal versucht, von Deinem Laptop aus auf ein anderes Netz zuzugreifen?
Bekommst Du denn eine Verbindung, wenn Du (das Risiko eingehst/eingehen kannst) und kurzfristig die Verschlüsselung ganz deaktivierst?

Eine Live-CD der bereits 8 Monate lang laufenden openSUSE 11.3 Version (http://software.opensuse.org/113/de), die wohl ebenso wie die von Dir erwähnten Systeme einen älteren Linux Kernel hätte, käme mir noch zur Fehlersuche in den Sinn.


Zu 6. Hardware/Treiber

Also wie ich das verstehe, müsste Dein Chip direkt vom Kernel unterstützt werden und keine besondere Treiber/Kernelmodul-Software brauchen:
Linux Kernel Driver Database: CONFIG_ATH9K: Atheros 802.11n wireless cards support (http://cateee.net/lkddb/web-lkddb/ATH9K.html)


[...]
found in Linux Kernels: from 2.6.27 release still available on 2.6.38 release
module created: ath9k, ath9k

Help text

This module adds support for wireless adapters based on Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.

If you choose to build a module, it'll be called ath9k.
Hardware
PCI

Numeric ID (from LKDDb) and names (from pci.ids) of recognized devices:
[...]
vendor: 168c ("Atheros Communications Inc."), device: 002a ("AR928X Wireless Network Adapter (PCI-Express)")


7.
Ich könnte mir noch vorstellen, das irgendwelche firmware fehlt/nicht funktioniert.
Was ergibt denn:

dmesg | grep Firmware
oder

dmesg | grep firmware
oder
(dann bitte unter SUSE Paste (http://paste.opensuse.org/) )

Eine weitere Möglichkeit wären dann die neusten/exotischen Pakete aus
Index of /repositories/driver:/wireless/openSUSE_11.4 (http://download.opensuse.org/repositories/driver:/wireless/openSUSE_11.4/) .

8.
Dein System 'sieht' auch die Acesspoints/Router/WLAN-Netze?

vgl.

sudo /usr/sbin/iwlist scan
da müsstest Du unter anderem auch die Art der benötigten Verschlüsselung erkennen können.

Beispielsweise:
für nur WPA2

IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK

oder für WPA und WPA2:

IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK


Viel Erfolg noch,
nun etwas puzzled pistazienfresser
(Martin)

Vgl. im Übrigen auch gerne in der Novell/openSUSE Dokumentation:

openSUSE 11.3 Start 21. September 2010 (http://download.opensuse.org/distribution/11.4/repo/oss/docu/startup_de.pdf)
> 5 Verwenden von NetworkManager (S. 63-79)

oder

auf Englisch
unter
/usr/share/doc/manual/opensuse-reference_en-pdf/opensuse-reference_en.pdf
auf Deinem Computer (falls installiert)
und unter doc.opensuse.org:

11.4 February 22, 2011 Reference
-> Chapter 34. Wireless LAN (page 553 and following)
entspricht Chapter 34. Wireless LAN (http://doc.opensuse.org/products/opensuse/openSUSE/opensuse-reference/cha.wireless.wlan.html)
-> Chapter 34. Using NetworkManager (page 571 and following)
entspricht Chapter 35. Using NetworkManager (http://doc.opensuse.org/products/opensuse/openSUSE/opensuse-reference/cha.nm.html)

pistazienfresser
30-Mar-2011, 09:53
Ich habe mal nachgeschaut, welche Meldungen mein Rechner während des Strats von sich gibt. Zum WLAN sagt er folgendes:



wlan0 starting wpa_supplicant
wlan0 starting DHCP4 clinet...
wlan0 IP address 192.168.2.26/24
wlan0 done
Setting up service (remotefs) network ......... done
30 MAR 17:49:18 sntp [3718]: started sntp


Verstehe ich das falsch oder hat er mir damit gesagt, dass er das WLAN eigentlich gestartet haben sollte? :confused:

Siehe 0.1 meines eben geschriebenen "Kurzromans":
-> Hast Du vielleicht noch die "traditionelle Methode mit ifup" aktiviert und Dein armer Netzworkmanager und seine graphischen Gesellen dürften gar nichts machen???

Grüße
Martin

buckesfeld
30-Mar-2011, 12:35
Ich kann es schlecht auf Deutsch beschreiben, weil meine Installation Englisch ist. Klick auf das Netzwerk-Manager-Ding, "Manage Connections"
links "Other", "Store Connection Secrets" auf "In file (unencrypted)".
Klappt es jetzt? Ich hatte das Problem, wenn ich die 5GHz-Verbindung meiner Fritzbox nutzen wollte.

Uwe

lutz09
31-Mar-2011, 08:30
Das mit dem unverschlüsselten Speichern auf der Platt ("unencryptet") hatte ich auch schon probiert, half aber nichts.

Ich habe es mit und ohne NetworkManager probiert.
ich hatte "Gerät aktiviern: bei Systemstart" eingestellt.
Nach meinem Verständnis sollte dann ja eine WLAN-Verbindung aufgebaut werden, wenn ich den Rechner neu boote. Aber das tat er bislang nicht.

Grundsätzlich würde es mir bei meiner Arbeitsweise auch reichen, wenn der Rechner beim Starten (und Abwesenheit einer Kabelverbindung) eine WLAN-verbindung aufbaut.

So und jetzt das Abarbeiten der übrigen Hinweise:

dmesg | grep firmware und dmesg | grep Firmware liefern keinerlei Ausgabe.



lutz@linux-su3c:~> /usr/sbin/rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


KeineSchalter blockiert.



lutz@linux-su3c:~> sudo /usr/sbin/iwconfig

wlan0 IEEE 802.11bgn ESSID:"BergerNet"
Mode:Managed Frequency:2.437 GHz Access Point: 00:15:0C:7E:6E:7C
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-28 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:33 Missed beacon:0


Hm, was mich jetzt etwas stutzig macht: er sagt da Ecryption key: off!
Ich behaupte mal, dass ich dem Konfigurationsprogramm meinen Schlüssel genannt habe.

Ach, und das hier habe ich auch noch gefunden:



lutz@linux-su3c:~> dmesg|grep wlan
[ 50.536345] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 52.007963] wlan0: direct probe to 00:15:0c:7e:6e:7c (try 1)
[ 52.010759] wlan0: direct probe responded
[ 52.012038] wlan0: authenticate with 00:15:0c:7e:6e:7c (try 1)
[ 52.025518] wlan0: authenticated
[ 52.104087] wlan0: associate with 00:15:0c:7e:6e:7c (try 1)
[ 52.106964] wlan0: RX AssocResp from 00:15:0c:7e:6e:7c (capab=0x411 status=0 aid=1)
[ 52.106968] wlan0: associated
[ 52.107662] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 62.210043] wlan0: no IPv6 routers present
[ 388.090564] wlan0: deauthenticating from 00:15:0c:7e:6e:7c by local choice (reason=3)
[ 388.849304] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 390.176348] wlan0: authenticate with 00:15:0c:7e:6e:7c (try 1)
[ 390.178275] wlan0: authenticated
[ 390.194365] wlan0: associate with 00:15:0c:7e:6e:7c (try 1)
[ 390.196889] wlan0: RX AssocResp from 00:15:0c:7e:6e:7c (capab=0x411 status=0 aid=1)
[ 390.196894] wlan0: associated
[ 390.197651] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 393.303988] martian source 255.255.255.255 from 192.168.2.1, on dev wlan0
[ 393.340046] martian source 255.255.255.255 from 192.168.2.1, on dev wlan0
[ 401.066041] wlan0: no IPv6 routers present
[ 453.485776] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 453.487696] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0

... viele grundsätzlich identische Zeilen ....

[ 1599.824047] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 1599.825977] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 1611.829230] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 1611.831879] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 1612.221242] wlan0: deauthenticating from 00:15:0c:7e:6e:7c by local choice (reason=3)
[ 1613.049415] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1614.389530] wlan0: authenticate with 00:15:0c:7e:6e:7c (try 1)
[ 1614.401210] wlan0: authenticated
[ 1614.401353] wlan0: associate with 00:15:0c:7e:6e:7c (try 1)
[ 1614.403900] wlan0: RX AssocResp from 00:15:0c:7e:6e:7c (capab=0x411 status=0 aid=1)
[ 1614.403904] wlan0: associated
[ 1614.404826] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1617.511822] martian source 255.255.255.255 from 192.168.2.1, on dev wlan0
[ 1617.549621] martian source 255.255.255.255 from 192.168.2.1, on dev wlan0
[ 1624.906067] wlan0: no IPv6 routers present
[ 1631.050996] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0
[ 1643.064074] martian source 192.168.2.255 from 192.168.2.25, on dev wlan0


Das mein Router kein IPv6 kann wusste ich. Das hat aber bei anderen Distributionen nicht gestört. Außerdem ist in der Konfiguration IPv4 eingestellt.

Könnt Ihr damit was anfangen?

Noch ein kleine Nachtrag:
Ich habe in YAST in den Globalen Optionen mal das Kreuzchen bei "IPv6 aktivieren" rausgenommen. Das hat aber leider auch nicht geholfen.

lutz09
01-Apr-2011, 03:22
Ich habe jetzt die Verschlüsselung auf WPA2 umgestellt. Hat auch nichts geändert.


"sudo /usr/sbin/iwlist scan" sagt:


Cell 04 - Address: 00:15:0C:7E:6E:7C
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-38 dBm
Encryption key:on
ESSID:"BergerNet"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000058023f7a
Extra: Last beacon: 40ms ago
IE: Unknown: 00094265726765724E6574
IE: Unknown: 010482848B96
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD0A0800280101000200FF0F
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00


und "sudo /usr/sbin/iwconfig":


wlan0 IEEE 802.11bgn ESSID:"BergerNet"
Mode:Managed Frequency:2.437 GHz Access Point: 00:15:0C:7E:6E:7C
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-25 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:29 Missed beacon:0

pistazienfresser
01-Apr-2011, 05:18
Hallo Lutz09,

ich glaube ich bin auch am Ende meines begrenzten Wissens angekommen.


Ich habe jetzt die Verschlüsselung auf WPA2 umgestellt. Hat auch nichts geändert.


"sudo /usr/sbin/iwlist scan" sagt:


Cell 04 - Address: [...]
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-38 dBm
Encryption key:on
ESSID:"BergerNet"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000058023f7a
Extra: Last beacon: 40ms ago
IE: Unknown: 00094265726765724E6574
IE: Unknown: 010482848B96
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD0A0800280101000200FF0F
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

Bei mir sieht das in etwa so aus:

Cell 01 - Address: [...]
ESSID:"MartinsNetz"
Protocol:IEEE 802.11g
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=93/100 Signal level=-34 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 12ms ago

weiter geht es in etwa mit:

Cell 02 - Address: [...]
ESSID:"irgendwerandershataucheinWLAN"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=48/100 Signal level=-72 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 108ms ago


IEEE 802.11i, WPA2 Version 1, WPA2, CCMP und AES würde ich miteinander assoziieren/verbinden.

Soweit ich das als bloßer RA (ungleich Informatiker oder Ingenieur) verstehe, nutzt Dein Router eine Art Kompatibilitätsmodus (WPA1/WPA2).

Und warum da so viele "IE"s auftauchen, wundert mich auch etwas.



und "sudo /usr/sbin/iwconfig":


wlan0 IEEE 802.11bgn ESSID:"BergerNet"
Mode:Managed Frequency:2.437 GHz Access Point:[...]
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-25 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:29 Missed beacon:0


Hast Du in dem knetworkmanager unten in der Leiste unter
- Verbindungen verwalten > Sonstiges > Verbindungspasswörter speichern: "In digitaler Brieftasche" ausgewählt ?
- Netzwerkverbindungen bearbeiten >
--[x] "Automatisch verbinden" ausgewählt ?
---Karteikarte/Tab: Drahtlos Sicherheit > WPA/WPA2 Personal
?

Mal versucht, den Eintag für Dein Netz zu löschen und neu zu erstellen?

Schwirren vielleicht noch irgendwo Einträge aus Versuchen, ifup zu nutzen, herum?

Wie sieht es mit dem vorgeschlagenen Testen der anderen Benutzeroberflächen und der anderen networkmanager-Hilfs-und-Steuerungsprogramme aus? Wurde für zu gefährlich/zu nervig/nicht erfolgsversprechend erachtet oder gab das Ergebnis: keine Veränderung? Magst Du mal einen neuen Benutzer/User einrichten, um die Fehlerursache Kaputt-Konfiguration zumindest etwas unwahrscheinlicher zu machen?

puzzled
pistazienfresser
(Martin)

buckesfeld
01-Apr-2011, 08:53
* lutz09 wrote, On 03/31/2011 05:36 PM:
> Das mit dem unverschlüsselten Speichern auf der Platt ("unencryptet")
> hatte ich auch schon probiert, half aber nichts

Dann ersetz mal den Networkmanager von KDE durch das "plasmoid-networkmanagement" (oder so ähnlich), das funktioniert in aller Regel besser.

Gruß
Uwe

lutz09
04-Apr-2011, 01:58
Auch den Wechsel der diversen "Networkmanager" (der normale, Plasmoid, "traditionelle Methode") habe ich schon durchgeführt.
Leider half das auch alles nichts.

Ich habe gerade auch noch einmal einen Test mit einer Suse 11.3 Live-CD durchgeführt. Auch diese konnte ich auf die Schnelle nicht dazu bewegen, das WLAN zu verbinden.

Eine Möglichkeit werde ich noch ausprobieren. ich werde das Netz mal komplett öffnen und es dann nochmal versuchen.

Ansonste bin ich für Vorschläge aller Art dankbar.

lutz09
06-Apr-2011, 01:08
Hallo allerseits,

ich habe das WLAN zum Laufen gebarcht!

Ich hatte meine Installation über das Internet durchgeführt und dabei die Verbindung per Ethernet (also kabelgestützt) hergestellt. Beide netzwerkkarten (Ethernet und WLAN) wurden korrekt erkannt und eingerichtet.

An anderer Stelle habe ich den Tipp bekommen, die Ethernet-Konfiguration in den Netzwerkeinstellungen zu löschen und die WLAN-Karte neu zu konfigurieren.

Nach einem Re-Boot (ohne Kabelanschluss) lief das WLAN dann ohne Probleme.

Danach habe ich die Ethernet-Konfiguration neu erstellt. Nach einem Weiteren Re-Boot lief auch diese wieder. Auch das WLAN funktioniert nach der Neukonfiguration des Ethernet problemlos.

Was nicht funktioniert ist der fliegende Wechsel zwischen Ethernet und WLAN. Dazu ist jeweils ein Re-Boot mit angestecktem abel oder aktivierter WLAN-Karte notwendig.

Damit kann ich erst einmal leben. Wenn ich bei gelegenheit Zeit und Lust habe, versuche ich auch das problem noch in den Griff zu bekommen,

danke nochmal an alle, die sich hier bemüht haben, mir zu helfen.

buckesfeld
06-Apr-2011, 03:32
Lutz,

klingt nach Gehampel ;-)
Vielleicht probierst Du nochmal "wicd" als Netzwerkmanager aus, das hab ich lange Zeit benutzt, als der Netzwerkmanager von openSUSE komplett unbrauchbar war. Wicd hat mit der KDE-Infrastruktur nicht viel zu tun, das macht es weniger anfällig für Änderungen/Bugs im Desktop Environment.

Gruß
Uwe

pistazienfresser
06-Apr-2011, 04:15
[....]
Vielleicht probierst Du nochmal "wicd" als Netzwerkmanager aus,[...]
Die Benutzung des Wireless Interface Connection Daemon (wicd) dürfte mit openSUSE 11.4 und der darin enthaltenen 'großen Schlange' (Python 2.7) meines (second-hand-)Wissens nach nicht ganz einfach sein, vgl. auf Englisch:
Wicd, Python 2.7, and OpenSUSE 11.4 (http://forums.opensuse.org/english/get-technical-help-here/wireless/456792-wicd-python-2-7-opensuse-11-4-a.html) (mit weiteren Nachweisen).
Möchte jemand Lutz durch das Compiling (die Programmübersetzung, das Kompilieren) der entsprechenden passenden Beta-Version (wohl: wicd-1.7.1b2 vom 20. November 2010) vom Wireless Interface Connection Daemon (wicd) lotsen?

Auch wenn ich mich her (teilweise?) wiederhole:
Ich denke, da könnte[1] das NetworkManager Applet 0.8.2 aus der GNOME Welt und dem Paket NetworkManager-gnome doch die einfachere Alternative sein.

Martin
(pistazienfresser)
[1]
Ceterum censeo:
...wenn das nm-Applet zumindest von einer aktuellen GNOME Live CD aus mit dieser Hardware von lutz09 getestet und für gut/funktionierend befunden würde...:|

buckesfeld
08-Apr-2011, 11:18
Ein paar Leute haben es aber offenbar hinbekommen :-)
http://software.opensuse.org/search?q=wicd&baseproject=openSUSE%3A11.4&lang=en&include_home=true&exclude_debug=true