PDA

View Full Version : Broadcom WLAN Chip funktioniert nicht



jsbe
16-Mar-2011, 08:27
Hallo alle zusammen.

ich benutze seit kurzem openSUSE 11.4 und bin eigentlich sehr zufrieden damit. Nur musste ich kürzlich feststellen, dass ich mich nicht mit WLAN Netzwerken verbinden kann. ich benutze ein HP Notebook. Woran das Liegt ist mir rätselhaft, denn openSUSE hat, wenn man nach dem Hardware-Informationen-Fenster geht, den Treiber für meinen Broadcom 4322 Wlan Chip installiert. Jedoch erkennt der KNetworkManager keinen WLAN CHip und die WLAN-Kontrollleuchte an meinem HP leucht auch Orange, was heißt, dass WLAN deaktiviert ist.
Ich habe nun recherchiert und gesehen, dass bei den Netzwerkeinstellungen nur mein LAN gerät installiert ist, nicht aber der WLAN Chip.

Hat jemand eine Idee wie ich das ganze zum laufen bringe? Ich bin auf mein WLAN angewiesen.

ich hänge noch zwei Bilder von HardwareInformationen und den Netzwerkeinstellungen an.

gruß

Bilder:
Hardware-Informationen (http://binux-project.de/images/NetzKarte.png)
Netzwerkeinstellungen (http://binux-project.de/images/NetzKarte2.png)

pistazienfresser
17-Mar-2011, 07:12
Hallo alle zusammen.

ich benutze seit kurzem openSUSE 11.4 und bin eigentlich sehr zufrieden damit. Nur musste ich kürzlich feststellen, dass ich mich nicht mit WLAN Netzwerken verbinden kann. ich benutze ein HP Notebook. Woran das Liegt ist mir rätselhaft, denn openSUSE hat, wenn man nach dem Hardware-Informationen-Fenster geht, den Treiber für meinen Broadcom 4322 Wlan Chip installiert. Jedoch erkennt der KNetworkManager keinen WLAN CHip und die WLAN-Kontrollleuchte an meinem HP leucht auch Orange, was heißt, dass WLAN deaktiviert ist.
Ich habe nun recherchiert und gesehen, dass bei den Netzwerkeinstellungen nur mein LAN gerät installiert ist, nicht aber der WLAN Chip.

Hat jemand eine Idee wie ich das ganze zum laufen bringe? Ich bin auf mein WLAN angewiesen.

ich hänge noch zwei Bilder von HardwareInformationen und den Netzwerkeinstellungen an.

gruß

Bilder:
Hardware-Informationen (http://binux-project.de/images/NetzKarte.png)
Netzwerkeinstellungen (http://binux-project.de/images/NetzKarte2.png)

Hallo jsbe,

willkommen hier im Forum.

1.
Offenbar nutzt Du KDE. Ich habe gerade GNOME laufen, aber auch unter KDE müsste unter YaST > Network Settings/Netzwerkeinstellungen ein 'Schalter' sein, an dem man zwischen "Traditionelle Methode mit ifup" und Verwaltung im Userraum mit networkmanager wählen kann. Hast Du dort den Networkmanager gewählt?

2.
Bist Du sicher, dass das WLAN-Gerät eingeschaltet ist bzw. was hast Du versucht, um es einzuschalten? Hast Du noch ein anderes Betriebssystem laufen und hattest Du es dort eingeschaltet? Kann man in Deinem BIOS anwählen, dass das WLAN beim Starten eingeschaltet ist?

3.
Die Hersteller von Hardware haben die lustige Idee, es sei nett verschiedene, unterschiedlich gebaute Arten von WLAN-Chips mit dem gleichen Namen zu bedenken. Auf Deinen Abbildungen sind zwar irgendwelche Nummern zu sehen aber sie haben leider nicht das Format, dass in den Datenbanken und Foren üblich ist (ich glaube dies sind hexadezimale Zahlen?).

Wahrscheinlich kann man 'Deine Nummern' irgendwie in das übliche Format umrechnen und dies könnte dann auch die Informationen liefern, aber einfacher und sinnvoller dürfte es sein, wenn Du konsole oder einen anderen Terminal-/Komandolinien-Emulator öffnest und dort


/sbin/lspci -vnn | grep 14e4

mit der Maus einfügst und ENTER drückst. Du kannst dann die Ausgabe mit der Maus markieren, mit der rechten Maustaste kopieren, hier einfügen und zwischen
..... setzen.
Es müsste eine numeric ID wie [14e4:4322] oder [14e4:432b] oder etwas ähnliches in der Ausgabe enthalten sein (14e4 steht für den Hersteller Broadcom). Ich habe auch bislang versucht, in der letzten Zeit die Anfragen in diesem und im englischsprachigen Teil des Forums mit Diesen Nummern zu 'taggen'.

Ich hoffe, wir anderen Benutzer diese Forums können Dir dann weiter helfen oder dies zumindest versuchen....

Bis bald und viel Erfolg
Martin
(pistazienfresser)

pistazienfresser
17-Mar-2011, 09:46
P.S.: Vielleicht fehlt auch einfach (nur) die proprietäre Firmware (warum ist steht dann aber die LED auf 'ausgeschaltet'?) - die könnte es dann beispielsweise im Repository von Packman geben. Aber um das eingrenzen zu können, wäre eben die numeric ID ganz sinnvoll, bevor man ganz wild/fast blind herumprobiert.
H.a.l.o.f.
Martin

jsbe
17-Mar-2011, 11:15
1. hab ich gemacht, drahtlos ist aber nicht klickbar, also deaktiviert.
2. Habe ich mehrmals versucht, der chip bleibt deaktiviert, mit ubuntu 10.10 funktioniert es aber eiwandfrei.
3.Folgende Ausgabe habe ich erhalten:


08:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

zur Firmware kann ich nur sagen, dass Ubuntu die durch die zusätzlichen Treiber geladen hat. Bei SUSE stand jedoch bei diesem Chip, dass die Firmware schon im Kernel integriert ist, daher habe ich auch nichts, dass ich installieren könnte oder so...

gruß

lOtz1009
17-Mar-2011, 11:49
Probier mal ob es nach der Installation von "kernel-firmware" und einem
Neustart funktioniert.


--
openSUSE official member
LXDE team

pistazienfresser
17-Mar-2011, 12:33
Hallo jsbe,


[...]
3.Folgende Ausgabe habe ich erhalten:


08:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

zur Firmware kann ich nur sagen, dass Ubuntu die durch die zusätzlichen Treiber geladen hat. Bei SUSE stand jedoch bei diesem Chip, dass die Firmware schon im Kernel integriert ist,
Wo stand das??? Bei dem eigentlichen Treiber würde ich es ja noch für möglich halten, aber die Firmware hat Broadcom bislang meines Wissens nach nicht offengelegt und als ihr Geheimnis betrachtet.

daher habe ich auch nichts, dass ich installieren könnte oder so...

gruß


Unter Install Broadcom Drivers from Packman (http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/446861-install-broadcom-drivers-packman.html#post2304002) #14 hat jemand berichtet, dass ein Chip mit der ID [14e4:432b (http://forums.opensuse.org/tags/14e4%3A432b.html)] unter openSUSE KDE 11.4 funktioniert habe, nachdem er der Anleitung in jenem Thread gefolgt sei.

b43 - Linux Wireless (http://www.linuxwireless.org/en/users/Drivers/b43#Known_PCI_devices) b43#Known_PCI_devices gibt mir (ebenfalls) die Information, dass Dein Chip von dem wl-Treiber (bzw. eventuell zusammen mit Kernelmodul und ggf. Firmware?) unterstützt würde.

Andere Informationen kann ich auch nicht herauslesen aus:
site:cateee.net 14e4:432b - Google-Suche (http://www.google.de/search?q=site%3Acateee.net+14e4%3A432b)

Auch nach der Aussage des wireless-Kernelentwicklers Larry Finger: Broadcom Drivers and Firmware, 11.4 M5 (http://forums.opensuse.org/english/get-technical-help-here/wireless/451722-broadcom-drivers-firmware-11-4-m5.html#post2274558) (06-Jan-2011 17:52)
On 01/06/2011 11:06 AM, yoyomc wrote:

> 0c:00.0 0280: 14e4:432b (rev 01)
[...]

The Broadcom 802.11n devices, including your BCM4322, will not be supported by
b43 until kernel 2.6.38, which is why you get the "UNSUPPORTED PHY" message.
That kernel will not be in openSUSE until the release AFTER 11.4. You need to
install the Broadcom wl hybrid driver from the Packman repository. The necessary
packages are "broadcom-wl" and "broadcom-wl-kmp-XXXXX", where XXXXX is
"default", "pae", "xen", or "desktop", depending on which kernel you run.

I also have a BCM4322 and I am running a 2.6.37 kernel from the wireless-testing
git tree that has the latest b43 code. In fact, I am connected with it right
now, and it never loses the connection. The main problems are that OFDM rates
are not yet implemented, thus the transmission rates cannot exceed 11 Mb/s, and
the device has trouble connecting with WPA/WPA2 encryption. I think I know the
reason for the failure of OFDM rates - that should soon be fixed, and I think
that will also fix the WPA/WPA2 difficulties.

würde ich dies meinen.

Insofern würde ich es an Deiner Stelle eventuell mal auf Diese Weise versuchen.

Dazu müsstest Du aber zunächst die Version und die 'Geschmacksrichtung' (flavor) Deines Kernels bestimmen mit:


uname -a

Das ergibt dann so etwas wie
uname -a
Linux linux-o7fu.site 2.6.37-desktop #1 SMP PREEMPT 2011-01-07 00:20:37 +0100 i686 i686 i386 GNU/Linux


Poste Deine Ausgabe bitte hier, dann leite ich Dich Schritt für Schritt weiter.


Ich frage aber gerne noch mal im englischsprachigen Forum nach, da antwortet oft der oben schon erwähnte Mensch, der (unbezahlt aber meist recht erfolgreich) versucht, die Treiber für alle Distributionen frei und offen und dann auch verbesserbar (in den Linux Kernel ein-) zu bauen (und nicht nur die [ev. proprietären] Pakete) der Hardwarehersteller für eine Distribution unbesehen zusammenzupacken ;-)

Bis dann

Martin
(pistazienfresser)

pistazienfresser
17-Mar-2011, 15:23
[...]

Ich frage aber gerne noch mal im englischsprachigen Forum nach, da antwortet oft der oben schon erwähnte Mensch, der (unbezahlt aber meist recht erfolgreich) versucht, die Treiber für alle Distributionen frei und offen und dann auch verbesserbar (in den Linux Kernel ein-) zu bauen (und nicht nur die [ev. proprietären] Pakete) der Hardwarehersteller für eine Distribution unbesehen zusammenzupacken ;-)

Bis dann

Martin
(pistazienfresser)


On 03/17/2011 03:06 PM, pistazienfresser wrote:
> TO: 'Broadcom WLAN Chip funktioniert nicht'
> (Broadcom WLAN Chip funktioniert nicht (http://tinyurl.com/4e72kr2))
>
> @lwfinger/Larry:
> ['14e4:432b' (http://forums.opensuse.org/tags/14e4%3A432b.html)] still
> needs the wl driver (installation and experience discribed in 'Install
> Broadcom Drivers from Packman' (Install Broadcom Drivers from Packman (http://tinyurl.com/4z5jmq2)) ), or?
> I have a German writing user and would like to try to set him on the
> right way.
> (And I do not think that I should tell him to use a new kernel. )

That is correct. With 11.5, installing firmware will allow the 14e4:432b to work
with b43. BTW, we are now transmitting with rates higher than 11 Mb/s.

Dann muss es wohl doch der propritäre/geschlossene wl Treiber von Broadcom (gepackt von Packman) sein.
Kernel bestimmen und wir sehen weiter.

Martin

jsbe
18-Mar-2011, 14:33
Also erstmal an lOtz1009: Diekernel-firmware ist bereits installiert.

@pistazienfresser:

meine ausgabe ist folgende:


Linux linux-ev1v.site 2.6.37.1-1.2-default #1 SMP 2011-02-21 10:34:10 +0100 i686 athlon i386 GNU/Linux

jsbe
18-Mar-2011, 14:54
Hallo jsbe,


Wo stand das??? Bei dem eigentlichen Treiber würde ich es ja noch für möglich halten, aber die Firmware hat Broadcom bislang meines Wissens nach nicht offengelegt und als ihr Geheimnis betrachtet.



Unter Install Broadcom Drivers from Packman (http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/446861-install-broadcom-drivers-packman.html#post2304002) #14 hat jemand berichtet, dass ein Chip mit der ID [14e4:432b (http://forums.opensuse.org/tags/14e4%3A432b.html)] unter openSUSE KDE 11.4 funktioniert habe, nachdem er der Anleitung in jenem Thread gefolgt sei.

b43 - Linux Wireless (http://www.linuxwireless.org/en/users/Drivers/b43#Known_PCI_devices) b43#Known_PCI_devices gibt mir (ebenfalls) die Information, dass Dein Chip von dem wl-Treiber (bzw. eventuell zusammen mit Kernelmodul und ggf. Firmware?) unterstützt würde.

Andere Informationen kann ich auch nicht herauslesen aus:
site:cateee.net 14e4:432b - Google-Suche (http://www.google.de/search?q=site%3Acateee.net+14e4%3A432b)

Auch nach der Aussage des wireless-Kernelentwicklers Larry Finger: Broadcom Drivers and Firmware, 11.4 M5 (http://forums.opensuse.org/english/get-technical-help-here/wireless/451722-broadcom-drivers-firmware-11-4-m5.html#post2274558) (06-Jan-2011 17:52)

würde ich dies meinen.

Insofern würde ich es an Deiner Stelle eventuell mal auf Diese Weise versuchen.

Dazu müsstest Du aber zunächst die Version und die 'Geschmacksrichtung' (flavor) Deines Kernels bestimmen mit:


uname -a

Das ergibt dann so etwas wie
uname -a
Linux linux-o7fu.site 2.6.37-desktop #1 SMP PREEMPT 2011-01-07 00:20:37 +0100 i686 i686 i386 GNU/Linux


Poste Deine Ausgabe bitte hier, dann leite ich Dich Schritt für Schritt weiter.


Ich frage aber gerne noch mal im englischsprachigen Forum nach, da antwortet oft der oben schon erwähnte Mensch, der (unbezahlt aber meist recht erfolgreich) versucht, die Treiber für alle Distributionen frei und offen und dann auch verbesserbar (in den Linux Kernel ein-) zu bauen (und nicht nur die [ev. proprietären] Pakete) der Hardwarehersteller für eine Distribution unbesehen zusammenzupacken ;-)

Bis dann

Martin
(pistazienfresser)

@pistazienfresser

ich habs hinbekommen. Deine Anleitung mit dem packman repositoryverweis hat funktioniert.



Unter Install Broadcom Drivers from Packman #14 hat jemand berichtet, dass ein Chip mit der ID [14e4:432b] unter openSUSE KDE 11.4 funktioniert habe, nachdem er der Anleitung in jenem Thread gefolgt sei.


Was ich gemacht habe: Ich habe den Link für die Packman Repo genommen, ihn in openSUSE 11.4 eingetragen und wie beschrieben den "broadcom-wl driver" über die Paketverwaltung installiert. Nach einem Neustart konnte ich WLAN nutzen. Funktioniert.

Danke!