PDA

View Full Version : geen of slecht geluid met geluidskaart met Codec: Realtek ALC888



ludje
06-Feb-2011, 03:14
Ik heb net als velen gedoe met een Realtek ALC888 chip. Wie o wie kan mij daarmee helpen? Ik heb een MSI x600 laptop met een moederboard geluidskaart die ik in bios niet kan uit schakelen en een Multimedia geluidskaart RV710/730 van ATI Technologies Inc met de beruchte Realtek ALC888 chip die ik maar niet goed geïnstalleerd krijg. Ik heb het eerst met UBUBTU geprobeerd, maar kon toen op zijn best alleen geluid over de interne geluidskaart krijgen. Heel vaak waren beide kaarten zelfs niet eens meer zichtbaar.
Ik heb nu mijn hoop gevestigd op open suse. Inmiddels heb ik met behulp van de uitleg op de google-pagina van Pjotr de geluidskaarten iets meer de aan praat gekregen(ook opensuse geheel multimediaklaar gemaakt).
Bij mij kwam er iets meer leven in de brouwerij door de regel options snd_hda_intel model=6stack-hp aan het bestand /etc./modeprobe.d/50 -sound.conf toe te voegen. De geluidskaart werd zichtbaar in het uitvoerscherm bij geluidsvoorkeuren, maar het geluid bleef over de interne luidspreker komen; heel blikkerig en geen kleur. Verder ging ook bij mij de snelheid heel raar doen, net als bij Ben beschreven in een Thread op 17 nov 2010. Dan weer snel dan weer veel te langzaam, alsof de snelheid van de muziek afhankelijk was van de mate van gebruikt geheugen? Ik heb de conversatie tussen Ben en Knurpht met belangstelling gevolgd, maar ik heb zoals gezegd een MSI laptop en GNOME ipv KDE. Kortom; Van wat jullie beiden uitvogelden kon ik geen soep maken. ik ben niet genoeg thuis in linux om gelijk jullie goocheltruc te begrijpen én een vertaalslag te maken naar GNOME :P. Toch leek het mij dat het jullie gelukt was dit zoveelste probleem met de ATI geluidskaarten te tekkelen?;) Kortom wie kan mij witte rook geven??
MVG Ludger

Knurpht
09-Feb-2011, 07:33
Hallo Ludger, allereerst welkom hier

Sorry voor de late reactie, had je post niet gezien. Voor de goede orde:
openSUSE 11.3 met Gnome?

Heb je al geprobeerd om via Yast de ATI kaart als primaire geluidskaart vast te leggen? Volgens mij zit daar namelijk het probleem, dat je systeem steeds probeert om de on-board geluidskaart te gebruiken. Voor zover ik weet is de ALC888 gewoon ondersteund door de kernel, zo te lezen ziet het systeem de kaart nu ook, alleen heeft het systeem nog steeds de interne geluidskaart als "sound-card 0". In Yast - Hardware - Geluid kun je dat zien, met de opties rechtsonder kun je dat ook "zetten".
Eerlijk gezegd, denk ik dat dat onder alle andere distros hetzelfde is.

ludje
16-Feb-2011, 13:54
moi knurpht , Fien das't stou mie nog ain droadpost schrieven hed Ik had de moed al een bietje opgem'n. Ik hed de juste koart nu an de proat t liekt 'r op dat 't ain bietje beter goat. Ik hed nu ain bietje meer kleur in de muziek, moar t is nog voak ain haile bult kattegejank. West tou nog wat anders?

In Ubuntu hed ik 't veur mekoar! Dor hed ik 't geluud met ain naie istalotie en de regel options snd_hda_intel model=6stack-hp an de proat kre'gn. Moar Ubuntu is Open Suse nait, en ik wol groag doar met verder

Groet'n an de olle grieze, hier van oet purmerend Ludger

Knurpht
20-Feb-2011, 06:59
Woohoo. Grunnig's oet P'mrend.

Ubuntu & openSUSE.....a'moal linux, dus krek as bie 'buntu.

Je moet exact dezelfde regel toevoegen aan /etc/modprobe.d/50-sound.conf. Daarna een reboot en dan zou het OK moeten zijn. Bedankt voor de rollende lach die ik door mijn werkhokje heb laten schallen :D

ludje
20-Feb-2011, 11:40
Moi knurpht, de regel stoat 'r in en geluud is goud, moar het tempo blieft kattengejank. Gain goede reclame veur mien noabers as ik euver linux zevel, nait? West tou nog wat anders?

Knurpht
21-Feb-2011, 11:49
Moi knurpht, de regel stoat 'r in en geluud is goud, moar het tempo blieft kattengejank. Gain goede reclame veur mien noabers as ik euver linux zevel, nait? West tou nog wat anders?

Ook de codecs geinstalleerd? D.w.z. de Packman repository toegevoegd en de multimedia HOWTO gevolgd? Ik denk 't niet.

flark
28-Feb-2011, 04:56
Hé Ludje,

In dit forum stond volgens mij al iets soortgelijks: Alle geluiden gaan veel te snel (http://forums.opensuse.org/nederlands-dutch/helpen-en-hulp/desktop/kde/449898-alle-geluiden-gaan-veel-te-snel.html). Misschien biedt dat uutkomst?

Dexter1979
28-Feb-2011, 08:59
Hmm, Google Translate kent Grunnig's niet..

Als je wilt dat deze discussie ook andere mensen kan helpen zou ik het toch in't Nederlands houden.. :P

Knurpht
28-Feb-2011, 13:21
Hmm, Google Translate kent Grunnig's niet..

Als je wilt dat deze discussie ook andere mensen kan helpen zou ik het toch in't Nederlands houden.. :P

Yep, Goochel blijft een gebrekkig iets :D