PDA

View Full Version : Atheros AR5007EG Wireless Network Adapter. Keine Verbindung zum Router.



slayoer
18-Jan-2011, 06:49
Hallo,
ich bin absolut neu bei Linux und habe gelesen Suse soll relativ nah an Windows sein und hab es deswegen ausgewählt.

Ich finde das ganze System eigentlich auch gut (Hab bisher nur bischen rumgespielt).
Nur leider komm ich nicht in mein Wlan.
Ich verwende die KDE Oberfläche. Also habe ich den ConnectionManager von KDE. Der Treiber scheint erkannt worden zu sein den ich kann alle Netzwerke sehen. Mit Ubuntu Livedisk konnte ich mich auch am Netzwerk anmelden. Jetzt mit Suse kann ich das leider nicht.
Ich werde aufgefordert meine Anmeldedaten einzugeben. Dann passiert ne weile nix und dann kommt die Auforderung erneut.

Woran kann das liegen?
Welche infos braucht ihr? (Bitte schreibt mir die Commands Danke!)

Netzwerkkarte: Atheros AR5007EG Wireless Network Adapter

Danke für euere Hilfe

Gruß
Slay

pistazienfresser
18-Jan-2011, 09:37
Hallo,
ich bin absolut neu bei Linux und habe gelesen Suse soll relativ nah an Windows sein und hab es deswegen ausgewählt.

Ich finde das ganze System eigentlich auch gut (Hab bisher nur bischen rumgespielt).
Nur leider komm ich nicht in mein Wlan.
Ich verwende die KDE Oberfläche. Also habe ich den ConnectionManager von KDE. Der Treiber scheint erkannt worden zu sein den ich kann alle Netzwerke sehen. Mit Ubuntu Livedisk konnte ich mich auch am Netzwerk anmelden. Jetzt mit Suse kann ich das leider nicht.
Ich werde aufgefordert meine Anmeldedaten einzugeben. Dann passiert ne weile nix und dann kommt die Auforderung erneut.

Woran kann das liegen?
Welche infos braucht ihr? (Bitte schreibt mir die Commands Danke!)

Netzwerkkarte: Atheros AR5007EG Wireless Network Adapter

Danke für euere Hilfe

Gruß
Slay

Ich benutze im Moment nur noch die GNOME Oberfläche und weiß nicht so ganz was der "ConnectionManager" so ist - in der openSUSE Software-Suche kann ich ein Paket mit "ConnectionManager" jedenfalls nicht finden: software.opensuse.org: Search Results (http://software.opensuse.org/search?q=Connection+Manager&baseproject=ALL&lang=en#)

Wahrscheinlich meinst Du irgendein Frontend / Sichtbares Programm,
um den NetworkManager zu bedienen (Pakete: NetworkManager-kde4 - NetworkManager client for KDE 4 ; plasmoid-networkmanagement - NetworkManager client for KDE 4 ???).

Wenn Du (erst) bei der Eingabe des Passwortes scheiterst (und Du alle WLAN-Netzwerke sehen kannst und somit wohl auch Deine WLAN-Karte grundsätzlich läuft), würde ich raten, dass es vielleicht an der Verschlüsselung (WPA2 also CCMP ?) oder an der Eingabe des Passwortes liegt.

Kannst Du mit Kabel (LAN) auf Deine Router zugreifen und dort die Art der Verschlüsselung ablesen/ändern und ggf. einfach das Passwort heraus kopieren und dann in Dein Netzwerk-Bedienungs-Programm herein kopieren (Copy-And-Paste)?

Oder was ist genau gemeint mit

Ich werde aufgefordert meine Anmeldedaten einzugeben. ?

Ansonsten könnte es noch eventuell (anderen) helfen, wenn Du schreiben würdest, welche Version von openSUSE Du benutzt (openSUSE 11.3?) und welchen WLAN-Router Du benutzt. Hat Dein graphisches Netzwerk-Programm auch irgendwo eine Schaltfläche About/Über (per Rechtsklick??), hinter der steht, wie es sich so nennt (meines heißt beispielsweise "NetworkManager Applet 0.8.2").

Viel Glück
pistazienfresser

slayoer
18-Jan-2011, 10:22
Also der Manager ist der hier
KNetworkManager (http://de.opensuse.org/KNetworkManager)
und als Router habe ich eine Vodafone EasyBox DSL-EasyBox 802

Wiegesagt am Passwort und an der Verschlüsselung sollte es nicht leigen mit Ubuntu geht es ja...

die Suse ist die neuste 11.3

edit:
Ich kann mich auch nicht mit meinem Andriod Handy verbinden. Auch das ging mit allen andern Betriebsystem wunderbar. (Als Wlan Access Point)

pistazienfresser
18-Jan-2011, 10:47
Also zumindest in dem Thread
Unable to access university WLAN Network (http://forums.opensuse.org/english/get-help-here/wireless/449723-unable-access-university-wlan-network.html)
konnte der Benutzer nicht eine spezielle Art der Verschlüsselung mit dem KNetworkManager verwenden.

Daher würde ich (zumindest für die Fehlereingrenzung) daran denken,
1. Die Verschlüsselungsmethode am Router zu ändern (beachte aber, dass WEP und WPA1 (privat) als geknackt gelten -> siehe Wi-Fi Protected Access (http://de.wikipedia.org/wiki/Wi-Fi_Protected_Access) und Wi-Fi Protected Access - Wikipedia, the free encyclopedia (http://en.wikipedia.org/wiki/Wi-Fi_Protected_Access) ).
2. Es mit einem anderen (Zugangs-)Programm zu versuchen - der GNOME 'Bruder' NetworkManager Applet (paket: NetworkManager-gnome - GNOME applications for use with NetworkManager) dürfte vergleichbare Funktionen bieten. Siehe auch die Empfehlungen zur Fehlereingrenzung unter NetworkManagement - KDE UserBase (http://userbase.kde.org/NetworkManagement)

Viel Erfolg
pistazienfresser

pistazienfresser
18-Jan-2011, 11:36
[...]
Wiegesagt am Passwort [..] sollte es nicht leigen mit Ubuntu geht es ja...
[...]
Zum Beispiel könnte Ubuntu auch eine andere Tastatur als Standard benutzen - jedenfalls y/z und Sonderzeichen können da Probleme machen, wenn man das Passwort nicht sieht...
Zu der Verschlüsselung und speziellen möglichen Problemen mit der KDE-Applikation habe ich mich schon wild herumratend ausgelassen.

Viel Glück beim Ausprobieren und Fehlersuchen!
(oder mit jemandem Schlaueren)
pistazienfresser

psifus
20-Mar-2011, 15:05
Hallo!

Hatte ein ähnliches Problem. Die ständige Frage nach dem WPA/WEP Passwort...
Opensuse wollte es sich nicht merken.

Ist der KWalletManager aktiv und konfiguriert?

Prüfe im Network Manager:

Links auf OTHER klicken. VERBINDUNGSPASSWÖRTER SPEICHERN

Wenn KWallet nicht läuft, Passwörter IN DATEI ( UNVERSCHLÜSSELT) SPEICHERN

Vielleicht ist dies das Problem.

Gruss
CK