PDA

View Full Version : Mutlimedia - Packman in het Kort -openSUSE 12.1



Knurpht
17-Oct-2010, 07:12
UPDATE: De kortste weg tot een volledige multimedia ervaring op openSUSE 12.1 is die via de hieronderstaande link:

http://opensuse-community.org/Restricted_formats/12.1

einde update

Om multimedia op je openSUSE volledig te kunnen gebruiken, heb je de Packman installatiebron/repo nodig, waar zich de multimedia pakketten vinden die niet onder open source vallen, dan wel niet overal vrij verspreid mogen worden met openSUSE.Deze Hoe-Te is gericht op openSUSE 11.3, vervang het versie nummer als je een oudere openSUSE draait. Er kan om het importeren/accepteren van een sleutel gevraagd worden, doe dat, zonder kun je de repo niet gebruiken.Start Yast - Software - Software BronnenKlik "Toevoegen",Kies "Installatiebronnen onderhouden door de gemeenschap"Kies "Packman"Klik OK, OK. sluit Software BronnenStart Yast - Software - Software beheerKlik Beeld, BronnenSelecteer de Packman repoKlik "Schakel systeempakketten....."Accepteer het omschakelen van evt. andere pakketten naar de Packman repoKlik Beeld, ZoekenZoek op "codecs" met alleen de "Naam" optie aan. Selecteer libxine1-codecs, k3b-codecs en w32codecsall voor installatie. Daarbij zulllen andere pakketten als afhankelijkheden ook voor installatie geselecteerd worden.Zoek op "libdvd" met alleen de "Naam" optie aan.Selecteer libdvdread3, libdvdread4 en libdvdnav voor installatieZoek op "ffmpeg" met alleen de "Naam" optie aanSelecteer ffmpeg voor installatieKlik nu op Accepteren om de installatie uit te voeren, waarna zaken als mp3 en dvd's afspelen geheel naar behoren werken.

mbenjamins
17-Oct-2010, 13:33
Ik krijg het volgende, wat moet ik hier kiezen?
http://allesoverlinux.nl/schermafdruk3.png

Knurpht
18-Oct-2010, 03:03
In beide gevallen: "Handhaven verouderde versie". Als je twijfelt, niet updaten. Beter is, om zoals je nu gedaan hebt, eerst uit te zoeken wat je moet doen.
Ter info: van beide installeert Packman een ...2 versie, dus voor libebml wordt libebml2 geļnstalleerd, idem voor libmatroska.

Dexter1979
19-Oct-2010, 06:30
Knurpht, kan je de "one-click" optie niet beter gebruiken?

Ik weet niet goed waarom de meeste "ervaren" OpenSUSE gebruikers erop tegen zijn, want ik vind ze erg handig. Je moet alleen even opletten voordat je "volgende" klikt. Maar dat geld voor alles wat je doet met een computer. 2 keer kijken, 1 keer klikken.

Als je dependency problemen krijgt word je ook gewaarschuwd op dezelfde manier als de methode die jij beschrijft. Zypper is ook handig, maar niet zo gebruiks vriendelijk als een GUI.

Knurpht
20-Oct-2010, 11:42
Knurpht, kan je de "one-click" optie niet beter gebruiken?

Ja en nee. One-click is snel en handig, maar ik wilde iets meer laten zien. De one-click heeft volgens mij hetzelfde eindresultaat (ongeveer). Je ziet zo een aantal aspecten van Software Beheer en Repositories. Als je, zoals de poster hierboven vanuit een one-click tegen hetzelfde item aanloopt, heb je eigenlijk nog niets gedaan, en het gaat mis.


Ik weet niet goed waarom de meeste "ervaren" OpenSUSE gebruikers erop tegen zijn, want ik vind ze erg handig.

Ik heb niets tegen op de one-click optie, gebruik die ook regelmatig voor losse dingetjes. Voorzichtig ben ik er wel mee. Discussie daarover graag in een apart onderwerp. Dat houdt het ook voor anderen helderder.

akaper
29-Oct-2010, 00:26
Als ik na het volgen van deze stappen nog geluidsproblemen mocht hebben (gebeurt soms als ik iets niet goed doe), volg ik deze procedure om te achterhalen welke bestanden nog missen of die ik van versie of van repo moet veranderen naar die uit packman:
http://forums.opensuse.org/english/get-help-here/multimedia/400119-check-your-multimedia-problem-ten-steps-21.html (http://forums-opensuse.provo.novell.../../../english/get-help-here/multimedia/400119-check-your-multimedia-problem-ten-steps-21.html).

Maar de procedure die Knurpht geeft, gaat alleen fout als je zelf iets verknoeit. Iets wat mij in ieder geval met enige regelmaat overkomt, doordat ik nu eenmaal graag knoei.

nomko
23-Oct-2012, 23:50
Selecteer libdvdread3, libdvdread4 en libdvdnav voor installatie

Moet er dan ook de volgende commando uitgevoerd worden na installatie van de bovenstaande packages?

sudo (of wat er van toepassing onder Suse) /usr/share/doc/libdvdread4/install-css.sh

Knurpht
24-Oct-2012, 02:52
Moet er dan ook de volgende commando uitgevoerd worden na installatie van de bovenstaande packages?

sudo (of wat er van toepassing onder Suse) /usr/share/doc/libdvdread4/install-css.sh

Nee. En pas op met deze instructies. Als je letterlijk kopiƫert op 12.2, zet je daar bronnen voor 12.1 in

nomko
31-Oct-2012, 02:16
Als je letterlijk kopiƫert op 12.2, zet je daar bronnen voor 12.1 in

Ik haal de info hier weg:13. Multimedia Codecs - Install Support For MP3, DVD, WMA, WMV, MOV etc. (http://www.opensuse-guide.org/codecs.php) en daar wordt deze code opgegeven voor 12.2:

zypper addrepo -f http://ftp.gwdg.de/pub/linux/packman/suse/12.2/ packman

Daar heb ik mij aan gehouden.

Knurpht
31-Oct-2012, 08:15
Ik haal de info hier weg:13. Multimedia Codecs - Install Support For MP3, DVD, WMA, WMV, MOV etc. (http://www.opensuse-guide.org/codecs.php) en daar wordt deze code opgegeven voor 12.2:

zypper addrepo -f http://ftp.gwdg.de/pub/linux/packman/suse/12.2/ packman

Daar heb ik mij aan gehouden.

Er zijn veel wegen die naar Rome leiden. Als jij 't zo werkend hebt is 't prima. Al deze handleidingen doen uiteindelijk hetzelfde. Da's het mooie van open source/linux