PDA

View Full Version : KDE upgraden



mbenjamins
17-Oct-2010, 04:15
Hoe kan ik het beste KDE upgraden naar de nieuwste versie, heb het met openSUSE 11.2 ook al een keer geprobeerd maar toen is het niet goed gegaan.

Knurpht
17-Oct-2010, 04:37
Ha Marcel,

Je moet daarvoor een aantal stappen ondernemen, waaronder de repos met de KDE updates toevoegen. Daarvoor moeten we eerst weten welke repos je nu "aan" hebt staan. Kun je output posten van:


zypper lr -d


Ik zal dan aangeven welke repos je eventueel uit moet zetten/verwijderen, en welke je toe moet voegen. Hoe je dat moet doen ook. Ben de hele middag online, hou dit draadje wel open in een tabje van mijn browser.

Edit: Je kunt in vast beginnen, door de rest te updaten:
Yast - Software Beheer
Pakketten - Alle pakketten - Opwaarderen als er een nieuwe versie is
Je zorgt hiermee, dat er geen andere updates de update naar de nieuwste KDE in de weg kunnen zitten.

mbenjamins
17-Oct-2010, 05:14
Hier is de output van zypper lr -d

# | Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service
--+---------------------------------------+---------------------------------------+--------------+------------+------------+--------+---------------------------------------------------------------------+--------
1 | Bijwerken van openSUSE 11.3 11.3-1.82 | Bijwerken van openSUSE 11.3 11.3-1.82 | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/11.3/ |
2 | KDE:Extra | KDE:Extra | Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3/ |
3 | google-chrome | google-chrome | Ja | Ja | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386 |
4 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Nee | Nee | 99 | yast2 | cd:///?devices=/dev/sr0 |
5 | repo-debug | openSUSE-11.3-Debug | Nee | Ja | 99 | NONE | http://download.opensuse.org/debug/distribution/11.3/repo/oss/ |
6 | repo-non-oss | openSUSE-11.3-Non-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/11.3/repo/non-oss/ |
7 | repo-oss | openSUSE-11.3-Oss | Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/11.3/repo/oss/ |
8 | repo-source | openSUSE-11.3-Source | Nee | Ja | 99 | NONE | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |

Knurpht
17-Oct-2010, 06:47
OK, je moet nrs.2, 4 (dan vraagt-ie ook niet meer om de DVD/CD), 5, 8 verwijderen.
Dan mis ik de Packman repo bij jou, heb je die normaal wel actief? Zonder ben je behoorlijk beperkt op multimedia gebied. Maar nu eerst KDE4:

Als je bovengenoemde repos verwijderd hebt, voeg je deze toe:

Index of /repositories/KDE:/Release:/45/openSUSE_11.3 (http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/) (deze bevat de standaard KDE pakketten). Noem het ding KDE4-Release

Vervolgens start je Yast-Software-Software Beheer.
Selecteer bij Beeld: Bronnen
Klik de KDE4-Release bron aan, rechts verschijnt de lijst met pakketten in de repo.
Daarboven zie je "Schakel systeempakketten.....", klik daarop.
Klik Accepteren en KDE4 4.5.2 komt naar je toe.

Het kan zijn dat je tijdens het installeren wat rare dingen krijgt met de draaiende KDE, gewoon even afwachten, uitloggen en opnieuw inloggen.

TIP: Installeer LXDE naast je KDE desktop. Mocht er een keer iets zijn waardoor je KDE niet kunt gebruiken, dan heb je toch een desktop omgeving.....

Knurpht
17-Oct-2010, 06:49
Eventueel kun je ook deze nog toevoegen:
Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Release_45 (http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3_KDE_Release_45/)

Ikzelf zou de "Schakel systeem ..... " hier niet gebruiken. Deze repo bevat toegevoegde pakketten.

Knurpht
17-Oct-2010, 06:55
Nog een toevoeginkje:

Het kan zijn dat je je desktop opnieuw moet instellen qua vormgeving/thema. Sommige mensen gebruiken veel widgets, die niet allemaal even goed onderhouden worden, voor wat het nieuwe KDE versies betreft. Dat kan soms wat neven-effecten hebben. Troost: het is simpel te verhelpen, mocht je iets tegenkomen. De instellingen van je programma's lijden er in ieder geval niet onder.

Knurpht
17-Oct-2010, 07:16
En nog één: in de NL-How-To staat een kort stukje m.b.t. Packman. Daarna zijn mp3, dvd enz. geen probleem meer.

mbenjamins
17-Oct-2010, 08:14
Eventueel kun je ook deze nog toevoegen:
Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Release_45 (http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3_KDE_Release_45/)

Ikzelf zou de "Schakel systeem ..... " hier niet gebruiken. Deze repo bevat toegevoegde pakketten.
Is het slim op dit te doen of wat je daarboven beschrijft.
Ik weet niet wat deze als extra heeft.

En packman heb ik er niet tussen staan maar als ik het goed begrijp is het wel slim.

mbenjamins
17-Oct-2010, 08:25
De volgende melding krijg ik, wat kan ik het beste doen?
http://allesoverlinux.nl/schermafdruk2.png

Knurpht
17-Oct-2010, 10:40
Ai, vervelend. Doorgaan/Toch gebruiken is vragen om moeilijkheden.


2 mogelijkheden:
1. Er is iets misgegaan tijdens het downloaden van het pakket. Kies Nee, er komt een nieuw schermpje, kies Opnieuw proberen. Gaat dat na 2 of 3 keer niet goed, dan
2. is er iets (in ieder geval in de repo) veranderd sinds de laatste verversing van de inhoud van de repos. In dat geval kun je niet anders dan het pakket overslaan, de rest afronden, meteen weer Software Beheer opstarten en de procedure herhalen. Het wil wel eens gebeuren dat tijdens het updaten nieuwe updates verschijnen in de repo.

mbenjamins
17-Oct-2010, 13:20
Volgens mij is de update goed gegaan zie netjes KDE: 4.5.2 (KDE 4.5.2) "release 10" staan en heb tot nu toe geen problemen.
Bedankt Knurpht

Knurpht
18-Oct-2010, 02:56
Nix te danken, veel plezier ermee. Als alles goed is zou je een beetje snelheidswinst moeten hebben, en een wat "gelikter" uiterlijk. Op mijn laptop "vliegt" het erover.

mbenjamins
04-Nov-2010, 15:24
Hoe update ik nu naar 4.5.3?

Knurpht
05-Nov-2010, 01:02
4.5.3 staat in dezelfde repo.

Het enige wat je hoeft te doen als je de switch naar deze repos al hebt uitgevoerd, is "Pakketten - Alle pakketten - Opwaarderen als er een nieuwe versie is".
De 2e methode is om hetzelfde te doen als bij het opwaarderen naar 4.5.2: repo selecteren in Softwarebeheer, optie "Schakel systeempakketten ....." aanklikken, en daar gaat-ie.

Verwacht niet veel spectaculairs, geen grote veranderingen. Bij mij loopt-ie lekker soepel en gladjes.

mbenjamins
05-Nov-2010, 15:37
Heb net even de update gedaan, heb het gevoel dat sommige dingen iets sneller zijn.

Knurpht
06-Nov-2010, 04:30
Heb net even de update gedaan, heb het gevoel dat sommige dingen iets sneller zijn.


In ieder geval op één punt: het afsluiten. Bij mij duurde het altijd even voordat de Kopete chat verbindingen dichtgegooid waren, 2 à 3 seconden. Nu is het klikken, en het systeem sluit af. Ook ik heb het gevoel dat het helemaal een stukje vlotter is.

mbenjamins
12-Dec-2010, 02:28
Hoe update ik nu naar de KDE 4.6 Beta?
Gaat dat op de zelfde manier als naar 4.5 maar dan de 5 door de 6 veranderen?

Knurpht
12-Dec-2010, 04:10
Nee, dat gaat niet hetzelfde, d.w.z. in zeker zin wel, maar niet met de repo wijziging zoals jij die suggereert. De repos die je hebt voor 4.5 bevatten de 4.5.x pakketten, op dit moment 4.5.4, als ze komen, komen hier de 4.5.5 en daarna de 4.5.6 pakketten. Als je iets meer zicht wilt op hoe de repos zijn opgebouwd, dan kun je hier eens rondbladeren:
http://download.opensuse.org/repositories/KDE:

Dit zijn de repos voor 4.6 beta (2 op dit moment):
Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.3 (http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_11.3/) (de gewone KDE repo)
Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory (http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory/) (de "Extra" repo die hoort bij de bovenstaande, niet echt nodig, wat experimenteler)

Je moet de huidige KDE repos deactiveren of verwijderen, en dan op de nieuwe repos "Schakel systeempakketten om naar......." uitvoeren.
Als je spectaculaire veranderingen verwacht, daarop hoopt, dan kan ik nu wel zeggen dat je het daarom niet hoeft te doen. Dan ben je beter af met de (zeer) stabiele pakketten voor de 4.5 serie.

Benmh
12-Dec-2010, 06:58
Yep heel spectaculair is het niet geheel, helaas was de upgrade niet best uitgevoerd (door mij).
Heb een taakbalk die nu nergens op reageerd.
Dus maar even terug naar een stabiele versie, na het vinden van de fout als dat mogelijk is.

Knurpht
12-Dec-2010, 08:14
Ik had eigenlijk alleen een probleem met het afsluiten van Dolphin (crash bij afsluiten), maar dat is sinds de laatste updates verdwenen.

Overigens zijn 'rare' verschijnselen na upgrade vaak te wijten aan plasmoids/widgets. Met een 'kale' default desktop beginnen, is vaak een oplossing, d.w.z. de plasma-files in ~/.kde4/share/config weggooien/wegkopiëren, en dan het desktop uiterlijk, incl. widgets opnieuw naar eigen smaak aanbrengen. Als een upgrade niet doet wat ik wil, is dat één van de eerste dingen die ik doe. Na het weggooien krijg je de standaard desktop weer voor je, met dien verstande, dat bijv. je instellingen voor Kmail Nz. bewaard blijven. Ik ben hier ooit achter gekomen dankzij een reactie hier in de forums, om zo'n nieuwe KDE versie eens te proberen in een even nieuw gebruikersaccount. Als het probleem daar niet bestaat, weet je al zeker dat de oorsprong van het probleem in je eigen ~/.kde4 map huist. Aangezien het hele uiterlijk van de desktop door plasma bepaald wordt, blijven er niet zoveel andere plaatsen over dan de plasma-files.

Om bovenstaande effectief te laten zijn, mag je niet ingelogd zijn op de KDE desktop, tenminste niet als de gebruiker waarvan je de plasma-files wilt weggooien. Dat kan zo:

- Log uit
- In het loginscherm: Ctrl-Alt-F1
- Log in met gebruikersnaam en wachtwoord, eenmaal ingelogd doe je:


rm ~/.kde4/share/config/plasma*

- De configuratie bestanden voor plasma zijn nu verwijderd
- Doe Ctrl-D om weer naar de loginprompt terug te keren
- Nu brengt Ctrl-Alt-F7 je terug naar het login scherm
- Log opnieuw in, en kijk of je een standaard desktop hebt.