PDA

View Full Version : opensuse linux 11.2 umstellen von xfce auf lxde window-manager



felbre
19-Aug-2010, 01:40
Liebe Linux-Experten,

ich habe auf einem älteren Laptop den Ressourcen schonenden xfce Window-Manager unter OpenSuSE 11.2 installiert. Jetzt würde ich gerne lxde ausprobieren, ohne dafür mein System neu aufsetzen zu müssen. Ein evtl. Update auf OpenSuSE 11.3 könnte ich mir durchaus vorstellen. Aber ich denke nicht, dass das mein Problem lösen würde, weil mir nicht bekannt ist, dass man bei einer System-Aktualisierung den Window-Manager umkonfigurieren kann. Und über Yast scheint das leider auch nicht zu gehen?

Der direkte Download-Link auf der OpenSuSE-Website ist leider verwaist: LXDE (http://de.opensuse.org/LXDE) . Deshalb habe ich mir das "Factory"-Repository eingebunden. Damit konnte ich die nötigen Pakete auch laden. Dann habe ich mit lxcc den Window-Manager für startlxde eingestellt. Daraufhin ging erst mal gar nix mehr nach der Anmeldung mit dem xdm Login-Manager von xfce! Sprich: das X-Windows System startete nicht mehr und ich habe wieder umgestellt auf startxfce4.

Da ich nicht den kdm Login-Manager, sondern xdm benutze, habe ich auch leider keine Möglichkeit, beim Login den Window-Manager auszuwählen.

Habt Ihr vielleicht noch irgendwelche Ideen, was ich da machen könnte? Auf den einschlägigen Websites werde ich zu diesem Thema leider nicht so recht fündig.

--

Besten Dank für die Aufmerksamkeit,
Felix

Pilgervater
19-Aug-2010, 02:18
Entschuldige, dass ich Dich nicht verstehe. XFCE und LXDE sind für mich keine Window Manager sondern Desktop Environments. Das heißt, wenn Du ein anderes DE auspropieren musst, musst Du wenigstens das Basissystem des Desktop Environments installieren. Damit Dein XDM etwas anderes startet musst Du die Konfigurationsdateien von xdm editieren. Die verstecken sich ggf. hier: /etc/X11/xdm. Ich bin mir aber nicht sicher weil ich kein XDM verwende.

pistazienfresser
19-Aug-2010, 02:26
Der direkte Download-Link auf der OpenSuSE-Website ist leider verwaist: LXDE (http://de.opensuse.org/LXDE) .

Ich glaube nicht, dass ich zu der genannten Definition der Angesprochen (Linux-Experten) ganz passe, aber zunächst eine Verständnisfrage vom selbsternannten Beauftragten für das Stellen von dumme Fragen:

Was ist "verweist"? Was meinst du mit "verweist"?
http://de.opensuse.org/LXDE - Ich sehe eine Webseite.
der link oben rechts davon für 11.2 gibt mir:
software.opensuse.org: Search Results (http://software.opensuse.org/search?q=lxde&baseproject=openSUSE%3A11.2&p=1)
=
http://software.opensuse.org/search?q=lxde&baseproject=openSUSE%3A11.2&p=1
mit dem zweiten Treffer:



LXDE [Software collection]



X11:lxde/openSUSE_11.2 (http://download.opensuse.org/repositories/X11:/lxde/openSUSE_11.2)

"Lightweight X11 Desktop Environment", is an extremely faster, performing and energy saving desktop environment.

1-Click Install (http://software.opensuse.org/search/download?base=openSUSE%3A11.2&file=X11%3A%2Flxde%2FopenSUSE_11.2%2FLXDE.ymp&query=lxde)

Go to OBS Project (https://build.opensuse.org/project/show?project=X11:lxde)


LXDE - openSUSE (http://en.opensuse.org/LXDE) ist allerdings zugegeben etwas aktueller aber auch knapper gefasst (Freiwillige/Mithilfe im deutschsprachigen Wiki wird wohl auch nicht unerwünscht sein ;) )
http://en.opensuse.org/LXDE#Downloads
verweist auf
http://en.opensuse.org/Derivatives#Unofficial_updated_LXDE_live_CDs
mit
http://download.opensuse.org/repositories/X11:/lxde/images/iso/

Das image/iso oder die entsprechende Live-CD interessiert mich selbst - werde sie wohl mal bald ausprobieren.

Zudem:
Ich habe es auch noch nicht versucht, aber kann man LXDE nicht auch von der Live-DVD oder von einem daraus hergestellten Live-USB-Stick / einer externen Live-USB Festplatte ausprobieren?

Beste Grüße und viel Glück und Spaß beim Ausprobieren
sowie für die Beantwortung Deiner Fragen
pistazienfresser

felbre
19-Aug-2010, 03:01
LXDE (http://de.opensuse.org/LXDE) - Ich sehe eine Webseite.
der link oben rechts davon für 11.2 gibt mir:
software.opensuse.org: Search Results (http://software.opensuse.org/search?q=lxde&baseproject=openSUSE%3A11.2&p=1)
=
software.opensuse.org: Search Results (http://software.opensuse.org/search?q=lxde&baseproject=openSUSE%3A11.2&p=1)
mit dem zweiten Treffer:
LXDE - openSUSE (http://en.opensuse.org/LXDE) ist allerdings zugegeben etwas aktueller aber auch knapper gefasst (Freiwillige/Mithilfe im deutschsprachigen Wiki wird wohl auch nicht unerwünscht sein ;) )
LXDE - openSUSE (http://en.opensuse.org/LXDE#Downloads)
verweist auf
Derivatives - openSUSE (http://en.opensuse.org/Derivatives#Unofficial_updated_LXDE_live_CDs)
mit
Index of /repositories/X11:/lxde/images/iso (http://download.opensuse.org/repositories/X11:/lxde/images/iso/)

Das image/iso oder die entsprechende Live-CD interessiert mich selbst - werde sie wohl mal bald ausprobieren.



Die 1 Click-Install Option für OpenSuSE 11.2 war gestern Abend verwaist. Anscheinend wurde das mittlerweile korrigiert:

LXDE/Installationsquellen (http://de.opensuse.org/LXDE/Installationsquellen)

Aber leider löst das noch nicht mein Problem...

lOtz1009
19-Aug-2010, 03:08
Schau mal in die /etc/sysconfig/windowmanager
AFAIK müsste es reichen wenn du als Default dort openbox-lxde einträgst.

felbre
19-Aug-2010, 03:30
Entschuldige, dass ich Dich nicht verstehe. XFCE und LXDE sind für mich keine Window Manager sondern Desktop Environments. Das heißt, wenn Du ein anderes DE auspropieren musst, musst Du wenigstens das Basissystem des Desktop Environments installieren. Damit Dein XDM etwas anderes startet musst Du die Konfigurationsdateien von xdm editieren. Die verstecken sich ggf. hier: /etc/X11/xdm. Ich bin mir aber nicht sicher weil ich kein XDM verwende.

Du magst evtl. recht haben:
WindowManager - LinuxWiki.org - Linux Wiki und Freie Software (http://linuxwiki.de/WindowManager)

Aber leider löst auch das noch nicht mein Problem.

Kennst Du Dich vielleicht aus mit den Konfigurationstools sax bzw. xorgconfig (ich glaube, die haben noch eine tückische Großschreibung in der Syntax)? Würde mir das vielleicht weiterhelfen?

pistazienfresser
19-Aug-2010, 03:34
Die 1 Click-Install Option für OpenSuSE 11.2 war gestern Abend verwaist. Anscheinend wurde das mittlerweile korrigiert:

LXDE/Installationsquellen (http://de.opensuse.org/LXDE/Installationsquellen)

Auch so. Ich hatte sowieso nicht so weit gescollt (und auch nicht auf "1-Klick" geklickt), sondern war den Links in dem Kasten oben rechts gefolgt, den ich aus dem 'neuen' en-wiki kannte.


Aber leider löst das noch nicht mein Problem...
Kannst Du nicht (alternativ oder hintereinader):
1. Den Lösungsvorschlägen der klugen Leute hinsichtlich der Sitzungs-/Einlog-Magager folgen?
2. Zumindest zeitweise einen anderen Session-Manger probieren?
3. Zumindest vorerst ein Live-Abbild mit LXDE drauf ausprobieren (ohne Dein [produktives?] weiter zu ärgern?)?
4. Die LXDE-Pakete aus der Factory (zusammen mit openSUSE 11.2 überhaupt eine gute Idee?) wieder herunter schmeißen und per 1-Click Install oder manueller Einbindung der für 11.2 gedachten Verzeichnisse LXDE einen etwa weniger 'experimentellen' Weg als den von Dir eingeschlagenen ausprobieren?

Nur so ein paar Ideen...
Viel Glück
pistazienfresser

felbre
19-Aug-2010, 03:36
Schau mal in die /etc/sysconfig/windowmanager
AFAIK müsste es reichen wenn du als Default dort openbox-lxde einträgst.

Danke für den Tipp! Werde ich später mal ausprobieren.

Wo würde zudem der Loginmanager lxdm konfiguriert werden (anstatt xdm)? ;)

pistazienfresser
19-Aug-2010, 03:48
Du magst evtl. recht haben:
WindowManager - LinuxWiki.org - Linux Wiki und Freie Software (http://linuxwiki.de/WindowManager)

Aber leider löst auch das noch nicht mein Problem.

Kennst Du Dich vielleicht aus mit den Konfigurationstools sax bzw. xorgconfig (ich glaube, die haben noch eine tückische Großschreibung in der Syntax)? Würde mir das vielleicht weiterhelfen?

SaX2 wird ab 11.2 nur noch teilweise und ab dem Erscheinen von 11.3 meines Wissens nach gar nicht mehr gepflegt:
SaX2 (http://de.opensuse.org/SaX2)
Archive:SaX2 - openSUSE (http://en.opensuse.org/index.php?title=Archive:SaX2&oldid=14388)

Ich würde spontan mal in der Gegend von
Yast2>System Configuration Editor=/etc/sysconfig Editor
> Display > Displaymagager
herumprobieren um entweder einen anderen
(Possible Values: kdm, kdm3, kdm4, xdm, gdm, wdm, console or any value)
zu wählen oder die Einstellungen des von Dir gewählten zu ändern.

Mal sehen, was die klugen Leute dazu meinen....

pistazienfresser

lOtz1009
19-Aug-2010, 04:16
Wenn der LXDM überhaupt installiert ist, dann über lxdm-conf ;)
Im Zweifelsfall mal schauen ob das Paket lxdm und lxdm-conf installiert ist.
Aber soweit ich mich entsinne kannst du mit lxdm-config selbst nicht die Verwendung von LXDM aktivieren. Dies geschieht über
Ich würde spontan mal in der Gegend von
Yast2>System Configuration Editor=/etc/sysconfig Editor
> Display > Displaymagager
herumprobieren um entweder einen anderen
(Possible Values: kdm, kdm3, kdm4, xdm, gdm, wdm, console or any value)

felbre
19-Aug-2010, 12:01
Ich würde spontan mal in der Gegend von
Yast2>System Configuration Editor=/etc/sysconfig Editor
> Display > Displaymagager
herumprobieren um entweder einen anderen
(Possible Values: kdm, kdm3, kdm4, xdm, gdm, wdm, console or any value)
zu wählen oder die Einstellungen des von Dir gewählten zu ändern.

Mal sehen, was die klugen Leute dazu meinen....

pistazienfresser

Das mit dem Sysconfig-Editor war ein super Tipp! Einfacher geht's an sich kaum noch. Muss ich mir unbedingt merken...

Ansonsten habe ich jetzt leider noch das Problem, dass der LXDM Login-Manager nicht funzt. Aber das ist leider ein systembedingtes Problem unter OpenSuSE 11.2, was sich ggf. mit einem Patch lösen ließe: LXDE/Applications/lxdm - openSUSE (http://old-en.opensuse.org/LXDE/Applications/lxdm) .

Ich werde nun jedoch ein Update auf 11.3 wagen, wo LXDE ja bekanntlich sauber unterstützt wird...

Besten Dank nochmal für die tolle Hilfe!

felbre
19-Aug-2010, 12:06
Entschuldige, dass ich Dich nicht verstehe. XFCE und LXDE sind für mich keine Window Manager sondern Desktop Environments. Das heißt, wenn Du ein anderes DE auspropieren musst, musst Du wenigstens das Basissystem des Desktop Environments installieren. Damit Dein XDM etwas anderes startet musst Du die Konfigurationsdateien von xdm editieren. Die verstecken sich ggf. hier: /etc/X11/xdm. Ich bin mir aber nicht sicher weil ich kein XDM verwende.

Ein Blick in den Sysconfig-Editor unter Yast zeigt, dass dort tatsächlich bloß "Display"- und "Window"-Manager zu konfigurieren sind. Ein Desktop Environment gibt es hier allenfalls in den erweiterten Optionen.

However... :shame:

felbre
19-Aug-2010, 12:10
Schau mal in die /etc/sysconfig/windowmanager
AFAIK müsste es reichen wenn du als Default dort openbox-lxde einträgst.

Der Sysconfig-Editor unter Yast ist ein super Tipp!

Openbox fand ich als Desktop allerdings nicht so prickelnd. Das ist ja im Prinzip ein schwarzer Bildschirm. Für meine Begriffe etwas zu spartanisch gelöst. Aber alternativ gäbe es auch eine openbox-kde Variante. Diese wiederum scheint mir schon ziemlich komfortabel zu sein...

Besten Dank nochmals für die fleißige und prompte Hilfe!

felbre
20-Aug-2010, 15:17
Update: ich habe heute Abend also eine Aktualisierung gemacht auf OpenSuSE 11.3. Leider bootet mir mein Laptop immer noch in den XFCE Desktop, obwohl ich mittlerweile in der /etc/sysconfig, sowie via lxcc "startlxde" (mit Auto User Login) eingetragen habe. Irgendwelche Ideen, warum? Ich würde dabei den LXDE Desktop wirklich gerne bevorzugen, weil er tatsächlich wesentlich schneller zu starten scheint als XFCE.

Naja, jetzt geht leider auch das WLAN nicht mehr (sh. anderes Posting an entsprechender Stelle). Hoffentlich muss ich deswegen den Laptop nicht komplett neu aufsetzen? Immerhin: LXDM als Login-Manager funzt! :P

--

Gut's Nächtle,
Felix :O