Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: msi ge70 nvidia gt750m lots of problem with opensuse12.3

  1. #1

    Default msi ge70 nvidia gt750m lots of problem with opensuse12.3

    dear all,
    sorry for beginner questions, but i feel lost!
    i try my best by reading a lot of thread here, still i can't fix the screen brightness, the wireless, the video...
    1- when i try to run the soft paraview i got this message:

    vtkXOpenGLRenderWindow (0x221d230): Could not find a decent visual
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".





    before installing nivida paraview was running perfectly well!

    ls -la /etc/X11/xorg.conf.d
    give

    total 48
    drwxr-xr-x 2 root root 4096 Aug 11 10:22 .
    drwxr-xr-x 11 root root 4096 Aug 8 11:44 ..
    -rw-r--r-- 1 root root 61 Mar 2 08:51 05-glamor.conf
    -rw-r--r-- 1 root root 1099 Jul 15 23:25 10-evdev.conf
    -rw-r--r-- 1 root root 3640 Jan 28 2013 11-mouse.conf
    -rw-r--r-- 1 root root 529 Jul 1 2011 50-device.conf
    -rw-r--r-- 1 root root 527 Jul 1 2011 50-monitor.conf
    -rw-r--r-- 1 root root 491 Jul 1 2011 50-screen.conf
    -rw-r--r-- 1 root root 1918 Feb 5 2013 50-synaptics.conf
    -rw-r--r-- 1 root root 115 Jan 28 2013 50-vmmouse.conf
    -rw-r--r-- 1 root root 835 Jan 28 2013 50-wacom.conf
    -rw-r--r-- 1 root root 144 Aug 8 12:10 90-keytable.conf



    if i do

    linux-dgf5:/home/laurent # lspci
    00:00.0 Host bridge: Intel Corporation Haswell DRAM Controller (rev 06)
    00:01.0 PCI bridge: Intel Corporation Haswell PCI Express x16 Controller (rev 06)
    00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
    00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)
    00:14.0 USB controller: Intel Corporation Lynx Point USB xHCI Host Controller (rev 04)
    00:16.0 Communication controller: Intel Corporation Lynx Point MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #1 (rev d4)
    00:1c.2 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #3 (rev d4)
    00:1c.3 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #4 (rev d4)
    00:1c.5 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #6 (rev d4)
    00:1d.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation Lynx Point LPC Controller (rev 04)
    00:1f.2 IDE interface: Intel Corporation Lynx Point 4-port SATA Controller 1 [IDE mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation Lynx Point SMBus Controller (rev 04)
    00:1f.5 IDE interface: Intel Corporation Lynx Point 2-port SATA Controller 2 [IDE mode] (rev 04)
    01:00.0 3D controller: NVIDIA Corporation Device 0fe4 (rev a1)
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5227 (rev 01)
    04:00.0 Ethernet controller: Atheros Communications Inc. Device e091 (rev 13)
    05:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8723

    2-the brightness is a desaster for my eyes at night!
    i have xbacklight install but nothing that i read here run...
    any help would be very wellcome, i thanks you be advance
    best regards LL

    for the wireless and the video camera, the is no urgency...

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,036
    Blog Entries
    12

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Re. the NVIDIA: you have an Optimus config, where there's an Intel (see) graphics card + an NVIDIA. A hardware setup like that needs Bumblebee, see Smithfarm - the Brain: openSUSE 12.3: How to install 'bumblebee' for NVIDIA Optimus VGA
    Re. the screen brightness, is it the keys that don't work, or can't you change anything through the desktop settings?
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    hi,
    thanks you for answering, by chance i can still write to you with a other computer, because i may break something on the msi one...
    i did as it said;
    And make sure to remove all packages and repositories relating to any previous installation of proprietary NVidia driver, Bumblebee, etc.
    now went it start there is no more kde, just a
    Welcome to opensuse 12.3 'dartmouth' kernek 3.7.10.1.16 destop tty1
    linux-dgf5 login;_
    like in a terminal...
    before that i get a error install fail, for the command
    # zypper in dkms-nvidia

    what can i do.??? all this is very stressful!!!
    to answer the brightness wasn t changing by any of kde setting, even power managerment, or short cut setting, or echo 9 backlight etc thinks... i try a lot... lo learn...

  4. #4

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    did i make something wrong.?
    i just don t understand why in 2013 it is so complicate to make thinks running ! the installation of nvidia fail, i went back to VGA and get kde back. then i try the first thing to do on this page;
    SDB:Configuring graphics cards - openSUSE
    and i get this message, that some partition in the system on sda6 are mounted by kernel-device name. this is not reliable for the update etc start the old system and change the mount by method...
    my wife just make a nervous break done because i spent all Saturday just the try to by able to adjust the brightness on a new computer!!!
    cheers LL

  5. #5

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Dear all,
    sorry to have been a little pessimist, lets be practical and persistent
    so
    Laptop msi ge70
    dual boot windows /opensuse 12.3 kde
    video carte nvidia geforce gt750m

    gpu intel(r) hd graphics 4600
    I install bumblebee following Smithfarm - the Brain: openSUSE 12.3: How to install 'bumblebee' for NVIDIA Optimus VGA
    but point 12 ok
    13 I had:


    laurent@linux-dgf5:~> primusrun glxspheres
    glxspheres: libglfork.cpp:244: PrimusInfo:rimusInfo(): Assertion `ncfg' failed.
    Aborted


    but if I do


    laurent@linux-dgf5:~> optirun glxspheres
    Polygons in scene: 62464
    Visual ID of window: 0x21
    Context is Direct
    OpenGL Renderer: GeForce GT 750M/PCIe/SSE2
    104.273457 frames/sec - 116.369178 Mpixels/sec
    104.361036 frames/sec - 116.466916 Mpixels/sec
    105.177407 frames/sec - 117.377986 Mpixels/sec
    96.488737 frames/sec - 107.681431 Mpixels/sec
    89.452579 frames/sec - 99.829078 Mpixels/sec


    it look like I got optimus and not primus... do i need to do point 15 to 20 ?



    laurent@linux-dgf5:~> optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.


    The problem is that paraview program need glx
    laurent@linux-dgf5:~> paraview
    ERROR: In /home/sergio/rpmbuild/BUILD/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
    vtkXOpenGLRenderWindow (0x32858a0): Could not find a decent visual
    ERROR: In /home/sergio/rpmbuild/BUILD/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 609
    vtkXOpenGLRenderWindow (0x32858a0): GLX not found. Aborting.

    thanks you for helping LL

  6. #6
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    523

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Try reinstalling the package xorg-x11-server.

  7. #7

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    hi,
    thanks a lot for helping a beginner!
    i tried to upload xorg-x11-server; doesn't change the problem. shall i uninstall and reinstall, even if there is warning message from Yast when you uninstall..???-(break dependency etc...)
    thanks again LL

  8. #8
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    523

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Quote Originally Posted by lolo98 View Post
    hi,
    thanks a lot for helping a beginner!
    i tried to upload xorg-x11-server; doesn't change the problem. shall i uninstall and reinstall, even if there is warning message from Yast when you uninstall..???-(break dependency etc...)
    thanks again LL
    I don't fully understand what you mean with "upload", but just open up Yast software management, search for the package, the checkbox should have an "X" in it click on it once and that will change to a green checkmark, then click Accept. There should be no dependency warnings about that, it's just ment to recover any files that have been deleted or overwritten by some other measures you've taken. Glx support for the integrated Intel chip is still needed for bumblebee to work, xorg-x11-server provides that support.

  9. #9

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Quote Originally Posted by hank_se View Post
    I don't fully understand what you mean with "upload",
    oh, sorry for being unclear! i should have tell you that i already have the green check-mark in Yast !
    here is may be the mistake i should have uninstall it before doing bumblebee installation?
    thanks for your help and advices

  10. #10
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    523

    Default Re: msi ge70 nvidia gt750m lots of problem with opensuse12.3

    Quote Originally Posted by lolo98 View Post
    oh, sorry for being unclear! i should have tell you that i already have the green check-mark in Yast !
    here is may be the mistake i should have uninstall it before doing bumblebee installation?
    thanks for your help and advices
    This suggests to me that you have pending updates, it's very important, mandatory I should say, that your system is fully up to date before you install software like bumblebee. So fire up a terminal, su to root and run zypper up, that might be all you need to do.

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •