Results 1 to 8 of 8

Thread: ragged/shifted screen on HD7670M w radeon/fglrx

  1. #1

    Default ragged/shifted screen on HD7670M w radeon/fglrx

    Hi people.


    I am currently having massive trouble with the configuration of the graphics on a friends laptop.
    The specs are as follows:


    Laptop: Toshiba Satellite L850-1L1
    CPU: i7-3630QM
    GPU: AMD Radeon HD 7670M @ 2GB DDR3 VRAM
    internal display Resolution: 1366 x 768
    Linux System: OS 12.3 64bit Install, KDE desktop, UEFI boot using GRUB2-EFI
    Windows system: Windows 8


    Problem description:
    Category: Screen distortion/displacement
    drivers: radeon, fglrx


    I first ran into a problem when trying to install OS 12.3 parallel to the preinstalled W8.
    At that time the bootloader refused an installation yielding an error saying sth. That “mkinitrd” failed and listing “radeon”. That was when I tried to install after switching from UEFI to CMS (trying to avoid any modiication to the existing W8 install, lest I damage it).



    Then I tried an installation with(!) UEFI enabled but forced text-mode installation for good measure(?). That worked all right.
    Problems started after the installation and configuration was complete. The system booted into a screen as in the following picture:


    OutTop.jpg - Bilder und Fotos kostenlos auf ImageBanana hochladen



    I then rebooted into failsafe mode and instaled the proprietary AMD driver. After running
    Code:
    aticonfig –initial


    and a reboot I got an output similar to this:


    StripedShifted.jpg - Bilder und Fotos kostenlos auf ImageBanana hochladen



    fiddling with aticonfig, hsync, vsync settings and Catalyst Control Center did not bring any changes, so I uninstalled fglrx in failsafemode using
    Code:
    aticonfig –uninstall


    Then got the same problem back as before.


    After a few more installs/uninstalls of FGLRX (script-install, generating a system specific package then installing it) and looking in the forums I found the proposition of appending “radeon.modeset=1” to the boot commands. That seemed to work when using the “radeon” driver.


    As the system was simply alive, not allowing any changes to screen resolution I decided to try FGLRX again (yeah – ignoring the saying “never touch a running system”)


    That went horribly wrong. Installing FGLRX as described in SDB (from the listed repos) (all with multiple reboots and blacklisting of “radeon”) didn't help the problem, still the warped and striped screen. Same holds for “radeon” though the problem there shifted to the warped and striped screen instead of simply an out-top screen.
    Note here: the “radeon.modeset=1” option did not help me again but “nomodeset” left the system at the message “Starting graphical interface” where the X-Server dies (be it fglrx or radeon driver).


    I have tried the suggestions written in:
    https://forums.opensuse.org/english/...ard-issue.html


    https://forums.opensuse.org/english/...ears-left.html


    and


    https://forums.opensuse.org/english/...y-problem.html


    I have tried these suggestions for both drivers. The xorg.conf file used with fglrx is



    Code:
     Section "ServerLayout" 
     	Identifier     "aticonfig Layout"  
     	Screen      0  "aticonfig-Screen[0]-0" 0 0  
     EndSection  
     
    
     Section "Module" 
     #	Disable "dri"  
     #	Disable "dri2" 
     EndSection  
     
    
     Section "Monitor" 
     	Identifier   "aticonfig-Monitor[0]-0"  
     	Option	    "VendorName" "ATI Proprietary Driver"  
     	Option	    "ModelName" "Generic Autodetecting Monitor"  
     #	Option	    "DPMS" "true"  
     	Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync  
     #	Modeline "1368x768_76.00"   111.00 1368 1448 1592 1816  768 771 781 805 -hsync +vsync  
     EndSection  
    
     
    
     Section "Device" 
     	Identifier  "aticonfig-Device[0]-0"  
     	Driver      "fglrx" 
     	Option	    "Capabilities" "0x00000800"  
     	Option	    "Centermode" "off"  
     	Option	    "UseFastTLS" "off"  
     #	Driver	    "radeon" 
     	BusID       "PCI:1:0:0" 
     EndSection  
     
    
     Section "Screen" 
     	Identifier "aticonfig-Screen[0]-0"  
     	Device     "aticonfig-Device[0]-0"  
     	Monitor    "aticonfig-Monitor[0]-0"  
     	DefaultDepth     24  
     	SubSection "Display" 
     		Viewport   0 0  
     		Depth     24  
     		Modes    "1368x768" 
     	EndSubSection  
     EndSection


    The best results were achieved with this – once two consecutive reboots with a normal screen.
    As the tips in the above threads were made for the radeon driver I have tried them with it, putting the settings into /etc/X11/xorg.conf.d/50-device.conf and 50-monitor.conf, that did not do any good – only two startups with shifted screen, then back to the out-top one.


    I also tried the configuration from ArchWiki, but it did not help.


    Currently the laptop is running with “x11failsafe” boot option, to allow at least some work but this problem seriously annoys me.


    The Xorg.0.log.old are for different startups. The first one is a startup with fglrx, the next one is with radeon into normal mode and then radeon and failsafe mode :

    SUSE Paste
    SUSE Paste

    SUSE Paste





    Does anybody have any idea how one could tackle it? I would appreciate it very much, as I have spent 12+h on this, any driver would be fine, as long as it at least works)


    Yours


    Aquinox

  2. #2

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    Suse Paste with fglrx drivers installed from an OS-repository as indicated in SDB:fglrx

    SUSE Paste

    SUSE Paste

  3. #3

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    On Fri, 09 Aug 2013 09:36:03 GMT
    Aquinox <Aquinox@no-mx.forums.opensuse.org> wrote:

    > I have tried the suggestions written in:


    >
    > http://tinyurl.com/lx7ellk


    Your picture of the sideways shift is the same as I experienced on a
    Radeon machine - though without the horizontal stripes.

    Did you check the bug report I referred to in the above link?
    If not, start at comment 11 as most of what goes before is me
    demonstrating my ignorance - again.
    https://bugzilla.novell.com/show_bug.cgi?id=803026#c11

    As it says later, a change to GRUB2 screen resolution of 800x600 worked
    for me but that may not be true for your machine.

    I've tried 13.1-M4 on the offending machine and that works OK for GRUB2.



    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 12.3 (64-bit); KDE 4.11.0; AMD Phenom II X2 550 Processor;
    Kernel: 3.10.6; Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  4. #4

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    I have tried to set different vga modes for GRUB2-EFI, both using yast and maually during boot.

    At least visually there did not seem to be any difference.

    For now I'm playing with different Modelines and options for the fglrx driver (albeit they seem to be stubbornly ignored) with very minor results.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    15,300
    Blog Entries
    14

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    Hi
    So I have a 7340 and had to run aticonfig to run CodeXL, before that I had no /etc/X11/xorg.conf and everything worked fine with just installing fglrx as per the SDB article and the 13.4 script....

    Code:
    /sbin/lspci -nnk |grep VGA
    
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 7340] [1002:9808]
    
    
    cat /etc/X11/xorg.conf
    
    Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    
    Section "Module"
    EndSection
    
    
    Section "Monitor"
        Identifier    "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "BlockSignalsOnLock" "off"
        BusID       "PCI:0:1:0"
    EndSection
    
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    Greetings, has anyone found solution to the problem mentioned by the original poster?

    Specifically the solution mentioned by malcolmlewis
    Quote Originally Posted by malcolmlewis View Post
    Hi
    So I have a 7340 and had to run aticonfig to run CodeXL, before that I had no /etc/X11/xorg.conf and everything worked fine with just installing fglrx as per the SDB article and the 13.4 script....
    is it working for the AMD Radeon 7670M?

    I'm considering buying the same laptop and install the latest opensuse version, so i'm having second thoughts now.

  7. #7

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    Also has anyone used the tutorial below for ATI 7XXX series, with success?

    SDB:AMD fglrx - openSUSE

    thank you in advance

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    15,300
    Blog Entries
    14

    Default Re: ragged/shifted screen on HD7670M w radeon/fglrx

    Quote Originally Posted by sthrss View Post
    Also has anyone used the tutorial below for ATI 7XXX series, with success?

    SDB:AMD fglrx - openSUSE

    thank you in advance
    Hi
    I use the "Building the rpm yourself" method, works a treat, plus adds an automatic rebuild/install after a kernel upgrade.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •