Results 1 to 4 of 4

Thread: Tip: Play MIDI files with VLC

  1. #1

    Default Tip: Play MIDI files with VLC

    Install VLC packages and snd_sf2 package.

    VLC -> Tools -> Preferences -> Show Settings: All -> Input/Codecs -> Audio Codecs -> FluidSynth -> Sound Fonts: /usr/share/sounds/sf2/Vintage_Dreams_Waves_v2.sf2 -> Save -> Close VLC -> Open VLC again.


    OpenSUSE 12.2

    Installed packages:

    vlc 2.0.6-123.2

    vlc-codecs 2.0.6-123.2

    vlc-noX 2.0.6-123.2

    libvlc5 2.0.6-123.2

    libvlccore5 2.0.6-123.2

    vlc-aout-pulse 2.0.6-123.2

    vlc-qt 2.0.6-123.2

    snd_sf2 0.1.2-672.1.1


    VLC repository:

    Index of /suse/openSUSE_12.2/Essentials/


    VLC RPM packages:

    Index of /suse/openSUSE_12.2/Essentials/i586/

    Index of /suse/openSUSE_12.2/Essentials/x86_64/




    SND_SF2 Repository:

    Index of /distribution/12.2/repo/oss/suse


    SND_SF2 RPM package:

    Index of /distribution/12.2/repo/oss/suse/noarch

  2. #2

    Default Re: Tip: Play MIDI files with VLC

    First error message from VLC without snd_sf2 package installed:

    MIDI synthesis not set up:

    A sound font file (.SF2) is required for MIDI synthesis.
    Please install a sound font and configure it from the VLC preferences (Input / Codecs > Audio codecs > FluidSynth).


    No suitable decoder module:
    VLC does not support the audio or video format "MIDI". Unfortunately there is no way for you to fix this.



  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    976

    Default Re: Tip: Play MIDI files with VLC

    This worked for me, I don't usually play MIDI with VLC but tested it now. I tested it with two local .sf2 sound-fonts (Chromium and Fluid, both GM).

    Did it work for you as well? I was a bit puzzled by the second post but expected it to a be an illustration of a potential error message from not having a configured sound-font set up (or installed).
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, NVIDIA GTX 550 Ti, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4

    Default Re: Tip: Play MIDI files with VLC

    Quote Originally Posted by F_Sauce View Post
    This worked for me, I don't usually play MIDI with VLC but tested it now. I tested it with two local .sf2 sound-fonts (Chromium and Fluid, both GM).

    Did it work for you as well? I was a bit puzzled by the second post but expected it to a be an illustration of a potential error message from not having a configured sound-font set up (or installed).

    Yes, the second post should be the first.
    You can not edit the post after 10 minutes so I had to make another comment.

    The error message occurs if you do not install the package snd_sf2 and set it in VLC.

    On my system is working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •