Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: sound crackling and popping

  1. #1

    Default sound crackling and popping

    i get crackling and popping in my sound. i cant figure out how to get rid of the crackling. i dont have a sound card. i didnt need a card im using my i7 CPU and p8z77 v deluxe motherboard for sound

    in my file 50-sound.conf

    options snd slots=snd-hda-intel
    # u1Nb.ol2_+rEHIw7:Intel Corporation
    alias snd-card-0 snd-hda-intelfile

    Code:
    su@linux-4902:~> head -n 1 /proc/asound/card0/codec*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC898
    
    ==> /proc/asound/card0/codec#3 <==
    Codec: Intel PantherPoint HDMI
    su@linux-4902:~>
    [CODEsu@linux-4902:~> speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.26

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 64 to 262144
    Period size range from 32 to 131072
    Using max buffer size 262144
    Periods = 4
    was set period_size = 65536
    was set buffer_size = 262144
    0 - Front Left
    1 - Front Right
    Time per period = 5.480887
    0 - Front Left
    1 - Front Right
    Time per period = 5.466056
    0 - Front Left
    1 - Front Right
    Time per period = 5.465691
    0 - Front Left
    1 - Front Right
    Time per period = 5.466483
    0 - Front Left
    1 - Front Right
    Time per period = 5.465817][/CODE]

    Code:
    su@linux-4902:~> cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version k3.7.10-1.4-desktop.
    Code:
    su@linux-4902:~> cat /proc/asound/modules
     0 snd_hda_intel
    Code:
    su@linux-4902:~> cat /proc/asound/cards
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xf7c30000 irq 80
    su@linux-4902:~>

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: sound crackling and popping

    Quote Originally Posted by diablo1 View Post
    i get crackling and popping in my sound. i cant figure out how to get rid of the crackling. i dont have a sound card. i didnt need a card im using my i7 CPU and p8z77 v deluxe motherboard for sound

    in my file 50-sound.conf

    options snd slots=snd-hda-intel
    # u1Nb.ol2_+rEHIw7:Intel Corporation
    alias snd-card-0 snd-hda-intelfile

    Code:
    su@linux-4902:~> head -n 1 /proc/asound/card0/codec*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC898
    
    ==> /proc/asound/card0/codec#3 <==
    Codec: Intel PantherPoint HDMI
    su@linux-4902:~>
    [CODEsu@linux-4902:~> speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.26

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 64 to 262144
    Period size range from 32 to 131072
    Using max buffer size 262144
    Periods = 4
    was set period_size = 65536
    was set buffer_size = 262144
    0 - Front Left
    1 - Front Right
    Time per period = 5.480887
    0 - Front Left
    1 - Front Right
    Time per period = 5.466056
    0 - Front Left
    1 - Front Right
    Time per period = 5.465691
    0 - Front Left
    1 - Front Right
    Time per period = 5.466483
    0 - Front Left
    1 - Front Right
    Time per period = 5.465817][/CODE]

    Code:
    su@linux-4902:~> cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version k3.7.10-1.4-desktop.
    Code:
    su@linux-4902:~> cat /proc/asound/modules
     0 snd_hda_intel
    Code:
    su@linux-4902:~> cat /proc/asound/cards
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xf7c30000 irq 80
    su@linux-4902:~>
    So I have never thought much of Realtek Sound chipsets and normally buy and install a Creative sound card if I have that option (not a Laptop) else you could look at installing their driver.

    They do show to have Linux support: Realtek

    Other things to look at include: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

    AND

    For even more info on using pavucontrol, have a look at this blog by oldcpu: Pulseaudio Basics for openSUSE with pavucontrol

    AND

    For Sound Testing and such: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.11 - Blogs - openSUSE Forums

    AND

    I have a bash script for testing sound you can find here: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15 - Blogs - openSUSE Forums

    AND

    If you have issues in playing video in openSUSE, then for Multimedia Setup in openSUSE 12.3, please have a look here: openSUSE 12.3 Multi-media and Restricted Format Installation Guide

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: sound crackling and popping

    I downloaded the realtek drivers and looked at the install directions but no luck. How do i install them? i downloaded the drivers extracted the folder to my desktop and opened a terminal in that folder and thats it, how do i install them?

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: sound crackling and popping

    Quote Originally Posted by diablo1 View Post
    I downloaded the realtek drivers and looked at the install directions but no luck. How do i install them? i downloaded the drivers extracted the folder to my desktop and opened a terminal in that folder and thats it, how do i install them?
    Installing the realtek drivers is a drastic measure, and very difficult if not impossible to undue once done. Hence IMHO this should be only a last resort. Did you try other measures wrt pulse audio? For example the newer implementation of PulseAudio sound server uses a timer-based audio scheduling instead of the traditional interrupt-driven approach.

    Timer-based scheduling may expose issues in some ALSA drivers. On the other hand, other drivers might be glitchy without it on, so check to see what works on your system.

    To turn timer-based scheduling off add tsched=0 in /etc/pulse/default.pa:
    Code:
    load-module module-udev-detect tsched=0
    Then restart the PulseAudio server:
    Code:
    pulseaudio -k
    pulseaudio --start
    (or resart if those pulse audio commands do not restart the pulseaudio server).

    Do the reverse to enable timer-based scheduling, if not already enabled by default.

    And test your audio.

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: sound crackling and popping

    Also, try not to have PCM/Master volume at maximum, as that can cause sound crackling and popping.

  6. #6
    Join Date
    Jan 2010
    Posts
    6,707

    Default Re: sound crackling and popping

    Or you could try to turn off PulseAudio and see if that helps. (or turn it on if it already is turned off)

    Enter YaST->Hardware->Sound, click on "Other" in the bottom-right and select "PulseAudio Configuration".

  7. #7

    Default Re: sound crackling and popping

    i typed in the code you suggested and it didnt work, i got these results


    Code:
    linux-r94p:/home/suse1 # load-module module-udev-detect tsched=0
    If 'load-module' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf load-module
    linux-r94p:/home/suse1 #  cnf load-module
    load-module: command not found                            
    linux-r94p:/home/suse1 #
    turning down thePCM/Master didnt stop the crackling popping.
    also i tired turning off pulseaudio and that didnt work either.

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: sound crackling and popping

    Quote Originally Posted by diablo1 View Post
    i typed in the code you suggested and it didnt work, i got these results
    I don't think you understood my post. I quote:

    Quote Originally Posted by oldcpu View Post
    To turn timer-based scheduling off add tsched=0 in /etc/pulse/default.pa:
    Code:
    load-module module-udev-detect tsched=0
    Then restart the PulseAudio server:
    Code:
    pulseaudio -k
    pulseaudio --start
    (or resart if those pulse audio commands do not restart the pulseaudio server).

    Do the reverse to enable timer-based scheduling, if not already enabled by default.

    And test your audio.
    "add tsched=0 in /etc/pulse/default.pa" does not mean send it in at terminal as a command. Please note that /etc/pulse/default.pa is a file to edit.

    I don't know how to send it in a terminal. Possibly something like:
    Code:
    pactl load-module module-udev-detect tsched=0
    and do NOT restart pulse, but thats pure speculation on my part. Rather just follow my quoted post instruction.

  9. #9

    Default Re: sound crackling and popping

    where in the file do I add add tsched=0 at the very top beginning or at the end of all the writing?

    Quote Originally Posted by oldcpu View Post
    I don't think you understood my post. I quote:



    "add tsched=0 in /etc/pulse/default.pa" does not mean send it in at terminal as a command. Please note that /etc/pulse/default.pa is a file to edit.

    I don't know how to send it in a terminal. Possibly something like:
    Code:
    pactl load-module module-udev-detect tsched=0
    and do NOT restart pulse, but thats pure speculation on my part. Rather just follow my quoted post instruction.

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: sound crackling and popping

    Quote Originally Posted by diablo1 View Post
    where in the file do I add add tsched=0 at the very top beginning or at the end of all the writing?

    Quote Originally Posted by oldcpu View Post

    "add tsched=0 in /etc/pulse/default.pa" does not mean send it in at terminal as a command. Please note that /etc/pulse/default.pa is a file to edit.
    Code:
    load-module module-udev-detect tsched=0
    Its easier to see if you quote the salient points in my post (I highlighted in red above to make more clear).

    Open /etc/pulse/default.pa. Search for a line with "load-module module-udev-detect" in the line. Add "tsched=0" at the end of that line.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •