Results 1 to 10 of 10

Thread: mariaDB

  1. #1

    Default mariaDB

    Hi there!
    mysql service don't start from Yast services console (unknown error).
    Is any configuration necessary in order to run mysql (mariaDB) on openSuse 12.3?

    Thank you, in advance.
    [Adrián E. Córdoba]

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,390

    Default Re: mariaDB

    The output from the following will probably provide some good hints if not tell you exactly what/where the problem is

    Code:
    systemctl status mysql.service
    HTH,
    TSU

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: mariaDB

    Quote Originally Posted by aecordoba View Post
    Hi there!
    mysql service don't start from Yast services console (unknown error).
    Is any configuration necessary in order to run mysql (mariaDB) on openSuse 12.3?

    Thank you, in advance.
    Restart and try the "runlevel". Sometimes after restart it works
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  4. #4

    Default Re: mariaDB

    Quote Originally Posted by tsu2 View Post
    The output from the following will probably provide some good hints if not tell you exactly what/where the problem is

    Code:
    systemctl status mysql.service
    HTH,
    TSU
    Thank you, for answer.
    This is the output:

    ASIA:/home/adrian # systemctl status mysql.service
    mysql.service - LSB: Start the MySQL database server
    Loaded: loaded (/etc/init.d/mysql)
    Active: inactive (dead)
    CGroup: name=systemd:/system/mysql.service
    [Adrián E. Córdoba]

  5. #5

    Default Re: mariaDB

    Quote Originally Posted by vazhavandan View Post
    Restart and try the "runlevel". Sometimes after restart it works
    I restarted the system, but the same thing happen.
    [Adrián E. Córdoba]

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: mariaDB

    output of following is required to check as to what packages for mariadb is installed
    Code:
     zypper se -i maria*
    also you can try
    Code:
    su -
    systemctl restart mysql.service
    or

    Code:
    su -
    systemctl start mysql.service
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  7. #7

    Default Re: mariaDB

    Quote Originally Posted by vazhavandan View Post
    output of following is required to check as to what packages for mariadb is installed
    Code:
     zypper se -i maria*
    also you can try
    Code:
    su -
    systemctl restart mysql.service
    or

    Code:
    su -
    systemctl start mysql.service
    I could start mariaDB: I just uninstalled mariaDB, then installed mysql server, then uninstalled mysql server, and installed mariaDB again.
    Thank you very much.
    [Adrián E. Córdoba]

  8. #8
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: mariaDB

    Quote Originally Posted by aecordoba View Post
    I could start mariaDB: I just uninstalled mariaDB, then installed mysql server, then uninstalled mysql server, and installed mariaDB again.
    Thank you very much.
    Do you see any dependencies not getting installed ?
    You can use this command to check through the packages
    Code:
    rpm -qa --last | less
    It would be helpful if you find something and raise a bug here https://bugzilla.novell.com/
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,390

    Default Re: mariaDB

    Sounds like the service hasn't been set to start automatically on boot

    Haven't yet tested YAST to see if it works as expected, that should be one way to configure.

    The following should work, too
    Code:
    systemctl enable mysql.service
    HTH,
    TSU

  10. #10
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,064

    Default Re: mariaDB

    It certainly looks like a configuration/dependency error as I simply edited system services after installing 12.3 and mariaDB was there waiting to run.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •