Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: 12.3 File /repodata/repomd.xml' not found on medium

  1. #1

    Default 12.3 File /repodata/repomd.xml' not found on medium

    Greeting fellow SUSE'ers. I come to you today with an error that has been solved on 12.2, but I am using 12.3. I read a lot of the 12.2 articles on the following error, but seeing how there are different distro's I thought I should ask about 12.3 specifically. I took the liberty of posting the errors I was getting and doing a "zypper ls -d" for you guys. I am a big Linux user who was looking for a distro that was more refined the Mint. I landed on OpenSUSE Hopefully I can get some insight from the SUSE gurus here. Sorry for the long post, but I might as well post what you were going to ask me to post anyway


    Code:
    linux-elbg:~ # zypper up
    Retrieving repository 'openSUSE-12.3-Non-Oss' metadata --------------------------------------------------------------------------------------------------------------------------------------[\]
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/12.3/repo/non-oss/'
    
    Abort, retry, ignore? [a/r/i/?] (a): a
    Retrieving repository 'openSUSE-12.3-Non-Oss' metadata ..................................................................................................................................[error]
    Repository 'openSUSE-12.3-Non-Oss' is invalid.
    [|] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Disabling repository 'openSUSE-12.3-Non-Oss' because of the above error.
    Retrieving repository 'openSUSE-12.3-Oss' metadata ------------------------------------------------------------------------------------------------------------------------------------------[|]
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/12.3/repo/oss/'
    
    Abort, retry, ignore? [a/r/i/?] (a): a
    Retrieving repository 'openSUSE-12.3-Oss' metadata ......................................................................................................................................[error]
    Repository 'openSUSE-12.3-Oss' is invalid.
    [|] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Disabling repository 'openSUSE-12.3-Oss' because of the above error.
    Retrieving repository 'openSUSE-12.3-Update-Non-Oss' metadata ............................................................................................................................[done]
    Building repository 'openSUSE-12.3-Update-Non-Oss' cache .................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      systemtap systemtap-runtime



    Code:
    # | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                           
    --+---------------------------+------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------
    1 | repo-debug                | openSUSE-12.3-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.3/repo/oss/
    2 | repo-debug-update         | openSUSE-12.3-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3/               
    3 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3-non-oss/       
    4 | repo-non-oss              | openSUSE-12.3-Non-Oss              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/12.3/repo/non-oss/  
    5 | repo-oss                  | openSUSE-12.3-Oss                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/12.3/repo/oss/      
    6 | repo-update               | openSUSE-12.3-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3/                     
    7 | repo-update-non-oss       | openSUSE-12.3-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3-non-oss/
    Last edited by Scozzar; 20-Mar-2013 at 12:10. Reason: Brackets, yo.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,029
    Blog Entries
    16

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    Clearly the file is there.

    Do you otherwise have a active / working internet connection?

    What happens when you open Yast > Software > Software Management

    Also check:
    https://forums.opensuse.org/english/...nt-sticky.html

    You might also disable IPv6
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  3. #3

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    Yeah I have a blazing connection at my university. As you were probably expecting, I did get errors when I opened up the "Software Management" tab.










    Also, I ran through the link you posted and I got the same error you did, so it's already working.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,029
    Blog Entries
    16

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    Possible there is a proxy running at the University, that cripples the connection that zypp makes.

    I'm having to crash right now.

    I know someone else is sure to assist in my sleep mode. I've been running nearly 20hrs now, so my brain is all done. There is IIRC a possible solution, but it escapes me ATM.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  5. #5

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    Err I'm not so sure of that. The internet is unrestricted (no blocked sites or anything I know if) once I "log in" to the internet using my id number. Thanks for the help so far! If anyone else reading this wants to chime in, go right ahead.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,867

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    On 2013-03-20 21:46, caf4926 wrote:
    >
    > Possible there is a proxy running at the University, that cripples the
    > connection that zypp makes.


    There is a proxy setting that yast uses.
    Have a look at "/etc/sysconfig/proxy" and "/etc/sysconfig/onlineupdate".
    Just guessing.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,867

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    On 2013-03-20 22:06, Scozzar wrote:
    > Err I'm not so sure of that. The internet is unrestricted (no blocked
    > sites or anything I know if) once I "log in" to the internet using my id
    > number. Thanks for the help so far! If anyone else reading this wants
    > to chime in, go right ahead.


    Yes, but probably yast hast to "log in" as well. You are not the first
    to hit this problem.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #8

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    I went to the "Proxy" section in Yast and I found this....



  9. #9

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    Seeing how I can't edit posts, this is what I got.

    Code:
    ## Path:    Network/Proxy
    ## Description:    
    ## Type:    yesno
    ## Default:    no
    ## Config:      kde,profiles
    #
    # Enable a generation of the proxy settings to the profile.
    # This setting allows to turn the proxy on and off while
    # preserving the particular proxy setup.
    # 
    PROXY_ENABLED="no"
    
    ## Type:    string
    ## Default:    ""
    #
    # Some programs (e.g. lynx, arena and wget) support proxies, if set in
    # the environment. 
    # Example: HTTP_PROXY="http://proxy.provider.de:3128/"
    HTTP_PROXY=""
    
    ## Type:    string
    ## Default:    ""
    #
    # Some programs (e.g. lynx, arena and wget) support proxies, if set in
    # the environment. 
    # This setting is for https connections
    HTTPS_PROXY=""
    
    ## Type:    string
    ## Default:    ""
    #
    # Example: FTP_PROXY="http://proxy.provider.de:3128/"
    #
    FTP_PROXY=""
    
    ## Type:    string
    ## Default:    ""
    #
    # Example: GOPHER_PROXY="http://proxy.provider.de:3128/"
    #
    GOPHER_PROXY=""
    
    ## Type:    string(localhost)
    ## Default:    localhost
    #
    # Example: NO_PROXY="www.me.de, do.main, localhost"
    #
    NO_PROXY="localhost, 127.0.0.1"

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,029
    Blog Entries
    16

    Default Re: 12.3 File /repodata/repomd.xml' not found on medium

    I can't recall exactly what the issue has been in the past. But something in the way zypper downloads is seen like torrent traffic.
    The again I could be talking out of my (insert whatever comes to mind)

    I guess you could test some of the free proxy services
    Be sure to check the box: use same for all protocol
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •