Results 1 to 9 of 9

Thread: Cannot dual boot opensuse 12.3 and windows 7 !!

  1. #1

    Default Cannot dual boot opensuse 12.3 and windows 7 !!

    Hi everybody

    i have 2 HDD ,
    sda :: windows 7
    sdb :: opensuse 12.3

    first i already installed windows 7 , in sda , then i installed opensuse 12.3 on sdb but windows gone ! and no options in grub when booting to choice the windows or suse !! just booting in opensuse .

    I’m beginner in opensuse but the previous versions 12.2 working fine with dual boot with windows !!

    how can i slove this problem in easy way ?

    Thank you

  2. #2
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    474

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    your solution might be in this thread: https://forums.opensuse.org/english/...de-12-3-a.html which is to check "Probe Foreign OS" in Boot Loader options. Good luck!

  3. #3
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    55

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Quick tip to try:

    Yast->Boot Loader->Boot Loader Options->> enable/tick Probe Foreign OS.
    Linux & Open Source World
    E@zyVG's Vichar::World Connected

    Free and open-source software is good for you and for the world.

  4. #4

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Quote Originally Posted by dmera View Post
    your solution might be in this thread: https://forums.opensuse.org/english/...de-12-3-a.html which is to check "Probe Foreign OS" in Boot Loader options. Good luck!
    thank you but same problem after cheack "Probe Foreign OS" !

  5. #5

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Quote Originally Posted by EazyVG View Post
    Quick tip to try:

    Yast->Boot Loader->Boot Loader Options->> enable/tick Probe Foreign OS.
    Same , i tried every thing ,
    i didnt have this problem in 12.2 or 12.1 !!

  6. #6

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Here is my fdisk-l :

    PHP Code:
    linux-nfbp:~ # fdisk -l

    Disk /dev/sda500.1 GB500106780160 bytes
    255 heads
    63 sectors/track60801 cylinderstotal 976771055 sectors
    Units 
    sectors of 1 512 512 bytes
    Sector size 
    (logical/physical): 512 bytes 512 bytes
    I
    /O size (minimum/optimal): 512 bytes 512 bytes
    Disk identifier
    0xf26e37e0

       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *        2048   307202046   153599999+   7  HPFS/NTFS/exFAT
    /dev/sda2       307202048   976768064   334783008+   7  HPFS/NTFS/exFAT

    Disk 
    /dev/sdb80.0 GB80025280000 bytes
    255 heads
    63 sectors/track9729 cylinderstotal 156299375 sectors
    Units 
    sectors of 1 512 512 bytes
    Sector size 
    (logical/physical): 512 bytes 512 bytes
    I
    /O size (minimum/optimal): 512 bytes 512 bytes
    Disk identifier
    0x00089585

       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1            2048     4208639     2103296   82  Linux swap Solaris
    /dev/sdb2   *     4208640   156299263    76045312   83  Linux 

  7. #7

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Which bootloader are you using?
    Code:
    grep LOADER_TYPE /etc/sysconfig/bootloader

  8. #8
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    608

    Default Re: Cannot dual boot opensuse 12.3 and windows 7 !!

    Quote Originally Posted by ali8383 View Post
    Same , i tried every thing ,
    i didnt have this problem in 12.2 or 12.1 !!
    First, where did you install grub2 to, It would be nice to know. Also what drive is your bios booting first, also nice to know. Not knowing exactly what you have done my suggestions follow.

    Please have the windows drives mounted First, you should click on them in dolphin and it will ask for a password to mount it. Then go into YaST and the bootloader module and check the mark for "boot from root partition" or you can check "boot from master boot record" BUT if you check that please change the drop down menu to /dev/sdb.
    Now goto bootloader options and check you have options checked for "probe foreign os" , "set active flag for boot partition" and " write generic boot code to MBR".
    Hit the back button and the accept changes or OK.

    This is important!!
    When you reboot you will have to go into the bios and set the default boot harddrive HDD to the one that holds /dev/sdb.
    Now boot up and take note of what is there and try booting everything. Report back problems.
    OS: Linux 3.11.6-4-desktop
    System:
    openSUSE 13.1 (Bottle) (x86_64)
    KDE 4.11.2

  9. #9

    Default Cannot start opensuse 12.3 with Grub

    Good night community,
    I have install Win 7 and Opensuse 12.3 on a 64 Bits machine
    I'm very happy with the Linux distribution is really good
    But I have a serius problem:
    The Grub2 allowme to start in Opensuse only 3 or 4 times after the installation and then impossible to start again opensuse (Win7 works fine) the computer reboots automatically going to a loop.
    I had try several thinks like change the boot way, install Grub in text mode, change HD, and others but there is no solution. When I install Fedora 18 it works correctly but I want to keep opensuse becuase of his performace.
    Could someone helpme please, tahnks in advance.

    Sincerly. Bernardo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •