Results 1 to 3 of 3

Thread: Help with locale, perl and web browser interface

  1. #1
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    608

    Default Help with locale, perl and web browser interface

    I am having a major problem with access to my local slimserver web interface via any browser on my system. You access the interface with
    Code:
    http://localhost:9000
    The backend for the web interface is mostly perl that I installed by hand, more on that below.

    Here is the jumbled multi-language page that gets returned, this should just be in english.


    Here is the output from locale
    Code:
    lee@linux-r5rj:/opt> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=en_US.UTF-8
    I noticed the LANG and LC_ALL do not have quotes as do the others, is this ok? I set those two items in ./profile because perl complained about LANG not being set.

    Some Background and things I have tried:
    I installed perl 5.14 and Slimserver in a closed environment in /opt via instructions from www.jamesarbrown.com
    I also did this exact same install on another computer here last night and it works perfectly there, both computers are running 12.2 x64 KDE 4.10.
    I have removed everything and tried this a couple of times always with the same results.
    I copied the /opt directory from the other computer and copied it to this one and the web interface started in english but then morphed into the same mess of other languages and finally died completely (server crashed).

    Does anyone have any insight on what could be causing these issues?
    OS: Linux 3.11.6-4-desktop
    System:
    openSUSE 13.1 (Bottle) (x86_64)
    KDE 4.11.2

  2. #2

    Default Re: Help with locale, perl and web browser interface

    anika200 wrote:
    > I am having a major problem with access to my local slimserver web
    > interface via any browser on my system.


    I've no idea what slimserver is so I suppose I can't help much.

    But in general, I think you need to explain what you are trying to do
    and why you have done what you have and provide more detail if people
    are to help you.

    > You access the interface with
    > Code:
    > --------------------
    > http://localhost:9000
    > --------------------
    > The backend for the web interface is mostly perl that I installed by
    > hand, more on that below.
    >
    > Here is the jumbled multi-language page that gets returned, this should
    > just be in english.
    > [image: http://paste.opensuse.org/view/download/31780896]


    Well, it's an image of something with a message in various languages,
    but we have no idea of what you expect to see or why, or what's
    producing it, or where any information about that software can be found.

    > Here is the output from locale


    Why do you think locale is relevant?

    > Code:
    > --------------------
    > lee@linux-r5rj:/opt> locale
    > LANG=en_US.UTF-8
    > LC_CTYPE="en_US.UTF-8"
    > LC_NUMERIC="en_US.UTF-8"
    > LC_TIME="en_US.UTF-8"
    > LC_COLLATE="en_US.UTF-8"
    > LC_MONETARY="en_US.UTF-8"
    > LC_MESSAGES="en_US.UTF-8"
    > LC_PAPER="en_US.UTF-8"
    > LC_NAME="en_US.UTF-8"
    > LC_ADDRESS="en_US.UTF-8"
    > LC_TELEPHONE="en_US.UTF-8"
    > LC_MEASUREMENT="en_US.UTF-8"
    > LC_IDENTIFICATION="en_US.UTF-8"
    > LC_ALL=en_US.UTF-8
    >
    > --------------------
    >
    >
    > I noticed the LANG and LC_ALL do not have quotes as do the others, is
    > this ok? I set those two items in ./profile because perl complained
    > about LANG not being set.


    ../profile is a relative address, so it's meaningless unless you tell us
    what directory it is in. Or is it a typo, perhaps for ~/.profile? In
    either case, you should show the command itself and the surrounding
    shell prompts, cut-and-pasted from the terminal. That avoids typos.

    And why do you think profile is relevant? Web servers don't usually have
    login sessions!

    > Some Background and things I have tried:
    > I installed perl 5.14 and Slimserver in a closed environment in /opt
    > via instructions from 'www.jamesarbrown.com '
    > (http://www.jamesarbrown.com/?p=186)


    Why have you installed that perl? Why not use the one that came with the
    distro. And if you think the perl install is relevant, you need to show
    us computer output that proves you have installed and configured it
    correctly.

    > I also did this exact same install on another computer here last night
    > and it works perfectly there, both computers are running 12.2 x64 KDE
    > 4.10.


    You need to think about what the differences are.

    > I have removed everything and tried this a couple of times always with
    > the same results.
    > I copied the /opt directory from the other computer and copied it to
    > this one and the web interface started in english but then morphed into
    > the same mess of other languages and finally died completely (server
    > crashed).
    >
    > Does anyone have any insight on what could be causing these issues?


  3. #3
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    608

    Default Re: Help with locale, perl and web browser interface

    Hi, thanks for the reply. I can add more detail about the server I guess maybe it will help.

    Here is slimserver (Logitech media Server) wiki and here is slimserver screenshot running as it should.
    There is already a link in the original post that expains perfectly what I am trying to do but the synopsis is thus:
    1) Install Perl 5.14 in a "closed" environment in /opt because that is what is needed by the server and getting it to work with 5.16 is a pain.
    2) Build all the cpan modules needed by the server in /opt as instuctions via web link in original post and above.
    3) Install the server and run it with perl 5.14

    This all proceeds fine without any errors (well one but it is documented on the blog post linked to above). The server starts from the command line without any errors and there are no errors in its log.
    The problem is the language is all messed up as pictured in the original post and nothing can be done with it.

    The reason I am investigating the locale is because I feel like either building Perl or the Server it is not picking up the right Lang settings or something. This is also why I set some Lang variable in ~/.profile but I realize now this may not be doing anything while building under su -.

    I have now compared the output of
    Code:
    env > env.txt
    of both computers and made them basically the same. I then rebuilt everything and the results are the same as before. So now I am stuck again without a clue where to go from here.

    So basically what would be the next logical things to check on to solve this problem?
    Conceivably, I should be able to bring the server (copy /opt) from the computer it works on and install it here but that does not work either. So that has me stumped as well.
    Maybe this is some strange browser problem or setting but why would all the browsers act the same way.
    OS: Linux 3.11.6-4-desktop
    System:
    openSUSE 13.1 (Bottle) (x86_64)
    KDE 4.11.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •