Results 1 to 3 of 3

Thread: To old openGL(v1.4) for kivy

  1. #1

    Default To old openGL(v1.4) for kivy

    I don't know if this is the rigth catagory to post this problem in, but her you have it.
    I cant get kivy to work it needs a newer version of openGL i get this mesage:

    [INFO ] Kivy v1.5.1
    [INFO ] [Logger ] Record log in /home/ruben/.kivy/logs/kivy_13-03-03_3.txt
    [INFO ] [Factory ] 137 symbols loaded
    [DEBUG ] [Cache ] register <kv.lang> with limit=None, timeout=Nones
    [DEBUG ] [Cache ] register <kv.image> with limit=None, timeout=60s
    [DEBUG ] [Cache ] register <kv.atlas> with limit=None, timeout=Nones
    [DEBUG ] [Cache ] register <kv.texture> with limit=1000, timeout=60s
    [DEBUG ] [Cache ] register <kv.shader> with limit=1000, timeout=3600s
    [DEBUG ] [App ] Loading kv <./mypaint.kv>
    [DEBUG ] [App ] kv <./mypaint.kv> not found
    [INFO ] [Window ] using <pygame> as window provider
    libGL error: failed to load driver: swrast
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.
    [WARNING] [WinPygame ] Video: failed (multisamples=2)
    [WARNING] [WinPygame ] trying without antialiasing
    [DEBUG ] [Window ] Display driver x11
    [DEBUG ] [Window ] Actual window size: 800x600
    [DEBUG ] [Window ] Actual color bits r8 g8 b8 a8
    [DEBUG ] [Window ] Actual depth bits: 24
    [DEBUG ] [Window ] Actual stencil bits: 8
    [DEBUG ] [Window ] Actual multisampling samples: 0
    [INFO ] [GL ] OpenGL version <1.4 (2.1 (4.2.12002 Compatibility Profile Context 9.012))>
    [INFO ] [GL ] OpenGL vendor <ATI Technologies Inc.>
    [INFO ] [GL ] OpenGL renderer <AMD Radeon HD 6800 Series >
    [INFO ] [GL ] OpenGL parsed version: 1, 4
    [CRITICAL] [GL ] Minimum required OpenGL version (2.0) NOT found!

    OpenGL version detected: 1.4

    Version: 1.4 (2.1 (4.2.12002 Compatibility Profile Context 9.012))
    Vendor: ATI Technologies Inc.
    Renderer: AMD Radeon HD 6800 Series

    Try upgrading your graphics drivers and/or your graphics hardware in case of problems.

    The application will leave now.
    Fatal Python error: (pygame parachute) Segmentation Fault
    Avbrutt (SIGABRT)


    I use the FGLRX driver from Amd for my 6850 card. can anyone help me solve this problem (yes driver it's up to date, downloaded today.)
    i use OpenSuse 12.2 kde 64bit

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: To old openGL(v1.4) for kivy

    Did you try the 1 clicks?

    After 1 click install on my system

    I could run the sample program Quickstart &mdash; Kivy 1.5.2-dev documentation


    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  3. #3

    Default Re: To old openGL(v1.4) for kivy

    yes i used the 1 click install, the first exsample works, it is the second who is not working and requires openGL2.


    from kivy.app import App
    from kivy.uix.widget import Widget

    class MyPaintWidget(Widget):
    pass

    class MyPaintApp(App):
    def build(self):
    return MyPaintWidget()

    if __name__ == '__main__': MyPaintApp().run()

    How can i update openGL or are ther another way to do it??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •