Results 1 to 10 of 10

Thread: Problem with enable 3D support in Vmware

  1. #1

    Default Problem with enable 3D support in Vmware

    Hi,
    Apter installed Vmware player, I enabled 3d accelerator feature. But When I startup a virtual machine, I received error message from vmware "No support 3d..".
    I think i must enable "S3TC"? How to enable "S3TC" ? ( I installed Driconf but when startup it have error "XDriInfo not found")
    This is my hardware information (VGA)

    Code:
    VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
            Subsystem: Dell Device 0402
            Flags: bus master, fast devsel, latency 0, IRQ 46
            Memory at f6c00000 (64-bit, non-prefetchable) [size=4M]
            Memory at e0000000 (64-bit, prefetchable) [size=256M]
            I/O ports at efe8 [size=8]
            Expansion ROM at <unassigned> [disabled]
            Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
            Capabilities: [d0] Power Management version 3
            Kernel driver in use: i915
    Please help me,
    Sorry for my English

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,464

    Default Re: Problem with enable 3D support in Vmware

    On 2013-01-30 10:26, vietjovi wrote:
    >
    > Hi,
    > Apter installed Vmware player, I enabled 3d accelerator feature. But


    There is a subforum dedicated to virtualization. Please ask a moderator
    to move your thread there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,960
    Blog Entries
    2

    Default Re: Problem with enable 3D support in Vmware

    I'll move this now to virtualisation

  4. #4
    Join Date
    Feb 2010
    Location
    Norfolk, VA US
    Posts
    132

    Default Re: Problem with enable 3D support in Vmware

    It looks like you're using Intel graphics from what you posted ("Kernel driver in use i915"). I had this same problem when I switched from nVidia to HD4000 on the i7. I can let you know how I fixed it after I get home this evening.

  5. #5
    Join Date
    Feb 2010
    Location
    Norfolk, VA US
    Posts
    132

    Default Re: Problem with enable 3D support in Vmware

    Here's what I did to fix it:

    1. Add Xorg to your repository list (Index of /repositories/X11:/XOrg/openSUSE_12.2), switch to this repository and then update all the packages.
    2. Make sure that package "Mesa-libtxc_dxtn1" is installed.
    3. Open your vm configuration files (the ones ending with .vmx) in a text editor and then add or edit the following two lines:
    Code:
    mks.enable3d = "TRUE"
    mks.gl.allowBlacklistedDrivers = "TRUE"
    You'll probably get a warning about the graphics when you start up your virtual machine (I can't remember exactly what it says) but you can ignore it.

    If you're in Windows Vista or Windows 7, run the Windows Experience Index. If it completes without crashing, then you're good.

  6. #6

    Default Re: Problem with enable 3D support in Vmware

    Quote Originally Posted by evetsnameloc View Post
    Here's what I did to fix it:

    1. Add Xorg to your repository list (Index of /repositories/X11:/XOrg/openSUSE_12.2), switch to this repository and then update all the packages.
    2. Make sure that package "Mesa-libtxc_dxtn1" is installed.
    3. Open your vm configuration files (the ones ending with .vmx) in a text editor and then add or edit the following two lines:
    Code:
    mks.enable3d = "TRUE"
    mks.gl.allowBlacklistedDrivers = "TRUE"
    You'll probably get a warning about the graphics when you start up your virtual machine (I can't remember exactly what it says) but you can ignore it.

    If you're in Windows Vista or Windows 7, run the Windows Experience Index. If it completes without crashing, then you're good.
    Thanks you very much. I 'll try it.

  7. #7
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,036

    Default Re: Problem with enable 3D support in Vmware

    Quote Originally Posted by evetsnameloc View Post
    Here's what I did to fix it:

    1. Add Xorg to your repository list (Index of /repositories/X11:/XOrg/openSUSE_12.2), switch to this repository and then update all the packages.
    2. Make sure that package "Mesa-libtxc_dxtn1" is installed.
    3. Open your vm configuration files (the ones ending with .vmx) in a text editor and then add or edit the following two lines:
    Code:
    mks.enable3d = "TRUE"
    mks.gl.allowBlacklistedDrivers = "TRUE"
    You'll probably get a warning about the graphics when you start up your virtual machine (I can't remember exactly what it says) but you can ignore it.

    If you're in Windows Vista or Windows 7, run the Windows Experience Index. If it completes without crashing, then you're good.
    Where do you get "Mesa-libtxc_dxtn1" from? It isn't in the X11 repo (for 12.3), and I can't find it by googling either. Also, can anyone confirm that the above still works for 12.3?
    Günter

    Desk: openSUSE 12.3, KDE4.10.2, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA, dual monitors.
    Lap: Toshiba Satellite L300, openSUSE 12.3, KDE4.10.2, Intel C2D 2.1GHz CPU, 4Gb, Intel X3100 video.

  8. #8
    Join Date
    Feb 2010
    Location
    Norfolk, VA US
    Posts
    132

    Default Re: Problem with enable 3D support in Vmware

    Quote Originally Posted by gminnerup View Post
    Where do you get "Mesa-libtxc_dxtn1" from? It isn't in the X11 repo (for 12.3), and I can't find it by googling either. Also, can anyone confirm that the above still works for 12.3?
    It looks like it is now named "libtxc_dxtn".

    I had not used vmplayer for a while, but I now find that with 3d acceleration enabled as I described above, when I run Internet Explorer I get nothing but a black screen. As I don't play any games in the virtual machine, I don't know what else might have been affected. I know that this is new behavior but I don't know when it might have appeared. Disabling 3d acceleration fixes that problem, but, of course, you lose aero, 3d games, etc.

    Oh well....

  9. #9
    Join Date
    Feb 2010
    Location
    Norfolk, VA US
    Posts
    132

    Default Re: Problem with enable 3D support in Vmware

    After further playing around, I found that Firefox renders web pages without any problem with all the 3d tweaks enabled. Maybe there is some setting within Internet Explorer that will allow it to work too. But if losing Internet Explorer functionality is the only problem that comes with enabling 3d, it is no great loss.

    By the way, the package "libtxc_dxtn" is in the Packman repository. And the package "libtxc_dxtn0" does not work for this purpose.

  10. #10
    Join Date
    Feb 2010
    Location
    Norfolk, VA US
    Posts
    132

    Default Re: Problem with enable 3D support in Vmware

    I just stumbled upon another fix that doesn't require the "libtxc_dxtn" package: add "force_s3tc_enable" to the environment for your vmplayer launcher.

    So if you launch vmplayer from a terminal, you can do:
    Code:
    export force_s3tc_enable=true
    vmplayer
    Alternatively, you can edit the launcher in your menu. Go to "Edit applications...", find the launcher for vmplayer, and in the command line add "export force_s3tc_enable=true && " before the command to launch vmplayer, so the finished line should read "export force_s3tc_enable=true && /usr/bin/vmplayer %f" or something similar.

    I'll be interested to know if this works for 3d games.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •