Results 1 to 9 of 9

Thread: How to disable git/haskpass/kwallet integration?

  1. #1
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,220

    Default How to disable git/haskpass/kwallet integration?

    Aggh.
    Nothing irritates me more than if some new feature is pushed down without being thought out clearly.

    So, it looks like sometime within the last couple months someone thought it would be a good idea to integrate git (yes, regular CLI git) with Kwallet, and now it's likely an update has been pushed down that does this.

    Problem though is that CLI git unlike any of the Git viewers, regular git is not a GUI app so now is complaining about the usual dbus errors associated with launching a KDE app from the CLI.

    As follows:
    Code:
    # git push origin gh-pages
    ksshaskpass(19634)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    KCrash: Application 'ksshaskpass' crashing...
    KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
    Warning: connect() failed: : No such file or directory
    KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi directly
    drkonqi(19635)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    error: unable to read askpass response from '/usr/lib/ssh/ssh-askpass'
    Username for 'https://github.com': ^[
    ksshaskpass(19691)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    KCrash: Application 'ksshaskpass' crashing...
    KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
    Warning: connect() failed: : No such file or directory
    KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi directly
    drkonqi(19692)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    error: unable to read askpass response from '/usr/lib/ssh/ssh-askpass'
    Password for 'https://github.com': 
    fatal: Authentication failed
    Frankly, I'm not interesting in storing my non-KDE apps credentials like CLI git in kwallet. Only maybe if I was using a KDE GUI git viewer.

    Any thoughts how to undo this new dependency with khaskpass?

    TIA,
    TSU

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,453

    Default Re: How to disable git/haskpass/kwallet integration?

    Just a guess: From your output, it seems you have 'ksshaskpass' installed. I guess it is involved in setting $SSH_ASKPASS, which is why /usr/lib/ssh/ssh-askpass gets called. Have you tried removing it?
    Last edited by deano_ferrari; 17-Jan-2013 at 02:07.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,453

    Default Re: How to disable git/haskpass/kwallet integration?

    Quote Originally Posted by deano_ferrari View Post
    Just a guess: From your output, it seems you have 'ksshaskpass' installed. I guess it is involved in setting $SSH_ASKPASS, which is why /usr/lib/ssh/ssh-askpass gets called. Have you tried removing it?
    I get
    Code:
     # rpm -q ksshaskpass --whatrequires
    no package requires ksshaskpass

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,453

    Default Re: How to disable git/haskpass/kwallet integration?

    You may find this interesting, (although it doesn't necessarily help you with disabling the unwanted behaviour)

    Grubix Blog: Git, https and kwallet (update)

    I note that ~/.kde/share/config/kwalletrc can be configured to deny a given application with
    Code:
    [Auto Deny]
    kdewallet=****
    Maybe that approach would work for you.

  5. #5
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,165

    Default Re: How to disable git/haskpass/kwallet integration?

    Tsu,
    All else fails (if you haven't tried this already)
    Kicker>Configure Desktop>Account Details>KDE Wallet
    Untick Enable the KDE wallet subsystem click Apply
    Lastly I think you'll need to Logout/Login for it to engage.
    Challenge your preconceptions, or they will challenge you.
    My 32 bit: E Machines T3103| VIA On board graphics|512MB RAM
    My 64 bit: Gateway 5670| Nvidia GeForce GT610 |CPU AMD Phenom 8400|4G RAM

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,453

    Default Re: How to disable git/haskpass/kwallet integration?

    Quote Originally Posted by Sagemta View Post
    Tsu,
    All else fails (if you haven't tried this already)
    Kicker>Configure Desktop>Account Details>KDE Wallet
    Untick Enable the KDE wallet subsystem click Apply
    Lastly I think you'll need to Logout/Login for it to engage.
    I don't think he wants to disable kwallet completely - just having the choice about whether it is invoked

  7. #7

    Default Re: How to disable git/haskpass/kwallet integration?

    Quote Originally Posted by deano_ferrari View Post
    I don't think he wants to disable kwallet completely - just having the choice about whether it is invoked
    I think I would like to have the option as kwallet seems to be broken on my new installation of 12.2 on laptop and I cannot connect to my wifi access point on the user account where I tried to save the password in the wallet. I have had to open a new user account in order to connect. Furthermore I have no "Kicker" > Configure Desktop Where is this please. What is path when using kde destop.
    Budgie2

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,453

    Default Re: How to disable git/haskpass/kwallet integration?

    Quote Originally Posted by Budgie2 View Post
    I think I would like to have the option as kwallet seems to be broken on my new installation of 12.2 on laptop and I cannot connect to my wifi access point on the user account where I tried to save the password in the wallet. I have had to open a new user account in order to connect.
    I have experienced bad configurations when trying to get the network manager to work with kwallet. Sometimes it pays to delete the wireless config entirely and start over. I have all my wireless connections configured as 'System Connections' and use kwallet for the secrets.

    Furthermore I have no "Kicker" > Configure Desktop Where is this please. What is path when using kde destop.
    Budgie2
    Menu>>System Settings....

  9. #9

    Default Re: How to disable git/haskpass/kwallet integration?

    Quote Originally Posted by deano_ferrari View Post
    I have experienced bad configurations when trying to get the network manager to work with kwallet. Sometimes it pays to delete the wireless config entirely and start over. I have all my wireless connections configured as 'System Connections' and use kwallet for the secrets.


    Menu>>System Settings....
    Hi and many thanks for instant reply. I did try deleting everyting and starting over but no joy.

    I rashly deleted the working test user profile too, leaving my own profile which didn't work.
    When I then created a new user in order to start again it seems the problem was copied over by KDE. There was a very brief window, name forgotten, which flashed up and indicated stuff was being transferred. I really wish the KDE team would stop trying to be cleverer than windoze by introducing these undocumented and unwanted options by default. After two hours of trying I never managed to get the wifi access point to work again.

    Am at home now and connected to my default access point without Kwallet. Will try and use the system option in future but what exactly does system mean? Is it that it will be used for all users?

    Thanks again,
    Budgie2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •