Results 1 to 10 of 10

Thread: Suse 12.2 kein eth0

  1. #1

    Default Suse 12.2 kein eth0

    Hallo,

    ich habe auf einem neuen Computer Suse 12.2 installiert. Leider wird für die Netzverbindung kein "eth0" generiert, obwohl die Netzwerkkarte (Attansic Ethernet controller) erkannt wird, wie in Yast-Netzwerkeinstellungen angezeigt wird. Sie wird aber als "Nicht konfiguriert" angezeigt. Der Text dazu lautet:

    Konfiguration der Netzwerkkarte nicht möglich, weil das Kernel-Gerät (eth0, wlan0) nicht verfügbar ist.

    ifconfig zeigt daher nur lo aber nicht eth0

    Wie kann ich eth0 installieren? Unter Windows 7 funktioniert der Netzzugang, die Netzwerkkarte ist also ok.

    Danke für Antworten, herhin

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,562

    Default Re: Suse 12.2 kein eth0

    Dass sie angezeigt wird, heisst erstmal nix. Vermutlich gibt es im Kernel keinen Treiber dafür. Was genau ist das für eine Karte? Und ist sie onboard? Falls ja, was für ein Board ist das genau?

    Gruß
    Uwe

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    628

    Default AW: Suse 12.2 kein eth0

    Wo geht es weiter?
    Suse 12.2 kein eth0 - linuxforen.de -- User helfen Usern

    Wäre auch vielleicht etwas fürs Unterforum Netzwerk?

  4. #4

    Default Re: Suse 12.2 kein eth0

    Quote Originally Posted by buckesfeld View Post
    Dass sie angezeigt wird, heisst erstmal nix. Vermutlich gibt es im Kernel keinen Treiber dafür. Was genau ist das für eine Karte? Und ist sie onboard? Falls ja, was für ein Board ist das genau?

    Gruß
    Uwe
    Danke für deine Antwort!

    Die Netzwerkkarte ist laut lspci: Atheros AR8161 Gigabit Ethernet onboard auf dem Motherbord: ASUS P8H77-V
    Ich bin inzwischen durch google-suche ein wenig schlauer geworden und habe gesehen, dass offensichtlich kein Kerneltreiber vorhanden ist und diese Karte auch auf anderen Linuxen Probleme macht.
    Unter /etc/udev/rules.d sollte eine Datei 70-persistent-net.rules angelegt sein. Sie ist bei mir zwar da aber ist total leer, so dass ich die Vorschläge von anderen Usern nicht anwenden kann.
    Was also ist zu tun? Schlimmstenfalls kann ich ja eine andere Netzkarte einbauen; aber irgendwie ärgert man sich doch, da ich eigentlich bei Linux kein Anfänger bin.

    herhin

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    628

    Default AW: Suse 12.2 kein eth0

    Evtl. mal die Ausgabe posten, wie ich schon im anderen Forum geschrieben habe?

    Alles andere ist Rate mal mit Rosenthal.

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    628

    Default AW: Suse 12.2 kein eth0

    Und da ich die Ausgabe von
    Code:
    lspci -nnk |grep -i -A2 net
    Code:
     Ethernet controller [0200]: Atheros Comm. AR8161 Gigabit Ethernet [1969:1091] (rev 10)
    Subsystem: ASUSTek Computer Inc Deive [1043:8507]
    PCI bridge [0604]: ASMedia Techn. ASM1083/1085 PCIe to PCI Bridge[1b21:1080}
    mittlerweile kenne ist selber bauen angesagt:
    https://forums.opensuse.org/english/...ontroller.html

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    628

  8. #8

    Default Re: AW: Suse 12.2 kein eth0

    Ich habe verschiedene Treiber nach der Anleitung ausprobiert, aber leider ohne Erfolg. Ich vermute mal, dass ein Problem daran bestehen
    könnte, dass in /etc/udev/rules.d die Datei 70-persistent-net.rules leer ist.

    Ich habe dann meine Bemühungen aufgegeben und eine andere Netzkarte installiert, mit der die Netzverbindung nach Konfiguration mit yast sofort geklappt hat.

    Trotzdem mein Dank für deine bzw. eure umfangreichen Hilfsangebote.

    herhin

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    628

    Default AW: Suse 12.2 kein eth0

    Nur mal eben zur Klarstellung:
    Die Netzwerkkarte mit der ID 1969:1091 wird weder von OpenSUSE 12.1 noch 12.2 out of the box unterstützt.
    Erst nach der manuellen Installation (siehe Links) wird die Karte unterstützt:
    Code:
    modprobe -c | grep -i "1969.*1091"
    alias pci:v00001969d00001091sv*sd*bc*sc*i* alx
    Code:
    modinfo alx
    filename:       /lib/modules/3.1.10-1.16-desktop/updates/drivers/net/ethernet/atheros/alx/alx.ko
    license:        Dual BSD/GPL
    description:    Qualcomm Atheros Gigabit Ethernet Driver
    author:         Qualcomm Corporation, <nic-devel@qualcomm.com>
    srcversion:     FB75B5AF439ED4A671330FA
    alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
    alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
    depends:        compat
    vermagic:       3.1.10-1.16-desktop SMP preempt mod_unload modversions 686
    So lang, wie bei obiger Ausgabe nichts herauskommt, ist der Kernel-Treiber nicht vorhanden und daher sind alle weiteren Schritte überflüssig.
    Ohne Treiber funktioniert keine Software.

    Auch hat der TE keine Konsolenausgabe oder andere Informationen gepostet (welche Version von compat-wireless, da in einigen das alx-Modul nicht vorhanden ist, die Ausgabe vom Aufruf des Scripts und evtl. Fehlermeldungen), anhand deren man sehen könnte, was da evtl. schief läuft.
    Außerdem:
    Bevor da was mit udev-rules geht, muss der Treiber vorhanden sein.

  10. #10
    Join Date
    Sep 2012
    Location
    Nürnberg
    Posts
    23

    Default Re: Suse 12.2 kein eth0

    Ich habe fasst gleiche Fall.
    MSI GT70 laptop mit atheros gigabit ethernet Karte.

    02:00.0 Ethernet controller [0200]: Atheros Communications Inc. Device
    [1969:e091] (rev 13)
    Subsystem: Micro-Star International Co., Ltd. Device [1462:10be]
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at f7300000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at d000 [size=128]
    Capabilities: <access denied>
    Kernel driver in use: alx

    Kernel source ist benötigt:

    Im Yast. Software management. 5 Paketen installieren:

    patch
    gcc
    make
    linux-glibc-devel
    kernel-devel


    Code:
    cd /home/user
    mkdir src
    cd /home/user/src
    Tarball für den neuer Treiber herunterladen:

    http://www.orbit-lab.org/kernel/comp...3-12-p.tar.bz2

    Es gibt auch neuere Treiber aber da ist alx nicht mehr enthalten.

    Code:
    bunzip2 compat-wireless-2012-03-12-p.tar.bz2
    cd compat-wireless-2012-03-13-p
    Ich habe e091 Karte und dafür brauche ich das folgendes Patch.
    1091 warschainlich geht auch ohne Patch.
    bei Ubuntuforum melden. Ich habe es nicht woanders gefunden.
    [SOLVED] Qualcomm Atheros Bigfoot Killer E2200 Ethernet working in linux - Ubuntu Forums
    compat-batch.txt
    Datei herunterladen.

    Erste mal leer laufen zu testen was geändert wird.
    Wenn keine Fehlermeldungen ausgegeben wird, dann weiter.

    Code:
    patch --dry-run -p2 < compat-patch.txt 
      patch -p2 < compat-patch.txt
    Mit die Karte 1091 hier weiter ->

    Code:
    ./script/driver-select alx
    
    make
    sudo make install
    
    sudo modprobe alx
    
    /sbin/ifconfig -a
    Jetzt sollte eth auch da sein.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •