Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Connecting Samsung Galaxy S2

  1. #1

    Default Connecting Samsung Galaxy S2

    Hello,

    I'm running OpenSuSE 12.2. I have a new Samsung Galaxy S2 mobile phone. I am trying to connect it to the computer (laptop) to transfer files between the two.

    I have connected with the USB cable. The device notifier pops up and I click to open the device in file manager. The device is seen as camera:/Samsung .... When I click on the device in file manager I get an empty window and the message "The process for the camera protocol died unexpectedly".

    Running dmseg I get "kio_kamera[2658]: segfault at 92d063e8 ip b5f1c2f4 sp bfef4f60 error 4 in libc-2.15.so[b5eeb000+19f000]"

    Of course, I have no idea what that means!

    Searching on the Internet I came across some posts that suggested installing mtpfs and using this. So I did and ran it and got the following:

    mtpfs /mnt/Android
    Listing raw device(s)
    Device 0 (VID=04e8 and PID=6860) is a Samsung GT-P7310/P7510/N7000/I9100/Galaxy Tab 7.7/10.1/S2/Nexus/Note.
    Found 1 device(s):
    Samsung: GT-P7310/P7510/N7000/I9100/Galaxy Tab 7.7/10.1/S2/Nexus/Note (04e8:6860) @ bus 2, dev 13
    Attempting to connect device
    PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
    LIBMTP libusb: Attempt to reset device
    LIBMTP PANIC: failed to open session on second attempt
    Unable to open raw device 0

    So, any ideas what I'm doing wrong and how I can connect?
    Donald

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    16,048

    Default Re: Connecting Samsung Galaxy S2

    Hello and welcome here.

    You do tell which version of openSUSE you use (which is very fine), but you forgot which "file manager" you are talking about. There are many (as there are many of almost everything in Linux) and although most desktop environments have their default one, you did not tell which desktop you use, thus we still have to guess.
    Henk van Velden

  3. #3
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Connecting Samsung Galaxy S2

    I have exactly the same issue trying to connect a Galaxy Tab 2 10.1 (5100) (Android 4.03) on OS as described in my signature[except for the 11.4]. (I don't really think the file manager is of much importance but I tried Dolphin, Konqueror and of course the shell (bash)).
    The newer Android versions use the MTP protocol for transferring files and are no longer mounted as external storage. I read somewhere in the net, that Samsung uses a proprietary implementation of MTP and not the one that is normally provided with Android, but I have not found a solution so far, nor could I verify this as a fact. I tried mtpfs, jmtp, mtp-go to no avail. So, if you find a solution to your problem, please be so kind and post it here.
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  4. #4

    Default [SOLVED] Re: Connecting Samsung Galaxy S2

    File manager is Konqueror (yes I'm old fashioned!). Desktop is KDE.

    I found the answer. You need to go to Setting on the phone, then More ... then USB settings and click to set as USB storage, then connect the cable to the computer. The computer now recognises the phone as a storage device.

    Sorry, it turns out this was a Samsung issue (obscure method for connecting) not an OpenSuSE issue.

    Donald

  5. #5

    Default Re: Connecting Samsung Galaxy S2

    ps How do I mark this thread as solved?

  6. #6
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Connecting Samsung Galaxy S2

    Also worth a try, but haven't done so yet gmtp, as described here:
    Connecting Samsung Galaxy Tab 10.1 to Linux
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  7. #7
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Connecting Samsung Galaxy S2

    then USB settings and click to set as USB storage, then connect the cable to the computer
    Hmm...unfortunately I don't think the tab has such a setting, but cool it worked for you.
    ps How do I mark this thread as solved?
    you can't, which is why there are no threads marked as solved in this forum.
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    16,048

    Default Re: [SOLVED] Re: Connecting Samsung Galaxy S2

    Quote Originally Posted by donalduk View Post
    File manager is Konqueror (yes I'm old fashioned!). Desktop is KDE.

    Sorry, it turns out this was a Samsung issue (obscure method for connecting) not an OpenSuSE issue.

    Donald
    Does not matter. Any solution whch makes working with openSUSE easier is appreciated.
    And we can not have a solution when thee wasn't a problem first ;

    Thank you for posting. And no, we do not mark threads solved. When the OP posts that he is satisfied, that is enough.
    Henk van Velden

  9. #9

    Default Re: Connecting Samsung Galaxy S2

    donalduk wrote:
    > I found the answer. You need to go to Setting on the phone, then More
    > .... then USB settings and click to set as USB storage, then connect the
    > cable to the computer. The computer now recognises the phone as a
    > storage device.


    Grr! I have an old Samsung phone that behaves like this. It's really
    annoying and it hurts if they still haven't fixed it.

    The worst part is that it forgets the setting. So I have to reconfigure
    it every time I want to connect it. Seriously stupid.

  10. #10
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Connecting Samsung Galaxy S2

    Quote Originally Posted by djh-novell View Post

    The worst part is that it forgets the setting. So I have to reconfigure
    it every time I want to connect it. Seriously stupid.
    Seriously, the Tabs don't even have this setting, which is definitely even worse...
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •