Page 1 of 15 12311 ... LastLast
Results 1 to 10 of 141

Thread: Installing Steam Linux Beta

  1. #1

    Default Installing Steam Linux Beta

    on 12.2 64bit, this is how I done it:

    download media.steampowered.com/client/installer/steam.deb
    open the .deb with ark
    open the data.tar.gz with ark
    extract the /lib/steam/bootstraplinux_ubuntu12_32.tar.xz file to any directory where you want, lets say Steam for now
    execute ./steam.sh from that directory and let it update
    enter your login

    and that is it

  2. #2

    Default Re: Installing Steam Linux Beta

    Hmm, I tried installing it following your steps. It ran the updater and updated successfully but when i try to run steam.sh now it exits with this message:

    Code:
    > ./steam.sh
    Installing breakpad exception handler for appid(steam)/version(1352224866_client)
    >
    Do i need any other 32 bit packages besides libX11? I'm running openSUSE 12.2 x64 w/ KDE 4.9.
    Edit: also I noticed the font in the updater window was really ugly, don't know if that's a clue or not.

  3. #3

    Default Re: Installing Steam Linux Beta

    Same here, I'll try to solve it and see if I can help. (Looks like lots of problems are in x64 versions of Linux)

  4. #4

    Default Re: Installing Steam Linux Beta

    Alright, it runs:
    openSUSE 12.2 x64 Gnome 3.4

  5. #5

    Default Re: Installing Steam Linux Beta

    Quote Originally Posted by Hyperz View Post
    Hmm, I tried installing it following your steps. It ran the updater and updated successfully but when i try to run steam.sh now it exits with this message:

    Code:
    > ./steam.sh
    Installing breakpad exception handler for appid(steam)/version(1352224866_client)
    >
    Do i need any other 32 bit packages besides libX11? I'm running openSUSE 12.2 x64 w/ KDE 4.9.
    Edit: also I noticed the font in the updater window was really ugly, don't know if that's a clue or not.
    On Gaming for Linux someone posted he was a Bumblebee user and had to run it with optirun... not sure that helps you, else maybe Tanshaydar can say what he did as he got same error

  6. #6

    Default Re: Installing Steam Linux Beta

    I have a similar problem. After launching "public/steambootstrapper_english.txt". error appears in my terminal and then small Steam updater (similar to the one from windows), but with ugly fonts. Even those in wine are better.
    Then the updater extracts some files (png, tar etc. ) to the directory with steam.sh and disappears with the second line printed in my terminal (the one with 1352224866_client error).
    Another thing is it created new and empty folder called 'Steam' in my home directory. (my steam.sh is in /home/programs/steam_beta/steam.sh)

    Code:
    > ./steam.sh 
    ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
    Installing breakpad exception handler for appid(steam)/version(1352224866_client)
    > echo $?
    255
    //Running 12.2 (64) + Gnome 3.4

  7. #7

    Default Re: Installing Steam Linux Beta

    Quote Originally Posted by ant6 View Post
    I have a similar problem. After launching "public/steambootstrapper_english.txt". error appears in my terminal and then small Steam updater (similar to the one from windows), but with ugly fonts. Even those in wine are better.
    Then the updater extracts some files (png, tar etc. ) to the directory with steam.sh and disappears with the second line printed in my terminal (the one with 1352224866_client error).
    Another thing is it created new and empty folder called 'Steam' in my home directory. (my steam.sh is in /home/programs/steam_beta/steam.sh)

    Code:
    > ./steam.sh 
    ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
    Installing breakpad exception handler for appid(steam)/version(1352224866_client)
    > echo $?
    255
    //Running 12.2 (64) + Gnome 3.4
    that sort of sounds like the patcher/updater did not get all ?

  8. #8
    Join Date
    Nov 2012
    Location
    Croatia
    Posts
    9

    Default Re: Installing Steam Linux Beta

    Quote Originally Posted by Tanshaydar View Post
    Alright, it runs:
    openSUSE 12.2 x64 Gnome 3.4
    OK, how?

    I'm running openSUSE with KDE (12.2 - x64). Maybe the reason is GNOME instead of KDE?

  9. #9

    Default Re: Installing Steam Linux Beta

    Quote Originally Posted by zpintar View Post
    OK, how?

    I'm running openSUSE with KDE (12.2 - x64). Maybe the reason is GNOME instead of KDE?

    going from 12.10 - Installing breakpad exception handler for appid(steam) while trying to run Steam - Ask Ubuntu
    I ran
    Code:
    strace -E LD_LIBRARY_PATH=~/Steam/ubuntu12_32/ -e trace=open ~/Steam/ubuntu12_32/steam
    to figure out what packages it was wanting. The last line should tell you what library it was looking for.
    Last thing I installed was libpng12-0-32bit. Not sure what others were required. I was installing a bunch of 32bit libs before that, so not sure what else it needed, but that strace command should let you figure it out.
    I used the output of that and ran
    Code:
    zypper se 32bit|grep [libname]
    for example
    Code:
    zypper se 32bit|grep png
    and saw libpng12-0-32bit which matched up with the output of the strace.
    kept doing this until it ran.

    Hope that helps.

  10. #10
    Join Date
    Nov 2012
    Location
    Croatia
    Posts
    9

    Default Re: Installing Steam Linux Beta

    Thanks! I will.

Page 1 of 15 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •