Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Right nvidia optimus driver configuration

  1. #1

    Default Right nvidia optimus driver configuration

    Hi all friends!!
    I've a problem with the nvidia driver for my notebook asus k53sj.
    The problem is with optimus configuration that switch between the intel integrated graphic card and nvidia card (model :gt 620m). If i install the nvidia official driver the OS begin unstable and sometimes i've to reboot because of OS freeze, so i'm working with no nvidia driver but with default nouveau.
    Another problem is battery autonomy because of the nvidia card that's always on even if isn't used. So my answers is: there's anyone who can help me with this problem ?
    Thanks a lot!!

  2. #2
    Join Date
    Mar 2009
    Location
    United States
    Posts
    625

    Default Re: Right nvidia optimus driver configuration

    You will need to look into this. Bumblebee - NVIDIA Optimus support for Linux!

    I am not sure how to set it up on openSUSE. There might be an open build service repo.

  3. #3
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    536

    Default Re: Right nvidia optimus driver configuration

    Yes there are some good repos for this now.
    First, if this laptop can only run in Optimus mode you're bound to use bumblebee, although you might be able to toggle the mode in the bios settings. If there's no way to change mode do as follows.

    First you should confirm that xorg is restored to what it was before installing the Nvidia driver, use the following command:

    glxinfo | grep OpenGL
    This should output something like this:

    vendor string: Tungsten Graphics, Inc
    renderer string: Mesa DRI Intel(R) IGD x86/MMX/SSE2
    version string: 1.4 Mesa 7.11
    The version numbers may differ, but all 3 lines should be there and glxgears should work, giving about 60 fps.
    If you don't get any DRI, reinstall the package xorg-x11-server. Now you should be ready to install the Nvidia drivers the bumblebee way, if you're on 12.2 use this repo, otherwise change 12.2 to 12.1 or 11.4:

    Bumblebee can be installed from the following repo, there's no 12.1 or 11.4 version but I have tested 12.2 on both 12.2 and 12.1, both 32-bit, and it worked on both:

    The installer will add your user to the bumblebee group, however I had to manually set up the bumblebee daemon manually under systemd, as root use the following commands:

    systemctl enable bumblebeed.service
    systemctl start bumblebeed.service
    Now logout or reboot and test it, run glxgears, it should give you direct rendering and 60 fps on the Intel chip. To test the Nvidia card run:

    optirun glxinfo | grep OpenGL
    optirun glxgears
    At a minimum you should at least expect that your Nvidia card is powered off on boot, on battery power check your battery state before and after you installed bumblebee, the difference should be significant:

    cat /proc/acpi/battery/BAT0/state
    That's it.

  4. #4

    Default Re: Right nvidia optimus driver configuration

    Hi, when I type "glxinfo | grep OpenGL" on my terminal. This is what it shows

    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Error: couldn't find RGB GLX visual or fbconfig
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".
    Xlib: extension "GLX" missing on display ":0".

    What does this mean? And how can I fix this to show the vendor name like yours?

  5. #5
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    536

    Default Re: Right nvidia optimus driver configuration

    I can imagine two reasons, either you followed the install instructions for Nvidia equipped systems and added the option "nomodeset" when you started the installation, this option would then be added to your boot loader. Have a look in yast>system/boot loader configuration>alternatives for bootloader, look at the box "Optional Kernel Command Line Parameter", if the word "nomodeset" occurs there delete it, save the changes and reboot.

    Another explanation might be that you have installed the Nvidia driver the "hard way", if so uninstall it and reinstall the package xorg-x11-server, reboot and see if that helps.

    If nothing of the above helps, post the content of /var/log/Xorg.0.log.

  6. #6

    Default Re: Right nvidia optimus driver configuration



    I did your first suggestion, the nomodeset isn't in the "optional kernel command line paramater". It is in the "failsafe kernel command line parameter". Do I need to delete it?

    And if what you meant by installing nvidia driver the hard way is by installing it from Yast. Then yes, I installed mine from yast. So will I uninstall it?

    Quote Originally Posted by hank_se View Post
    I can imagine two reasons, either you followed the install instructions for Nvidia equipped systems and added the option "nomodeset" when you started the installation, this option would then be added to your boot loader. Have a look in yast>system/boot loader configuration>alternatives for bootloader, look at the box "Optional Kernel Command Line Parameter", if the word "nomodeset" occurs there delete it, save the changes and reboot.

    Another explanation might be that you have installed the Nvidia driver the "hard way", if so uninstall it and reinstall the package xorg-x11-server, reboot and see if that helps.

    If nothing of the above helps, post the content of /var/log/Xorg.0.log.

  7. #7
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    536

    Default Re: Right nvidia optimus driver configuration

    No don't delete it from the failsafe line, problems with graphics hardware and/or drivers is probably the most common cause for using failsafe mode, the "nomodeset" option ensures your system will boot into framebuffer mode, which is much more robust.
    And yes, uninstall Nvidia completly, also make sure to disable or delete the Nvidia repo, you'll install Nvidia from the repo I suggested in post #3.

  8. #8

    Default Re: Right nvidia optimus driver configuration

    Hi. I' ve uninstalled the nvidia driver that I installed and now I' m getting the one you said that i should get when i enter this command "glxinfo | grep OpenGL".

    But how will I install the driver from the links that you've given? I' m really new to this so I' m sorry if I don't know how.




    Now you should be ready to install the Nvidia drivers the bumblebee way, if you're on 12.2 use this repo, otherwise change 12.2 to 12.1 or 11.4:

    Index of /repositories/home:/Bumblebee-Project:/nVidia:/latest/openSUSE_12.2


    Bumblebee can be installed from the following repo, there's no 12.1 or 11.4 version but I have tested 12.2 on both 12.2 and 12.1, both 32-bit, and it worked on both:

    Index of /repositories/home:/Overman79/openSUSE_12.2

  9. #9
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    536

    Default Re: Right nvidia optimus driver configuration

    Install the Nvidia repo with the following command, as root:

    Code:
    zypper ar -r http://download.opensuse.org/repositories/home:/Bumblebee-Project:/nVidia:/latest/openSUSE_12.2/home:Bumblebee-Project:nVidia:latest.repo
    Then open up yast/software/software management, in the show tab select archives or if it is repos in the english version. Now select Downloader and installer for the nVi... . dkms will be preselected, if you're on 64-bit select dkms-nvidia, nvidia-compute and x11-video-nvidia, if you're on 32-bit select the corresponding 32-bit packages. Click on accept and you should be done with thw Nvidia stuff.

    Now proceed with Bumblebee, start with adding the repo:

    Code:
    zypper ar -r http://download.opensuse.org/repositories/home:/Overman79/openSUSE_12.2/home:Overman79.repo
    In yast follow the same procedure as for the Nvidia stuff, except now you select the Bumblebee repo. For 64-bit VirtualGL, bumblebee, dkms-bbswitch, libturbojpeg and profile-sync-daemon, for 32-bit you guess it.

    Proceed with rest of the instructions.

  10. #10

    Default Re: Right nvidia optimus driver configuration

    Wow. Thank you very much.
    Now, when I run "optirun glxinfo | grep OpenGL". This are the outputs

    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce GT 540M/PCIe/SSE2
    OpenGL version string: 4.2.0 NVIDIA 304.64
    OpenGL shading language version string: 4.20 NVIDIA via Cg compiler
    OpenGL extensions:
    Does this mean that I successfully installed the driver for my graphics card?

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •