Results 1 to 2 of 2

Thread: Spotlite

  1. #1
    Join Date
    Oct 2012
    Location
    /home/nomko
    Posts
    90

    Question Spotlite

    Hallo,

    Bestaat er een soortgelijke programma als deze die te gebruiken is onder OpenSuse? Deze gebruik ik onder *buntu systemen en werkt prima.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Spotlite

    Ik weet dat 't kan, want ik heb 't werkend gehad, maar op dit moment niet geinstalleerd. Het komt erop neer dat je het Ubuntu pakket ombouwt tot rpm.

    Dat doe je zo:

    Met Firefox naar software.opensuse.org: Download openSUSE 12.2 en daar zoeken op alien. Kies je openSUSE versie, onder unstable packages installeer je de juiste versie uit de utilities repo
    Via softwarebeheer installeer je de pakketten libopenssl0_9_8 en rpm-build
    Open een terminal en voor onderstaande commando's uit:
    Code:
    mkdir ~/SpotLite
    cd ~/Spotlite
    wget http://www.spot-net.nl.vfcdn.net/downloads/spotlite/SpotLite\(v2\)Ubuntu.zip
    unzip SpotLite\(v2\)Ubuntu.zip
    ls
    je ziet nu twee versies van de .deb staan. Welke je moet hebben hangt af van of je 32bits of 64bits openSUSE draait. Dat kun je opvragen met
    Code:
    uname -a
    als je in de output daarvan x86_64 ziet staan, moet je de 64bits versie, spotlite-amd64.deb, hebben, anders de 32bits, spotlite-i386.deb. Nu moeten we de .deb ombouwen tot een .rpm, die we op openSUSE kunnen installeren. Hieronder noem ik die even JUISTE.DEB
    Code:
    su -c 'alien -r JUISTE.DEB'
    (rootwachtwoord invullen)
    ls *rpm
    Nu wordt je de naam van de gegenereerde .rpm getoond, die noem ik hieronder JUISTE.RPM. Die moet geïnstalleerd worden, maar ik zeg hier al dat daar een afhankelijkheids foutmelding over komt, omdat bij Ubuntu dingen soms iets anders verpakt worden. Het volgens Ubuntu missende stukje heb je hierboven al geïnstalleerd.
    We installeren de rpm
    Code:
    su -c 'zypper in JUISTE.RPM'
    Als er een melding over libcrypto komt, kun je kiezen voor de optie om te negeren, mochten er meer meldingen komen, dan die graag hier posten tussen CODE tags
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •