Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: test audio works but no sound from any application

  1. #1

    Default test audio works but no sound from any application

    on my tumbleweed with kde 4.9.2, if I open yast control center>sound and I test my 5 Series/3400 Series Chipset High Definition Audio it works perfectly, but if I launch clementine, amarok, firefox>youtube vlc etc no sound comes out from speakers, if I launch pavucontrol the sound bar moves.......

    how can I solve???
    thnx, ciao, pier :-))

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: test audio works but no sound from any application

    Quote Originally Posted by pier_andreit View Post
    on my tumbleweed with kde 4.9.2, if I open yast control center>sound and I test my 5 Series/3400 Series Chipset High Definition Audio it works perfectly, but if I launch clementine, amarok, firefox>youtube vlc etc no sound comes out from speakers, if I launch pavucontrol the sound bar moves.......

    how can I solve???
    thnx, ciao, pier :-))
    If you have more than one sound device in your system, its possible that it is not set as the default. There are a couple of things to do. I do have two so I must configure PulseAudio so that the nVIDIA sound device uses the Profile of Off and in YaST / Hardware / Sound, I set my preferred sound device ahead of the nVIDIA sound device. In KDE for PulseAudio Look at Menu / Configure Desktop / Multimedia / Phonon / Audio Hardware Setup Tab / Hardware Profile. In YaST I go to System / Hardware / Sound and make sure my primary device is the default. I recommend to anyone they may want to look at these blogs on the subject:

    Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

    AND

    S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15 - Blogs - openSUSE Forums

    Further, I have had good luck installing the xfce4-mixer from YaST which will load several things for it to work which is OK. It is more like the Alsa control of old and for each sound device you can add all controls it contains. For instance, on my Sound Blaster Card, in order to hear sound from my TV, connected to the Line-in, the Master, Front, Line-In and Analog-Mix volume controls all must be turned up even as they don't show up in PulseAudio.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,915

    Default Re: test audio works but no sound from any application

    On 2012-10-14 15:46, pier andreit wrote:
    >
    > on my tumbleweed


    You should ask in the tumbleweed forum.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,033
    Blog Entries
    12

    Default Re: test audio works but no sound from any application

    Ashamed to admit, but I faced same issue on my new laptop, I appeared to have muted the speakers with a keystroke .....
    Another option is to check the sound settings in KDE's system settings.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: test audio works but no sound from any application

    I don't know what happened but last week sound worked :-)

    Quote Originally Posted by jdmcdaniel3 View Post
    If you have more than one sound device in your system, its possible that it is not set as the default.
    There are a couple of things to do. I do have two so I must configure PulseAudio so that the nVIDIA sound device uses the Profile of Off and in YaST / Hardware / Sound, I set my preferred sound device ahead of the nVIDIA sound device.
    ok it is so

    Quote Originally Posted by jdmcdaniel3 View Post
    In KDE for PulseAudio Look at Menu / Configure Desktop / Multimedia / Phonon / Audio Hardware Setup Tab / Hardware Profile.
    ok, I made the profile off
    but I noticed that in In KDE in Menu / Configure Desktop / Multimedia / Phonon / Device Preference
    my Internal audio analog stereo is gray, (this is the one that should works, and phonon doesnt recognize?)
    the high definitio audio controller digital stereo (HDMI) is now grey too (but I greyed it making the profile off)
    simultaneous output is green

    Quote Originally Posted by jdmcdaniel3 View Post
    In YaST I go to System / Hardware / Sound and make sure my primary device is the default.
    yes it is

    Quote Originally Posted by jdmcdaniel3 View Post
    I recommend to anyone they may want to look at these blogs on the subject:

    Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

    AND

    S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15 - Blogs - openSUSE Forums
    I installed start too

    Quote Originally Posted by jdmcdaniel3 View Post
    Further, I have had good luck installing the xfce4-mixer
    me also installed now, and disabled kmix
    but, how to put it in the dock where kmis was??

    Quote Originally Posted by jdmcdaniel3 View Post
    from YaST which will load several things for it to work which is OK. It is more like the Alsa control of old and for each sound device you can add all controls it contains. For instance, on my Sound Blaster Card, in order to hear sound from my TV, connected to the Line-in, the Master, Front, Line-In and Analog-Mix volume controls all must be turned up even as they don't show up in PulseAudio.
    all controls are up

    thnx, ciao, pier :-))

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Default Re: test audio works but no sound from any application

    Unless you use xfce, I am not sure it can replace kmix in the system tray, but kmix should still be able to adjust the main volume control. From your last statement I was unable to determine if we had success or still no sound at the end of it all?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,033
    Blog Entries
    12

    Default Re: test audio works but no sound from any application

    Give alsamixer a try, it should show all channels for all cards.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: test audio works but no sound from any application

    Quote Originally Posted by jdmcdaniel3 View Post
    Unless you use xfce, I am not sure it can replace kmix in the system tray, but kmix should still be able to adjust the main volume control. From your last statement I was unable to determine if we had success or still no sound at the end of it all?

    Thank You,
    no sound :-))))
    and also alsamixer everything is at max:-)

  9. #9

    Default Re: test audio works but no sound from any application

    Quote Originally Posted by pier_andreit View Post
    no sound :-))))
    and also alsamixer everything is at max:-)
    How about adding user to audio group, will that help/work?. YaST -> Users and Group Management -> Select user and click edit tab -> Details tab.
    Give it a try.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  10. #10

    Default Re: test audio works but no sound from any application

    Quote Originally Posted by mmarif4u View Post
    How about adding user to audio group, will that help/work?. YaST -> Users and Group Management -> Select user and click edit tab -> Details tab.
    Give it a try.
    added user to audio group, rebooted, no sound, yast sound test sound ok, pulseaudio volume meter shows that sound is produced but no sound happen, I think is a phonon or gstreamer problem
    thnx, ciao, pier :-))

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •