Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Unable to change KDM theme

  1. #1
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,386

    Default Unable to change KDM theme

    Not a big fan of the default KDM theme shipped with 12.2 so
    looking to change to something that interests me a bit more.
    However, I am unable to change the theme using the applet
    supplied under configure desktop. I select a different theme,
    click Apply and then it asks for root password which I supply,
    then log out or reboot and KDM is the same. So I was wondering what I
    might need to do or which file I may need to look at to
    change it. Thanks.


  2. #2
    dd@home.dk NNTP User

    Default Re: Unable to change KDM theme

    On 09/27/2012 06:08 PM, GofBorg wrote:
    > I select a different theme,
    > click Apply and then it asks for root password which I supply,
    > then log out or reboot and KDM is the same.


    that sounds very strange! because your KDE theme is _yours_, there is no
    need whatsoever for root to be involved..

    another way to say that: i can change KDE themes on my machine without
    providing root or any other password (well, of course i provided my user
    password when i logged on---and that is all that is required)

    well, i wonder if you and i are talking about the same thing? here is
    the way i change themes:

    -open Personal Settings - Configure Desktop > Workspace Appearance and
    Behavior > Workspace Appearance > Desktop Theme (on the left) > then
    click on any theme shown in the list on the right, then click "Apply"
    button and the theme is changed almost instantly (no passwords asked
    for, no need to shutdown or reboot, no nothing...just click Apply and
    the theme changes, boom!)

    so, i wonder how your system got so damaged...any ideas?

    --
    dd http://tinyurl.com/DD-Caveat

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,386

    Default Re: Unable to change KDM theme

    Desktop themes change fine, it's the login greeter,
    which imho should ask for root permission.

    Try going to:

    Start>Configure Desktop>Login Screen>Theme.
    Select a different theme, then click 'apply'.
    It will ask for permission to set the kdm greeter.

    Logout to see if kdm greeter is changed. On
    my machine it doesn't.





  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,386

    Default Re: Unable to change KDM theme

    Effectively the 'Login Screen' applet is useless. Even setting it to
    not use themes it stays with the default greeter. Definitely a bug here,
    at the very least severe usability issues.

  5. #5

    Default Re: Unable to change KDM theme

    Quote Originally Posted by GofBorg View Post
    Effectively the 'Login Screen' applet is useless. Even setting it to
    not use themes it stays with the default greeter. Definitely a bug here,
    at the very least severe usability issues.
    Indeed, the login screen applet has never worked on opensuse as far as i know. The only way i know you can change the kdm theme is via:

    Code:
    yast - etc/sysconfig - search for kdm - change value of a key similar to KDM_GREETER_THEME
    That being said, i really like to know why opensuse does not make the login screen applet working. Why do we have to change theme on such unuserfriendly way? The same applies for the mouse cursor theme of kdm

  6. #6
    dd@home.dk NNTP User

    Default Re: Unable to change KDM theme

    On 09/27/2012 07:44 PM, GofBorg wrote:
    > Desktop themes change fine, it's the login greeter,
    > which imho should ask for root permission.


    sorry! i was pretending to be able to read--and can now easily see the
    difference between KDE and KDM


    > Try going to:...
    > It will ask for permission to set the kdm greeter.


    yes, it does...and, here it does change to the selected theme....but, i
    am using 11.4, so maybe 12.2's is broken, BUT i think if it is a bug
    (and not just a local phenomenon) it would have been reported
    widely...and, i don't recall seeing this problem before...

    so, why not search bugzilla http://tinyurl.com/nzhq7j and see if it has
    been reported...if so, and if you have new info please add to the
    initial report AND return here with the bug number so the next seeing
    the problem can follow along..

    if you don't find a bug there then i'd suggest if no others with 125.2
    reading alone here can duplicate it, then maybe someone can help find
    the nature of the corner case...or maybe what on your system got
    corrupted and how..

    say, tell us what version of KDE you are using and please show us the
    terminal output *and* input from

    Code:
    zypper lr -d
    copy/paste the in/output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    --
    dd

  7. #7
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,386

    Default Re: Unable to change KDM theme

    Thanks suskewiet,

    That method works a treat.

    Login Screen applet = FAIL

    I'll see about filing a bug report, although if it's been broken as long as
    you say, obviously it's not going to be fixed.

  8. #8
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,386

    Default Re: Unable to change KDM theme

    I am using OS12.2 DVD downloaded, verified before installing.
    Only repositories are the default configured at install time.
    suskewiet has the answer in his post. The applet is just borked.


  9. #9
    Taki NNTP User

    Default Re: Unable to change KDM theme

    On 09/27/2012 09:08 AM, GofBorg wrote:
    > Not a big fan of the default KDM theme shipped with 12.2 so
    > looking to change to something that interests me a bit more.
    > However, I am unable to change the theme using the applet
    > supplied under configure desktop. I select a different theme,
    > click Apply and then it asks for root password which I supply,
    > then log out or reboot and KDM is the same. So I was wondering what I
    > might need to do or which file I may need to look at to
    > change it. Thanks.
    >


    There are two files/directories to consider:

    (1) /usr/share/kde4/apps/kdm/themes/
    This is where themes are stored.

    openSUSE has three installed:
    $ ls /usr/share/kde4/apps/kdm/themes/
    ariya circles horos

    (2) /etc/sysconfig/displaymanager
    This file KDM-related settings.

    For example, to use the "horos" theme,
    become 'root':
    $ su
    [enter 'root' passwd]
    run a text editor of your choice:
    # vim /etc/sysconfig/displaymanager
    [find the line containing "DISPLAYMANAGER_KDM_THEME";
    edit the line to look like this:
    DISPLAYMANAGER_KDM_THEME="horos"

    Save the file, log out.
    You should see the "horos"-themed KDM screen.

    For more examples of KDM themes, check out:
    http://kde-look.org/

    Look for and click on "KDM Themes" in the left-hand column.
    Download a theme of interest.
    Unpack the theme file.
    Become 'root' and mv/cp the unpacked file to the directory,
    /usr/share/kde4/apps/kdm/themes/.
    Then edit /etc/sysconfig/displaymanager as above.

    [Until a few versions back, it was a bit easier.
    YaST2/System/'/etc/sysconfig Editor':
    'Search': kdm_theme (or DISPLAYMANAGER_KDM_THEME)
    Click to go to the line.
    Pick a theme in /usr/share/kde4/apps/kdm/themes/.
    *Unfortunately, YaST no longer automatically presents
    *the names of the themes in the directory to choose from.
    *Now, the theme name must be entered manually.]






  10. #10
    dd@home.dk NNTP User

    Default Re: Unable to change KDM theme

    On 09/27/2012 09:21 PM, GofBorg wrote:
    > I'll see about filing a bug report, although if it's been broken as long as
    > you say, obviously it's not going to be fixed.


    as said, it works here on still supported 11.4 so it has not been broken
    (if it is) for long...

    so don't use "it won't be fixed" as an excuse for not reporting, please.

    --
    dd

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •