Results 1 to 2 of 2

Thread: RTL8188CE disconnects lockups compat-wireless

  1. #1

    Default RTL8188CE disconnects lockups compat-wireless

    HP DV7-6c20us laptop

    Linux HP-pos.site 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64 x86_64 x86_64 GNU/Linux

    Searched and found this:

    http://forums.opensuse.org/forums/en...ng-12-2-a.html


    Attempted the diff and compat-wireless listed with the following results;

    02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
    Subsystem: Hewlett-Packard Company Device 1629
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 5
    Region 0: I/O ports at 2000 [size=256]
    Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
    Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Capabilities: [70] Express (v2) Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
    ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
    ClockPM+ Surprise- LLActRep- BwNot-
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis+
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance De-emphasis: -6dB
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
    EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
    Capabilities: [100 v1] Advanced Error Reporting
    UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
    Capabilities: [140 v1] Virtual Channel
    Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
    Arb: Fixed- WRR32- WRR64- WRR128-
    Ctrl: ArbSelect=Fixed
    Status: InProgress-
    VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
    Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
    Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
    Status: NegoPending- InProgress-
    Capabilities: [160 v1] Device Serial Number 01-91-81-fe-ff-4c-e0-00


    [ 5.398607] rtsx_acquire_irq: chip->msi_en = 0, pci->irq = 18
    [ 5.406207] Backport based on linux-next.git next-20120910
    [ 5.408229] compat.git: linux-next.git


    [ 6.634100] ALSA hda_intel.c:1578 Enable sync_write for stable communication
    [ 6.654546] rtlwifi: Unknown symbol pcie_capability_read_word (err 0)
    [ 6.658397] ALSA patch_sigmatel.c:5592 mute LED gpio 1 polarity 0


    HP-pos:/home/kevin # modprobe rtl8192ce
    WARNING: Error inserting rtl8192c_common (/lib/modules/3.4.6-2.10-desktop/updates/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting rtl8192ce (/lib/modules/3.4.6-2.10-desktop/updates/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    Make uninstall got me back to (stock) sorta wireless, so I could post this. lspci -vvvvvvvvv when it works is:

    02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
    Subsystem: Hewlett-Packard Company Device 1629
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 17
    Region 0: I/O ports at 2000 [size=256]
    Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
    Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Capabilities: [70] Express (v2) Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
    ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
    ClockPM+ Surprise- LLActRep- BwNot-
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis+
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis+
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance De-emphasis: -6dB
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
    EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
    Capabilities: [100 v1] Advanced Error Reporting
    UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    CESta: RxErr+ BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
    Capabilities: [140 v1] Virtual Channel
    Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
    Arb: Fixed- WRR32- WRR64- WRR128-
    Ctrl: ArbSelect=Fixed
    Status: InProgress-
    VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
    Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
    Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
    Status: NegoPending- InProgress-
    Capabilities: [160 v1] Device Serial Number 01-91-81-fe-ff-4c-e0-00
    Kernel driver in use: rtl8192ce


    Tried slackware, ubuntu 12.04/12.10, mint, fuduntu. The reliability is poor. Access point is Netgear WNDAP-360 with stock latest firmware, wpa2. IP-cop router handling dhcp. Windows with same card has no issues, nor do any other wifi device in the house. After the third manual disconnect and reconnect, it goes to airplane mode which cannot be undone without a reboot. Ping does seem to keep it going longer. Sometimes I have to unplug power, remove battery and hold down power button to get it back up.

    Tried mac in bssid to stop two minute scanning, rtl8192ce.conf with ips=0. Every version of compat-wireless to date. The SUSE way is taking a little extra time (I'm learning) with build essentials, development tools etc.

    Tried to provide relevant info, holler if I missed something.

    Thanks!
    Kevin

  2. #2

    Default Re: RTL8188CE disconnects lockups compat-wireless

    Reading a bit from troubleshooting guides here is the output from iwconfig and iwlist scan

    eth0 no wireless extensions.

    lo no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:"nunyabiz"
    Mode:Managed Frequency:2.462 GHz Access Point: E0:46:9A:4A:6E:20
    Bit Rate=150 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr=2347 B Fragment thr:off
    Encryption key:off
    Power Management:off
    Link Quality=56/70 Signal level=-54 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:77 Missed beacon:0

    HP-pos:/home/kevin # iwlist scan
    eth0 Interface doesn't support scanning.

    lo Interface doesn't support scanning.

    wlan0 Scan completed :
    Cell 01 - Address: E0:46:9A:4A:6E:20
    Channel:11
    Frequency:2.462 GHz (Channel 11)
    Quality=53/70 Signal level=-57 dBm
    Encryption key:on
    ESSID:"nunyabiz"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s
    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=000000023f2412cd
    Extra: Last beacon: 32ms ago
    IE: Unknown: 00086E756E796162697A
    IE: Unknown: 010882848B0C12961824
    IE: Unknown: 03010B
    IE: Unknown: 0706555349010B1B
    IE: Unknown: 2A0100
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    IE: Unknown: 32043048606C
    IE: Unknown: DD180050F2020101840003A4000027A4000042435E0062322F00
    IE: Unknown: 2D1A4E101BFFFF000000000000000000000000000000000000000000
    IE: Unknown: 3D160B071900000000000000000000000000000000000000
    IE: Unknown: 3E0100
    IE: Unknown: 3C0401000000
    IE: Unknown: DD0900037F01010000FF7F
    IE: Unknown: DD0A00037F04010000000000

    I did install compat-wireless 20012-09-10 not including the diff patch without any issues. Still locks up.

    I found /etc/init.d/network restart that works to restore wireless. Since this happens so often, I would like to make a "shortcut" on the favorites to reset the wireless quickly. this has to be run as root. I am not 10% smarter than sudo so that doesn't work yet. How can I, with my normal login, have a shortcut that runs as root to reset network?

    Of course I'd rather fix the wireless if anyone has any suggestions.

    Thanks
    Kevin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •