Results 1 to 7 of 7

Thread: Deluge Firewall Exception?

  1. #1
    Join Date
    Jul 2012
    Location
    Bay Area California
    Posts
    31

    Default Deluge Firewall Exception?

    I'm new to openSUSE, and I was wondering how do you add deluge to a firewall exception, I know this is the problem 'cause when I stop my firewall for a brief moment and click "Test Active Port"...everything is fine. But when the firewall is turned on and I test the port , its closed! And I've checked the "use random ports at the start" box. On the other hand, if I were to use just one port for Deluge every time is starts, how to open that one single in the firewall settings in Yast? I previously had problems with ssh, ie, when i ssh from ubuntu on my desktop to opensuse on my notebook it wouldn't connect as it would time out, I allowed the secure shell severs in allowed services. Is there a similar way I can add deluge to the allowed services list?

  2. #2
    Join Date
    Jul 2008
    Location
    Bellevue, WA
    Posts
    14,114

    Default Re: Deluge Firewall Exception?

    On Mon, 23 Jul 2012 00:36:02 +0000, havock07 wrote:

    > if I were to use just one port for Deluge every time is starts, how to
    > open that one single in the firewall settings in Yast?


    Under the firewall advanced settings, just open the port (TCP or UDP
    depending on the application) and restart the firewall. Don't use a
    random port.

    If you have a router that's doing NAT, you also have to configure port
    forwarding to make sure the inbound connections are getting to your
    system.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jul 2012
    Location
    Bay Area California
    Posts
    31

    Default Re: Deluge Firewall Exception?

    Thank you works perfectly I had tried that before but only entered the port number under TCP , now entered it under both TCP and UDP works fine, and yes I disabled the random ports option!

    On a side note, this forum is awesome. Thanks for the swift reply.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,615

    Default Re: Deluge Firewall Exception?

    On 2012-07-23 02:36, havock07 wrote:
    >
    > I'm new to openSUSE, and I was wondering how do you add deluge to a

    ....
    > out, I allowed the secure shell severs in allowed services. Is there a
    > similar way I can add deluge to the allowed services list?


    Sorry, wrong forum. This forum here is not for asking questions. It is where you
    explain to us _howto_ do things, and we do a peer review on your document.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  5. #5
    Join Date
    Jul 2008
    Location
    Bellevue, WA
    Posts
    14,114

    Default Re: Deluge Firewall Exception?

    On Mon, 23 Jul 2012 01:16:03 +0000, havock07 wrote:

    > Thank you works perfectly I had tried that before but only entered
    > the port number under TCP , now entered it under both TCP and UDP works
    > fine, and yes I disabled the random ports option!
    >
    > On a side note, this forum is awesome. Thanks for the swift reply.


    Glad we were able to help out.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,615

    Default Re: Deluge Firewall Exception?

    I will not withstanding fact that the OP was allready helped on a "non asking for help forum", move this to Networking. More change then that it will help others.
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,615

    Default Re: Deluge Firewall Exception?

    Moved and open for posting.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •