Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

  1. #1

    Default openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Hello,

    Toshiba laptop with Celeron M CPU, 2 GB RAM, using Linksys WPC300N V1 wireless N PCMCIA adapter.
    openSUSE 12.2 M4 KDE with kernel 3.3.0-2-default

    Installed b43 successfully via the following as previously prompted by dmesg, and two SOLID pilot lights appear on the wireless card:

    Code:
    #sudo /usr/sbin/install_bcm43xx_firmware
    Edited /etc/sysconfig/kernel to show MODULES_LOADED_ON_BOOT=b43

    Edited /etc/init.d/rc to include "modprob b43" before "0 exit" then saved file

    Still have no wireless despite the above steps!

    Code:
    #lspci -nnk
    
    0a:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11b/g/n [14e4:4329] (rev 01)
            Subsystem: Linksys WPC300N v1 Wireless-N Notebook Adapter [1737:0058]
            Kernel driver in use: b43-pci-bridge
    Code:
    #dmesg
    
    [   13.130937] b43-phy0: Broadcom 4321 WLAN found (core revision 11)
    [   13.234490] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    [   13.235365] Registered led device: b43-phy0::tx
    [   13.235395] Registered led device: b43-phy0::rx
    [   13.235425] Registered led device: b43-phy0::radio
    [  13.235448] Broadcom 43xx driver loaded [ Features: PMNLS ]
    
    [   23.654574] b43-phy0: Loading firmware version 508.154 (2009-08-18 00:58:22)
    [   23.779799] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   23.862347] 8139too 0000:09:06.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    [   24.123416] NET: Registered protocol family 17
    [   40.729281] martian source 192.168.1.255 from 192.168.1.104, on dev eth0
    
       wlan0: authenticate with 00:1f:33:b4:e1:d8 (try 1)
    [  243.665981] wlan0: authenticated
    [  243.672130] wlan0: associate with 00:1f:33:b4:e1:d8 (try 1)
    [  243.674747] wlan0: RX AssocResp from 00:1f:33:b4:e1:d8 (capab=0x411 status=18 aid=0)
    [  243.674755] wlan0: 00:1f:33:b4:e1:d8 denied association (code=18)
    [  243.675163] wlan0: deauthenticating from 00:1f:33:b4:e1:d8 by local choice (reason=3)
    NB: This time I only use Network Manager to configure wireless connection. However, KDE Daemon keeps asking for password to open kwallet and passphrase to authenticate wireless connection. I got these 2 prompts several times whether wireless connection is created the first time or deleted then re-created later, so wireless connection is never established.

    /usr/sbin/rfkill list shows no blocks.

    Code:
    # /usr/sbin/iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan0     Scan completed :
    Cell 02 - Address: 00:1F:33:B4:E1:D8
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=35/70  Signal level=-75 dBm  
                        Encryption key:on
                        ESSID:"snynhatrang"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000008ac3768bb1
                        Extra: Last beacon: 568ms ago
                        IE: Unknown: 000B736E796E68617472616E67
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0104
                        IE: Unknown: 2F0104
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1A1E181AFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D16010D0400000000000000000000000000000000000000
                        IE: Unknown: 7F0101
                        IE: Unknown: DD090010180201F0010000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                        IE: Unknown: DD1E00904C331E181AFFFF000000000000000000000000000000000000000000
                        IE: Unknown: DD1A00904C34010D0400000000000000000000000000000000000000
    Any ideas or suggestions? Thank you
    Last edited by taytong888; 07-May-2012 at 20:30. Reason: revisions

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,034
    Blog Entries
    16

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Delete any connection in the kde network manager
    Make a new one and make sure you check it to be a system connection
    http://dl.dropbox.com/u/10573557/SUS...reless-new.png

    I do use kwallet, but it should bother you after you have set it up this way
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  3. #3

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Quote Originally Posted by caf4926 View Post
    Delete any connection in the kde network manager
    Make a new one and make sure you check it to be a system connection
    http://dl.dropbox.com/u/10573557/SUS...reless-new.png

    I do use kwallet, but it should bother you after you have set it up this way
    Hello caf4926,

    Yes, I did exactly what you suggested before posting this thread but the problem remains. It's possible that using the same password for system and Kwallet is the cause. How do I clean up Kwallet settings and start over?

    Thank you.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,034
    Blog Entries
    16

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Delete this folder
    .kde4/share/apps/kwallet/

    this file
    .kde4/share/config/kwalletrc
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  5. #5

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Hi caf4926,

    Thanks for your suggestions in Posts #3 &4. This time I also deleted the kwalletmanagerrc file. Uninstalled, rebooted then re-installed kwalletmanager. After another reboot, I followed the guide in Post#3. The APPLY button in the first window is grayed out so I can only hit OK. I then provide system password to make changes to network settings and used a different password to open kwallet. The first time kwallet opened it only asked for a password to set up and open the wallet; however, subsequently it did not ask for the WPA passphrase nor did it ask if I ALWAYS want to use the passphase.

    I then keep getting prompts for kwallet password and WPA passphrase. I gave up after 4 times, ie. 4 sets of these two prompts. The Wireless Connection window still shows:

    Last use= never
    State= not connected

    By the way, I also tried switching to NetworkManager Gnome (nm-applet) but ran into the same problem.

    I don't know why KNM does not pass the WPA passphrase secrets along to Kwallet. On the same laptop, openSUSE 12.1 KNetworkManager and Broadcom wl give no problem.
    Last edited by taytong888; 08-May-2012 at 19:22. Reason: revisions

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,034
    Blog Entries
    16

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking for passwords:

    Could be a bug
    I only have M3 Gnome and no problem
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,378

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking

    On 05/08/2012 09:26 PM, caf4926 wrote:
    >
    > Could be a bug
    > I only have M3 Gnome and no problem


    I have had no problems with KDE M3 and the Factory update to pseudo-M4.


  8. #8

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking

    Hello caf4926 & lwfinger,

    I installed 12.2 M3 GNOME then updated to M4. Installed bcm43xx_firmware and the card shows 2 solid pilot lights. However, Network Manager does not detect my SSID and as a result, network connection window shows my connection as never connected. Here's part of terminal output:

    Code:
    [   30.382639] b43-phy0: Loading firmware version 508.154 (2009-08-18 00:58:22)
    [   30.497317] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   30.575042] 8139too 0000:09:06.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    [   30.652774] NET: Registered protocol family 17
    [   33.925838] wlan0: authenticate with 00:1f:33:b4:e1:d8 (try 1)
    [   33.937449] wlan0: authenticated
    [   33.938388] wlan0: associate with 00:1f:33:b4:e1:d8 (try 1)
    [   33.968344] wlan0: RX AssocResp from 00:1f:33:b4:e1:d8 (capab=0x411 status=18 aid=0)
    [   33.968352] wlan0: 00:1f:33:b4:e1:d8 denied association (code=18)
    [   33.968768] wlan0: deauthenticating from 00:1f:33:b4:e1:d8 by local choice (reason=3)
    Code:
     /usr/sbin/rfkill list
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    Any idea or suggestion?

    Thank you!

  9. #9
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,378

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking

    On 05/09/2012 11:46 PM, taytong888 wrote:
    >
    > Code:
    > --------------------
    >
    > [ 30.382639] b43-phy0: Loading firmware version 508.154 (2009-08-18 00:58:22)
    > [ 30.497317] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    > [ 30.575042] 8139too 0000:09:06.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    > [ 30.652774] NET: Registered protocol family 17
    > [ 33.925838] wlan0: authenticate with 00:1f:33:b4:e1:d8 (try 1)
    > [ 33.937449] wlan0: authenticated
    > [ 33.938388] wlan0: associate with 00:1f:33:b4:e1:d8 (try 1)
    > [ 33.968344] wlan0: RX AssocResp from 00:1f:33:b4:e1:d8 (capab=0x411 status=18 aid=0)
    > [ 33.968352] wlan0: 00:1f:33:b4:e1:d8 denied association (code=18)
    > [ 33.968768] wlan0: deauthenticating from 00:1f:33:b4:e1:d8 by local choice (reason=3)


    This output says that you have the authentication secret correctly entered as
    your system was able to authenticate and associate. That "denied association"
    output is the clue. I did a quick google for "denied association code 18" and
    the second result yielded the answer to be "Association denied due to requesting
    station not supporting all of the datarates in the BSSBasicServiceSet Parameter
    (0x0012)". That seems to be "official speak" for "your AP is misconfigured". I
    know that b43 is providing the correct data rate info.

    Please post the result returned by your AP for the command

    Code:
    sudo /usr/sbin/iwlist wlan0 scan


  10. #10

    Default Re: openSUSE 12.2 KDE i686: b43 installed but KDE Wallet keeps asking

    Hello Larry,

    Here it is:

    Code:
    # sudo /usr/sbin/iwlist wlan0 scan
    
    wlan0     Scan completed :
                        
                        
                     
                        
              Cell 02 - Address: 00:1F:33:B4:E1:D8
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=38/70  Signal level=-72 dBm  
                        Encryption key:on
                        ESSID:"snynhatrang"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=000000c238bbd185
                        Extra: Last beacon: 572ms ago
                        IE: Unknown: 000B736E796E68617472616E67
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1A1E181AFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D16010D0000000000000000000000000000000000000000
                        IE: Unknown: 7F0101
                        IE: Unknown: DD090010180200F0010000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                        IE: Unknown: DD1E00904C331E181AFFFF000000000000000000000000000000000000000000
                        IE: Unknown: DD1A00904C34010D0000000000000000000000000000000000000000

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •